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About This Guide
This guide features a selection of the most important tools offered by your SUSE Linux.
Learn which applications to pick for office tasks, browsing the Internet, enjoying your
image or multimedia collections, and much more.

TIP: Finding the Right Linux Application

If switching to Linux from Windows or MacOS and wondering which Linux ap-
plication can replace the software you have been using so far, check out Ap-
pendix A, Getting to Know Linux Software (page 195).

Office
Learn how to use the OpenOffice.org office suite and how to manage e-mailing,
calendaring, and data synchronization with Evolution and Kontact. Beagle offers
powerful desktop search capabilities.

Internet
Choose Konqueror or Firefox to browse the Web and learn how to use Linphone
for Internet telephony. KGpg offers a means for handling GPG keys for file and e-
mail encryption.

Multimedia
Learn about the various Linux sound applications, such as AmaroK and Banshee,
radio and TV applications, and media burning with K3b.

Graphics
Manage your digital image collections with f-spot or Digikam and use The GIMP
for advanced image processing.

1 Feedback
We want to hear your comments and suggestions about this manual and the other doc-
umentation included with this product. Please use the User Comments feature at the
bottom of each page of the online documentation and enter your comments there.



2 Additional Documentation
There are other manuals available on this SUSE Linux product, either online at
http://www.novell.com/documentation/ or in your installed system under
/usr/share/doc/manual/:

SUSE Linux Start-Up
This guide introduces you to the installation procedure of SUSE Linux and the
basic use of your desktop environment. Find an online version of this document at
http://www.novell.com/documentation/suse101/.

SUSE Linux Reference
This guide covers advanced system administration tasks with SUSE Linux. Find
an online version of this document at http://www.novell.com/
documentation/suse101/.

Novell AppArmor 2.0 Administration Guide
This guide contains in-depth information about the use of AppArmor in your envi-
ronment. Find an online version of this document at http://www.novell
.com/documentation/apparmor/.

3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt , Alt + F1 : a key to press or a key combination; keys are shown in uppercase
as on a keyboard

• File, File → Save As: menu items, buttons

x Applications
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• Dancing Penguins (Chapter Penguins, ↑Reference): This is a reference to a chapter
in another book.

4 About the Making of this Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xmllint, processed by xsltproc,
and converted into XSL-FO using a customized version of Norman Walsh's stylesheets.
The final PDF is formatted through XEP from RenderX.

5 Acknowledgment
With a lot of voluntary commitment, the developers of Linux cooperate on a global
scale to promote the development of Linux. We thank them for their efforts—this dis-
tribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar.
Special thanks, of course, go to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
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Part I. Office





1The OpenOffice.org Office Suite
OpenOffice.org is a powerful office suite that offers tools for all types of office tasks,
such as writing texts, working with spreadsheets, or creating graphics and presentations.
With OpenOffice.org, use the same data across different computing platforms. You can
also open and edit files in Microsoft Office formats then save them back to this format,
if needed. This chapter only covers the basic skills needed to get started with OpenOf-
fice.org. Start the application from the SUSE menu or using the command ooffice.

OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 1.1, “The OpenOffice.org
Application Modules” (page 15). The discussion in this chapter is focused on Writer.
A full description of each module is available in the online help, described in Section 1.6,
“For More Information” (page 21).

Table 1.1 The OpenOffice.org Application Modules

Powerful word processor applicationWriter

Spreadsheet application that includes a chart utilityCalc

Drawing application for creating vector graphicsDraw

Application for generating mathematical formulasMath

Application for creating presentationsImpress

Database applicationBase
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The appearance of the application varies depending on which desktop or window
manager is used. Additionally, the open and save dialog formats for your desktop are
used. Regardless of the appearance, the basic layout and functions are the same.

1.1 Compatibility with Other Office
Applications

OpenOffice.org is able to work with Microsoft Office documents, spreadsheets, presen-
tations, and databases. They can be seamlessly opened like other files and saved back
to that format. Because the Microsoft formats are closed and the specifics are not
available to other applications, there are occasionally formatting issues. If you have
problems with your documents, consider opening them in the original application and
resaving in an open format, such as RTF for text documents or CSV for spreadsheets.

To convert a number of documents, such as when first switching to the application,
select File → Wizard → Document Converter. Choose the file format from which to
convert. There are several StarOffice and Microsoft Office formats available. After
selecting a format, click Next then specify where OpenOffice.org should look for tem-
plates and documents to convert and in which directory the converted files should be
placed. Before continuing, make sure that all other settings are appropriate. Click Next
to see a summary of the actions to perform, which gives another opportunity to check
whether all settings are correct. Finally, start the conversion by clicking Convert.

IMPORTANT: Finding Windows Files

Documents from a Windows partition are usually in a subdirectory of
/windows.

When sharing documents with others, you have several options. If the recipient only
needs to read the document, export it to a PDF file with File → Export as PDF. PDF
files can be read on any platform using a viewer like Adobe Acrobat Reader. To share
a document for editing, use one of the regular document formats. The default formats
comply with the OASIS standard XML format, making them compatible with a number
of applications. TXT and RTF formats, although limited in formatting, might be a good
option for text documents. CSV is useful for spreadsheets. OpenOffice.org might also
offer your recipient's preferred format, especially Microsoft formats.
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OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.

1.2 Word Processing with Writer
Figure 1.1 The OpenOffice.org Writer

There are two ways to create a new document. To create a document from scratch, use
File → New → Text Document. To use a standard format and predefined elements for
your own documents, try a wizard. Wizards are small utilities that let you make some
basic decisions then produce a ready-made document from a template. For example,
to create a business letter, select File → Wizards → Letter. Using the wizard's dialogs,
easily create a basic document using a standard format. A sample wizard dialog is
shown in Figure 1.2, “An OpenOffice.org Wizard” (page 18).
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Figure 1.2 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.

1.2.1 Selecting Text
To select text, click the desired beginning of the selection and, keeping the mouse button
pressed, move the cursor towards the end of the range (which can be characters, lines,
or entire paragraphs). Release the button when all desired text is selected. While selected,
text is displayed in inverted colors. Open a context menu by right-clicking the selection.
Use the context menu to change the font, the font style, and other text properties.

Selected text can be cut or copied to the clipboard. Cut or copied text can be pasted
back into the document at another location. Use the context menu, Edit, or the relevant
toolbar icons to access these functions.
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1.2.2 Navigating in Large Documents
The Navigator displays information about the contents of a document. It also enables
you to jump quickly to the different elements included. For example, use the Navigator
to get a quick overview of all the chapters or to see a list of the images included in the
document. Open it by selecting Edit → Navigator or by pressing F5 . Figure 1.3, “The
Navigator in Writer” (page 19) shows the Navigator in action. The elements listed in
the Navigator vary according to the document loaded in Writer.

Figure 1.3 The Navigator in Writer

1.2.3 Formatting with Styles
The dialog opened with Format → Styles and Formatting can help you format text in
a number of ways. If you set the drop-down list at the bottom of this dialog to Automatic,
OpenOffice.org tries to offer a selection of styles adapted to the task at hand. If you
select All Styles, the Stylist offers all styles from the currently active group. Select
groups with the buttons at the top.

By formatting your text with this method, called soft formatting, text is not formatted
directly. Instead, a style is applied to it. The style can be modified easily, automatically
resulting in a formatting change of all the text to which it is assigned.
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To assign a style to a paragraph, select the style to use then click the paint bucket icon
in Styles and Formatting. Click the paragraphs to which to assign the style. Stop assign-
ing the style by pressing Esc or clicking the paint bucket icon again.

Easily create your own styles by formatting a paragraph or a character as desired using
the Format menu or toolbar. Select the formatted item from which to copy the style.
Then click and hold the button to the right of the bucket in Styles and Formatting and
select New Style from Selection from the menu that opens. Enter a name for your style
and click OK. This style can then be applied to other texts.

Change details of a style by selecting it in the list, right-clicking, and selecting Modify
from the menu. This opens a dialog in which all the possible formatting properties are
available for modification.

1.3 Introducing Calc
Calc is OpenOffice.org's spreadsheet application. Create a new spreadsheet with File
→ New → Spreadsheet or open one with File → Open. Calc can read and save in Mi-
crosoft Excel's format.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.

1.4 Introducing Impress
Impress is designed for creating presentations for screen display or printing, such as
on transparencies. Create a presentation from scratch with File→ New→ Presentation.
To create one with the assistance of a wizard, use File → Wizards → Presentation.
Open an existing presentation with File → Open. Impress can open and save Microsoft
PowerPoint presentations.
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1.5 Introducing Base
OpenOffice 2.0 introduces a new database module. Create a database with File → New
→ Database. A wizard opens to assist in creating the database. Base can also work
with Microsoft Access databases.

Figure 1.4 Base—Databases in OpenOffice.org

Tables, forms, queries, and reports can be created manually or using convenient wizards.
For example, the table wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

1.6 For More Information
OpenOffice.org includes a number of information options that provide different levels
of information. To get thoroughly acquainted with a topic, selectHelp→OpenOffice.org
Help. The help system provides in-depth information about each of the modules of
OpenOffice.org (Writer, Calc, Impress, etc.).
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When the application is first started, it provides Tips, short information about buttons
when the mouse hovers over them, and the Help Agent, information based on actions
performed. To get more extensive information about buttons than the Tips provide, use
Help → What's This then hover over the desired buttons. To end What's This mode,
click. If you frequently need this function, consider enabling the Extended Tips in Tools
→Options→OpenOffice.org→General. TheHelp Agent and Tips can also be enabled
and disabled here.

The OpenOffice.org Web site is http://www.openoffice.org. There, find
mailing lists, articles, and bug information. This site provides the versions for various
operating systems for download.
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2Evolution: An E-Mail and Calendar
Program
Evolution is a groupware suite that offers the usual e-mail features along with extended
features, like task lists and a calendar. The application also provides a complete address
book that includes the ability to send contact information to others in vCard format.

Start Evolution from the menu or press Alt + F2 and enter evolution. When
started for the first time, Evolution offers a configuration assistant. Its use is described
in Section 2.2.2, “Configuring Accounts” (page 25).

IMPORTANT: Microsoft Exchange Accounts

To use Evolution with Microsoft Exchange, you must install the
ximian-connector package. Install it with YaST.

2.1 Evolution Overview
The default window view is shown in Figure 2.1, “The Evolution Window with Mail”
(page 24). The available menus, menu items, and the icons in the toolbar vary depending
on the open component. Use the left frame to select which information to display in
the right frame (Mail,Contacts,Calendar, etc.). Adjust the size of the frames by dragging
the dividing bars.
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Figure 2.1 The Evolution Window with Mail

2.1.1 Mail
In this view, the upper half of the window shows the contents of the current folder. The
lower half is a preview pane used to display the selected mail message. To display a
different folder, select a folder from the folder list in the left frame.

Use the search bar to search the messages in a folder. To sort messages by a table
header, click the desired header (To, Subject, Date). The arrow to the right shows
whether the column is sorted in ascending or descending order. Click the column
header until the messages are sorted in the desired direction.

2.1.2 Contacts
This view shows all the addresses in your address book. To locate a particular address,
use the search bar or click the button to the right displaying the first letter of the contact's
last name. Add contacts or lists with the toolbar.
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2.1.3 Calendar
The initial display shows a view of the current day with the month and a task list shown
in an additional pane to the right. Week, work week, and month views are also available
from the toolbar or the View menu. Use the search bar to find an appointment that has
been entered in the calendar. Add appointments and tasks using the buttons in the
toolbar. You can also use the toolbar to page through the calendar or jump to a specific
date.

2.1.4 Tasks
Tasks provides a list of tasks. Details of the selected task are shown in the lower part
of the window. Use File → New → Task to add a new task. Search the tasks with the
search bar. Assign tasks to others by right-clicking the task and selecting Assign Task.
Open the task to add more details, such as a due date and completion status.

2.2 Mail
The Evolution mail component can work with multiple accounts in a variety of formats.
It offers useful features, such as virtual folders for showing search results and filtering
for junk mail. Configure the application in Edit → Preferences.

2.2.1 Importing E-Mail from Other Mail
Programs

To import e-mail from other e-mail programs, such as Netscape, select File → Import.
For mbox formats, select Import a single file. For Netscape, select Import data and
settings from older programs. To work with data from programs using the maildir format,
such as KMail, configure an account that accesses the mail directory.

2.2.2 Configuring Accounts
Evolution can retrieve e-mail from multiple mail accounts. Select the account from
which to send e-mail when you compose a message. Configure mail accounts in Edit
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→ Preferences → Mail Accounts. To modify an existing configuration, select it and
click Edit. To delete an account, select it and click Delete.

To add a new account, click Add. This opens the configuration assistant. Click Forward
to use it. Enter your name and your e-mail address in the respective fields. Enter the
optional information if desired. Check Make this my default account to use this account
by default when writing mails. Click Forward.

Select the appropriate incoming e-mail format for this address in Server Type. POP is
the most common format for downloading mail from a remote server. IMAP works
with mail folders on a special server. Obtain this information from your ISP or server
administrator. Complete the other relevant fields displayed when the server type is se-
lected. Click Forward when finished. Select the desired Receiving Options, if available.
Click Forward.

Next, configure the mail delivery options. To submit outgoing e-mail to the local system,
select Sendmail. For a remote server, select SMTP. Get the details from your ISP or
server administrator. For SMTP, complete the other fields displayed after selection.
Click Forward when finished.

By default, the e-mail address is used as the name to identify the account. Enter another
name if desired. Click Forward. Click Apply to save your account configuration.

To make an account the default account for sending e-mail, select the desired account
then pressDefault. To disable the retrieval of e-mail from an account, select the account
then click Disable. A disabled account can still be used as the address for sending, but
that account is not checked for incoming e-mail. If necessary, reactivate the account
with Enable.

2.2.3 Creating Messages
To compose a new message, click New → Mail Message. Replying to or forwarding a
message opens the same message editor. Next to From, select from which account to
send the message. In the recipient fields, enter an e-mail address or part of a name or
address in your address book. If Evolution can match what you enter to something in
the address book, a selection list is displayed. Click the desired contact or complete
your input if there are no matches. To select a recipient directly from the address book,
click To or CC.
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Evolution can send e-mail as plain text or HTML. To format HTML mail, select Format
in the toolbar. To send attachments, select Attach or Insert → Attachment.

To send your message, click Send. If not ready to send it immediately, make another
selection under File. For example, save the message as a draft or send it later.

2.2.4 Encrypted E-Mail and Signatures
Evolution supports e-mail encryption with PGP. It can sign e-mail and check signed e-
mail messages. To use these features, generate and manage keys with an external appli-
cation, such as gpg or KGpg.

To sign an e-mail message before sending it, select Security → PGP sign. When you
click Send, a dialog prompts for the passphrase of your secret key. Enter the passphrase
and exit the dialog with OK to send the signed e-mail. To sign other e-mail messages
in the course of this session without needing to “unlock” the secret key repeatedly,
check Remember this password for the remainder of this session.

When you receive signed e-mail from other users, a small padlock icon appears at the
end of the message. If you click this symbol, Evolution starts an external program (gpg)
to check the signature. If the signature is valid, a green check mark appears next to the
padlock symbol. If the signature is invalid, a broken padlock appears.

The encryption and decryption of e-mail is just as easy. After composing the e-mail
message, go to Security→ PGP encrypt and send the e-mail message. When you receive
encrypted messages, a dialog asks for the password of your secret key. Enter the
passphrase to decrypt the e-mail message.

2.2.5 Folders
It is often convenient to sort e-mail messages into a variety of folders. Your folder tree
is shown in the left frame. If accessing mail over IMAP, the IMAP folders are also
shown in this folder bar. For POP and most other formats, your folders are stored locally,
sorted under On This Computer.

Several folders are included by default. Inbox is where new messages fetched from a
server are initially placed. Sent is used for saving copies of sent e-mail messages. The
Outbox provides temporary storage for e-mail that has not yet been sent. It is useful if
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working offline or if the outgoing mail server is temporarily unreachable.Drafts is used
for saving unfinished e-mail messages. The Trash folder is intended for temporary
storage of deleted items. Junk is for Evolution's junk mail filtering feature.

New folders can be created underOn This Computer or as subfolders of existing folders.
Create as complex a folder hierarchy as desired. To create a new folder, select File →
New → Mail Folder. In the Mail Folder dialog, enter a name for the new folder. Use
the mouse to determine the parent folder under which to place the new folder. Exit the
dialog with OK.

To move a message into a folder, select the message to move. Right-click to open the
context menu. Select Move to Folder and, in the dialog that opens, the destination
folder. Click OK to move the message. The message header in the original folder is
shown with a line through it, meaning that message is marked for deletion from that
folder. The message is stored in the new folder. Messages can be copied in a similar
manner.

Manually moving a number of messages into different folders can be time-consuming.
Filters can be used to automate this procedure.

2.2.6 Filters
Evolution offers a number of options for filtering e-mail. Filters can be used to move
a message into a specific folder or to delete a message. Messages can also be moved
directly to the trash with a filter. There are two options for creating a new filter: creating
a filter from scratch or creating a filter based on a message to filter. The latter is useful
for filtering messages sent to a mailing list.

Setting Up a Filter
Select Tools → Filters. This dialog lists your existing filters, which can be edited or
deleted. Click Add to create a new filter. Alternatively, to create a filter based on a
message, select the message then Tools → Create Filter from Message.

Enter a name for the new filter in Rule Name. Select the criteria to use for the filter.
Options include sender, recipients, source account, subject, date, and status. The drop-
box showing Contains provides a variety of options, such as contains, is, and is not.
Select the appropriate condition. Enter the text for which to search. Click Add to add
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more filter criteria. Use Execute actions to determine if all or only some of the criteria
must be met to apply the filter.

In the lower part of the window, determine the action to take when the filter criteria are
met. Messages can, for example, be moved or copied to a folder or assigned a special
color. When moving or copying, click to select the destination folder. In the folder list
that appears, select the folder. To create a new folder, click New. Click OK when the
correct folder is selected. When finished creating the filter, click OK.

Applying Filters
Filters are applied in the order listed in the dialog accessed with Tools→ Filters. Change
the order by highlighting a filter and clicking Up or Down. Click OK to close the filter
dialog when finished.

Filters are applied to all new mail messages. They are not applied to mail already in
your folders. To apply filters to messages already received, select the desired messages
then select Actions → Apply Filters.

2.3 Contacts
Evolution can use several different address books. Available books are listed in the left
frame. Search for a particular contact using the search bar. Add contacts in several
formats to the Evolution address book using File → Import. Right-click a contact to
open a menu in which to select from a variety of options, such as forwarding the contact
or saving it as a vCard. Double-click a contact to edit it.
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Figure 2.2 The Evolution Address Book

2.3.1 Adding Contacts
Along with the name and e-mail address, Evolution can store other address and contact
information about a person. Quickly add the e-mail address of a sender by right-clicking
the marked address in the message preview. To enter a completely new contact, click
New in the Contacts view. Both methods open a dialog in which to enter contact infor-
mation.

In the Contact tab, enter the contact's name, e-mail addresses, telephone numbers, and
instant messaging identities. Personal Information is for Web addresses and other de-
tailed information. Enter the contact's other address information in Mailing Address.
After entering all desired details for the contact, click OK to add it to the address book.

2.3.2 Making a List
If you frequently send e-mail messages to a group of people, you can simplify the process
by creating a list containing those addresses. Click File → New → Contact List. The
contact list editor opens. Enter a name for the list. Add addresses by typing the address
in the box and clickingAdd or by dragging contacts from theContacts view and dropping
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them in the box. Toggle Hide addresses to select whether the recipients can see who
else has received the mail. ClickOKwhen finished. The list is now one of your contacts
and appears in the composition window after the first few letters are typed.

2.3.3 Adding Address Books
Configure additional GroupWise and Exchange address books in the account configu-
ration. To add other local or LDAP books, select File → New → Address Book. In the
dialog that opens, select the type of address book and enter the required information.

2.4 Calendars
Evolution can work with multiple calendars. With File → Import, import calendars in
iCalendar format. Use the calendar to enter appointments and schedule meetings with
others. If desired, set reminders to let you know when your scheduled appointments
are going to start.

Figure 2.3 The Evolution Calendar
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2.4.1 Adding Appointments
To add a new appointment to your calendar, click File → New → Appointment. Under
the Appointment tab, enter the details for the appointment. Select a category, if desired,
to ease searching and sorting later. Optionally, use Alarm to set an alarm so Evolution
will remind you before your appointment starts. If the appointment occurs regularly,
set the recurring dates under Recurrence. Click OK after all settings are made. The new
appointment is then shown in your calendar.

2.4.2 Scheduling a Meeting
To schedule a meeting with other people, select File → New → Meeting. Enter infor-
mation as you would for an appointment. Add the attendees in Invitations or Scheduling.
To enter attendees from your address book, use Contacts to open a list of the contacts
in your address book. Scheduling can also be used to schedule a time that fits all atten-
dees. Press Autopick after configuring participants to automatically find a time.

2.4.3 Adding Calendars
GroupWise and Exchange calendars should be configured in the account configuration.
To add additional local or Web calendars, select File → New → Calendar. Select the
desired type and enter the required information.

2.5 Syncing Data with a Handheld
Evolution is designed so its data can be synced with handheld devices, such as a Palm.
The synchronization uses GNOME Pilot. Select Edit → Synchronizations Options to
open the configuration wizard. Refer to the help for more information.

2.6 Evolution for GroupWise Users
GroupWise users should have little trouble using Evolution to access their GroupWise
accounts. Evolution and GroupWise use very similar terminology. Users familiar with
one system should be able to learn the other with minimal effort.
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Use the configuration assistant to configure Evolution to access your GroupWise system.

1 To start the assistant, click Preferences → Mail Accounts → Add then click
Forward.

2 On the Identity page, provide your e-mail address in the GroupWise system (for
example, joe@example.com) then click Forward.

3 On the Receiving Email page, select IMAP in Server Type, specify the hostname
of your GroupWise server in Host, set the other settings on the Receiving Options
page as appropriate for your system, then click Forward.

4 On the Sending Email page, select SMTP in Server Type, specify the hostname
of your GroupWise server in Host, set the other Sending Email options as appro-
priate for your system, then click Forward.

5 On theAccountManagement page, specify the name to use to identify this account
on the Evolution Settings page then click Forward.

6 Click Apply to create the GroupWise account. Your GroupWise mailbox now
appears in the list of available e-mail accounts.

2.7 For More Information
Evolution offers extensive internal help pages. Use the Help menu to access this infor-
mation. For more information about Evolution, refer to the project's Web site at
http://www.gnome.org/projects/evolution/.
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3Kontact: An E-Mail and Calendar
Program
Kontact combines the functionality of a number of KDE applications into a convenient,
single interface for personal information management. These applications include KMail
for e-mail, KOrganizer for the calendar, KAddressbook for contacts, and KNotes for
notes. It is also possible to sync data with external devices, such as a PalmPilot or other
handheld device. Kontact integrates easily with the rest of the KDE desktop and connects
to a variety of groupware servers. It includes extra features, such as spam and virus
filtering and an RSS reader.

Start Kontact from the main menu. Alternatively, enter kontact in a command line
or in the Run Command dialog. You can also open the individual components instead
of the combined application if you only need partial functionality.

3.1 Kontact Overview
The default window view, which shows the Summary, is shown in Figure 3.1, “The
Kontact Window Showing the Summary” (page 36). Use the buttons in the left section
to access the different components.

The Summary provides basic information, including upcoming birthdays and to-dos
and the number of new mail messages. The news section can access RSS feeds to provide
updated news of interest to you. Use Settings → Configure Summary View to configure
the information displayed.
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Figure 3.1 The Kontact Window Showing the Summary

3.1.1 Mail
The folder area to the left contains a list of your mail folders (mail boxes) indicating
the total number of messages and how many are still unread. To select a folder, simply
click it. The messages in that folder appear in the top right frame. The number of mes-
sages in that folder is also shown in the status bar at the bottom of the application win-
dow.

The subject, sender, and time of receipt of each message are listed in the header area
to the right. Click a message to select it and display it in the message window. Sort the
messages by clicking one of the column headers (subject, sender, date, etc.). The contents
of the currently selected message are displayed in the message frame of the window.
Attachments are depicted as icons at the end of the message, based on the MIME type
of the attachment, or they can be displayed inline.

Messages can be marked with different status flags. Change the status with Message
→ Mark Message. You can use this feature to assign a status to a message, such as
important or ignored. For example, you can highlight important messages that you do
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not want to forget. Display only messages with a certain status using Status in the search
bar.

3.1.2 Contacts
The upper left frame of this component shows all addresses in the currently activated
address books. The lower left frame lists your address books and shows whether each
one is currently active. The right frame shows the currently selected contact. Use the
search bar at the top to find a particular contact.

3.1.3 Calendar
The calendar view is divided into a number of frames. By default, view a small calendar
of this month and a week view of the current week. Also find a list of to-dos, a detailed
view of the current event or to-do, and a list of calendars with the status of each. Select
a different view from the toolbar or the View menu.

3.1.4 To-Do List
To-do List shows your list of tasks. Click the field at the top to add a new item to the
list. Right-click in a column of an existing item to make changes to the value in that
column. An item can be broken into several subitems. Right-click and select New Sub-
to-do to create a subitem. You can also assign to-dos to other people.

3.1.5 Journal
The Journal provides a place for your reflections, occurences, or experiences. Choose
a date in the calendar frame and click Add Journal Entry to add a new entry. If a journal
entry already exists for the chosen date, edit it in the right frame.

3.1.6 Notes
Use the Notes component to keep sticky notes to yourself. If you are using KDE, use
the KNote icon in the system tray to make your notes visible on the desktop.
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3.1.7 Feeds
The Feeds window is divided into three frames—a tree view with RSS feeds on the
left, an article list on the top right, and the article view on the bottom right side. Click
a feed in the tree view to display it. Right-click a feed to update, edit, or delete it. Right-
click a folder in the tree view to open a menu where you can add a new feed or manip-
ulate existing feeds within this folder.

3.2 Mail
Kontact uses KMail as its e-mail component. To configure it, open the mail component
then select Settings → Configure KMail. KMail is a fully-featured e-mail client that
supports a number of protocols. Tools contains several useful tools for managing un-
wanted e-mails. Use Find to perform a detailed search for messages. Anti-SpamWizard
can help manage tools for filtering unwanted commercial e-mails. Anti-Virus Wizard
helps manage e-mail virus scanners. These two wizards work with external spam and
virus software. If the options are disabled, install additional packages for protection
against spam and viruses.

Figure 3.2 The Kontact Mail Component
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3.2.1 Configuring Identities and Accounts
Kontact can manage multiple e-mail accounts, such as your private e-mail address and
your business address. When writing an e-mail, select one of the identities previously
defined by clicking View → Identity. To create a new identity profile, select Settings
→ Configure KMail then Identities → Add. In the dialog that opens, give the new
identity a name, such as “private” or “office.” Click OK to open a dialog in which to
enter additional information. You can also assign an identity to a folder so that, when
replying to a message in that folder, the assigned identity is selected.

Under the General tab, enter your name, organization, and e-mail address. Under
Cryptography, select your keys to send digitally signed or encrypted messages. For the
encryption features to work, first create a key with KGpg, described in Chapter 13,
Encryption with KGpg (page 107).

Under Advanced, you can enter a default reply-to and a default blind carbon-copy ad-
dress, choose a dictionary, select the folders for drafts and sent messages, and define
how messages should be sent. Under Signature, decide if and how each of your messages
should be signed with an extra block of text at the end. For example, you might sign
each e-mail with your contact information. To activate this option, select Enable Signa-
ture and decide whether to obtain the signature from a file, an input field, or the output
of a command. With Picture, you can specify the path to a small (48x48 pixel)
monochrome icon to display in all your mails if the recipient's software supports this
feature. When you are finished with all your identity settings, confirm with OK.

The settings under Accounts decide how Kontact receives and sends e-mail. There are
two tabs, one each for sending and for receiving mail. Many of these settings vary de-
pending on the system and network in which your mail server is located. If you are not
sure about the settings or items to select, consult your ISP or system administrator.

To create outgoing mail boxes under the Sending tab, click Add. Choose between the
SMTP and sendmail transport types. SMTP is the correct choice in most cases. After
making this selection, a window appears in which to enter SMTP server data. Provide
a name and enter the server address (as given to you by your ISP). If the server wants
you to authenticate yourself, enable Server requires authentication. Security settings
are under the Security tab. Specify your preferred encryption method here.

Make settings for receiving e-mail under the Receiving tab. Use Add to create a new
account. Choose between different methods for retrieving mail, such as local (stored
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in Mbox or Maildir format), POP3, or IMAP. Make the settings appropriate for your
server.

3.2.2 Importing E-Mail from Other Mail
Programs

To import e-mail from other applications, select Tools → Import Messages from the
mail view in Kontact. It currently features import filters for Outlook Express, the mbox
format, e-mail text format, Pegasus Mail, Opera, Evolution, and more. The import
utility can also be started separately with the command kmailcvt.

Select the corresponding application and confirm withContinue. A file or a folder must
be provided, depending on the selected type. Kontact then completes the process.

3.2.3 Creating Messages
To compose new messages, selectMessage→NewMessage or click the corresponding
icon in the toolbar. To send messages from different e-mail accounts, select one of the
identities as described in Section 3.2.1, “Configuring Identities and Accounts” (page 39).
In To, enter an e-mail address or part of a name or address in your address book. If
Kontact can match what you enter to something in the address book, a selection list
opens. Click the desired contact or complete your input if none matches. To select di-
rectly from the address book, click the ... button next to the Address field.

To attach files to your message, click the paperclip icon and select the file to attach.
Alternatively, drag a file from the desktop or another folder to theNewMessagewindow
or select one of the options in the Attach menu. Normally, the format of a file is recog-
nized correctly. If the format is not recognized, right-click the icon. From the menu
that appears, select Properties. Set the format and filename in the next dialog and add
a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, send it immediately with Message
→ Send or move it to the outbox with Message → Queue. If you send the e-mail, the
message is copied to sent-mail after having been sent successfully. Messages moved
to the outbox can be edited or deleted.
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3.2.4 Encrypted E-Mail and Signatures
To encrypt your e-mail, first generate a key pair as described in Chapter 13, Encryption
with KGpg (page 107). To configure the details of the encryption procedure, select Set-
tings → Configure KMail → Identities to specify the identity under which to send en-
crypted and signed messages. Then press Modify. After confirming with OK, the key
should be displayed in the corresponding field. Close the configuration dialog withOK.

3.2.5 Folders
Message folders help organize your messages. By default, they are located in the direc-
tory ~/.kde/share/apps/kmail/mail. When starting KMail for the first time,
the program creates several folders. inbox is where new messages fetched from a
server are initially placed. outbox is used for temporary storage of messages queued
for sending. sent-mail is for copies of messages sent. trash contains copies of all
e-mails deleted with Del or Edit → Delete. drafts is where you can save unfinished
messages. If you are using IMAP, the IMAP folders are listed below the local folders.
Each incoming mail server has its folders in the Folder list.

If you want to organize your messages in additional folders, create new folders by se-
lecting Folder → New Folder. This opens a window in which to specify the name and
format of the new folder.

Right-click the folder for a context menu offering several folder operations. Click Expire
to specify the expiration date for read and unread messages, what should happen with
them after expiration, and whether expired messages should be deleted or moved to a
folder. If you intend to use the folder to store messages from a mailing list, set the
necessary options under Folder → Mailing List Management.

To move one or several messages from one folder to another, drag them from the upper
window and drop them into the appropriate folder in the left window. Messages can
also be moved by highlighting the messages then pressing M or selecting Message
→ Move to. In the list of folders that appears, select the folder to which to move your
messages.
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3.2.6 Filters
Filters are a convenient method of automatically processing incoming mail. They use
aspects of the mail, such as sender or size, to move mail to certain folders, delete un-
wanted mails, bounce mails back to the sender, or perform a number of other actions.

Setting Up a Filter
To create a filter from scratch, select Settings → Configure Filters. To create a filter
based on an existing message, right-click the desired message then select Create Filter
and the desired filter criteria.

Select the match method for filter criteria (all or any). Then select criteria that applies
only to the desired messages. In Filter Actions, set what the filter should do to the
messages that meet the criteria. Advanced Options provides control over when the filter
is applied and whether additional filters should be considered for these messages.

Applying Filters
Filters are applied in the order listed in the dialog accessed with Settings → Configure
Filters. Change the order by selecting a filter and clicking the arrow buttons. Filters
are only applied to new incoming messages or sent messages as specified in the filter's
advanced options. To apply filters to existing messages, right-click the desired messages
and choose Apply Filter and the desired filter.

If your filters do not act as expected, monitor them with Tools → Filter Log Viewer.
When logging is enabled in this dialog, it shows how messages are processed by your
filters and can help locate the problem.

3.3 Contacts
The contacts component uses KAddressBook. Configure it with Settings → Configure
KAddressBook. To search for a particular contact, use the search bar. With Filter, select
to display only contacts in a certain category. Right-click a contact to open a menu in
which to select from a variety of options, such as sending the contact information in an
e-mail.
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Figure 3.3 The Kontact Address Book

3.3.1 Adding Contacts
To add a contact with the name and e-mail address from an e-mail, right-click the address
in the mail component and select Open in Address Book. To add a new contact without
using an e-mail, select File → New Contact in the address component. Both methods
open a dialog in which to enter information about the contact.

In the General tab, enter basic contact information, such as name, e-mail addresses,
and telephone numbers. Categories can be used to sort addresses.Details contains more
specific information, such as birthday and spouse's name.

If your contact uses an instant messenger, you can add these identities in IM Addresses.
If you do this and have Kopete or another KDE chat program running at the same time
as Kontact, view status information about these identities in Kontact. InCrypto Settings,
enter the contact's encryption data, such as public key.

Misc has additional information, such as a photograph and the location of the user's
Free/Busy information. Use Custom Fields to add your own information to the contact
or address book.
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Contacts can also be imported in a variety of formats. Use File → Import and select
the desired format. Then select the file to import.

3.3.2 Making a Distribution List
If you frequently send e-mail messages to the same group of people, a distribution list
enables you to store multiple e-mail addresses as a single contact item so that you do
not need to enter each name individually in every e-mail you send to that group. First,
click Settings → Show Extension Bar → Distribution List Editor. In the new section
that appears, click New List. Enter a name for the list then click OK. Add contacts to
the list by dragging them from the address list and dropping them in the distribution
list window. Use this list like you would an individual contact when creating an e-mail.

3.3.3 Adding Address Books
IMPORTANT: Groupware Address Books

The best way to add groupware resources is with the Groupware Wizard, a
separate tool. To use it, close Kontact then run groupwarewizard in a
command line or from the Office group of the KDE menu. Select the server
type, such as SLOX, GroupWise, or Exchange, from the list offered then enter
the address and authentication data. The wizard then adds the available re-
sources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell
GroupWise or an LDAP server. Select Settings → Show Extension Bar → Address
Books to view the current address books. Press Add to add one then select the type and
enter the required information.

The check boxes in front of the books show the activation status of each address book.
To prevent the display of a book without deleting it, uncheck it. Remove deletes the
selected book from the list.
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3.4 Calendar
Kontact uses KOrganizer as its calendar component. To configure it, use Settings →
Configure KOrganizer. With the calendar, enter appointments and schedule meetings
with others. If desired, you can be reminded of upcoming events. You can also import,
export, and archive calendars with the options in File.

Figure 3.4 The Kontact Calendar

3.4.1 Scheduling an Event
Add a new event or meeting with Actions→New Event. Enter the desired details. Under
Reminder, specify the exact time (minutes, hours, or days in advance) when the attendees
should be reminded of the event. If an event recurs, specify the appropriate interval.
Another way to create an event at a specific point in the calendar is to double-click the
corresponding field in one of the program's calendar views. This opens the same dialog
window as that available from the menu. Alternatively, select a time range in the Cal-
endar view and right-click.

Specify the attendees of an event by entering their data manually in the dialog or by
inserting data from the address book. To enter data manually, select New. To import
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data from the address book, click Select Addressee then select the corresponding entries
from the dialog. To schedule the event based on the participants' availability, go to
Free/Busy and click Pick Date.

Use the Recurrence tab to configure an event that happens on a regular basis. Attach-
ments can be convenient for linking other information with the event, such as an agenda
for a meeting.

3.4.2 Adding Calendars
IMPORTANT: Groupware Calendars

The best way to add groupware resources is with Groupware Wizard, a separate
tool. To use it, close Kontact then run groupwarewizard in a command line
or from the Office group of the KDE menu. Select the server type, such as
SLOX, GroupWise, or Exchange, from the list offered then enter the address
and authentication data. The wizard adds the available resources to Kontact.

The calendar module can connect to multiple calendars simultaneously. This is useful,
for example, to combine a personal calendar with an organizational one. To add a new
calendar, click Add then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To prevent
the display of a calendar without deleting it, uncheck it. Remove deletes the selected
calendar from the list.

3.5 Syncing Data with a Handheld
Kontact is designed so its data can be synced with handheld devices, such as a Palm.
View information about the status of KPilot in the summary. Refer to Chapter 4, Syn-
chronizing a Handheld Computer with KPilot (page 49) for information about config-
uring and using KPilot.
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3.6 Kontact for GroupWise Users
If you are used to working in GroupWise, you should have very little trouble adjusting
to Kontact. The two programs share many concepts and provide many of the same
services. This section discusses notable terminology differences, as well as some tips
to help GroupWise users make the most of Kontact.

3.6.1 Terminology Differences
The following table lists some key terminology differences between Kontact and
GroupWise.

Table 3.1 Kontact and GroupWise Terminology Differences

KontactGroupWise

EventsAppointments

Free/BusyBusy search

Journal entriesNotes

An event without attendees is posted. If an
event has attendees, it is a Sent item.

Posted, nonposted items

To-dosTasks

3.6.2 Tips for GroupWise Users
This section contains hints to help GroupWise users work with some of the differences
between GroupWise and Kontact.
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Contact Information
You can add your GroupWise Messenger and e-mail contacts to your Kontact contact
information. Then you can create an e-mail or open an instant messaging session with
that contact by right-clicking the name in the Contact view.

Color Coding
It is helpful to color code GroupWise items, as well as items from other sources. Color
coding makes it easy to scan your e-mails, contacts, and other information for items
from a particular source.

Inviting Attendees to Events
Unlike GroupWise, Kontact does not automatically enter you as an attendee for events
you schedule. Make sure that you remember to invite yourself.

3.7 For More Information
Kontact includes help for itself and its various components. Access it with Help →
Kontact Handbook. The project's Web page, http://www.kontact.org, is also
informative.
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4Synchronizing a Handheld
Computer with KPilot
Handheld computers are in widespread use among users who need to have their
schedules, to-do lists, and notes with them everywhere they go. Often users want the
same data available on both the desktop and the portable device. This is where KPilot
comes in—it is a tool to synchronize data on a handheld with that used by the KDE
applications KAddressBook, KOrganizer, and KNotes, which are part of Kontact.

The main purpose of KPilot is to allow sharing of data between the applications of a
handheld computer and their KDE counterparts. KPilot does come with its own built-
in memo viewer, address viewer, and file installer, but these cannot be used outside the
KPilot environment. Independent KDE applications are available for all functions except
the file installer.

For communication between the handheld and the different desktop programs, KPilot
relies on conduits. KPilot itself is the program that oversees any data exchange between
the two computer devices. Using a particular function of the handheld on your desktop
computer requires that the corresponding conduit is enabled and configured. For the
most part, these conduits are designed to interact with specific KDE programs, so in
general they cannot be used with other desktop applications.

The time synchronization conduit is special in that there is no user-visible program for
it. It is activated in the background with each sync operation, but should only be enabled
on computers that use a network time server to correct their own time drift.

When a synchronization is started, the conduits are activated one after another to carry
out the data transfer. There are two different sync methods: a HotSync operation only
synchronizes the data for which any conduits have been enabled while a backup operation
performs a full backup of all data stored on the handheld.
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Some conduits open a file during a sync operation, which means that the corresponding
program should not be running at that time. Specifically, KOrganizer should not be
running during a sync operation.

4.1 Conduits Used by KPilot
The conduits used by KPilot can be enabled and configured after selecting Settings →
Configure KPilot. The following is a list of some important conduits:

Addressbook
This conduit handles the data exchange with the handheld's address book. The KDE
counterpart for managing these contacts is KAddressBook. Start it from the main
menu or with the command kaddressbook.

KNotes/Memos
This conduit allows you to transfer notes created with KNotes to the handheld's
memo application. Start the KDE application from the main menu or with the
command knotes.

Calendar (KOrganizer)
This conduit is responsible for syncing the appointments (events) of the hendheld.
The desktop equivalent is KOrganizer.

ToDos (KOrganizer)
This conduit is responsible for syncing to-do items. The desktop counterpart is
KOrganizer.

Time Synchronization
Enabling this conduit adjusts the handheld's clock to that of the desktop computer
during each sync operation. This is only a good idea if the clock of the desktop
computer itself is corrected by a time server at fairly frequent intervals.
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Figure 4.1 Configuration Dialog with the Available Conduits

4.2 Configuring the Handheld
Connection

To be able to use KPilot, first set up the connection with the handheld computer. The
configuration depends on the type of cradle (docking unit) used with the handheld.
There are two types of these: USB cradles or cables and serial cradles or cables.

4.2.1 Configuring the Connection from
within KPilot

The easiest way to set up the connection is by using the configuration assistant. Do the
following:
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1 Select Settings → Configuration Wizard to start the assistant.

2 Enter your username and the name of the device to which the handheld is con-
nected.

3 Choose from one of the following options:

• Select Autodetect Handheld & Username if you want the assistant to detect
your handheld. If the autodetection fails, refer to Section 4.2.2, “Creating a
/dev/pilot Link” (page 52).

• Click Next to configure it manually.

4 Specify the applications that should be used for synchronization. You can choose
among the KDE application suite (default), Evolution, and none. After selecting,
close the window with Finish.

4.2.2 Creating a /dev/pilot Link
The setup of the connection with a serial handheld cradle is different from that of a
USB cradle. Depending on which cradle is used, you may or may not need to create a
symbolic link named /dev/pilot.

USB
Normally, a USB cradle is autodetected and there should be no need to create the
symbolic link mentioned.

Serial
With a serial cradle, you need to know to which serial port it is actually connected.
Serial devices are named /dev/ttyS?, starting from /dev/ttyS0 for the first
port. To set up a cradle connected to the first serial port, enter the command:
ln -s /dev/ttyS0 /dev/pilot
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4.3 Configuring the KAddressBook
Conduit

Initially, it should be sufficient to enable the KAddressBook conduit without changing
any of the defaults. After the data has been synchronized for the first time, configure
the details: what to do in case of conflicts, the way in which backup databases are saved,
and how certain fields stored on the handheld should be assigned to the fields expected
by KAddressBook.

4.4 Managing To-Do Items and Events
On the KDE desktop, to-dos (tasks) and events (appointments) are managed with KOr-
ganizer. Start the application from the main menu, with the command korganizer,
or as part of Kontact. After enabling the calendar and the to-do conduit of KPilot, set
some configuration options before using them.

Figure 4.2 KPilot Configuration

KOrganizer stores its files in the directory ~/.kde/share/apps/korganizer.
However, given that the directory .kde begins with a dot, it may not be shown by the
file selection dialog. In this case, enter the complete path manually or explicitly toggle
the display of hidden files (dot files) in the file selection dialog. The default shortcut
for this is F8 .
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After opening the directory ~/.kde/share/apps/korganizer, select a file that
can be used as a calendar file by KOrganizer. In this example, this is the file palm
.ics. In the case of a user called tux, the complete path and filename would be
/home/tux/.kde/share/apps/korganizer/palm.ics, as shown in Fig-
ure 4.3, “Dialog Showing the Path to a KOrganizer Calendar File” (page 54).

Figure 4.3 Dialog Showing the Path to a KOrganizer Calendar File

KOrganizer should not be running when data is being exchanged with the handheld.
Otherwise KPilot fails to carry out the sync operation.

4.5 Working with KPilot
Synchronizing the data of KDE applications with those of the handheld computer is
easy. Simply start KPilot then press the HotSync button on the cradle or cable to initiate
the sync operation.
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Figure 4.4 The Main Window of KPilot

4.5.1 Backing Up Data from the Handheld
To do a full backup, select File → Backup. The backup is performed during the next
sync operation. After that, switch back by selecting File → HotSync from the menu.
Otherwise, the time-consuming full backup will be performed again during the next
sync operation.

After a full backup, all copies of the handheld's programs and databases are found in
~/.kde/share/apps/kpilot/DBBackup/USERNAME, where USERNAME is
the name of the user registered on the handheld.

The two built-in KPilot viewers can be used for a quick lookup of addresses or memos,
but they are not designed to actually manage this data. The KDE applications mentioned
above are much more suited for these tasks.
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4.5.2 Installing Programs on the Handheld
The File Installermodule is an interesting and useful tool for the installation of handheld
programs. These programs normally have the extension .prc and they are ready to
start immediately after uploading them to the handheld. Before using such add-on pro-
grams, read their licenses as well as the instructions included.
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5Using Beagle
Beagle is a search tool that indexes your personal information space to help you find
whatever you are looking for. You can use Beagle to find documents, e-mails, Web
history, IM/ITC conversations, source code, images, music files, applications, and much
more.

Beagle supports the following data sources:

• File system

• Application launchers

• Evolution mail and address book

• Gaim instant messaging logs

• Firefox Web pages (as you view them)

• Blam and Liferea RSS aggregators

• Tomboy notes

It also supports the following file formats:

• OpenOffice.org

• Microsoft Office (doc, ppt, xls)

• HTML
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• PDF

• Images (jpeg, png)

• Audio (mp3, ogg, flac)

• AbiWord

• Rich Text Format (rtf)

• Texinfo

• Man pages

• Source code (C, C++, C#, Fortran, Java, JavaScript, Pascal, Perl, PHP, Python)

• Plain text

Beagle automatically indexes everything in your home directory, but you can choose
to exclude certain files or directories. Beagle also includes a variety of tools that you
can use to search your data.

5.1 Indexing Data
The Beagle daemon (beagled) automatically performs all indexing. By default, ev-
erything in your home directory gets indexed. Beagle detects changes made to your
home directory and reindexes the data accordingly.

• Files are immediately indexed when they are created, reindexed when they are
modified, and dropped from the index when they are deleted.

• E-mails are indexed upon arrival.

• IM conversations are indexed as you chat, one line at a time.

Indexing your data requires a fair amount of computing power, but the Beagle daemon
tries to be as unobtrusive as possible. It contains a scheduler that works to prioritize
tasks and control CPU usage, based on whether you are actively using your workstation.
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5.1.1 Preventing Files and Directories from
Being Indexed

To prevent a directory (and all of its subdirectories) from being indexed, create an
empty file named .noindex and place it in the directory. Add a list of files and direc-
tories to the .noindex file to prevent those files and directories from being indexed.
Wild cards are permitted in the .noindex file.

You can also put a .neverindex file in your home directory with a list of files that
should never be indexed. Wild cards are also allowed in this file. Use the same wild
cards as you use for glob (for example, f*le??.txt). You can also use more powerful
regular expressions by adding a forward slash both before and after your pattern (for
example, /file.*.txt/). For more information, see http://docs.python.org/
lib/module-glob.html.

5.1.2 Indexing Manually
Beagle is smart about how it determines when to index your files and it tries to not in-
terfere with other running applications. It intentionally times its indexing based on load
and whether your system is idle to avoid adversely affecting your desktop experience.
To index your home directory right away, enter the following commands in a terminal
window:
export BEAGLE_EXERCISE_THE_DOG=1
beagled --replace --bg

5.1.3 Checking the Status of Your Index
Beagle includes the following commands to let you see the current indexing status:

beagle-index-info
Displays how many documents have been indexed and what type of documents
have been indexed.

beagle-status
Displays the current work the Beagle daemon is doing (on an ongoing basis).
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5.2 Searching Data
Beagle offers several tools that let you search through the data that you have indexed.

5.2.1 Desktop Search
Desktop Search is a graphical tool that searches through your indexed information.
Desktop Search does not query the index directly. It passes the search terms to the
Beagle daemon, which sends any matches back to the tool. The search tool then renders
the results and allows you to perform actions on the matching objects. To start Desktop
Search, press Alt + F2 and enter beagle-search.

To use Desktop Search, simply type your search text in the entry box at the top then
press Enter or click Find. Desktop Search queries your indexed files and returns the
results.

Figure 5.1 Beagle Search

You can use the results list to open a file, mail a file, send an instant message, forward
a file, or display a file in your file manager. The options available for each file depend
on the type of file it is.
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You can also use items in Search to limit your search to files in a specific location, such
as your address book or Web pages, or to display only a specific type of file in your
results list.

5.2.2 beagle-query
Beagle has a command line tool you can use to search your Beagle index. To use this
tool, enter beagle-query search in a terminal window.

Replace search with the text to find. The beagle-query tool returns results. You can
use wild cards with this command. Use beagle-query --verbose search to
display detailed information about the search results.

Figure 5.2 Using the beagle-query Command
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6Managing Internet Connections
with KInternet
To surf the Internet or send and receive e-mail messages, connect a modem or an ISDN
or ethernet card to your machine and configure it. This can be done with the help of
the YaST system assistant.

If you do not use NetworkManager and do use KDE, manage your Internet connections
with KInternet. The program checks whether an Internet connection can be established.
If this is possible, the application icon, a plug, automatically appears in the right section
of the KDE panel. Depending on the state of the network connection, the panel icon
changes appearance:

Currently there is no connection to the Internet.

The connection is being established or terminated.

The connection has been established.

Data is being transmitted to or from the Internet.
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An error has occurred. If a connection has already been configured with YaST, use
View Log to identify the reason for the error. Access the menu by right-clicking
the KInternet icon.

The connection is not yet active, but will be established as soon as a request is
made.

Right-click the KInternet panel icon to access its configuration menu. Start the YaST
configuration dialog with Settings → Configure with YaST. After entering the root
password, YaST starts. Depending on the access type, start the modem, ISDN, network,
or DSL configuration of YaST.

If you are using an ISDN connection and selected Channel Bundling in YaST, add a
second ISDN channel to an existing connection with Add link. This doubles the transfer
rate (although at a higher price). Activate channel bundling if you need to download
large files. The activated channel bundling is evident from the red plus symbol at the
top left corner of the KInternet icon.

If your computer has more than one network device and you have configured all of
them with YaST, you can use the KInternet option Interface to switch between these
interfaces. You must have selectedUser Controlled device activation in the appropriate
YaST network dialog to do this. If you have multiple providers as well, choose them
using Provider in KInternet. Providers are also set in YaST.

To establish Internet connections automatically, use dial on demand (DoD). If this
mode is selected, KInternet automatically connects to your Internet service provider
(ISP) as soon as a request is submitted. After a certain time-out, the connection is ter-
minated. A DoD connection is evident from the blue D at the bottom right corner of
the KInternet icon.

WARNING: Cost Control

Note that DoD only makes sense if you have a flat rate Internet account. If that
is not the case, connecting and disconnecting all the time can become very
costly.
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To use a wireless network card as your connection to the Internet, configure it using
YaST as described in Reference and make sure that the device activation in YaST is
set to User Controlled. As soon as the interface is configured, you can use KInternet
to control your wireless network connection, just as you would for normal network in-
terfaces.

To access the WLAN functionality of KInternet, right-click the icon to open the menu.
Select Wireless Connection and a window showing two tabs opens. First, scan for
suitable wireless networks to which to connect. Select the tab Scan forWireless Networks
and start the scan with Start Scan. For KInternet to continuously scan the network en-
vironment, also select Auto Refresh. Activate acoustic feedback for each connection
found with Acoustic Scan. Any connection found is displayed in the list window. Select
one and click Connect to connect to the selected network. If additional configuration
efforts are needed to connect to the selected network, click Start YaST to launch the
YaST network module for wireless network devices.

The Current Connection tab allows you to monitor the state of your current wireless
connection. The left-hand view of this tab offers a summary of all connection parameters
for network address and ESSID, signal quality, signal and noise level, channel frequency
and speed, and encryption parameters, such as type of encryption and key length. Select
any of these parameters in the tree structure and see the details displayed in the right
part of the window.
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7The Web Browser Konqueror
Konqueror is not only a versatile file manager. It is also a modern Web browser. If you
start the browser with the icon in the panel, Konqueror opens with the Web browser
profile. As a browser, Konqueror offers tabbed browsing, the possibility of saving Web
pages with graphics, Internet keywords, bookmarks, and support for Java and JavaScript.

Figure 7.1 The Browser Window of Konqueror
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Start Konqueror from the main menu or by entering the command konqueror. To
load a Web page, enter its address in the location bar, for example, http://www
.suse.com. Konqueror now tries to reach the address and display the page. Entering
the protocol at the beginning of the address (http:// in this case) is not strictly re-
quired. The program is able to complete the address automatically, but this only works
reliably with Web addresses. For an FTP address, always enter ftp:// at the beginning
of the input field.

7.1 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window. The ad-
vantage is that you keep more control over your desktop because you only have one
main window. After logout, the KDE session management allows for saving your Web
session in Konqueror. The next time you log in, Konqueror loads the exact URLs visited
last time.

To open a new tab, select Window → New Tab or press Ctrl + Shift + N . To change
the behavior of tabs, go to Settings → Configure Konqueror. In the dialog box that
opens, selectWeb Behavior→ Tabbed Browsing. To open new tabs instead of windows,
enable Open links in new tab instead of in new window. You can also hide the tab bar
with Hide the tab bar when only one tab is open. To see more options, press Advanced
Options.

7.2 Automatic Scrolling
In general, scrolling with the mouse is the normal way to view information farther down
a Web page. However, there are sometimes occasions when it is preferable not to use
a mouse. It can be very convenient to use key combinations instead of removing hands
from the keyboard.

To scroll down automatically, use Shift + ↓ . This scrolls down the page without
further intervention. Increase the speed by pressing Shift + ↓ again. Pressing Shift
+ ↑ slows down. To stop scrolling, use ↓ .
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7.3 Profiles
Section 7.1, “Tabbed Browsing” (page 70) described how to handle tabs in Konqueror.
You can save your tabs with URLs and the position of the window in a profile. This
differs from the session management already mentioned. With profiles, your saved tabs
are at hand without the intensive start-up time of session management.

To create a profile, do the following:

1 Go to Settings → Configure View Profiles.

2 In the dialog box that appears, insert a name in Profile name.

3 To save your URLs, select Save URLs in profile.

4 To freeze the position and size of the windows, select Save window size in profile.

5 Approve with Save.

The next time you need your tab collection, go to Settings → Load View Profile and
find the name listed in the menu. After you select it, Konqueror restores your tabs.

7.4 Saving Web Pages and Graphics
As in other browsers, you can save Web pages. To do this, select Location → Save as
and specify a name for your HTML file. However, images are not saved. To archive
an entire Web page including the images, select Tools→ Archive Web Page. Konqueror
suggests a filename that you can usually accept. The filename ends with .war, the
extension for Web archives. To view the saved Web archive later, simply click the re-
spective file and the Web page is displayed in Konqueror along with its images.
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7.5 Searching with Konqueror
Searching with Konqueror is very convenient. You can use the search bar or Web
shortcuts.

7.5.1 Using the Search Bar
Konqueror contains a search bar where you can choose from many search engines. If
you want to search for a specific term, proceed as follows:

1 Start Konqueror.

2 Locate the search bar. It is on the right side after the location bar.

3 Click the icon inside the search bar. Choose a search engine from the pop-up
menu.

4 Insert your search term and press Enter . The result is displayed in Konqueror.

If you need a search engine that is not listed in the pop-up menu, add it as follows:

Procedure 7.1 Adding More Search Engines

1 Start Konqueror.

2 Click the icon in the search bar.

3 Choose Select Search Engines.

4 Make sure that Enable Web shortcuts is activated.

5 Enable the respective search engine and close the dialog with Ok. You can see
your selected search engine if you click the icon in the search bar.
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7.5.2 Using Web Shortcuts
Each search engine defined is attached to a web shortcut. This shortcut can be entered
in the location bar.

To see which are already defined, go to Settings → Configure Konqueror → Web
Shortcuts. You can see the names of the search providers and the shortcuts. Konqueror
defines many search engines: Google, Yahoo, and Lycos, and a number of less common
resources, like an acronym database, the Internet movie database, and KDE application
searches.

If you do not find your preferred search engine here, easily define a new one. For ex-
ample, to search our support database for some interesting articles, normally go to
http://portal.suse.com/, find the search page, and enter your query. This
can be simplified

Procedure 7.2 Creating New Web Shortcuts

1 Go to the search bar, click the icon, and select Select Search Engines.

2 Make sure that Enable Web Shortcuts is activated.

3 Click New.

4 Create a new Web shortcut:

a Assign your Web shortcut a name in Search provider name.

b Enter the search URI. Pressing Shift + F1 and clicking in the field opens
a small help. The search query is specified as \{@}. The challenge is insert-
ing this at the correct position. For example, if you want to search in the
SUSE Support Database, usehttps://portal.suse.com/PM/page/
search.pm?q=\{@}&t=optionSdbKeywords&m=25&l=en&x=
true.

c Enter your abbreviations in URI shortcuts. There can more than one, sepa-
rated by commas.

5 Proceed with Ok.
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TIP: Using Shortcuts Directly without Opening Konqueror

You do not need to open Konqueror and enter the Web shortcut. It is also
possible to call it directly. Select Run command from the main menu or press
Alt + F2 . After the dialog box appears, enter your shortcut with the search
term.

After creating a new Web shortcut, for example, sdb_en, you can use this in the loca-
tion bar. The result is displayed in the current window.

7.6 Bookmarks
Instead of remembering and reentering addresses for sites visited often, you can book-
mark these URLs using the Bookmark menu. As well as Web page addresses, you can
also bookmark any directories of your local disk in this way.

To create a new bookmark in Konqueror, click Bookmarks → Add Bookmark. Any
bookmarks added previously are included as items in the menu. It is a good idea to ar-
range the bookmark collection by subjects in a hierarchical structure, so that you do
not lose track of the different items. Create a new subgroup for your bookmarks with
New Bookmark Folder. Selecting Bookmarks → Edit Bookmarks opens the bookmark
editor. Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape, Mozilla, or Firefox as additional browsers, it is not necessary
to recreate your bookmarks. File → Import → Import Netscape Bookmarks in the
bookmark editor enables you to integrate your Netscape and Mozilla bookmarks into
your most current collection. The reverse is also possible via Export as Netscape
Bookmarks.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which
to select the desired action (cut, copy, delete, etc.). When you are satisfied with the result,
save the bookmarks with File → Save. If you only want to change the name or link,
just right-click the entry in the bookmark toolbar and select Properties. Change the
name and location and confirm with Update.

To save your bookmark list and have instant access to it, make your bookmarks visible
in Konqueror. Select Settings → Toolbars → Bookmark Toolbar (Konqueror). A
bookmark panel is automatically displayed in the current Konqueror window.
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7.7 Java and JavaScript
Do not confuse these two languages. Java is an object-oriented, platform-independent
programming language from Sun Microsystems. It is frequently used for small programs
(applets), which are executed over the Internet for things like online banking, chatting,
and shopping. JavaScript is an interpreted scripting language mainly used for the dy-
namic structuring of Web pages, for example, for menus and other effects.

Konqueror allows you to enable or disable these two languages. This can even be done
in a domain-specific way, which means that you can permit access for some hosts and
block access for others. Java and JavaScript are often disabled for security reasons.
Unfortunately, some Web pages require JavaScript for correct display.

7.8 Enabling Advertisment Blockers
Some Web pages open annoying advertisments. With the help of Konqueror, these
windows can be blocked. Proceed as follows:

Procedure 7.3 Blocking Annoying Advertisments

1 Start Konqueror.

2 Go to Settings → Configure Konqueror → AdBlock Filter.

3 Activate Enable filters.

4 Click Insert.

5 Enter an expression for the Web page to filter. For example:
http://www.example.com/*

This filters everything that comes from that URL.
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7.9 For More Information
For any questions or problems that arise when working with Konqueror, refer to the
application's handbook, which is available from the Help menu. Konqueror also has a
Web page, located at http://www.konqueror.org.
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8The Web Browser Firefox
Included with your SUSE Linux is the Mozilla Firefox Web browser. With features
like tabs, pop-up window blocking, and download and image management, Firefox
combines the latest Web technologies. You can view more than one Web page in a
single window. You can suppress annoying advertisements and disable images that
only slow you down. Its easy access to different search engines helps you find the in-
formation you need. Start the program from the main menu or by entering the command
firefox. The main program features are described in the following sections.

8.1 Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 8.1,
“The Browser Window of Firefox” (page 78). The navigation toolbar includesForward
and Back and a location bar for a Web address. Bookmarks are also available for quick
access. For more information about the various Firefox features, use the Help menu.
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Figure 8.1 The Browser Window of Firefox

8.1.1 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select File → New Tab. This opens an empty tab in the Firefox
window. Alternatively, right-click a link and select Open link in new tab. Right-click
the tab itself to access more tab options. You can create a new tab, reload one or all
existing tabs, or close them. You can also change the sequence of the tabs by dragging
and dropping them on a requested position.
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8.1.2 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the Sidebar,
select View → Sidebar and select the desired contents.

8.2 Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The
search bar looks for pages while the find bar looks for things on the current page.

8.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about SUSE using the current
engine, click in the search bar, type SUSE, and hit Enter . The results appear in your
window. To choose your search engine, click the icon in the search bar. A menu opens
with a list of available search engines.

8.2.2 Installing a Different Search Engine
If you favorite search engine is not listed, Firefox gives you the possibility to configure
it. Try the following steps:

1 Establish an Internet connection first.

2 Click in the search bar on the icon.

3 Select Add Engines from the menu.

4 Firefox displays a Web page with available search engines. It is also sorted by
categories. You can choose from Wikipdedia, Leo, and others. Click the desired
search plug-in.

5 Install your search plug-in with Ok or abort with Cancel.
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8.2.3 Searching in the Current Page
To search inside a Web page, click Edit → Find in This Page or press Ctrl + F . The
find bar opens. Usually, it is displayed at the bottom of a window. Type your query in
the input field. Firefox finds the first occurence of this phrase. You can find other oc-
curences of the phrase by pressing F3 or Find Next button in the find bar. You can
also highlight all occurences by pressing the Highlight all button.

8.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. To add
the current Web site to your list of bookmarks, click Bookmarks → Bookmark This
Page. If your browser currently displays multiple Web sites on tabs, only the URL on
the currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and
select a folder where Firefox should store it. To bookmark Web sites on multiple tabs,
select Bookmark All Tabs. Firefox creates a new folder that includes bookmarks of each
site displayed on each tab. To remove a Web site from the bookmarks list, click Book-
marks, right-click the bookmark in the list, then click Delete.

8.3.1 Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address loca-
tion) for each bookmark and organize the bookmarks into folders and sections. It resem-
bles Figure 8.2, “Using the Firefox Bookmark Manager” (page 81).
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Figure 8.2 Using the Firefox Bookmark Manager

To open the bookmark manager, click Bookmark → Manage Bookmarks. A window
opens and displays your bookmarks. With New Folder, create a new folder with a name
and a description. If you need a new bookmark, click New Bookmark. This lets you
insert the name, location, keywords, and also a description. The keyword is a shortcut
to your bookmark. If you need your newly created bookmark in the sidebar, check Load
this bookmark in the sidebar.

8.3.2 Importing Bookmarks from Other
Browsers

If you used a different browser in the past, you probably want to use your preferences
and bookmarks in Firefox, too. At the moment, you can import from Netscape 4.x, 6,
7, Mozilla 1.x, and Opera.

To import your settings, click File → Import. Select the browser from which to import
settings. After you clickNext, your settings are imported. Find your imported bookmarks
in a newly created folder, beginning with From.
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8.3.3 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites.

Many sites and blogs support this format. A Web site indicates this by showing an orange
icon in the right part of the location bar. Click it and choose Add NAMEOF THE FEED
as Live Bookmark. A dialog box opens where you can select the name and location of
your live bookmark. Confirm with Add.

Some sites do not tell Firefox that they support a news feed, although they actually do.
To add a live bookmark manually, you need the URL of the feed. Do the following:

Procedure 8.1 Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks → Manage Bookmarks. A new
window opens.

2 Select File → New Live Bookmark. A dialog box opens.

3 Insert a name for the live bookmark and add your URL, for example, http://
www.novell.com/newsfeeds/rss/coolsolutions.xml. Firefox
updates your live bookmarks.

4 Close your bookmark manager.

8.4 Using the Download Manager
With the help of the download manager, keep track of your current and past downloads.
To open the download manager, click Tools → Downloads. Firefox opens a window
with your downloads. While downloading a file, see a progress bar and the current file.
If necessary, pause a download and resume it later. To open a downloaded file, click
Open. With Remove, remove it from the list. If you need information about the file,
right-click the filename and choose Properties.
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If you need further control of the download manager, open the configuration window
from Edit → Preferences and go to the Downloads tab. Here, determine the download
folder, how the manager behaves, and some configuration of file types.

8.5 Customizing Firefox
Firefox can be customized extensively. You can install extensions, change themes, and
add smart keywords for your online searches.

8.5.1 Extensions
Mozilla Firefox is a multifunctional application, which means that you can download
and install add-ons, known as extensions. For example, add a new download manager
and mouse gestures. This has the advantage that Firefox itself stays small and unbloated.

To add an extension, click Tools → Extensions. In the bottom-right corner, click Get
More Extensions to open the Mozilla extensions update Web page where you can choose
from a variety of available extensions. Click the extension to install then click the install
link to download and install it. When you restart Firefox, the new extension is functional.
You can also look at the various extensions at http://addons.mozilla.org/
.

Figure 8.3 Installing Firefox Extensions
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8.5.2 Changing Themes
If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser. When installing a
theme, Firefox asks for confirmation first. Allow the installation or cancel it. After a
successful installation, you can enable the new theme.

1 Click Tools → Themes.

2 In the new dialog that appears, click Get More Themes. If you already installed
a theme, find it in the list, as in Figure 8.4, “Installing Firefox Themes” (page 84).

Figure 8.4 Installing Firefox Themes

3 A new window appears with the Web sitehttps://addons.mozilla.org.

4 Choose a theme and click Install Now.

5 Confirm the download and installation.

6 After downloading the theme, a dialog appears and informs you about your list
of themes. Activate the new theme with Use Theme.

7 Close the window and restart Firefox.
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If a theme is installed, you can always switch to a different theme without restarting
by clicking Tools → Themes then Use Theme. If you do not use a theme anymore, you
can delete it in the same dialog with Uninstall.

8.5.3 Adding Smart Keywords to Your
Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox
lets you define your own smart keywords: abbreviations to use as a “command” for
searching the Web. For example, if you use Wikipedia often, use a smart keyword to
simplify this task:

1 Go to http://en.wikipedia.org.

2 After Firefox displays the Web page, see the search text field. Right-click it then
choose Add a Keyword for this Search from the menu that opens.

3 The Add Bookmark dialog appears. In Name, name this Web page, for example,
Wikipedia (en).

4 For Keyword, enter your abbreviation of this Web page, for example, wiki.

5 With Create in, choose the location of the entry in your bookmarks section. You
can put it into Quick Searches, but any other level is also appropriate.

6 Finalize with Add.

You have successfully generated a new keyword. Whenever you need to look into
Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an
entry about Linux.

8.6 Printing from Firefox
Configure the way Firefox prints the content it displays using the Page Setup dialog.
Click File → Page Setup then go to the Format & Options tab to select the orientation
of your print jobs. You can scale or make it adjust automatically. To print a background,
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select Print Background (colors & images). Click the Margins & Header/Footer tab
to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with File → Print. Select the
printer or a file in which to save the output. With Properties, set the paper size, specify
the print command, choose grayscale or color, and determine the margins. When satisfied
with your settings, approve with Print.

8.7 For More Information
Get more information about Firefox from the official home page at http://www
.mozilla.com/firefox/. Refer to the integrated help to find out more about
certain options or features.
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9The KGet Download Manager
KGet is the download manager for KDE. It manages your transfers in a window. You
can stop, resume, delete, queue, and add transfers. Start KGet from the main menu or
by pressing Alt + F2 then entering kget.

When KGet is started for the first time, you can choose to have it integrated with Kon-
queror. If you integrate KGet with Konqueror, KGet is added to the system tray as an
icon with a downward arrow. Click this arrow to view KGet transfers.

Figure 9.1 KGet

9.1 Adding Transfers to the List
To add a transfer, click File → Paste. Specify a URL then click OK. Finally, select
where to save the downloaded file. The entry for the transfer is added to the main window
of KGet and the download starts. Another way to add a transfer is to simply drag a file
(for example, from an FTP server) from Konqueror and drop it in the main KGet window.
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Modify the preferences for your downloads by clicking Settings → Configure KGet.

9.2 Timer-Controller Transfers
You can configure KGet to perform transfers at a specific time.

1 Start KGet.

2 Click Options → Offline Mode. All transfers inserted from this point are not
started immediately but are queued.

3 To start the clock, double-click the entry then click Advanced.

4 Enter the day, month, year, and time to start the transfer, click the Timer icon,
then close the dialog.

5 After making the desired settings for all your transfers, click Options → Offline
Mode to set KGet back in online mode.

The transfers should start at the specified times.
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10Getting News with Akregator
If you want to get the latest news, get your information with a news feed reader. One
reader is Akregator. It connects to a server that contains a newsticker file and downloads
it then shows the headlines and sometimes a small text to give an overview. See Fig-
ure 10.1, “Akregator Showing Some News” (page 89). If interested in this news, click
it and view it in a separate tab.

Figure 10.1 Akregator Showing Some News

Akregator contains some predefined news feeds for KDE. You can add news feeds
manually or some Web sites announce it. For example, a Web site with feed support
contains an orange rectangle in the bottom right corner. Click it to open a pop-up menu
where you can select Add Feed to Akregator. Sometimes a Web site does not announce
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that it supports a news feed. Then you can search this site with some keywords like
feed or rss. Sometimes you are successful and can obtain a link.

To add a news feed, do the following:

Procedure 10.1 Adding a News Feed to Akregator

1 Determine the URL of your news feed. Normally this can be found on your pre-
ferred Web site. More links can be found in the KNewsticker tool, an applet for
the KDE panel.

2 Open Akregator by pressing Alt + F2 and entering akregator. It opens a
new window with the list of all feeds in your configuration. If you close this
window, it docks in the system tray.

3 Create a new folder with Feed → New Folder. This gives you the opportunity
to group your feeds in categories.

4 Name your new folder.

5 Click this folder and choose Feed → Add Feed.

6 Insert the feed URL, for example,http://www.novell.com/newsfeeds/
rss/coolsolutions.xml. A new window opens where you can change
the feed name, URL, or the update interval. With the Feed Archive tab, change
how long articles should be stored.

7 Proceed with Ok. Akregator downloads the latest articles.

After the download of the latest headers is finished, you can click an entry. Depending
on the feed, this can list a small summary or just a link. With Complete Story, read the
entire article.

Check for new news manually with Fetch Feed. Another option is to specify an update
interval. Configure this by clicking Settings → Configure Akregator. A window opens
where you can select the interval in General → Use interval fetching. Confirm with
Ok.

You can read the complete story in Akregator or an external browser. ClickingComplete
Story lets you select which.
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11Chatting with Friends: Kopete
Kopete is an online messenger application allowing multiple partners connected to the
Internet to chat with each other. Kopete currently supports all common messenger
protocols, such as ICQ, MSN, Yahoo, SMS, Jabber, and IRC.

11.1 Configuring Kopete
Configure Kopete by entering your personal user data. Click Settings → Configure
Kopete. With Accounts, enter your user data. You must register with a provider offering
instant messaging services before using such service. ClickNew to open a configuration
assistant that can assist you in completing your user profile.

The next step lists the available messaging services. Select the service with which you
have registered and click Continue. Then enter the user data received on registration
with the messaging service. This usually consists of the nickname or e-mail address
and a password. Complete the configuration of the messenger account by clicking
Finish.
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Figure 11.1 Kopete Configuration Panels

The next item in the configuration dialog is Appearance. It influences how Kopete is
displayed. Emoticons provides a selection of various types of smileys.

Use Chat window and Colors & Fonts to adjust the appearance of the chat windows
for communication with other participants. Choose from the classic themes of the cor-
responding providers or create a custom theme by adjusting the font or color to your
preferences.

11.2 Adding Contacts
Add contacts to chat with them. If you have already created an account on another PC,
this data is imported and automatically added to your contact list. To create a contact
entry manually, click File→ Add Contact. A new assistant appears to help with creation.
However, you must be online and connect with Kopete to the selected messaging service
to add a contact to your list.

11.3 Adding Groups
Access this with File → Create New Group. Name the group and confirm this with
OK. A new folder appears in the contact list that can be used to store the desired contacts.
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Drag and drop contacts into the desired folder. Grouping contacts can give a better
overview.

Figure 11.2 The Main Kopete Window

Empty groups can be disabled by activating Settings → Hide Empty Groups.

11.4 Using Kopete
It is necessary to establish a connection to the Internet to be able to chat with other
participants. When this is done, you should set your status by clicking File→ Set Status
→ Online. This establishes a connection between Kopete and the selected messaging
service. After the successful login, you are visible to others.

The main application windows features a list of contacts. You must have contacts to
chat with others (see Section 11.2, “Adding Contacts” (page 92) for more information).
When you right-click a contact marked as online, a menu opens with various options.
Send that person a message or start a chatting session. A chat allows invitation of addi-
tional participants for real-time discussion. Connection to all participants is closed when
the creator of the chat session closes it.

If you want to see your former chatting session, select a contact and go to Edit → View
History. This menu item opens a dialog where you can search and view your chatting
sessions with this person.

Chatting with Friends: Kopete 93



You can view other options by right-clicking a username. A pop-up menu opens. An
important option is Start Chat to start a chatting session. With Rename Contact and
Remove Contact, you can run the respective action. The pop-up menu also contains a
submenu item with the username where you can block the user or get user information.
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12Linphone—VoIP for the Linux
Desktop
Linphone is a small Web phone application for your Linux desktop. It allows you to
make two-party calls over the Internet. There is no need for special hardware items: a
standard workstation with a properly configured sound card, microphone, and speakers
or headphones is all you need to get started with Linphone.

12.1 Configuring Linphone
Before you start using Linphone there are some basic decisions to make and some
configuration tasks to complete. First, determine and configure the run mode of Lin-
phone, determine the connection type to use, then start the Linphone configuration (Go
→ Preferences) to make the necessary adjustments.

12.1.1 Determining the Run Mode of
Linphone

Linphone can be run in two different different modes, depending on the type of desktop
you run and on its configuration.

Normal Application
After the Linphone software has been installed, it can be started via the GNOME
and KDE application menus or via the command line. When Linphone is not run-
ning, incoming calls cannot be received.
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GNOME Panel Applet
Linphone can be added to the GNOME panel. Right-click an empty area in the
panel, select Add to Panel, and select Linphone. Linphone is then permanently
added to the panel and automatically started on login. As long as you do not receive
any incoming calls, it runs in the background. As soon as you get an incoming call,
the main window opens and you can receive the call. To open the main window to
call someone, just click the applet icon.

12.1.2 Determining the Connection Type
There are several different ways to make a call in Linphone. How you make a call and
how you reach the other party is determined by the way you are connected to the network
or the Internet.

Linphone uses the session initiation protocol (SIP) to establish a connection with a re-
mote host. In SIP, each party is identified by a SIP URL:
sip:username@hostname

username is your login on your Linux machine and hostname the name of the
computer you are using. If you use a SIP provider, the URL would look like the follow-
ing example:
sip:username@sipserver

username is the username chosen when registering at a SIP server. sipserver is
the address of the SIP server or your SIP provider. For details on the registration proce-
dure, refer to Section 12.1.5, “Configuring the SIP Options” (page 99) and check the
provider's registration documentation. For a list of providers suitable for your purpose,
check the Web pages mentioned in Section 12.8, “For More Information” (page 105).

The URL to use is determined by the type of connection you choose. If you chose to
call another party directly without any further routing by a SIP provider, you would
enter a URL of the first type. If you chose to call another party via a SIP server, you
would enter a URL of the second type.

Calling in the Same Network
If you intend to call a friend or coworker belonging to the same network, you just need
the correct username and hostname to create a valid SIP URL. The same applies if this
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person wants to call you. As long as there is no firewall between you and the other
party, no further configuration is required.

Calling across Networks or the Internet (Static IP
Setup)
If you are connected to the Internet using a static IP address, anyone who wants to call
you just needs your username and the hostname or IP address of your workstation to
create a valid SIP URL, as described in Section “Calling in the Same Network”
(page 96). If you or the calling party are located behind a firewall that filters incoming
and outgoing traffic, open the SIP port (5060) and the RTP port (7078) on the firewall
machine to enable Linphone traffic across the firewall.

Calling across Networks or the Internet (Dynamic IP
Setup)
If your IP setup is not static—if you dynamically get a new IP address every time you
connect to the Internet—it is impossible for any caller to create a valid SIP URL based
on your username and an IP address. In these cases, either use the services offered by
a SIP provider or use a DynDNS setup to make sure that an external caller gets connected
to the right host machine. More information about DynDNS can be found at http://
en.wikipedia.org/wiki/Dynamic_DNS.

Calling across Networks and Firewalls
Machines hidden behind a firewall do not reveal their IP address over the Internet. Thus,
they cannot be reached directly from anyone trying to call a user working at such a
machine. Linphone supports calling across network borders and firewalls by using a
SIP proxy or relaying the calls to a SIP provider. Refer to Section 12.1.5, “Configuring
the SIP Options” (page 99) for a detailed description of the necessary adjustments for
using an external SIP server.

12.1.3 Configuring the Network Parameters
Most of the settings contained in the Network tab do not need any further adjustments.
You should be able to make your first call without changing them.
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NAT Traversal Options
Enable this option only if you find yourself in a private network behind a firewall
and if you do not use a SIP provider to route your calls. Select the check box and
enter the IP address of the firewall machine in dot notation, for example,
192.168.34.166.

RTP Properties
Linphone uses the real-time transport protocol (RTP) to transmit the audio data of
your calls. The port for RTP is set to 7078 and should not be modified, unless you
have another application using this port. The jitter compensation parameter is used
to control the number of audio packages Linphone buffers before actually playing
them. By increasing this parameter, you improve the quality of transmission. The
more packages buffered, the greater a chance for “late comers” to be played back.
On the other hand increasing the number of buffered packages also increases the
latency—you hear the voice of your counterpart with a certain delay. When
changing this parameter, carefully balance these two factors.

Other
If you use a combination of VoIP and landline telephony, you might want to use
the dual tone multiplexed frequency (DTMF) technology to trigger certain actions,
like a remote check of your voice mail just by punching certain keys. Linphone
supports two protocols for DTMF transmission, SIP INFO and RTP rfc2833. If
you need DTMF functionality in Linphone, choose a SIP provider that supports
one of these protocols. For a comprehensive list of VoIP providers, refer to Sec-
tion 12.8, “For More Information” (page 105).

12.1.4 Configuring the Sound Device
Once your sound card has been properly detected by Linux, Linphone automatically
uses the detected device as the default sound device. Leave the value ofUse sound device
as it is. Use Recording source to determine which recording source should be used. In
most cases, this would be a microphone (micro). To select a custom ring sound, use
Browse to choose one and test your choice using Listen. Click Apply to accept your
changes.
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12.1.5 Configuring the SIP Options
The SIP dialog contains all SIP configuration settings.

SIP Port
Determine on which port the SIP user agent should run. The default port for SIP
is 5060. Leave the default setting unchanged unless you know of any other appli-
cation or protocol that needs this port.

Identity
Anyone who wants to call you directly without using a SIP proxy or a SIP provider
needs to know your valid SIP address. Linphone creates a valid SIP address for
you.

Remote Services
This list holds one or more SIP service providers where you have created a user
account. Server information can be added, modified, or deleted at any time. See
Adding a SIP Proxy and Registering at a Remote SIP Server (page 99) to learn
about the registration procedure.

Authentication Information
To register at a remote SIP server, provide certain authentication data, such as a
password and username. Linphone stores this data once provided. To discard this
data for security reasons, click Clear all stored authentification data.

The Remote services list can be filled with several addresses of remote SIP proxies or
service providers.

Procedure 12.1 Adding a SIP Proxy and Registering at a Remote SIP Server

1 Choose a suitable SIP provider and create a user account there.

2 Start Linphone.

3 Go to Go → Preferences → SIP.

4 Click Add proxy/registrar to open a registration form.

5 Fill in the appropriate values for Registration Period, SIP Identity, SIP Proxy
and Route. If working from behind a firewall, always select Send registration
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and enter an appropriate value for Registration Period. This resends the original
registration data after a given time to keep the firewall open at the ports needed
by Linphone. Otherwise, these ports would automatically be closed if the firewall
did not receive any more packages of this type. Resending the registration data
is also needed to keep the SIP server informed about the current status of the
connection and the location of the caller. For SIP identity, enter the SIP URL
that should be used for local calls. To use this server also as a SIP proxy, enter
the same data for SIP Proxy. Finally, add an optional route, if needed, and leave
the dialog with OK.

12.1.6 Configuring the Audio Codecs
Linphone supports a several codecs for the transmission of voice data. Set your connec-
tion type and choose your preferred codecs from the list window. Codecs not suitable
for your current connection type are red and cannot be selected.

12.2 Testing Linphone
Check your Linphone configuration using sipomatic, a small test program that can
answer calls made from Linphone.

Procedure 12.2 Testing a Linphone Setup

1 Open a terminal.

2 Enter sipomatic at the command line prompt.

3 Start Linphone.

4 Enter sip:robot@127.0.0.1:5064 as SIP address and click Call or An-
swer.

5 If Linphone is configured correctly, you will hear a phone ringing and, after a
short while, you will hear a short announcement.

If you successfully completed this procedure, you can be sure that your audio setup and
the network setup are working. If this test fails, check whether your sound device is
correctly configured and whether the playback level is set to a reasonable value. If you
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still fail to hear anything, check the network setup including the port numbers for SIP
and RTP. If any other application or protocol uses the defaults ports for these as proposed
by Linphone, consider changing ports and retry.

12.3 Making a Call
Once Linphone is configured appropriately, making a call is straightforward. Depending
on the type of call (see Section 12.1.2, “Determining the Connection Type” (page 96)
for reference), the calling procedures differ slightly.

1 Start Linphone using the menu or a command line.

2 Enter the SIP address of the other party at the SIP address prompt. The address
should look like sip:username@domainname or username@hostname
for direct local calls or likeusername@sipserver oruserid@sipserver
for proxied calls or calls using the service of a SIP provider.

3 If using a SIP service provider or a proxy, select the appropriate proxy or provider
from Proxy to use and provide the authentication data requested by this proxy.

4 Click Call or Answer and wait for the other party to pick up the phone.

5 Once you are done or wish to end the call, click Release or Refuse and leave
Linphone.

If you need to tweak the sound parameters during a call, click Show more to show four
tabs holding more options. The first one holds the Sound options for Playback level
and Recording level. Use the sliders to adjust both volumes to fit your needs.

The Presence tab lets you set your online status. This information can be relayed to
anyone who tries to contact you. If you are permanently away and wish to inform the
calling party of this fact, just check Away. If you are just busy, but want the calling
party to retry, check Busy, I'll be back in ... min and specify how long you will not be
reachable. Once you are reachable again, set the status back to the default (Reachable).
Whether another party can check your online status is determined by the Subscribe
Policy set in the address book, as described in Section 12.5, “Using the Address Book”
(page 102). If any party listed in your address book published their online status, you
can monitor it using the My online friends tab.
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The DTMF tab can be used to enter DTMF codes for checking voice mail. To check
your voice mail, enter the appropriate SIP address and use the keypad in the DTMF tab
to enter the voice mail code. Finally, click Call or Answer as if you were making an
ordinary call.

12.4 Answering a Call
Depending on the run mode selected for Linphone, there are several ways you would
notice an incoming call:

Normal Application
Incoming calls can only be received and answered if Linphone is already running.
You then hear the ring sound on your headset or your speakers. If Linphone is not
running, the call cannot be received.

GNOME Panel Applet
Normally, the Linphone panel applet would run silently without giving any notice
of its existence. This changes as soon as a call comes in: the main window of Lin-
phone opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Call or Answer to pick up the phone
and start talking. If you do not want to accept this call, click Release of Refuse.

12.5 Using the Address Book
Linphone offers to manage your SIP contacts. Start the address book withGo→ Address
book. An empty list window opens. Click Add to add a contact.

The following entries need to be made for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here. Choose something you easily remember this person as. If you
choose to see this person's online status, this name is shown in theMy online friends
tab of the main window.
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SIP Address
Enter a valid SIP address for your contact.

Proxy to Use
If needed, enter the proxy to use for this particular connection. In most cases, this
would just be the SIP address of the SIP server you use.

Subscribe Policy
Your subscribe policy determines whether your presence or absence can be tracked
by others.

To call any contact from the address book, select this contact with the mouse, click
Select to make the address appear in the address field of the main window, and start
the call with Call or Answer as usual.

12.6 Troubleshooting
I try to call someone, but fail to establish a connection.

There are several reasons why a call could fail:

Your connection to the Internet is broken.
Because Liphone uses the Internet to relay your calls, make sure that your
computer is properly connected to and configured for the Internet. This can
easily be tested by trying to view a Web page using your browser. If the Internet
connection works, the other party might not be reachable.

The person you are calling is not reachable.
If the other party refused your call, you would not be connected. If Linphone
is not running on the other party's machine while you are calling, you will not
be connected. If the other party's Internet connection is broken, you cannot
make the connection.

My call seems to connect, but I cannot hear anything.
First, make sure that your sound device is properly configured. Do this by launching
any other application using sound output, such as a media player. Make sure that
Linphone has sufficient permissions to open this device. Close all other programs
using the sound device to avoid resource conflicts.

Linphone—VoIP for the Linux Desktop 103



If the above checks were successful, but you still fail to hear anything, raise the
recording and playback levels under the Sound tab.

The voice output on both ends sounds strangely clipped.
Try to adjust the jitter buffer using RTP properties in Preferences → Network to
compensate for delayed voice packages. When doing this, be aware that it increases
the latency.

DTMF does not work.
You tried to check your voice mail using the DTMF pad, but the connection could
not be established. There are three different protocols used for the transmission of
DTMF data, but only two of these are supported by Linphone (SIP INFO and RTP
rfc2833). Check with your provider whether it supports one of these. The default
protocol used by Linphone is rfc2833, but if that fails you can set the protocol to
SIP INFO in Preferences → Network → Other. If it does not work with either of
them, DTMF transmission cannot be done using Linphone.

12.7 Glossary
Find some brief explanation of the most important technical terms and protocols men-
tioned in this document:

VoIP
VoIP stands for voice over Internet protocol. This technology allows the transmis-
sion of ordinary telephone calls over the Internet using packet-linked routes. The
voice information is sent in discrete packets like any other data transmitted over
the Internet via IP.

SIP
SIP stands for session initiation protocol. This protocol is used to establish media
sessions over networks. In a Linphone context, SIP is the magic that triggers the
ring at your counterpart's machine, starts the call, and also terminates it as soon as
one of the partners decides to hang up. The actual transmission of voice data is
handled by RTP.

RTP
RTP stands for real-time transport protocol. It allows the transport of media streams
over networks and works over UDP. The data is transmitted by means of discrete

104 Applications



packets that are numbered and carry a time stamp to allow correct sequencing and
the detection of lost packages.

DTMF
A DTMF encoder, like a regular telephone, uses pairs of tones to represent the
various keys. Each key is associated with a unique combination of one high and
one low tone. A decoder then translates these touch-tone combinations back into
numbers. Linphone supports DTMF signalling to trigger remote actions, such as
checking voice mail.

codec
Codecs are algorithms specially designed to compress audio and video data.

jitter
Jitter is the variance of latency (delay) in a connection. Audio devices or connection-
oriented systems, like ISDN or PSTN, need a continuous stream of data. To com-
pensate for this, VoIP terminals and gateways implement a jitter buffer that collect
the packets before relaying them onto their audio devices or connection-oriented
lines (like ISDN). Increasing the size of the jitter buffer decreases the likelihood
of data being missed, but the latency of the connection is increased.

12.8 For More Information
For general information about VoIP, check the VoIP Wiki at http://voip-info
.org/tiki-index.php. For a comprehensive list of providers offering VoIP ser-
vices in your home country, refer to http://voip-info.org/wiki-VOIP
+Service+Providers+Residential.
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13Encryption with KGpg
KGpg is an important component of the encryption infrastructure on your system. With
the help of this program, generate and manage all needed keys. Use its editor function
for the quick creation and encryption of files or use the applet in your panel to encrypt
or decrypt by dragging and dropping. Other programs, such as your mail program
(Kontact or Evolution), access the key data to process signed or encrypted contents.
This chapter covers the basic functions needed for daily work with encrypted files.

13.1 Generating a New Key Pair
To be able to exchange encrypted messages with other users, first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can use it to encrypt the files or e-mail messages they send. The other part of the
key pair—the private key—is used to decrypt the encrypted contents.

IMPORTANT: Private Key versus Public Key

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

Start KGpg from the main menu by selecting Utilities → KGpg or enter kgpg on the
command line. When you start the program for the first time, an assistant appears to
guide you through the configuration. Follow the instructions up to the point where you
are prompted to create a key. Enter a name, an e-mail address, and, optionally, a com-
ment. If you do not like the default settings provided, also set the expiration time for
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the key, the key size, and the encryption algorithm used. See Figure 13.1, “KGpg:
Creating a Key” (page 108).

When you start kgpg in later sessions, only a small icon with a padlock appears in the
system tray. Click that icon to display the main kgpg window on your desktop.

Figure 13.1 KGpg: Creating a Key

Confirm your settings withOK. The next dialog prompts you to enter a password twice.
The program then generates the key pair and displays a summary. It is a good idea to
save or print a revocation certificate right away. Such a certificate is needed if you
forget the password for your private key so need to revoke it. After you confirm with
OK, KGpg displays its main window. See Figure 13.2, “The Key Manager” (page 109).
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Figure 13.2 The Key Manager

13.2 Exporting the Public Key
After generating your key pair, make the public key available to other users. This enables
them to use it to encrypt or sign the messages or files they send you. To make the public
key available for others, select Keys → Export Public Key(s). The dialog that opens
offers four options:

Email
Your public key is sent to a recipient of your choice by e-mail. If you activate this
option and confirm with OK, the dialog for creating a new e-mail message with
KMail appears. Enter the recipient and click Send. The recipient receives your key
and can then send you encrypted contents.

Clipboard
You can place your public key here before continuing to process it.

Default Key Server
To make your public key available to a wide audience, export it to one of the key
servers on the Internet. For more information, refer to Section 13.4, “The Key
Server Dialog” (page 111).

File
If you prefer to distribute your key as a file on a data medium instead of sending
it by e-mail, click this option, confirm or change the file path and name, and click
OK.
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13.3 Importing Keys
If you receive a key in a file (for example, as an e-mail attachment), integrate it in your
key ring with Import Key and use it for encrypted communication with the sender. The
procedure is similar to the procedure for exporting keys already described.

13.3.1 Signing Keys
Keys can be signed like every other file to guarantee their authenticity and integrity. If
you are absolutely sure an imported key belongs to the individual specified as the
owner, express your trust in the authenticity of the key with your signature.

IMPORTANT: Establishing a Web of Trust

Encrypted communication is only secure to the extent that you can positively
associate public keys in circulation with the specified user. By cross-checking
and signing these keys, you contribute to the establishment of a web of trust.

Select the key to sign in the key list. Select Keys → Sign Keys. In the following dialog,
designate the private key to use for the signature. An alert reminds you to check the
authenticity of this key before signing it. If you have performed this check, click Con-
tinue and enter the password for the selected private key in the next step. Other users
can now check the signature by means of your public key.

13.3.2 Trusting Keys
Normally, you are asked by the corresponding program whether you trust the key
(whether you assume it is really used by its authorized owner). This happens each time
a message needs to be decrypted or a signature must be checked. To avoid this, edit the
trust level of the newly imported key. By default, a newly imported key is listed with
a white box, meaning that no concrete value has been assigned for the trust level.

Right-click the newly imported key to access a small context menu for key management.
Select Sign Keys from it. KGpg opens a text a message box and asks the user to recheck
the fingerprint of the key. Use Continue to access the key signing dialog.
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Select your trust level, for example, select I Have Done Very Careful Checking. After
finishing this dialog, you need to enter your passphrase to finish the key signing process.
The newly imported key now displays a green trust level for a trusted key.

The trust level of the keys in your key ring is indicated by a colored bar next to the key
name. The lower the trust level is, the less you trust the signer of the key to have checked
the true identity of the keys signed. You may be entirely sure about the signer's identity,
but he may still be lazy in regard to checking other people's identities before signing
their keys. Therefore, you could still trust him and his own key, but assign lower trust
levels to the keys of others that have been signed by him. The trust level's purpose is
solely one of a reminder. It does not trigger any automatic actions by KGpg.

13.4 The Key Server Dialog
Several Internet-based key servers offer the public keys of many users. To engage in
encrypted communication with a large number of users, use these servers to distribute
your public key. For this purpose, export your public key to one of these servers. Simi-
larly, KGpg enables you to search one of these servers for the keys of certain people
and import their public keys from the server. Open the key server dialog with File →
Key Server Dialog.

13.4.1 Importing a Key from a Key Server
By means of the Import tab in the key server dialog, import public keys from one of
the Internet-based key servers. Select one of the preconfigured key servers and enter a
search string (e-mail address of the communication partner) or the ID of the key to find.
When you click Search, your system connects to the Internet and searches the specified
key server for a key that matches your specifications. Refer to Figure 13.3, “Search
Screen for Importing a Key” (page 112).
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Figure 13.3 Search Screen for Importing a Key

If your search on the key server is successful, a list of all retrieved server entries is
displayed in a new window. Select the key to include in your key ring and click Import.
See Figure 13.4, “Hits and Import” (page 112). Confirm the following message with
OK then exit the key server dialog with Close. The imported key then appears in the
main overview of the key manager and is ready for use.

Figure 13.4 Hits and Import
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13.4.2 Exporting Your Keys to a Key Server
To export your key to one of the freely accessible key servers on the Internet, select
the Export tab in the key server dialog. Designate the target server and the key to export
by means of two drop-down menus. Then start the export with Export.

Figure 13.5 Exporting a Key to a Key Server

13.5 Text and File Encryption
KGpg also offers the possibility to encrypt text or clipboard contents. Right-click the
padlock icon and find the options Encrypt clipboard and Decrypt clipboard as well as
the option for opening the integrated editor.

13.5.1 Encrypting and Decrypting the
Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the function
overview by right-clicking the KGpg padlock icon. Select Encrypt Clipboard and des-
ignate the key to use. A status message about the encryption procedure is displayed on
the desktop. The encrypted contents can now be processed from the clipboard as
needed. The decryption of clipboard contents is just as easy. Simply open the menu on
the panel, selectDecrypt Clipboard, and enter the password associated with your private
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key. The decrypted version is now available for processing in the clipboard and in the
KGpg editor.

13.5.2 Encrypting and Decrypting by
Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag
them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg
asks for the key to use. As soon as you select a key, the file is encrypted without any
further messages. In the file manager, encrypted files are designated with the suffix
.asc and the padlock icon. These files can be decrypted by clicking the file icon,
dragging it to the KGpg symbol in the panel, and dropping it there. If the original file-
name already exists, a dialog opens that asks how to name the file or if it should be
overwritten.

13.5.3 The KGpg Editor
Instead of creating contents for encryption in an external editor then encrypting the file
with one of the methods described above, you can use the integrated editor of KGpg
to create the file. Open the editor (Open Editor from the context menu), enter the desired
text, and clickEncrypt. Then select the key to use and complete the encryption procedure.
To decrypt files, use Decrypt and enter the password associated with the key.

Generating and checking signatures on documents is just as easy as encrypting directly
from the editor. Select a file in the file manager and copy it to the clipboard. Right-click
the padlock icon in the panel and select Sign/Verify Clipboard. Then choose the private
key to use and enter the associated password. KGpg informs about the successful gen-
eration of the signature. Files can also be signed from the editor by simply clicking
Sign/Verify. To check a signed file, go to File → Open Editor, load the file to check in
the editor, and click Sign/Verify.
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13.6 For More Information
For theoretical background information about the encryption method, refer to the brief
and clear introduction on the GnuPG project pages at http://www.gnupg.org/
documentation/howtos.html.en. This document also provides a list of further
information sources.
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Part III. Multimedia





14Sound in Linux
Linux includes a wide range of sound and multimedia applications. Some of these ap-
plications are part of one of the main desktop environments. With the applications de-
scribed here, control the volume and balance of playback, play CDs and music files,
and record and compress your own audio data.

14.1 Mixers
Mixers provide a convenient means of controlling the volume and balance of the sound
output and input of computers. The main difference between the various mixers is the
outer appearance of the user interface. However, there are a number of mixers that are
designed for specific hardware. One example is envy24control, a mixer for the Envy 24
sound chip. Another one is hdspmixer, which is for RME Hammerfall cards. From the
mixers available, select the one that best suits your needs.

TIP: Starting the Mixer

Generally, it is advisable to open a mixer application before opening other
sound applications. Use the mixer to test and adjust the control settings for
the input and output of the sound card.

14.1.1 The KDE Mixer Applet
KMix is the default KDE mixer application. It is integrated into the KDE panel as a
small panel applet located in the system tray. Click the panel icon (a speaker) to control
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the volume of your speakers with a control slider. If you right-click the icon, the context
menu of KMix appears. SelectMute to switch off the sound output. The panel icon then
changes its appearance. Clicking Mute again unmutes the volume. To fine-tune your
sound settings, select Show Mixer Window and configure Output, Input, and Switches.
Each of the devices featured there has its own context menu that is opened by a right-
clicking the device icon. You can mute or hide each one of them separately.

Figure 14.1 The Mixer KMix

14.1.2 The GNOME Volume Control
The GNOME volume control applet for the GNOME desktop can be integrated into
the GNOME panel. Click the panel icon to control the volume of your speakers with a
simple control slider. To switch off the sound output, right-click the icon and select
Mute. The volume control icon then changes its appearance. To unmute the sound output,
right-click the icon again and select Mute from the menu. Select Open Volume Control
to access the more advanced mixer features, shown in Figure 14.2, “The GNOME
Volume Control” (page 121). Each sound device has its own mixer tab.
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Figure 14.2 The GNOME Volume Control

14.1.3 alsamixer
alsamixer can be run from the command line without the X environment, so is entirely
controlled by keyboard shortcuts. An alsamixer window always consists of an informa-
tion area and the volume bars of the devices with their respective names.

Select devices with → and ← or N and P . Use ↑ and ↓ or + and - to
increase and decrease the volume. Control stereo channels independently, using Q ,
W , and E for increasing the volume and Z , X , and C for decreasing the volume.
Use the number keys between 0 and 9 to change the absolute volume quickly.
These correspond to 0 to 90% of full volume. Toggle between muted and unmuted state
of any mixer control using M . A muted control has MM written below its name.

alsamixer has three different view modes: Playback, Capture, and All. By default, al-
samixer is started in playback mode, displaying only those mixer controls relevant for
playback (Master Volume, PCM, CD, etc.). Capture displays only those controls used
for recording. All displays all controls available. Switch the view modes using F3 ,
F4 , and F5 or toggle them using →| .
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14.1.4 Look and Feel of Mixer Applications
The look and feel of mixer applications depend on the type of sound card used. Some
drivers, like SB Live!, have many controllable (tunable) mixer elements while the
drivers for professional sound cards may have elements with totally different names.

On-Board Sound Chip
Most of the PCI on-board sound chips are based on AC97 codec. Master controls the
main volume from the front speakers. Surround, Center, and LFE control the rear,
center, and bass-boost speakers. Each of them has a mute switch. In addition to that,
some boards have individual Headphone and Master Mono volumes. The latter is used
for the built-in speaker on some laptops.

PCM controls the internal volume level of digital WAVE playback. PCM is an acronym
for pulse code modulation, one of the digital signal formats. This control also has an
individual mute switch.

Other volumes, like CD, Line, Mic, and Aux, control the loop-back volume from the
corresponding input to the main output. They do not influence the recording level, only
the playback volumes.

For recording, turn on the Capture switch. This is the master recording switch. The
Capture volume is the input gain for recording. By default, this switch is set to zero.
Choose a recording source like Line or Mic. The recording source is exclusive, so you
cannot choose two of them at the same time. Mix is a special recording source. You
can record the currently played signal from this source.

Depending on the AC97 codec chip, special effects, like 3D or bass/treble, are available,
too.

SoundBlaster Live! and Audigy Family
SoundBlaster Live! and SB Audigy1 have numerous mixer controls for their AC97
codec chip and DSP engine. In addition to the controls already described, they have
Wave, Music, and AC97 volumes to control the internal signal routing and attenuation
for PCM, WaveTable MIDI, and AC97 mixing. Keep the volume at 100% to hear all
of them. SB Audigy2 (depending on the model) has less controls than SB Live, but still
has Wave and Music controls.
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The recording on SB Live is similar to on-board chip. You can choose Wave and Music
as the additional recording source to record the played PCM and WaveTable signals.

USB Audio Devices
USB audio devices usually have a small number of mixer controls. Sometimes they
even have none at all. Most devices either have a Master or PCM control switch to
control the playback volume.

14.1.5 The Mixer for the Sound Chip Envy24
envy24control is a mixer application for sound cards using the Envy24 (ice1712) chip.
The flexibility of the Envy24 chip can result in varying functionalities in different sound
cards. The latest details on this sound chip are available in /usr/share/doc/
packages/alsa-tools/envy24control. Install the package
alsa-tools-gui in order to use envy24control.

Figure 14.3 Monitor and Digital Mixer of envy24control

TheMonitorMixer of envy24control shows the signal levels that can be mixed digitally
in the sound card. The signals designated as PCM Out are generated by applications
that send PCM data to the sound card. The signals of the analog inputs are shown under
H/W In. The S/PDIF inputs are shown to the right. Set the input and output levels of
the analog channels under Analog Volume.

Use the Monitor Mixer sliders for digital mixing. The respective levels are displayed
in the Digital Mixer. For each output channel, the Patchbay contains a row of radio
buttons for selecting the desired channel source.
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Adjust the amplification for the analog-to-digital and digital-to-analog converters under
Analog Volume. Use the DAC sliders for the output channels and the ADC sliders for
the input channels.

The S/PDIF channel settings are made underHardware Settings. The Envy24 chip reacts
to volume changes with a delay that can be configured with Volume Change.

14.2 Multimedia Players

14.2.1 amaroK
The amaroK media player handles various audio formats and plays the streaming audio
broadcasts of radio stations on the Internet. The file types supported depend on the engine
used, currently xine or Helix.

On first start, amaroK launches a First-Run Wizard, which helps set up amaroK. In the
first step, configure your preferred look and feel for amaroK. Choose to display player
and playlist in separate windows (see Figure 14.4, “The amaroK Media Player”
(page 125)) or combine their functionality in one single window (default). In the second
step, determine where amaroK should look for your music collection. amaroK scans
these folders for playable media. By default, amaroK is configured to scan the selected
folders recursively (to include all their subdirectories in the scan), monitor changes to
the content of the selected directories, and import any playlists located there. All the
settings made with the wizard can be modified later by starting the wizard again with
Tools → First-Run Wizard.
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Figure 14.4 The amaroK Media Player

Quick Start
On start-up, amaroK scans the folders that are part of your collection for music files.
Although you can use amaroK without building a collection, it is recommended to do
so, because most of the powerful, advanced features are only available with an existing
collection.

The amaroK main window is divided into two parts. The sidebar browsers on the left
contain different views of your music collection and your playlists, a file browser, and
an interface to an iPod. Change the browser by clicking a tab on the far left. The right
part contains the playlist window and, below it, the player (if you have not configured
it to be shown in a separate window).

To play music, first create a playlist. Just drag and drop items from any of the sidebar
browsers to the playlist window. Use Shift or Ctrl to select multiple items. Double-
click an item in the playlist to play it. You can add or delete items from the list during
playback. Use the icons in the bottom right corner to Undo and Redo changes or to
Clear the entire list.
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The Sidebar Browsers
Context

With this tab, view information and statistics about your collection and the current
artist. Switch to different views using the tabs on top of the Context browser. The
Home view provides statistics on your listening habits, listing your favorite, newest,
and least-played tracks or albums. Current provides data related to the track cur-
rently being played, such as the album cover (see Section “The Cover Manager”
(page 128)), the listening statistics related to this track, and much more. If available,
Lyrics displays the lyrics of the track currently played. You need to be connected
to the Internet to use this feature. Artist shows information about the artist. This
information is fetched from Wikipedia, so an Internet connection is needed as well.

Collection
Use this view to manage and display your personal collection of titles. The toolbar
on top of the browser allows you to configure the way your collection is displayed
and to rescan or reorganize the collection. Define the order your titles are displayed
in the browser withGroup By. You can choose between predefined criteria or create
your own sort criteria using Primary, Secondary, and Tertiary. The next two icons
let you toggle between tree and flat view. Use the update icon to rescan your entire
collection for changes and add or delete folders to scan by clicking the wrench
icon.

If you are searching for a particular album, title, genre, or year, use Filter here.
The selection in the browser is adjusted as you type. You can only search in criteria
used to group the collection. If you have grouped your collection by Artist / Album,
it is not possible to search for titles belonging to a certain genre.

Playlists
You can access different playlists with the playlist browser. Playlists holds your
personal playlists found in your collection folders. Every time you create and save
a new playlist from the playlist window, it appears here. Right-click to open a menu
where you can manually add a new playlist or a subfolder. To add new items from
the playlist window to an existing playlist, just drag and drop them on the playlist
in the browser window.
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IMPORTANT: Sharing Playlists with Other Players

Save playlists in m3u or pls format, so you can share them with any other
players using these formats.

Smart Playlists offer various views of your collection, such as tracks never played,
newest tracks, or tracks by genre. Right-click to add subfolders or to create your
own smart playlists.

Radio Streams lets you listen to live radio streams from the Internet. An extensive
list is already shipped with amaroK. Right-click to add more or create subfolders.

Podcasts imports podcasts to amaroK. Right-clicking opens a menu where you can
add podcasts and subfolders, refresh all podcasts, or set the scan interval.

At the bottom of the playlist browser window, you can Enable dynamic mode and
configure it with Show Options. Dynamic mode is a feature that allows you the
flexibility of picking music from your entire collection while keeping a relatively
small playlist that is easy to maintain. Refer to the online documentation (open it
with F1 ) for details.

Media Device
If you own an iPod, you can use this browser to play music from it or to add music
from your collection to the iPod. It must be mounted at /mnt/ipod before starting
amaroK. To listen to tracks from the iPod, drag and drop them from the list view
to the playlist window. To add tracks from the collection to the iPod, drag tracks
from the playlist window to the list view.

File Browser
This tab opens a file browser. It corresponds to the standard KDE file selector dialog
with the usual controls for navigating the file system. Enter a URL or a path directly
into the text input field. From the contents displayed, drag elements to the playlist
to include them. You can also perform a recursive search for a file in a given direc-
tory. To do so, enter a text string for the title and the location at which to start the
search. Then select Search and wait for the results to appear in the lower section
of the window.
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The Cover Manager
With amaroK, you can assign a cover to each album of your collection. With the Cover
Manager, easily add, delete, and retrieve album covers.

Start the cover manager with Tools → Cover Manager. A tree view in the left part of
the window lists all artists in your collection. The main part of the window lists the
covers of all albums. To filter the covers displayed, click an individual artist in the tree
view or enter a term in the input field at the top of the window. Use View to toggle be-
tween displaying all albums, albums with covers, or albums without covers.

There are three different methods for assigning covers to the albums:

Automatically Assign Covers
amaroK can automatically fetch all missing covers displayed in the main windows
from Amazon. Use Amazon Locale to determine from which Amazon Web server
the covers should be fetched then click Fetch Missing Covers.

IMPORTANT: Proper Tagging Needed

amaroK fetches the covers from Amazon using the query string Artist
- Album. This information is extracted from the tags of your music files.
The better they are tagged, the better the hit rate is when automatically
fetching covers.

Manually Choose a Cover Fetched from Amazon
If you want more control over what image to use and what query string to use to
retrieve a cover, right-click an album in the main window and choose Fetch from
amazon. Next Cover lets you cycle through all images available. Save selects the
actual cover and assigns it to the album selected. If you are not satisfied with the
covers displayed, use New Search to refine the search. Use Amazon Locale from
the toolbar of the main window to determine from which Amazon Web server the
covers should be fetched.

Manually Assign Covers
If you already have your own cover images, you can assign them by right-clicking
an album and choosing Set Custom Image.
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Visualizations
amaroK comes with a number of visualizations that display a graphical effect for the
music played. Native amaroK visualizations are displayed in the player window. Cycle
through the various available display modes by clicking the animation.

In addition to the above, amaroK also supports the visualization plug-ins of the XMMS
media player. To use these, first install the xmms-plugins package then select Tools
→ Visualizations from the amaroK menu. This opens a window listing the available
plug-ins. XMMS plug-ins are always displayed in separate windows. In some cases,
there is an option to display them in full-screen mode. For some plug-ins, you may not
get a smooth visual effect unless you use a 3D-accelerated graphics card.

The amaroK Tray Icon
Like other KDE applications, amaroK adds an icon to the KDE system tray. You can
use this icon to control a large number of amaroK's features. Hovering the mouse over
the icon displays information about the track currently played. A single left-click closes
the application window without affecting playback. Click again to reopen the window.
Clicking with the middle mouse button pauses playback—middle-click again to resume
playback. Right-clicking opens a context menu where you have access to the player
controls and can exit amaroK. Scrolling the mouse wheel changes the playback volume.

Using the Shift and Ctrl keys together with the mouse gives you access to more ad-
vanced features. Holding Shift while scrolling the mouse wheel seeks through the
current track. Holding Ctrl while scrolling the mouse wheel skips through tracks in
the playlist.

You may also drag and drop items on the tray icon to add them to the current playlist.
A pop-up menu opens, asking whether to append the track to the playlist, append and
play it, or queue it after the current track.

14.2.2 Banshee
Banshee is a GNOME music management and playback application that lets you import
CDs, sync your music collection to an iPod, play music directly from an iPod, create
playlists with songs from your library, and create audio and MP3 CDs from subsets of
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your library. To access Banshee, select Applications → Multimedia → Audio Player
→ Banshee Music Player.

The first time you open Banshee, it prompts you to import music. ClickAutomatic Import
to search for music in your home directory and add it to the library. Click Import
Folder to tell Banshee where to look for music. After successfully importing your music,
your library is displayed.

Figure 14.5 Banshee Library

Managing Your Library
You can use the library to do a variety of things, including playing, organizing, and
importing music. You can also view a variety of information about your music collection,
including playback statistics (when a song was last played and how many times).

Playing Your Music

To play a song, simply select the song in the library and click the play button. During
playback, an icon appears in your panel. Right-click the icon to get a list of available
options. You can pause the current song, repeat the song, play the previous or next song
in the list, shuffle the playlist, or exit Banshee. You can also use the buttons on the
upper left corner to pause a song or play the next or previous song.

Banshee also has an integrated CD player. When you insert a music CD, your CD title
appears in the left pane. Select the title and click the Play button to play your full CD.
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Organizing Your Music

To create a new playlist, click Music → New Playlist (or press Ctrl + N ). A new
playlist is displayed in the left panel. Double-click New Playlist and enter the name
you want. You can drag and drop songs from one playlist to another or use the options
on the Edit menu to remove or delete songs and rename or delete the playlist.

To view the properties of a song, select a song in the library and click Edit→ Properties.
This shows the duration of a song, the number of times it has been played, when it was
last played, and when it was imported.

Figure 14.6 Track Properties Editor

You can edit the artist, album, title, track number, and track count. If you want to set
all fields in a set to the same value, select multiple songs in a playlist then click Edit
→ Properties.
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Figure 14.7 Multitrack Editor

Importing Music

Banshee can import music from a file, folder, or CD. Click Music → Import Folder,
Import Files, or Import CD then specify the files, folder, or CD to import. To copy
music from a CD to your music collection, click the Rip button near the top right.

Using Banshee with Your iPod
To play music from your iPod, simply plug your iPod into your system. Your iPod ap-
pears in the left pane. Select the song to hear then click the Play button.

Figure 14.8 iPod List in Banshee

When the iPod is selected in the left pane, information about your iPod is displayed at
the bottom left, including disk usage and Sync, Properties, and Eject buttons.

132 Applications



Figure 14.9 iPod Buttons in Banshee

There are three ways to manage the music on your iPod:

Manually
Browse your iPod and drag music between your library and the iPod.

Automatically Sync
Automatically copies everything in your library to the iPod.

Automatically Merge
All the music on your iPod that is not in your library is downloaded to your library
and all the music that is in your library and not in your iPod is uploaded to your
iPod.

Use the iPod Properties dialog to rename your iPod and view vital statistics.
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Figure 14.10 Banshee iPod Properties

Creating Audio and MP3 CDs
To create audio and MP3 CDs, select the songs you want then click theWrite CD button
in the upper right side of Banshee.

Configuring Preferences
You can configure Banshee preferences by clickingEdit→Preferences. ThePreferences
dialog contains the following tabs:

Library
Specify a music folder location. This location is used when you import music.
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Encoding
Determine encoding profiles for CD ripping and iPod transcoding.

Burning
Specify CD burning options. You can choose a disk drive, write speed, and disk
format (Audio CD, MP3 CD, or Data CD). You can also configure advanced options,
such as ejecting the CD when finished.

Advanced
Choose the Helix/RealPlayer engine or the GStreamer engine for audio playback
in Banshee.

14.2.3 XMMS
XMMS is another full-featured media player with robust audio support, so that pops
or breaks during playback should be very rare. The application is easy to use. The button
for displaying the menu is located in the upper left corner of the program window. For
those preferring a GNOME-like look and feel, there is a GTK2 version of XMMS
available, the Beep Media Player. Just install the package bmp. However, not all XMMS
plug-ins are supported by this port of XMMS. XMMS applets for KDE or GNOME
are also available.

Figure 14.11 XMMS with Equalizer, OpenGL Spectrum Analyzer, and Infinity
Plug-Ins
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Select the output plug-in module with Options → Preferences → Audio I/O Plugins.
If the xmms-kde package is installed, the aRts sound server can be configured here.

IMPORTANT: Using the Disk Writer Plug-In

XMMS automatically redirects its output to the Disk Writer Plugin if it is not
able to find a configured sound card. In this case, the played files are written
to the hard disk as WAV files. The time display then runs faster than when
playing the output through a sound card.

Start various visualization plug-ins with Options → Preferences → Visualization Plu-
gins. If you have a graphics card with 3D acceleration, select an application such as the
OpenGL spectrum analyzer. If the xmms-plugins package is installed, try the Infin-
ity plug-in.

To the left under the menu button, there are five buttons with different letters on them.
These buttons allow quick access to additional menus, dialogs, and configurations.
Open the playlist with PL and the equalizer with EQ.

14.3 CDs: Playback and Ripping
There are many ways to listen to your favorite music tracks. Either play a CD or play
digitized versions of them. The following section features some CD player applications
as well as some applications that can be used for ripping and encoding audio CDs.

IMPORTANT: CDDA and Analog CD Playback

There are two different ways of playing back audio CDs. CD and DVD drives
capable of analog CD playback read the audio data and send it to the sound
output device. Some external drives connected via PCMCIA, FireWire, or USB
need to use CDDA (Compact Disk Digital Audio) to extract the audio data first
then play it as digital PCM. The players featured in the following sections do
not support CDDA. Use XMMS if you need CDDA support.
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14.3.1 KsCD—Audio CD Player
KsCD is an easy-to-use audio CD player. It integrates into the KDE taskbar and can be
configured to start playing automatically after a CD has been inserted. To access the
configuration menu, select Extras → Configure KsCD. Fetch album and track informa-
tion from a CDDB server on the Internet if KsCD is configured accordingly. You can
also upload CDDB information to share it with others. Use the CDDB dialog for infor-
mation retrieval and upload.

Figure 14.12 The KsCD User Interface

14.3.2 GNOME CD Player
This is a simple CD player. When a CD is inserted, it automatically looks up album
and track information if an Internet connection exists. You can change the information
retrieved by clicking the track editor icon. The preferences icon lets you choose a theme
and configure automatic playback and CD ejection. The GNOME CD player also inte-
grates into the panel. Right-clicking the tools icon gives you access to the playback
controls.

Figure 14.13 The GNOME CD player
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14.3.3 Compressing Audio Data: Ripping
Audio compression can be handled by various tools. The following sections feature a
command line approach to encoding and playing audio data as well as some graphical
applications capable of audio compression.

Command Line Tools for Encoding and Playback of
Audio Data
Ogg Vorbis (package vorbis-tools) is a free audio compression format that is now
supported by the majority of audio players and even portable MP3 players. The Web
page of the project is http://www.xiph.org/ogg/vorbis.

SUSE Linux comes with several tools supporting Ogg Vorbis. oggenc is a command
line tool used for encoding WAV files to Ogg. Just run oggenc myfile.wav to
transform a given .wav file into Ogg Vorbis. The option -h displays an overview of
the other parameters. Oggenc supports encoding with a variable bit rate. In this way,
an even higher degree of compression can be achieved. Instead of the bit rate, specify
the desired quality with the parameter -q. -b determines the average bit rate. -m and
-M specify the minimum and maximum bit rate.

ogg123 is a command line Ogg player. Start it with a command like ogg123
mysong.ogg.

Compressing Audio Data Using Sound Juicer
Sound Juicer is a GNOME ripper application. Upon insertion of a CD, album and track
information is displayed. You can directly edit title, artist and genre information. To
edit track information, slowly double-click a track (normal double-click plays the song).
Select or deselect a track for encoding with the check box in front of a title. Clicking
Extract starts ripping the selected tracks. To configure the output directory, filenames,
and encoder, open the configuration dialog with Edit → Preferences.
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Figure 14.14 Ripping Audio CDs with Sound Juicer

Compressing Audio Data Using KAudioCreator
KAudioCreator is a lean CD ripper application (see Figure 14.15, “Ripping Audio CDs
with KAudioCreator” (page 140)). Once started, it lists all the tracks of your CD in the
CD Tracks tab. Select the tracks to rip and encode. To edit the track information, use
theAlbumEditor underFile→Edit Album. Otherwise just start the ripping and encoding
with File → Rip Selection. Watch the progress of these jobs using the Jobs tab. If con-
figured accordingly, KAudioCreator also generates playlist files for your selection that
can be used by players like amaroK, XMMS, or banshee.
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Figure 14.15 Ripping Audio CDs with KAudioCreator

Compressing Audio CDs Using Konqueror
Before you start the actual ripping process with Konqueror, configure the handling of
audio CDs and the Ogg Vorbis encoder in the KDE Control Center. Select Sound &
Multimedia→Audio CDs. The configuration module is divided into three tabs:General,
Names, and Ogg Vorbis Encoder. Normally, a suitable CD device is detected automat-
ically. Do not change this default setting unless the autodetection failed and you need
to set the CD device manually. Error correction and encoder priority can also be set
here. The Ogg Vorbis Encoder tab determines the quality of the encoding. To configure
online lookup of album, track, and artist information for your ripped audio data, select
Add Track Information.

Start the ripping process by inserting the CD into the CD-ROM drive and entering
audiocd:/ in the Location bar. Konqueror then lists the tracks of the CD and some
folders (see Figure 14.16, “Ripping Audio Data with Konqueror” (page 141)).
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Figure 14.16 Ripping Audio Data with Konqueror

To keep uncompressed audio data on your disk, just select the .wav files and drag
them into another Konqueror window to copy them to their final destination. To start
the Ogg Vorbis encoding, drag the Ogg Vorbis folder or files from this folder to
another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis
folder at its destination.

14.4 Hard Disk Recording with
Audacity

With audacity (package audacity), record and edit audio files. This is called hard
disk recording. When you start the program for the first time, select a language. At
other times, change the language setting under File → Preferences → Interface. The
language change is then effective the next time you start the program.
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Figure 14.17 Spectral View of the Audio Data

14.4.1 Recording WAV Files and Importing
Files

Click the red recording button to create an empty stereo track and start the recording.
To change the standard parameters, make the desired settings under File→ Preferences.
Audio I/O and Quality are important for the recording. Even if tracks already exist,
pressing the recording button creates new tracks. Initially, this may be confusing, because
these tracks cannot be seen in the standard-size program window.

To import audio files, select Project → Import Audio. The program supports the WAV
format and the compressed Ogg Vorbis format. See Section 14.3.3, “Compressing Audio
Data: Ripping” (page 138) for more information about this format.

14.4.2 Editing Audio Files
Open the AudioTrack menu to the left of the track. This menu offers various options
for different views and basic editing operations. To rename the track, select Name and
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enter a new name. The different view modes offered by Audacity include Waveform,
Waveform (dB), Spectrum, and Pitch. Choose the one suiting your needs. If you want
to edit each channel of a stereo track separately, select Split Track. Each channel can
then be treated as a separate track. Set Sample Format (in bit) and Sample Rate (in Hz)
for each track.

Before you can use most of the tools offered in the Edit menu, first select the channel
and the segment of the track to edit. After making your selection, you can apply all
kinds of modifications and effects to it.

Depending on the chosen file type, various view formats for segment selections are
offered under View → Set Selection Format. With Set Snap-To Mode, the segment
boundaries can automatically be adapted to the selected view format. For example, if
you select PAL frames as the view format and activate Snap-To, the segment boundaries
are always selected in multiples of frames.

All editing tools come with tool tips, so should be easy to use. The Undo History
function, accessed with View → History, is a useful feature for viewing recent editing
steps and undoing them by clicking in the list. Use Discard with caution, because it
deletes editing steps from the list. Once discarded, these steps can no longer be undone.

Figure 14.18 The Spectrum

The built-in spectrum analyzer assists in quickly tracking down any noises. View the
spectrum of the selected segment with View → Plot Spectrum. Select a logarithmic
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frequency scale in octaves with Log frequency. If you move the mouse pointer within
the spectrum, the frequencies of the peaks are automatically displayed together with
the respective notes.

Remove unwanted frequencies withEffect→FFT Filter. In connection with the filtering
process, it may be necessary to readjust the signal amplitude with Amplify. Additionally,
use Amplify to check the amplitude. By default, the New Peak Amplitude is set to 0.0
dB. This value represents the highest possible amplitude in the selected audio format.
Amplification shows the value needed to amplify the selected segment to this peak
amplitude. A negative value indicates over-amplification.

14.4.3 Saving and Exporting
To save the entire project, select File→ Save Project or Save Project As. This generates
an XML file with the extension .aup, which describes the project. The actual audio
data is saved in a directory named after the project with _data appended.

The entire project or the currently selected segment can also be exported as a stereo
WAV file. To export the project in Ogg Vorbis format, refer to the information in
Section 14.3.3, “Compressing Audio Data: Ripping” (page 138).

14.5 Direct Recording and Playback
of WAV Files

arecord and aplay from the alsa package provide a simple and flexible interface
to the PCM devices. arecord and aplay can be used to record and play audio data
in the WAV format and other formats. The command arecord -d 10 -f cd -t
wav mysong.wav records a WAV file of 10 seconds in CD quality (16 bit, 44.1
kHz). List all options of arecord and aplay by running them with the --help
option.

qaRecord (package kalsatools) is a simple recording program with a graphical in-
terface and level display. Because this program uses an internal buffer of about 1 MB
(configurable with --buffersize), it enables uninterrupted recordings even on slow
hardware, especially if it is run with real-time priority. During the recording, the cur-
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rently-used buffer size is displayed in the status line under Buffer and the maximum
buffer size required so far for this recording is displayed under Peak.

Figure 14.19 QARecord—A Simple Hard Disk Recording Application
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15TV, Video, Radio, and Webcam
This chapter introduces some basic Linux video, radio, and webcam applications. Learn
how to configure and use motv for watching analog TV, using a webcam, and browsing
video text. Webcams can be run using gqcam. EPG information can be accessed using
nxtvepg.

15.1 Watching TV with motv
motv is an improved successor to xawtv. It incorporates all essential functions into the
user interface. Start the application with Multimedia → TV → MoTV. Start it at the
command line with motv. Initially, only a TV window appears after the application
starts. Open a menu window by right-clicking it.
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Figure 15.1 The TV Application motv

15.1.1 Video Source and Network Search
In Settings → Input, select the video source. If you select Television here, set up the
broadcasting network before starting the application. This automatically takes place
with the network search, also found under the Settings menu. If you click Save settings,
the network found is entered into the .xawtv file in your home directory and will be
available the next time you start the application.

TIP: Selecting Channels

If you do not want to browse for all available channels, find the next channel
with Ctrl + ↑ . If needed, subsequently adjust the broadcast frequency with
← or → .

15.1.2 Retrieving Audio Data
The audio output of the TV card is connected to the line input of your sound card, to
the speakers, or to an amplifier. Some TV cards can change the volume of the audio
output. The volume can then be set with the sliders that appear after selecting Settings
→ Slider. This window also provides the sliders for brightness, contrast, and color.
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To use your sound card for audio playback, check the mixer settings using gamix, de-
scribed in Section 14.1, “Mixers” (page 119). For sound cards meeting the AC97 speci-
fications, set Input-MUX to Line. The volume can then be adjusted with the Master and
Line sliders.

15.1.3 Screen Proportions and Full-Screen
Mode

Most television images have a height and width ratio of 4:3. These proportions can be
set with Tools → Screen Dimensions. If 4:3 is selected here (this is the default setting),
the screen dimensions are retained automatically, even when the display size is changed.

With F or Tools → Fullscreen, switch to full-screen mode. If the TV image in full-
screen mode is not scaled to the full monitor size, some fine-tuning is required. Many
graphics cards can scale the full-screen mode television image to the full monitor size
without changing the graphical mode. If your card does not support this function, the
graphics mode must be switched to 640x480 for the full-screen mode. Create the related
configuration in Settings → Configuration. After restarting motv, the monitor mode is
also changed if you have switched to full-screen mode.

TIP: Storing the Configuration in .xawtv

The .xawtv file is created automatically and updated by clicking Settings →
Save settings. Here, the broadcasters are saved along with the configuration.
More information about the configuration file can be found in the man page
for xawtvrc.

15.1.4 The Launcher Menu
Use the launcher menu to start other applications to use with motv. Start the audio
mixer gamix and the video text application alevt, for example, using a keyboard shortcut.
Applications to launch from motv must be entered in the .xawtv file. The entries
should look like this:
[launch] Gamix = Ctrl+G, gamix AleVT = Ctrl+A, alevt

The shortcut then the command used to start the application should follow the application
name itself. Start the applications entered under [launch] via the Tool menu.
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15.2 Video Text Support
Use alevt to browse video text pages. Start the application with Multimedia → TV →
AleVT or at the command line with alevt.

The application saves all the pages of the selected station just activated with motv.
Browse pages by entering the desired page number or by clicking a page number. Move
forward or backward through the pages by clicking << or >>, located in the lower
window margin.

Recent versions of motv include their own video text viewer application mtt.

15.3 Webcams and motv
If your webcam is already supported by Linux, access it with motv. Find a summary
of the supported USB devices athttp://www.linux-usb.org. If you have already
used motv to access the TV card prior to accessing the webcam, the bttv driver is
loaded. The webcam driver is loaded automatically when your webcam is connected
to the USB. Start motv at the command line with the parameter -c /dev/video1
to access the webcam. Access the TV card with motv -c /dev/video0.

When connecting the webcam to the USB before the bttv driver has been automatically
loaded (for example, by starting a TV application), /dev/video0 is reserved for the
webcam. In this case, if you start motv with the -c /dev/video1 parameter to access
the TV card, you might get an error message, because the bttv driver was not automat-
ically loaded. Solve this problem by loading the driver separately with modprobe
bttv as the user root. Access an overview of the configurable video devices on your
system with motv -hwscan.

15.4 nxtvepg—The TV Magazine for
Your PC

From some broadcasters, an EPG signal (Electronic Program Guide) is transmitted
along with the video text signal. Easily view this electronic guide using the program
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nxtvepg. To do this, however, you must have a TV card supported by the bttv driver
and be able to receive one of the channels broadcast with an EPG.

With nxtvepg, the broadcasts are sorted according to channel and topic, such as movie
and sport, and filtered according to criteria, such as Live, Stereo, or Subtitle. Start the
application withMultimedia→Video→ nxtvepg or at the command line withnxtvepg.

15.4.1 Importing the EPG Database
To set up and update the program database via the EPG signal, set the tuner of your
TV card to a station that broadcasts EPG. This can be done using a TV application,
such as motv or nxtvepg. Only one application at a time can access the tuner.

If you set an EPG broadcaster in motv, nxtvepg immediately begins importing the
current list of TV programs. The progress is displayed.

Figure 15.2 The Electronic TV Magazine nxtvepg
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If you have not started a TV application, let nxtvepg search for EPG broadcasters. To
do this, use Configure→ Provider scan. Use .xatv is activated by default. This indicates
that nxtvepg is accessing the broadcasters saved in this file.

TIP: Troubleshooting

If there are problems, check to see if the proper video source has been chosen
under TV card input.

Select from the EPG providers found in Configure → Select Provider. Configure →
Merge Providers even creates flexible associations between the various provider
databases.

15.4.2 Sorting the Programs
nxtvepg provides a convenient filter function for managing even the most extensive
program offerings. Activate a network selection list with Configure → Show networks.
The Filter menu offers plenty of filter functions. Right-click the program list to open
a special filter menu in which to activate contextual filter functions.

Of particular interest is the Navigate menu. This is built directly from the EPG data. It
appears in the language provided by the network.

15.5 Webcam Operation with gqcam
gqcam is a webcam application that assists in taking snapshots or automatic picture
series with webcams. To use gqcam, your webcam must be supported by Video4Linux.
Many USB webcams are automatically recognized. Grayscale and color cameras can
be used. TV cards that support Video4Linux can also be used as an image source. An
overview of the supported USB devices is maintained at http://www.linux-usb
.org. A graphical user interface is not compulsory because gqcam can also run from
the command line.
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15.5.1 Operation
Connect your camera to the USB port of your computer before starting gqcam. Then
run gqcam. The current picture of your webcam is automatically shown in the upper
part of the application window. The lower part has sliders for adjusting the brightness,
white balance, contrast, tint, and color saturation as needed. The brightness is automat-
ically preset. This feature can be set in General in File → Preferences. Filters features
false color correction switches because some cameras swap the red and blue channels
in transmission.

If you operate more than one webcam, use File → Open New Camera to switch to an-
other camera. Select the new device from the dialog that opens. The first camera is at-
tached to the device /dev/video0, the second is attached to /dev/video1, and
so on.

15.5.2 Snapshots
To take a snapshot with a camera, click Snap Picture. Select a filename and picture
format in the dialog that opens. Create a picture series with Camera → Set Timer. Set
the capturing frequency in seconds or minutes along with the properties of the images
in Set image information. An optional script to run after every capture event can be
chosen with Run command after snap. This could, for example, be used to upload the
captured image onto an FTP server.

15.5.3 Command Line
gqcam can also be run without its graphical user interface. This may be interesting, for
instance, for automatic surveillance controlled by a cron job. This requires that all the
necessary settings be passed to the application as parameters. Running gqcam -t
JPEG -s -d webcam.jpg saves the current image captured by the camera with the
filename webcam.jpg. The option -t defines the file format. Possible values are
JPEG, PNG, and PPM. The command line switch -s activates the color correction.
The filename for saving is passed with the option -d. If more than one webcam is op-
erated, the name of the device must be passed. If no device is given, the default device
/dev/video0 is used. To capture an image from the second camera, the option -v
/dev/video1 must be added. List all options with gqcam --help.
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16K3b—Burning CDs or DVDs
K3b is a comprehensive program for writing data and audio CDs and DVDs. Start the
program from the main menu or by entering the command k3b. The following sections
brief you on how to start a basic burning process to get your first Linux-made CD or
DVD.

16.1 Creating a Data CD
To create a data CD, go to File → New Project → New Data CD Project. The project
view appears in the lower part of the window, as shown in Figure 16.1, “Creating a
New Data CD” (page 156). Drag the desired directories or individual files from your
home directory to the project folder and drop them there. Save the project under a name
of your choice with File → Save as.
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Figure 16.1 Creating a New Data CD

Then select Burn from the toolbar or hit Ctrl + B . A dialog with six tabs offering
various options for writing the CD opens. See Figure 16.2, “Customizing the Burning
Process” (page 157).
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Figure 16.2 Customizing the Burning Process

The Writing tab has various settings for the burning device, the speed, and the burning
options. The following options are offered here:

Burning Device
The detected writer is displayed under this pop-up menu. You can select the speed
here too.

WARNING: Select the Writing Speed with Care

Normally, you should select Auto, which chooses the maximum writing
speed possible. However, if you increase this value but your system is not
able to send the data fast enough, the likelihood of buffer underruns in-
creases.

Writing Mode
This option determines how the laser writes a CD. In DAO (disk at once) mode,
the laser is not deactivated while the CD is written. This mode is recommended for
the creation of audio CDs. However, it is not supported by all CD writers. In the
TAO mode (track at once), a separate write process is used for each individual
track. The RAW mode is not used very often, because the writer does not perform
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any data corrections. The best setting is Auto, because it allows K3b to use the most
suitable settings.

Simulate
This function can be used to check if your system supports the selected writing
speed. The writing is performed with the laser deactivated to test the system.

On the Fly
Burns the desired data without first creating an image file (do not use this feature
on low-performance machines). An image file—also known as an ISO image—is
a file containing the entire CD content that is subsequently written to the CD exactly
as it is.

Only Create Image
This option creates an image file. Set the path for this file under Temporary File.
The image file can be written to CD at a later time. To do this, use Tools → CD
→ Burn CD Image. If this option is used, all other options in this section are deac-
tivated.

Remove Image
Remove the temporary image file from hard disk when finished.

Verify Written Data
Check the integrity of the written data by comparing the MD5 sums of the original
and the burned data.

The Image tab is only accessible if the option Only create image from the previous tab
is selected. If this is the case, you can determine the file where the ISO is written.

The Settings tab contains two options: Datatrack Mode and Multisession Mode. The
Datatrack Mode options contains configuration of how data tracks may be written. In
general, auto is considered the best suited method. The Multisession Mode is used to
append data to an already written but not finalized CD.

In the Volume Desc tab, enter some general information that can be used to identify
this particular data project, its publisher and preparer, and the application and operating
system used in the creation of this project. Under File system, specify settings for the
file system on the CD (RockRidge, Joliet, UDF). Also determine how symbolic links,
file permissions, and blanks are treated. In the Advanced tab, experienced users can
make additional settings.
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After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

16.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Select File → New Audio CD Project. Drag and drop the individual audio
tracks to the project folder. The audio data must be in WAV or Ogg Vorbis format.
Determine the sequence of the tracks by moving them up or down in the project folder.

With the help of CD Text, you are able to add certain text information to a CD, such
as CD title, artist name, and track name. CD players that support this feature can read
and display this information. To add CD Text information to your audio tracks, select
the track first. Right-click and select Properties. A new window opens in which to enter
your information.

The dialog for burning an audio CD is not very different from the dialog for burning a
data CD. However, the Disc at once and the Track at once modes have greater impor-
tance. The Track at once mode inserts an intermission of two seconds after each track.

TIP: Preserving Data Integrity

When burning audio CDs, choose a lower burning speed to reduce the risk of
burning errors.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

16.3 Copying a CD or DVD
Select Tools→Copy CD or Tools→Copy DVD depending on your media. In the dialog
that opens, make the settings for the reading and writing device as shown in Figure 16.3,
“Copying a CD” (page 160). The writing options discussed are also available here. An
additional function enables the creation of several copies of the CD or DVD.
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Figure 16.3 Copying a CD

Check On the fly to burn the CD as soon as it has been read or select Only create image
to create an image in the path specified on the Image tab in theWrite image file to option
and burn the image later.

16.4 Writing ISO Images
If you already have an ISO image, go to Tools → CD → Burn CD image. A window
opens in which to enter the location of the Image to Burn. K3b calculates a check sum
and displays it in MD5 Sum. If the ISO file was downloaded from the Internet, this sum
shows if the download was successful.

Use the Options and Advanced tabs to set your preferences. To burn the CD, click Start.
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16.5 Creating a Multisession CD or
DVD

Multisession discs can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following:

1 Create your data disc first and add all your files. You cannot start with an audio
CD session. Make sure that you do not fill up the entire disc, because otherwise
you cannot append a new session.

2 Burn your data with Project → Burn.

3 In the dialog box that appears, go to the Settings tab and select Start Multisession.

4 Configure other options if needed. See also Section 16.1, “Creating a Data CD”
(page 155).

5 Start the burning session with Burn.

After a successful burning process, you have created a multisession disc. As long as
the media contains enough space, you can append more sessions if you like. Finish
discs only if you are sure you do not need any new sessions or the space is occupied.

NOTE: About Storage Space on Multisession Discs

Be aware that multisession discs need space for bookkeeping all the entries
from your sessions. This leads to a smaller amount of available space on your
disc. The amount depends on the number of sessions.
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16.6 For More Information
Apart from the two main functions described above, K3b offers other functions, such
as the creation of DVD copies, reading audio data in WAV format, rewriting CDs, and
playing music with the integrated audio player. A detailed description of all available
program features is available at http://k3b.sourceforge.net.
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Part IV. Graphics





17Managing Images with f-spot
f-spot is a management tool for your collection of digital images tailored for the GNOME
desktop. It allows you to assign different tags to your images to categorize them and
offers various image editing options.

The first time you run f-spot, tell it where to find the images to import to your f-spot
collection. If you already have a collection of images stored on your hard drive, enter
the path to the directory and optionally include subfolders. f-spot imports these images
into its database.

TIP: Tagging Images on Import

If all the images you are importing belong to the same category, you can attach
the appropriate tag on import. Select Attach Tag and choose the matching tag.

Figure 17.1 Importing Images to f-spot

f-spot's main window is divided into three main areas. Categories, tags, and detailed
information for the selected images are displayed in a sidebar to the left and thumbnails
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of all images bearing the selected tag or category or, if none is selected, the entire col-
lection are displayed in the right part of the window.

Figure 17.2 f-spot's Main Window

A menu bar right at the top of the window allows you to access the main menus. A
toolbar below offers several different functions depicted by a matching icon:

Rotate (Left or Right)
Use this shortcut to change an image's orientation.

Browse
The Browse mode allows you to view and search you entire collection or tagged
subsets of it. You can also use the time line to search images by creation date.

Edit Image
This mode allows you to select one image and do some basic image processing.
Details are available in Section 17.6, “Basic Image Processing with f-spot”
(page 171).

Fullscreen
Switch to fullscreen display mode.
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Slideshow
Start a slide show.

17.1 Downloading Pictures from Your
Camera

Import new images from a digital camera connected to the USB port of your computer
using File → Import from Camera. The type of camera is detected automatically.

Figure 17.3 Import from Camera

f-spot opens a preview window displaying all the images that are available for download
from camera. The files are copied to the target directory specified in Copy Files to. If
Import files after copy is selected, all images copied from the camera are automatically
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imported to f-spot's database. Tagging can be done on import if you select the appropriate
tag with Select Tags. If you do not want to import all images on your camera to your
database, just deselect the unwanted ones in the preview window.

17.2 Getting Information
Once you select an image, some basic statistical information on this image is displayed
in the lower left part of the window. This includes the filename, its version (copy or
original image), the date of creation, its size, and the exposure used to create this par-
ticular image. View the EXIF data associated with the image file with View → EXIF
Data.

17.3 Managing Tags
Use tags to categorize any of your images to create manageable subsets of your collec-
tion. If, for example, you want some sort of order in your collection of portrait shots
of your loved ones, proceed as follows:

1 Select the Browse mode of f-spot.

2 In the left frame of the f-spot window, select the People category, right-click it,
then choose Create New Tag. The new tags then appear as subcategories below
the People category:

a Create a new tag called Friends.

b Create a new tag called Family.

3 Now attach tags to images or groups of selected images. Right-click an image,
choose Attach Tag, and select the appropriate tag for this image. To attach a tag
to a group of images, click the first one then press Shift and select the other
ones without releasing the Shift key. Right-click for the tag menu and select
the matching category.

After the images have been categorized, you can browse your collection by tag. Just
check People → Family and the displayed collection is limited to the images tagged
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Family. Search your collection by tag with Find → Find by Tag. The result of your
search is displayed in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching
them. The tag editing functions are also accessible in Tags in the top menu bar.

17.4 Search and Find
As mentioned in Section 17.3, “Managing Tags” (page 168), tags can be used as a means
to find certain images. Another way, unique to f-spot, is to use the Timeline below the
toolbar. By dragging the little frame along this time line, limit the images displayed in
the thumbnail overview to those taken in the selected time frame. f-spot starts with a
sensibly chosen default time line, but you can always edit the time span by moving the
sliders at the right and left ends of the time line.

17.5 Exporting Image Collections
f-spot offers a range of different export functions for your collections under File →
Export. Probably the most often used of these are Export to Web Gallery and Export
to CD.

To export a selection of images to a Web gallery, proceed as follows:

1 Select the images to export.

2 Click File → Export → Export to Web Gallery and select a gallery to which to
export your images or add a new one. f-spot establishes a connection to the Web
location entered for your web gallery. Select the album to which to export the
images and decide whether to scale the images automatically and export titles
and comments.
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Figure 17.4 Exporting Images to a Web Gallery

To export a selection of images to CD, proceed as follows:

1 Select the images to export.

2 Click File → Export → Export to CD and click OK.

f-spot copies the files and opens the CD writing dialog. Assign a name to your
image disk and determine the writing speed. Click Write to start the CD writing
process.

Figure 17.5 Exporting Images to CD
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17.6 Basic Image Processing with
f-spot

f-spot offers several very basic image editing functionalities. Enter the edit mode of f-
spot by clicking the Edit Image icon in the toolbar or by double-clicking the image to
edit. Switch images using the arrow keys at the bottom right. Choose from the following
edit functions:

Sharpen
Access this function with Edit → Sharpen. Adjust the values for Amount, Radius,
and Threshold to your needs and click OK.

Crop Image
To crop the image to a selection you made, either choose a fixed ratio crop or the
NoConstraint option from the drop-down menu at the bottom left, select the region
to crop, and click the scissor icon next to the ratio menu.

Red Eye Reduction
In a portrait shot, select the eye region of the face and click the red eye icon.

Adjust Color
View the histogram used in the creation of the shot and correct exposure and color
temperature if necessary.

TIP: Advanced Image Processing

Professional image editing can be done with The GIMP. More information about
The GIMP can be found in Chapter 19, Manipulating Graphics with The GIMP
(page 185).
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18Digital Cameras and Linux
Managing photos from your camera can be fun if you have the right tools. Linux offers
several handy utilities for sorting and organizing your photographs. These include
gphoto2, Konqueror, Digikam, and f-spot.

A comprehensive list of supported cameras is available at http://www.gphoto
.org/proj/libgphoto2/support.php. If gphoto2 is installed, retrieve the
list with the command gphoto2 --list-cameras. Get information about the
available commands with gphoto2 --help.

TIP: Unsupported Cameras

If you do not find your camera in the list from gphoto, do not despair. It is
very likely that your camera is supported as a USB mass storage device. Find
more information in Section 18.2, “Accessing the Camera” (page 174).

18.1 Connecting to the Camera
The fastest and most convenient way to connect digital cameras to the computer is USB,
provided the kernel, the camera, and the computer support it. The standard SUSE kernel
provides this support. A suitable cable is also required.

Simply connect the camera to the USB port and turn on the camera. You may need to
switch your camera to a special data transfer mode. For this procedure, consult the
manual of your digital camera.
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18.2 Accessing the Camera
There are three possibilities for accessing the pictures on the camera. It depends on
your camera and which protocol it supports. Usually it is USB mass storage, which is
handled by the hotplug system, or PTP (also known as PictBridge). Some camera
models do not work with either protocol. To support these, gphoto2 includes specific
drivers.

It is easiest if your camera supports USB mass storage. Read the documentation of your
camera if you are unsure if this is possible. Some support two protocols, like both PTP
and USB mass storage. Unfortunately, there are also some that communicate with a
proprietary protocol, which can complicate the tasks. If your camera does not support
USB mass storage or PTP, the following descriptions will not work. Try gphoto2
--list-cameras and the information at http://www.gphoto.org/.

If your camera can be switched to a USB mass storage device, select this option. After
you connect it with the USB port of your computer and turn it on, it is detected by the
hotplug system. This takes care of mounting the device automatically, so it is easily
accessible. The KDE desktop shows a camera icon after a successful mount.

After the camera is successfully mounted, see a new directory under /media, beginning
with usb and lots of numbers. Each vendor and product has a number, so when you
connect a device on your computer it has always the same name. Depending on what
you have connected to the USB bus, find different entries. The only problem left is to
find the correct entry for your camera. Try to list one of these directories (DCIM/xxx)
and see what happens. Each camera has a different tree structure, so there is no general
rule. If you can see JPEG files in a directory, you probably found it.

After you find your correct directory, you can copy, move, or delete the files from your
camera with a file manager, such as Konqueror, or simple shell commands (see Sec-
tion “Important Linux Commands” (Chapter 3, Working with the Shell, ↑Start-Up) and
the Reference).

18.3 Using Konqueror
KDE users can easily access digital cameras by means of the familiar Konqueror inter-
face. Connect your camera to the USB port. A camera icon should appear on the desktop.
Click this icon to open the camera in Konqueror. The camera can also be accessed by
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entering the URL camera:/ in Konqueror. Navigate through the camera's directory
structure until the files are shown. Use the usual Konqueror file management features
to copy the files as desired. More information about using Konqueror is available in
Chapter 7, The Web Browser Konqueror (page 69).

18.4 Using Digikam
Digikam is a KDE program for downloading photographs from digital cameras. The
first time it is run, Digikam asks where to store your photo album. If you enter a direc-
tory that already contains a collection of photographs, Digikam treats each subfolder
as an album.

On start-up, Digikam presents a window with two sections: your albums are displayed
to the left and the photographs of the current album are displayed to the right. See Fig-
ure 18.1, “The Main Window of Digikam” (page 175).

Figure 18.1 The Main Window of Digikam

18.4.1 Configuring Your Camera
To set up a camera in Digikam, select Camera → Add Camera. First, try to autodetect
the camera with Auto-Detect. If this fails, browse the list for your model with Add. If
your camera model is not included in the list, try an older model or use USB/IEEEmass
storage camera. Confirm with Ok.
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18.4.2 Downloading Pictures from Your
Camera

After your camera has been configured correctly, connect to your camera with the
Camera menu and the name that you gave in the dialog from Section 18.4.1, “Config-
uring Your Camera” (page 175). Digikam opens a window and begins to download
thumbnails and displays them as in Figure 18.2, “Downloading Pictures from Camera”
(page 176). Right-click an image to open a pop-up menu with the options toView, display
some Properties or EXIF Information,Download, orDelete the image. With Advanced,
select renaming options and how the camera-provided information (EXIF) should be
handled.

Figure 18.2 Downloading Pictures from Camera

The renaming options can be very convenient if your camera does not use meaningful
filenames. You can let Digikam rename your photographs automatically. Give a unique
prefix and, optionally, a date, time, or sequence number. The rest is done by Digikam.

Select all photographs to download from the camera by pressing the left mouse button
or clicking individual photographs with Ctrl pressed. Selected photographs appear
with inverted colors. ClickDownload. Select the destination from the list or by creating
a new album with New Album. This automatically suggests a filename with the current
date. Confirm with Ok to start the download process.
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18.4.3 Getting Information
Getting information about the photograph is not difficult. A short summary is displayed
as a tool tip if you point with the mouse cursor at the thumbnail. For longer information,
right-click the photograph and choose Properties from the menu. A dialog box opens
with three tabs, General, EXIF, and Histogram.

General lists the name, type, owner, and some other basic information. The more inter-
esting part is the EXIF tab. The camera stores some metadata for each photograph.
Digikam reads these properties and displays them in this list. Find the exposure time,
pixel dimensions, and others. To get more information for the selected list entry, press
Shift + F1 . This shows a small tool tip. The last tab,Histogram, shows some statistical
information.

18.4.4 Managing Albums
Digikam inserts a My Albums folder by default, which collects all your photographs.
You can store these into subfolders later. The albums can be sorted by their directory
layout, by the collection name that has been set in the album properties or by the date
that the albums were first created (this date can also be changed in the properties of
each album).

To create a new album, you have some possibilities:

• Uploading new photographs from the camera

• Creating a new album by clicking the New Album button in the toolbar

• Importing an existing folder of photographs from your hard disk (select Album →
Import → Import Folders)

• Right-clicking My Albums and selecting New Album

After selecting to create an album in your preferred way, a dialog box appears. Give
your album a title. Optionally, choose a collection, insert some comments, and select
an album date. The collection is a way of organizing your albums by a common label.
This label is used when you select View→ Sort Albums→ By Collection. The comment
is shown in the banner at the top of the main window. The album date is used when
you select View → Albums → By Date.
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Digikam uses the first photograph in the album as the preview icon in the My Albums
list. To select a different one, right-click the respective photograph and select Set as
Album Thumbnail from the context menu.

18.4.5 Managing Tags
Managing lots of different photographs with different albums can sometimes be complex.
To organize individual photographs, Digikam provides the My Tag system.

For example, you have photographed your friend John at different times and you want
to collect all images, independent of your album. This let you find all photographs very
easily. First, create a new tag by clicking My Tags → People. From the context menu,
choose New Tag. In the dialog box that appears, enter John as title and optionally set
an icon. Confirm with Ok.

After creating your tag, assign it to the desired pictures. Go to each album and select
the respective photographs. Right-click and choose Assign Tag → People→ John from
the menu that appears. Alternativly, drag the photographs to the tag name under My
Tags and drop them there. Repeat as necessary with other albums. View all the images
by clicking My Tags → People → John. You can assign more than one tag to each
photograph.

Editing tags and comments can be tedious. To simplify this task, right-click a photograph
and select Edit Comments & Tags. This opens a dialog box with a preview, a comment
field, and a tag list. Now you can insert all the needed tags and add a comment. With
Forward and Back, navigate in your album. Store your changes with Apply and leave
with Ok.

18.4.6 Exporting Image Collections
Digikam provides several export options that help you archive and publish your personal
image collections. It offers archiving to CD or DVD (via k3b), HTML export, and export
to a remote gallery.
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To save your image collection to CD or DVD, proceed as follows:

1 Select File → Export → Archive to CD/DVD.

2 Make your adjustments in the Create CD/DVD Archive dialog using its various
submenus. After that, click OK to initiate the burning process.

a Selection: Determine which part of your collection should be archived by
selecting albums and tags.

b HTML Interface: Decide whether your image collection should be accessible
via an HTML interface and whether autorun functionality should be added
to your CD/DVD archive. Set a selection title and image, font, and back-
ground properties.

c Media Volume Descriptor: Change the settings for volume description, if
necessary.

d Media Burning: Adjust the burning options to your needs, if necessary.

To create an HTML export of your image collection, proceed as follows:

1 Select File → Export → HTML Export.

2 Adjust the settings in Create Image Galleries to your needs, using the various
submenus. When you are done, click OK to initiate the gallery creation.

a Selection: Determine which part of your collection should be archived by
selecting albums and tags.

b Look: Set the title and appearance of your HTML gallery.

c Album: Determine the location of the gallery on disk as well as image size,
compression, format, and the amount of metadata displayed in the resulting
gallery.

d Thumbnails: As with the target images, specify size, compression and file
type for the thumbnails used for gallery navitation.
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To export your collection to an external image gallery on the Internet, proceed as
follows:

1 Get an account for an external web site holding your gallery.

2 Select File → Export → Export to Remote Gallery and provide URL, username,
and password for the external site when asked for them.

Digikam establishes a connection to the site specified and opens a new window
called Gallery Export.

3 Determine the location of your new album inside the gallery.

4 Click New Album and provide the information requested by Digikam.

5 Upload the images to the new album with Add Photos.

18.4.7 Useful Tools
Digikam provides several tools to simplify some tasks. Find them in the Tools menu.
The following is a small selection of the available tools.

Creating a Calendar
If you want to please someone, a custom calendar can be a nice gift. Go to Tools →
Create Calendar, which opens a wizard dialog like that in Figure 18.3, “Creating a
Template for a Calendar” (page 181).

Customize the settings (paper size, image position, font, etc.) and confirm with Next.
Now you can enter the year and select the images to use. After clicking Next again, see
a summary. The final Next opens the KDE Printer dialog. Here, decide if you want to
see a preview, save as PDF, or just print directly.
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Figure 18.3 Creating a Template for a Calendar

Finding Duplicate Photographs
Sometimes you photograph similar scenes repeatedly and want to keep only the best
shots. This is the perfect task for the Find Duplicate plug-in.

Go to Tools → Find Duplicate Images. Select the albums or tags to handle. Under
Method & Cache, choose the search method: a more accurate or a faster method. After
you confirm with Ok, Digikam proceeds with the investigation.

If it finds some duplicates, it shows the result in a window like Figure 18.4, “Results
of Find” (page 182). Decide which images to delete by activating the desired check
boxes then clicking Delete. Leave the window with Close.
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Figure 18.4 Results of Find

Batch Processes
Digikam also provides some batch processes that perform a specific task on lots of files.
This can be renaming, converting, resizing, and much more. Find them under Tools →
Batch Processes.

18.4.8 Basic Image Viewing and Editing with
Digikam

Digikam includes its own lean image viewing and editing program. It automatically
opens if you double-click an image's thumbnail.

Use this tool to do some basic image editing on the images you just downloaded from
your camera. You can crop, rotate or flip the image, do some basic color adjustments,
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apply various colored filters (for example, to export a colored image to black and white),
and efficiently reduce red eyes in portrait shots.

The most important menus are:

Image
Use Edit Comments & Tags to enter comments to a particular image and to assign
a tag (category) to this image. Properties takes you to a window consisting of three
tabs providing general information, EXIF information, and the histogram of this
image.

Fix
This menu contains some of the editing functions most needed in digital photogra-
phy. Colors takes you to a submenu where you can modify all basic color settings.
You can also blur or sharpen either the entire picture or just a part of the image
you selected. To reduce red eyes in a portrait shot, roughly select the eye region
of the face by just clicking and holding the left mouse pointer and gradually expand-
ing the selection, select Red Eye Reduction and choose either mild or aggressive
reduction depending on whether you selected a whole region or just the eyes.

Transform
The Transform menu offers the crop, rotate, flip, and resize functions. You can also
use the Aspect Ratio Crop option to produce crops in a fixed aspect ratio.

Filters
If you need to transform your color shots into black and white or want to achieve
an aged look in your photographs, check out the Filters menu and choose from the
various export options.

A more detailed description of this tool can be found in Digikam's online help in digiKam
Image Editor, which can be reached with the Help button in Digikam's menu bar.

TIP: Advanced Image Processing

Professional image editing can be done with the GIMP. More information about
The GIMP can be found in Chapter 19, Manipulating Graphics with The GIMP
(page 185).
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18.5 For More Information
For more information about using digital cameras with Linux, refer to the following
Web sites:

• http://digikam.sourceforge.net/—Information about Digikam

• http://www.gphoto.org—Information about gPhoto2

• http://www.gphoto.org/proj/libgphoto2/support.php—A
comprehensive list of supported cameras

• http://www.thekompany.com/projects/gphoto/—Information about
Kamera, a KDE front-end for gPhoto2
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19Manipulating Graphics with The
GIMP
The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing pixel graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, make covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your SUSE Linux may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 19.6, “For More Information”
(page 193) for ideas of where to find more information about the program.

19.1 Graphics Formats
There are two main formats for graphics—pixel and vector. The GIMP works only with
pixel graphics, which is the normal format for photographs and scanned images. Pixel
graphics consist of small blocks of color that together create the entire image. The files
can easily become quite large because of this. It is also not possible to increase the size
of a pixel image without losing quality.
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Unlike pixel graphics, vector graphics do not store information for all individual pixels.
Instead, they store information about how image points, lines, or areas are grouped to-
gether. Vector images can also be scaled very easily. The drawing application of
OpenOffice.org, for example, uses this format.

19.2 Starting GIMP
Start GIMP from the main menu. Alternatively, enter gimp & in a command line.

19.2.1 Initial Configuration
When starting GIMP for the first time, a configuration wizard opens for preparatory
configuration. The default settings are acceptable for most purposes. Press Continue in
each dialog unless you are familiar with the settings and prefer another setup.

19.2.2 The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, GIMP saves your window layout when you exit. Dialogs left
open reappear when you next start the program.

The Toolbox
The main window of GIMP, shown in Figure 19.1, “The Main Window” (page 187),
contains the main controls of the application. Closing it exits the application. At the
very top, the menu bar offers access to file functions, extensions, and help. Below that,
find icons for the various tools. Hover the mouse over an icon to display information
about it.
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Figure 19.1 The Main Window

The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.
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Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Channels shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.

19.3 Getting Started in GIMP
Although GIMP can be a bit overwhelming for new users, most quickly find it easy to
use once they work out a few basics. Crucial basic functions are creating, opening, and
saving images.

19.3.1 Creating a New Image
To create a new image, select File → New or press Ctrl + N . This opens a dialog in
which to make settings for the new image. If desired, select a predefined setting called
a Template. To create a custom template, select File → Dialogs → Templates and use
the controls offered by the window that opens.

In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
is open. A resolution of 72 pixels per inch corresponds to screen display. It is sufficient
for Web page graphics. A higher resolution should be used for images to print. For
most printers, a resolution of 300 pixels per inch results in an acceptable quality.

In Colorspace, select whether the image should be in color (RGB) or Grayscale. Select
the Fill Type for the new image. Foreground Color and Background Color use the
colors selected in the toolbox. White uses a white background in the image. Transparent
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creates a clear image. Transparency is represented by a gray checkerboard pattern. Enter
a comment for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

19.3.2 Opening an Existing Image
To open an existing image, select File → Open or press Ctrl + O . In the dialog that
opens, select the desired file. You can also press Ctrl + L and type directly the URI
of the desired image. Then click OK to open the selected image or press Cancel to skip
opening an image.

19.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from the GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File → Acquire → XSane: scanning device.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a grayscale or color image and the required
scan resolution. The higher the resolution, the better the quality of the scanned image
is. However, this also results in a correspondingly larger file and the scanning process
can take a very long time at higher resolutions. The size of the final image (both in
pixels and bytes) is shown in the lower part of the dialog.

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
Changes are visible in the preview immediately. Once all settings have been made,
click Scan to scan the image.

19.3.4 The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
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menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.

File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current window with Zoom. When Shrink
Wrap is selected, the image window is resized to fit the current image display exactly.

19.4 Saving Images
No image function is as important as File → Save. It is better to save too often than too
rarely. Use File → Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set toBy Extension. With that setting, GIMP determines
the file type based on the extension appended to the filename. The following file types
are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications.

PAT
This is the format used for GIMP patterns. Saving an image in this format enables
using the image as a fill pattern in GIMP.
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JPG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compression method enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered by GIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, press Cancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.

19.5 Printing Images
To print an image, selectFile→ Print from the image menu. If your printer is configured
in SUSE Linux, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size with Media
Size and the type in Media Type. Other settings are available in the Image / Output
Settings tab.

Manipulating Graphics with The GIMP 191



Figure 19.2 The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an ap-
propriate print size and resolution in the image. Adjust the image's position on the page
with the fields in Position or by dragging the image in Preview.

When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.
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19.6 For More Information
The following resources are useful for a GIMP user, even if some of them apply to
older versions.

• Help provides access to the internal help system. This documentation is also
available in HTML and PDF formats at http://docs.gimp.org.

• The GIMP User Group offers an informative Web site athttp://gug.sunsite
.dk.

• http://www.gimp.org is the official home page of The GIMP.

• Grokking the GIMP by Carey Bunks is an excellent book based on an older GIMP
version. Although some aspects of the program have changed, it can provide excel-
lent guidance for image manipulation. An online version is available at http://
gimp-savvy.com/BOOK/.
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AGetting to Know Linux Software
The next few sections introduce some of the most powerful Linux counterparts of
common Windows software. Each section is dedicated to one particular field of appli-
cation and lists the tasks, Windows applications, and Linux equivalents. These applica-
tions are then discussed in further detail and links to more information are provided.
This list is by no means complete, because software development is an evolutionary
process and new applications are being created every minute.

TIP: Missing Applications

In case one of the listed applications is not installed by default on your SUSE
Linux system, use YaST to install the missing packages. Use the search function
of the YaST package management tool to find the package names.

A.1 Office
This section features the most popular and powerful Linux office and business software
solutions. These include office suites, databases, accounting software, and project
management software.



Table A.1 Office Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

OpenOffice.org, StarOffice,
KOffice

MS Office, StarOffice,
OpenOffice.org

Office Suite

OpenOffice.org/StarOffice
Writer

MS Word, StarOffice/OpenOf-
fice.org Writer, WordPerfect

Word Processor

OpenOffice.org/StarOffice
Calc, Gnumeric, KSpread

MS Excel, StarOffice/OpenOf-
fice.org Calc

Spreadsheet

OpenOffice.org Impress,
StarOffice Presentation

MS PowerPoint, StarOffice
Presentation, OpenOffice.org
Impress

Presentation

OpenOffice.org Calc, Gnuplot,
Grace (Xmgr), LabPlot

MS Excel, MicroCall OriginData Plotting

OpenOffice.org + MySQL,
Rekall, kexi, Mergeant, Postgre-
SQL

MS Access, OpenOffice.org +
MySQL

Local Database

GnuCash, moneyplexMS Money, Quicken, money-
plex

Financial Account-
ing

Planner, TaskjugglerMS ProjectProject Manage-
ment

VYM (View Your Mind), Free
Mind

MindManager, Free MindMind Mapping

OpenOffice.org
OpenOffice.org is the open source equivalent of MS Office. It is a very powerful
office suite including a word processor (Write), a spreadsheet and database manager
(Calc), a presentation manager (Impress), and a drawing program (Draw). Users
familiar with the MS Office family of applications find a very similar application
interface and all the functionality to which they are accustomed. Because
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OpenOffice.org is capable of importing data from MS Office applications, the
transition from one office suite to the other is very smooth. A Windows version of
OpenOffice.org even exists, enabling Windows users to switch to an open source
alternative while still using Windows. Find more information about OpenOffice.org
at http://www.openoffice.org/ and read Chapter 1, The OpenOffice.org
Office Suite (page 15) for an introduction to OpenOffice.org and a short guide to
migrating your data from one office suite to the other.

StarOffice
StarOffice is a proprietary version of OpenOffice.org and is distributed by Sun
Microsystems. It is available on multiple platforms including Windows and Solaris.
It includes certain advanced features not available with the free version (OpenOf-
fice.org). Find more information about StarOffice at http://www.sun.com/
software/star/staroffice/.

KOffice
KOffice is an integrated office suite for the KDE desktop. It comes with various
modules like word processing (KWord), spreadsheets (KSpread), presentation
(KPresenter), several image processing applications (Kivio, Karbon14, Krita), a
database front-end (Kexi), and many more. Find more information about KOffice
at http://www.koffice.org/.

Gnumeric
Gnumeric is a spreadsheet solution for the GNOME desktop environment. Find
more information about Gnumeric at http://www.gnumeric.org.

Gnuplot
Gnuplot is a very powerful and portable command line controlled data plotting
software. It is also available for MacOS and Windows platforms. Plots created by
Gnuplot can be exported to various formats, such as PostScript, PDF, SVG, and
others, allowing you to process these plots easily. Find more information about
Gnuplot at http://www.gnuplot.info/index.html.

Grace
Grace is a very mature 2D plotting tool for almost all flavors of Unix including
Linux. Plot creation and editing can be done via a graphical user interface. Grace
supports an unlimited number of graphs per plot. Its export formats include JPEG,
PNG, SVG, PDF and (E)PS. More information can be found at http://
plasma-gate.weizmann.ac.il/Grace/.
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LabPlot
LabPlot is a program for creating and managing two or three-dimensional data
plots. Graphs can be produced both from data and functions and one plot might
include multiple graphs. It also offers various data analysis methods. More infor-
mation about LabPlot can be found athttp://labplot.sourceforge.net/
.

Rekall
Rekall is a tool for manipulating databases. Supported databases include MySQL,
PostgreSQL, XBase with XBSQL, IBM DB2, and ODBC. Use Rekall to generate
different sorts of reports and forms, design database queries, or import and export
data to various formats. Find more information about Rekall at http://www
.thekompany.com/products/rekall/.

Kexi
Kexi is a database front-end to various different types of databases. It supports
connections to MySQL, PostgreSQL, and SQLite database servers. Kexi can be
used for manipulating data in tables and creating and storing queries. Find more
information about kexi at http://www.koffice.org/kexi/.

Mergeant
Mergeant is a database front-end for the GNOME desktop. Find more information
at http://www.gnome-db.org.

PostgreSQL
PostgreSQL is an object-relational database management system that supports an
extended subset of the SQL standard, including transactions, foreign keys, sub-
queries, triggers, and user-defined types and functions. Find more information
about PostgreSQL at http://www.postgresql.org/.

GnuCash
GnuCash is a software tool to control both your personal and business finances.
Keep track of income and expenses and manage your bank accounts and stock
portfolios all using one piece of software. Learn more about GnuCash at http://
www.gnucash.org.

moneyplex
moneyplex is a tool to control your finances. All tasks from managing incoming
resources and expenses and monitoring your stock portfolio to online transactions
via the HBCI standard are handled by moneyplex. Keep track of your financial
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transactions over time using various analysis options. Because this tool is also
available for Windows, users can migrate very easily without having to learn a
whole new application interface. More information about moneyplex can be found
at http://www.matrica.de.

Planner
Planner is a project management tool aiming to provide functionality similar to the
project management tools used under Windows. Among its various features are
Gantt charting abilities, different kinds of views on tasks and resources, and much
more. Find more information about Planner at http://www.imendio.com/
projects/planner/.

Taskjuggler
Taskjuggler is a lean, but very powerful project management software. Take control
of your projects using the Gantt charting features or by generating all kinds of reports
(in XML, HTML, or CSV format). Those users who are not comfortable with
controlling applications via the command line can use a graphical front-end to
Taskjuggler. Find more information about Taskjuggler at http://www
.taskjuggler.org.

VYM (View Your Mind)
VYM is a software for visualizing your thoughts by creating and manipulating
mind maps. Most manipulations do not require more than one mouse click.
Branches can be inserted, deleted, and reordered very easily. VYM also offers a
set of flags allowing you to mark certain parts of the map (important, time critical,
etc.). Links, notes, and images can be added to a mind map as well. VYM mind
maps use an XML format, allowing you to export your mind maps to HTML easily.
Find more information about VYM at http://www.insilmaril.de/vym.

A.2 Network
The following section features various Linux applications for networking purposes.
Get to know the most popular Linux browsers and e-mail and chat clients.
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Table A.2 Network Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, Firefox, Opera,
Epiphany

Internet Explorer, Firefox,
Opera

Web Browser

Evolution, Kontact, Mozilla
Thunderbird

MS Outlook, Lotus Notes,
Mozilla Thunderbird

E-Mail Client/Personal
Information Management

Gaim, Kopete, Konversa-
tion, XChat

MSN, AIM, Yahoo Messen-
ger, XChat, Gaim

Instant Messaging/IRC
Clients

GnomeMeetingNetMeetingConferencing (Video and
Audio)

Linphone, kphone, SkypeX-LiteVoice over IP

gftp, kbearleechftp, wsftpFTP Clients

Konqueror
Konqueror is a multitalented application created by the KDE developers. It acts as
file manager and document viewer, but is also a very powerful and highly customiz-
able Web browser. It supports the current Web standards, such as CSS(2), Java
applets, JavaScript and Netscape plug-ins (Flash and RealVideo), DOM, and SSL.
It offers neat helpers like an integrated search bar and supports tabbed browsing.
Bookmarks can be imported from various other Web browsers, like Internet Explor-
er, Mozilla, and Opera. Find more information about Konqueror at http://www
.konqueror.org/ and read our introduction to using Konqueror in Chapter 7,
The Web Browser Konqueror (page 69).

Firefox
Firefox is the youngest member of the Mozilla browser family. It runs on various
platforms, including Linux, MacOS, and Windows. Its main features include built-
in customizable searches, pop-up blocking, RSS news feeds, password management,
tabbed browsing, and some advanced security and privacy options. Firefox is very
flexible, allowing you to customize almost anything you want (searches, toolbars,
skins, buttons, etc.). Neat add-ons and extensions can be downloaded from the
Firefox Web site (https://addons.update.mozilla.org/
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?application=firefox). Find more information about Firefox at http://
www.mozilla.org/products/firefox/ and read our introduction to using
Firefox in Chapter 8, The Web Browser Firefox (page 77).

Opera
Opera is a powerful Web browser with neat add-ons like an optional e-mail client
and a chat module. Opera offers pop-up blocking, RSS feeds, built-in and customiz-
able searches, a password manager, and tabbed browsing. The main functionalities
are easily reached via their respective panels. Because this tool is also available
for Windows, it allows a much easier transition to Linux for those who have been
using it under Windows. Find more information about Opera at http://www
.opera.com/.

Epiphany
Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of
its features and extensions will remind you of Firefox. Find more information about
Epiphany at http://www.gnome.org/projects/epiphany/.

Evolution
Evolution is personal information management software for the GNOME desktop
combining mail, calendar, and address book functionality. It offers advanced e-
mail filter and search options, provides sync functionality for Palm devices, and
allows you to run Evolution as an Exchange or GroupWise client to integrate better
into heterogeneous environments. Find more information about Evolution at
http://www.gnome.org/projects/evolution/ and read our introduc-
tion to using Evolution in Chapter 2, Evolution: An E-Mail and Calendar Program
(page 23).

Kontact
Kontact is the KDE personal information management suite. It includes e-mail,
calendar, address book, and Palm sync functionalities. Like Evolution, it can act
as an Exchange or GroupWise client. Kontact combines several stand-alone KDE
applications (KMail, KAddressbook, KOrganizer, and KPilot) to form an entity
providing all the PIM functionality you need. Find more information about Kontact
at http://www.kontact.org/ and read our introduction to using Kontact
in Chapter 3, Kontact: An E-Mail and Calendar Program (page 35).

Mozilla Thunderbird
Thunderbird is an e-mail client application that comes as part of the Mozilla suite.
It is also available for Microsoft Windows and MacOS which facilitates the transi-
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tion from one of these operating systems to Linux. Find more information about
Mozilla Thunderbird at http://www.mozilla.org/products/
thunderbird/.

Gaim
Gaim is a smart instant messenger program supporting multiple protocols, such as
AIM and ICQ (Oscar protocol), MSN Messenger, Yahoo!, IRC, Jabber, SILC, and
GroupWise Messenger. It is possible to log in to different accounts on different
IM networks and chat on different channels simultaneously. Gaim also exists in a
Windows version. Find more information about Gaim at http://gaim
.sourceforge.net/about.php.

Kopete
Kopete is a very intuitive and easy-to-use instant messenger tool supporting proto-
cols including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, Gadu-Gadu,
Lotus Sametime, SMS messages, and Jabber. Find more information about Kopete
at http://kopete.kde.org/ and read an introduction to using Kopete in
Chapter 11, Chatting with Friends: Kopete (page 91).

Konversation
Konversation is an easy-to-use IRC client for KDE. Its features include support
for SSL connections, strikeout, multichannel joins, away and unaway messages,
ignore list functionality, Unicode, autoconnect to a server, optional time stamps in
chat windows, and configurable background colors. Find more information about
Konversation at http://konversation.kde.org.

XChat
XChat is an IRC client that runs on most Linux and UNIX platforms as well as
under Windows and MacOS X. Find more information about XChat at http://
www.xchat.org/.

GnomeMeeting
GnomeMeeting is the open source equivalent of Microsoft's NetMeeting. It features
LDAP and ILS support for address lookup and integrates with Evolution to share
the address data stored there. GnomeMeeting supports PC-to-phone calls, allowing
you to call another party with just your computer, sound card, and microphone
without any additional hardware. Find more information about GnomeMeeting at
http://www.gnomemeeting.org/.
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Linphone
Linphone is a smart and lean Voice over IP client using the SIP protocol to establish
calls. Find more information athttp://www.linphone.org and in Chapter 12,
Linphone—VoIP for the Linux Desktop (page 95).

KPhone
KPhone is a program to initiate Voice over IP connections across the Internet. Find
more information at http://www.wirlab.net/kphone.

gftp
gftp is an FTP client using the GTK toolkit. Its features include simultaneous
downloads, resume of interrupted file transfers, file transfer queues, download of
entire directories, FTP proxy support, remote directory caching, passive and non-
passive file transfers, and drag and drop support. Find more information at
http://gftp.seul.org.

kbear
KBear is a KDE FTP client with the ability to have concurrent connections to
multiple hosts, three separate view modes, support for multiple protocols (like ftp,
sftp, etc.), a site manager plug-in, firewall support, logging capabilities, and much
more. Find more information at http://sourceforge.net/projects/
kbear.

A.3 Multimedia
The following section introduces the most popular multimedia applications for Linux.
Get to know media players, sound editing solutions, and video editing tools.

Table A.3 Multimedia Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KsCD, Grip, BansheeCD Player, Winamp, Windows
Media Player

Audio CD Player

K3bNero, Roxio Easy CD CreatorCD Burner
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Linux ApplicationWindows ApplicationTask

Grip, kaudiocreator, Sound
Juicer, Banshee

WMPlayerCD Ripper

amaroK, XMMS, Rhythm-
box, Banshee

Winamp, Windows Media
Player, iTunes

Audio Player

Kaffeine, MPlayer, Xine,
XMMS, Totem

Winamp, Windows Media
Player

Video Player

AudacitySoundForge, Cooledit, Auda-
city

Audio Editor

alsamixer, Kmixsndvol32Sound Mixer

LilyPond, MusE, Noteedit,
Rosegarden

Finale, SmartScore, SibeliusMusic Notation

MainActor, KinoWindows Movie Maker, Adobe
Premiere, Media Studio Pro,
MainActor

Video Creator and
Editor

xawtv (analog), motv (ana-
log), xawtv4, tvtime, kdetv,
zapping, Kaffeine

AVerTV, PowerVCR 3.0,
CinePlayer DVR

TV Viewer

KsCD
KsCD is a neat little CD player application for the KDE desktop. Its user interface
very much resembles that of a normal hardware CD player, guaranteeing ease of
use. KsCD supports CDDB, enabling you to get any track and album information
either from the Internet or your local file system. Find more information at
http://docs.kde.org/en/3.3/kdemultimedia/kscd/.

Grip
Grip provides CD player and ripper functionalities for the GNOME desktop. It
supports CDDB lookups for track and album data. Ripping can be done using the
built-in cdparanoia capabilities or via external rippers. Find more information at
http://www.nostatic.org/grip/.
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Sound Juicer
Sound Juicer is a lean CD ripper application for the GNOME desktop. Find more
information about Sound Juicer at http://www.burtonini.com/blog/
computers/sound-juicer.

Banshee
Banshee is a digital jukebox very similar to iTunes.

K3b
K3b is a multitalented media creation tool. Create data, audio, or video CD and
DVD projects by dragging and dropping. Find more information about K3b at
http://www.k3b.org/ or refer to Chapter 16, K3b—Burning CDs or DVDs
(page 155).

Kaffeine
Kaffeine is a versatile multimedia application supporting a wide range of audio
and video formats including Ogg Vorbis, WMV, MOV, and AVI. Import and edit
play lists of various types, create screenshots, and save media streams to your local
hard disk. Find more information about Kaffeine at http://kaffeine
.sourceforge.net/.

Totem
Totem is a movie player application for the GNOME desktop. It supports Shoutcast,
m3u, asx, SMIL, and ra play lists, lets you use keyboard controls, and plays a wide
range of audio and video formats. Find more information about Totem at http://
www.gnome.org/projects/totem/.

amaroK
The amaroK media player handles various audio formats and plays the streaming
audio broadcasts of radio stations on the Internet. The program handles all file
types supported by the sound server acting as a back-end—currently aRts or
GStreamer. Find more information about amaroK at http://amarok.kde
.org/ or refer to Section 14.2.1, “amaroK” (page 124).

XMMS
XMMS is the traditional choice for multimedia playback. It is focused on music
playback, offering support for CD playback and Ogg Vorbis files. Users of Winamp
should find XMMS comfortable because of its similarity. Find more information
about XMMS at http://www.xmms.org/ or refer to Section 14.2.3, “XMMS”
(page 135).
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Rhythmbox
Rhythmbox is a powerful, multitalented media player for the GNOME desktop. It
allows you to organize and browse your music collection using playlists and even
supports Internet radio. Find more information about Rhythmbox at http://www
.gnome.org/projects/rhythmbox/.

Audacity
Audacity is a powerful, free sound editing tool. Record, edit, and play any Ogg
Vorbis or WAV file. Mix tracks at your whim, apply effects to them, and export
the results to WAV or Ogg Vorbis. Find more information about Audacity at
http://audacity.sourceforge.net/ or refer to Section 14.4, “Hard
Disk Recording with Audacity” (page 141).

LilyPond
LilyPond is a free music sheet editor. Because the input format is text-based, you
can use any text editor to create note sheets. Users do not need to tackle any format-
ting or notation issues, like spacing, line-breaking, or polyphonic collisions. All
these issues are automatically resolved by LilyPond. It supports many special nota-
tions like chord names and tablatures. The output can be exported to PNG, TeX,
PDF, PostScript, and MIDI. Find more information about LilyPond at http://
lilypond.org/web/.

MusE
MusE's goal is to be a complete multitrack virtual studio for Linux. Find more in-
formation about MusE at http://www.muse-sequencer.org/index
.php.

Noteedit
Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and
to export and import scores to and from many formats, such as MIDI, MusicXML
and LilyPond. Find more information about Noteedit at http://developer
.berlios.de/projects/noteedit/.

Rosegarden
Rosegarden is a free music composition and editing environment. It features an
audio and MIDI sequencer and a score editor. Find more information about
Rosegarden at http://rosegardenmusic.com/.
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MainActor
MainActor is a fully fledged video authoring software. Because there is a Windows
version of MainActor, transition from Windows is easy. Find more information
about MainActor at http://www.mainactor.com/.

xawtv and motv
xawtv is a TV viewer and recorder application supporting analog TV. motv is ba-
sically the same as xawtv, but with a slightly different user interface. Find more
information about the xawtv project athttp://linux.bytesex.org/xawtv/
.

xawtv4
xawtv4 is a successor of the xawtv application. It supports both analog and digital
audio and video broadcasts. The xawtv4 package contains several useful applications
apart from the TV viewer: pia4 (a command line controlled movie player for streams
recorded by xawtv4), mtt4 (a video text browser), alexplore (a DVB channel
scanner; built-in), dvbradio (a DVB radio player; needs an initial channel scan),
and dvbrowse (an EPG browser). For more information, refer to http://linux
.bytesex.org/xawtv/.

tvtime
tvtime is a lean TV viewer application supporting analog TV. Find more information
about tvtime, including a comprehensive usage guide, at http://tvtime
.sourceforge.net/.

kdetv
A TV viewer and recorder application for the KDE desktop supporting analog TV.
Find more information about kdetv at http://www.kdetv.org/.

zapping
A TV viewer and recorder application for the GNOME desktop supporting analog
TV. Find more information about Zapping athttp://zapping.sourceforge
.net/cgi-bin/view/Main/WebHome.

A.4 Graphics
The following section presents some of the Linux software solutions for graphics work.
These include simple drawing applications as well as fully-fledged image editing tools
and powerful rendering and animation programs.
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Table A.4 Graphics Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

The GIMP, KritaMS PaintSimple Graphic Edit-
ing

The GIMP, KritaAdobe Photoshop, Paint Shop
Pro, Corel PhotoPaint, The
GIMP

Professional Graphic
Editing

OpenOffice.org Draw,
Inkscape, Dia

Adobe Illustrator, CorelDraw,
OpenOffice.org Draw, Free-
hand

Creating Vector
Graphics

Inkscape, Dia, Karbon14,
Kivio

WebDraw, Freehand, Adobe
Illustrator

SVG Editing

POV-Ray, Blender,
KPovmodeler

3D Studio MAX, Maya, POV-
Ray, Blender

Creating 3D Graphics

Digikam, F-SpotSoftware provided by the cam-
era manufacturer

Managing Digital Pho-
tographs

Vuescan, The GIMPVuescanScanning

gwenview, gThumb, Eye
of Gnome

ACDSeeImage Viewing

The GIMP
The GIMP is the open source alternative to Adobe Photoshop. Its feature list rivals
that of Photoshop, so it is well suited for professional image manipulation. There
is even a Windows version of GIMP available. Find more information at http://
www.gimp.org/ or refer to Chapter 19, Manipulating Graphics with The GIMP
(page 185).

Krita
Krita is KOffice's answer to Adobe Photoshop and The GIMP. It can be used for
pixel-based image creation and editing. Its features include many of the advanced
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image editing capabilities you would normally expect with either Adobe Photoshop
or The GIMP. Find more information at http://www.koffice.org/krita.

Dia
Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports
many types of special diagrams, such as network or UML charts. Export formats
include SVG, PNG, and EPS. To support your own custom-made diagram types,
provide the new shapes in a special XML format. Find more information about Dia
at http://www.gnome.org/projects/dia/.

Inkscape
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio
can find a similar range of features and a familiar user interface in Inkscape. Among
its features, find SVG-to-PNG export, layering, transforms, gradients, grouping of
objects, and more. Find more information about Inkscape at http://www
.inkscape.org/.

Karbon14
Karbon14 is a vector graphics application that integrates into KOffice. Find more
information at http://www.koffice.org/karbon/.

Kivio
Kivio is a flow-charting application that integrates into the KOffice suite. Former
users of Visio will find a familiar look and feel in Kivio. Find more information
about Kivio at http://www.koffice.org/kivio/.

POV-Ray
The Persistence of Vision Raytracer creates three-dimensional, photo-realistic im-
ages using a rendering technique called ray tracing. Because there is a Windows
version of POV-Ray, it does not take much for Windows users to switch to the
Linux version of this application. Find more information about POV-Ray at
http://www.povray.org/.

Blender
Blender is a powerful rendering and animation tool available on many platforms,
including Windows, MacOS, and Linux. Find more information about Blender at
http://www.blender3d.com/.

Getting to Know Linux Software 209

http://www.koffice.org/krita
http://www.gnome.org/projects/dia/
http://www.inkscape.org/
http://www.inkscape.org/
http://www.koffice.org/karbon/
http://www.koffice.org/kivio/
http://www.povray.org/
http://www.blender3d.com/


KPovmodeler
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop.
KPovmodeler saves users from needing a detailed knowledge of POV-Ray scripting
by translating the POV-Ray language in an easy to understand tree view. Native
POV-Ray scripts can be imported to KPovmodeler as well. Find more information
at http://www.kpovmodeler.org.

Digikam
Digikam is a smart digital photo management tool for the KDE desktop. Importing
and organizing your digital images is a matter of a few clicks. Create albums, add
tags to spare you from copying images around different subdirectories, and eventu-
ally export your images to your own Web site. Find more information about Digikam
at http://digikam.sourceforge.net/Digikam-SPIP/ and in Sec-
tion 18.4, “Using Digikam” (page 175).

f-spot
f-spot is a flexible digital photographs management tool for the GNOME desktop.
It lets you create and manage albums, supports various export options like HTML
pages or burning of image archives to CD. Find more information about f-spot at
http://www.gnome.org/projects/f-spot/ and in Chapter 17,Managing
Images with f-spot (page 165).

Gwenview
Gwenview is a simple image viewer for KDE. It features a folder tree window and
a file list window that provides easy navigation of your file hierarchy. Find more
information at http://gwenview.sourceforge.net/home/.

gThumb
gThumb is an image viewer, browser, and organizer for the GNOME desktop. It
supports the import of your digital images via gphoto2, allows you to carry out
basic transformation and modifications, and lets you tag your images to create al-
bums matching certain categories. Find more information about gThumb at
http://gthumb.sourceforge.net/.

Eye of Gnome (eog)
Eye of Gnome is an image viewer application that is part of the GNOME Office
suite. Find more information athttp://www.gnome.org/gnome-office/
eog.shtml.
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A.5 System and File Management
The following section provides an overview of Linux tools for system and file manage-
ment. Get to know text and source code editors, backup solutions, and archiving tools.

Table A.5 System and File Management Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

kate, gedit, (X)Emacs, vimNotePad, WordPad,
(X)Emacs

Text Editor

ScribusAdobe DistillerPDF Creator

Adobe Reader, Evince,
KPDF, Xpdf

Adobe ReaderPDF Viewer

GOCRRecognita, FineReaderText Recognition

zip, tar, gzip, bzip2, etc.zip, rar, arj, lha, etc.Command Line Pack
Programs

Ark, File RollerWinZipGUI Based Pack Pro-
grams

YaST, GNU PartedPowerQuest, Acronis, Parti-
tion Commander

Hard Disk Partitioner

dar, taper, dumpntbackup, VeritasBackup Software

kate
Kate is part of the KDE suite. It has the ability to open several files at once either
locally or remotely. With syntax highlighting, project file creation, and external
scripts execution, it is a perfect tool for a programmer. Find more information at
http://kate.kde.org/.
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gedit
GEdit is the official text editor of the GNOME desktop. It provides similar features
to Kate. Find more information at http://www.gnome.org/projects/
gedit/.

(X)Emacs
GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU
Emacs. To quote the GNU Emacs Manual, “Emacs is the extensible, customizable,
self-documenting real-time display editor.” Both offer nearly the same functional-
ity with minor differences. Used by experienced developers, they are highly exten-
sible through the Emacs Lisp language. They support many languages, like Russian,
Greek, Japanese, Chinese, and Korean. Find more information at http://www
.xemacs.org/ and http://www.gnu.org/software/emacs/emacs
.html.

vim
vim (vi improved) is a program similar to the text editor vi. Users may need time
to adjust to vim, because it distinguishes between command mode and insert mode.
The basic features are the same as in all text editors. vim offers some unique options,
like macro recording, file format detection and conversion, and multiple buffers in
a screen. Find more information at http://www.vim.org/ or in Reference.

GOCR
GOCR is an OCR (optical character recognition) tool. It converts scanned images
of text into text files. Find more information at http://jocr.sourceforge
.net/.

Adobe Reader
Adobe Reader for Linux is the exact counterpart of the Windows and Mac versions
of this application. The look and feel on Linux are the same as on other platforms.
The other parts of the Adobe Acrobat suite have not been ported to Linux. Find
more information at http://www.adobe.com/products/acrobat/
readermain.html.

Evince
Evince is a document viewer for PDF and PostScript formats for the GNOME
desktop. Find more information at http://www.gnome.org/projects/
evince/.
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KPDF
KPDF is a PDF viewing application for the KDE desktop. Its features include
searching the PDF and full screen reading mode like in Adobe Reader. Find more
information at http://kpdf.kde.org/.

Xpdf
Xpdf is lean PDF viewing suite for Linux and Unix platforms. It includes a viewer
application and some export plug-ins for PostScript or text formats. Find more in-
formation at http://www.foolabs.com/xpdf/.

gzip, tar, bzip2
There are plenty of packaging programs for reducing disk usage. In general, they
differ only in their pack algorithm. Linux can also handle the packaging formats
used on Windows. Find more information about gzip and tar in Section “File
Administration” (Chapter 3, Working with the Shell, ↑Start-Up). bzip2 is a bit
more efficient than gzip, but needs more time, depending on the pack algorithm.

GNU Parted
GNU Parted is a command-line tool for creating, destroying, resizing, checking,
and copying partitions and the file systems on them. If you need to create space
for new operating systems, use this tool to reorganize disk usage and copy data
between different hard disks. Find more information athttp://www.gnu.org/
software/parted/.

KDar
KDar stands for KDE disk archiver and is a hardware-independent backup solution.
KDar uses catalogs (unlike tar), so it is possible to extract a single file without
having to read the whole archive and it is also possible to create incremental
backups. KDar can split an archive into multiple slices and trigger the burning of
a data CD or DVD for each slice. Find more information about KDar at http://
kdar.sourceforge.net/.

taper
Taper is a backup and restore program that provides a friendly user interface to allow
backup and restoration of files to and from a tape drive. Alternatively, files can be
backed up to archive files. Recursively selected directories are supported. Find
more information at http://taper.sourceforge.net/.

Getting to Know Linux Software 213

http://kpdf.kde.org/
http://www.foolabs.com/xpdf/
http://www.gnu.org/software/parted/
http://www.gnu.org/software/parted/
http://kdar.sourceforge.net/
http://kdar.sourceforge.net/
http://taper.sourceforge.net/


dump
The dump package contains both dump and restore. dump examines files in a file
system, determines which ones need to be backed up, and copies those files to a
specified disk, tape, or other storage medium. The restore command performs the
inverse function of dump—it can restore a full backup of a file system. Find more
information at http://dump.sourceforge.net/.

A.6 Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems
for professional software development.

Table A.6 Development Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KDevelop, Eric, Eclipse,
MonoDevelop, Anjuta

Borland C++, Delphi, Visual
Studio, .NET

Integrated Development
Environments

Qt, GTKMFC, Qt, GTKToolkits

GCCVisualStudioCompilers

GDB, valgrindVisual StudioDebugging Tools

Glade, Qt DesignerVisual Basic, Visual C++GUI Design

CVS, SubversionClearcase, Perforce, Source-
Safe

Versioning Systems

KDevelop
KDevelop allows you to write programs for different languages (C/C++, Python,
Perl, etc.). It includes a documentation browser, a source code editor with syntax
highlighting, a GUI for the compiler, and much more. Find more information at
http://www.kdevelop.org.
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Eclipse
The Eclipse Platform is designed for building integrated development environments
that can be extended with custom plug-ins. The base distribution also contains a
full-featured Java development environment. Find more information at http://
www.eclipse.org.

MonoDevelop
The Mono Project is an open development initiative that is working to develop an
open source Unix version of the .NET development platform. Its objective is to
enable Unix developers to build and deploy cross-platform .NET applications.
MonoDevelop complements the Mono development with an IDE. Find more infor-
mation about MonoDevelop at http://www.monodevelop.com/.

Anjuta
Anjuta is an IDE for GNOME/GTK application development. It includes an editor
with automated formatting, code completion and highlighting. Apart from GTK it
supports Perl, Pascal, and Java development. A GDB based debugger is also includ-
ed. Find more information about Anjuta at http://anjuta.sourceforge
.net.

Eric
Eric is an IDE optimized for Python and Python-Qt development. Find more infor-
mation about Eric athttp://www.die-offenbachs.de/detlev/eric3
.html.

Qt
Qt is a program library for developing applications with graphical user interfaces.
It allows you to develop professional programs rapidly. The Qt library is available
not only for Linux, but for a number of Unixes and even for Windows and Macin-
tosh. Thus it is possible to write programs that can be easily ported to those plat-
forms. Find more information at http://www.trolltech.com. Language
bindings for Qt development are summarized under http://developer.kde
.org/language-bindings/.

GTK
GTK is a multiplatform toolkit for creating graphical user interfaces. It is used for
all GNOME applications, The GIMP, and several others. GTK has been designed
to support a range of languages, not only C/C++. Originally it was written for
GIMP, hence the name “GIMP Toolkit.” Find more information at http://www
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.gtk.org. Language bindings for GTK are summarized under http://www

.gtk.org/bindings.html.

GCC
GCC is a compiler collection with front-ends for various programming languages.
Check out a complete list of features and find extensive documentation at http://
gcc.gnu.org.

GDB
GDB is a debugging tool for programs written in various programming languages.
Find more information about GDB at http://www.gnu.org/software/
gdb/gdb.html.

Valgrind
Valgrind is a suite of programs for debugging and profiling x86 applications. Find
more information about Valgrind at http://valgrind.org/info/.

Glade
Glade is a user interface builder for GTK and GNOME development. As well as
GTK support, it offers support for C, C++, C#, Perl, Python, Java, and others. Find
more information about Glade at http://glade.gnome.org/.

Qt Designer
Qt Designer is a user interface and form builder for Qt and KDE development. It
can be run as part of the KDevelop IDE or in stand-alone mode. QtDesigner can
be run under Windows and even integrates into the Visual Studio development
suite. Find more information about Qt Designer at http://www.trolltech
.com/products/qt/designer.html.

CVS
CVS, the Concurrent Versions System, is one of the most important version control
systems for open source. It is a front-end to the Revision Control System (RCS)
included in the standard Linux distributions. Read more about CVS in Reference.
Find more information at the home page http://www.cvshome.org/.

Subversion
Subversion does the same thing CVS does but has major enhancements, like moving,
renaming, and attaching meta information to files and directories. Read more about
Subversion inReference or go to the home pagehttp://subversion.tigris
.org/.
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