
n

SUSE Linux Enterprise Desktop 10 GNOME User Guide
SUSE

m

ovdocx (E
N

U
)  01 February 2006
www . n o v e l l . c o

Linux Enterprise Desktop
1 0
J u l y  1 7 ,  2 0 0 6

G N O M E  U S E R  G U I D E



novdocx (E
N

U
)  01 February 2006
Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. 
Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, 
without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims 
any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. 
reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to 
notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the 
trade laws of other countries. You agree to comply with all export control regulations and to obtain any required 
licenses or classification to export, re-export, or import deliverables. You agree not to export or re-export to entities 
on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export 
laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. 
Please refer to www.novell.com/info/exports/ for more information on exporting Novell software. Novell assumes no 
responsibility for your failure to obtain any necessary export approvals.

Copyright © 2004-2006 Novell, Inc. All rights reserved. Permission is granted to copy, distribute, and/or modify this 
document under the terms of the GNU Free Documentation License (GFDL), Version 1.2 or any later version, 
published by the Free Software Foundation with no Invariant Sections, no Front-Cover Texts, and no Back-Cover 
Texts. A copy of the GFDL can be found at http://www.fsf.org/licenses/fdl.html.

THIS DOCUMENT AND MODIFIED VERSIONS OF THIS DOCUMENT ARE PROVIDED UNDER THE 
TERMS OF THE GNU FREE DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING 
THAT:

1. THE DOCUMENT IS PROVIDED ON AN “AS IS” BASIS, WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE 
DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS FREE OF DEFECTS, MERCHANTABLE, 
FIT FOR A PARTICULAR PURPOSE, OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, 
ACCURACY, AND PERFORMANCE OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT 
IS WITH YOU. SHOULD ANY DOCUMENT OR MODIFIED VERSION PROVE DEFECTIVE IN ANY 
RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR ANY CONTRIBUTOR) ASSUME THE COST OF 
ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY 
CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOCUMENT OR MODIFIED 
VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER; 
AND

2. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY 
CONTRIBUTOR, OR ANY DISTRIBUTOR OF THE DOCUMENT OR MODIFIED VERSION OF THE 
DOCUMENT, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY 
DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, 
COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER DAMAGES OR LOSSES ARISING 
OUT OF OR RELATING TO USE OF THE DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT, 
EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this 
document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. 
patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent 
applications in the U.S. and in other countries.
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Online Documentation: To access the online documentation for this and other Novell products, and to get 
updates, see www.novell.com/documentation.
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Novell Trademarks

For Novell trademarks, see the Novell Trademark and Service Mark list (http://www.novell.com/company/legal/
trademarks/tmlist.html).

Third-Party Materials

All third-party trademarks are the property of their respective owners.
Parts of this manual are copyright © 2003-2004 Sun Microsystems.
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About This Guide

Congratulations on choosing the SUSE® Linux* Enterprise Desktop (SLED). This manual is 
designed to introduce you to the GNOME graphical desktop environment and show you how to 
configure it to meet your personal needs and preferences. It also introduces you to several programs 
and services, including office programs such as OpenOffice.org, Web browsers, file managers, 
scanning tools, and image editing tools. It is intended for users who have some experience using a 
graphical desktop environment such as Macintosh*, Windows*, or other Linux desktops.

This guide contains the following sections:

• Part I, “GNOME Desktop,” on page 13
• Part II, “Office and Collaboration,” on page 63
• Part III, “Internet,” on page 123
• Part IV, “Multimedia,” on page 133
• Part V, “Appendixes,” on page 153

Audience

This guide is intended for SLED users using the GNOME desktop.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Updates

For the latest version of this documentation, see the SUSE Linux Enterprise Desktop documentation 
(http://www.novell.com/documentation/lg/sled/index.html) Web site.

Additional Documentation

The SUSE Linux Enterprise Desktop GNOME User Guide and documentation for each of the 
components included with SUSE Linux Enterprise Desktop can be accessed using the Help Center. 
To access the Novell Help Center, click Help on the top panel of the desktop and then click User's 
Manual.

For documentation about the SLED KDE Desktop, see SUSE Linux Enterprise Desktop KDE User 
Guide (http://www.novell.com/documentation/sled/userguide_kde/data/front.html).

For information about installing and administering SLED, see the SUSE Linux Enterprise Desktop 
Deployment Guide (http://www.novell.com/documentation/nld/nld_deployment/data/front.html).
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Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
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1Getting Started with the GNOME 
Desktop

This chapter assists you in becoming familiar with the conventions, layout, and common tasks of 
SUSE® Linux Enterprise Desktop (SLED) with the GNOME desktop. If you have not yet installed 
SLED, see the SUSE Linux Enterprise Desktop Quick Start (http://www.novell.com/documentation/
nld/qsnld/data/brmch9i.html).

• Section 1.1, “Starting SLED,” on page 15
• Section 1.2, “Logging Out,” on page 16
• Section 1.3, “Desktop Basics,” on page 17
• Section 1.4, “Accessing Folders and Files,” on page 20
• Section 1.5, “Opening or Creating Documents with OpenOffice.org,” on page 29
• Section 1.6, “Exploring the Internet,” on page 29
• Section 1.7, “E-mail and Calendering,” on page 29
• Section 1.8, “Moving Text between Applications,” on page 29
• Section 1.9, “Other Useful Programs,” on page 30
• Section 1.10, “Obtaining Software Updates,” on page 30

1.1  Starting SLED
When you start SLED, you are prompted to enter your username and password. This is the username 
and password you created when you installed SLED. If you did not install SLED, check with your 
system administrator for the username and password.

The login has three menu items:

• Login Prompt:  Enter your username and password to log in.
• Session:  Specify the desktop to run during your session. If other desktops are installed, they 

appear in the list.
• Actions:  Perform a system action, such as shut down the computer, reboot the computer, or 

configure the Login Manager.

• Section 1.1.1, “What Is a Session?,” on page 15
• Section 1.1.2, “Switching Desktops,” on page 16
• Section 1.1.3, “Locking Your Screen,” on page 16

1.1.1  What Is a Session?
A session is the period of time from when you log in to when you log out. The login screen offers 
several login options. For example, you can select the language of your session so that text that 
appears in the SLED interface is presented in that language. 
Getting Started with the GNOME Desktop 15
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After your username and password are authenticated, the Session Manager starts. The Session 
Manager lets you save certain settings for each session. It also lets you save the state of your most 
recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:

• Appearance and behavior settings, such as fonts, colors, and mouse settings.
• Applications that you were running. such as a file manager or an OpenOffice.org program. 

TIP: You cannot save and restore applications that Session Manager does not manage. For 
example, if you start the vi editor from the command line in a terminal window, Session 
Manager cannot restore your editing session.

For information on configuring session preferences, see “Managing Sessions” on page 56.

1.1.2  Switching Desktops
If you installed both the GNOME and the KDE desktops, use the following instructions to switch 
desktops.

1 Click Computer > Logout > OK.

In KDE, click N > Logout > Logout.
2 On the SUSE Linux Enterprise Desktop login screen, click Session.
3 Select the desktop you want (GNOME or KDE), then click OK.
4 Type your username, then press Enter.
5 Type your password, then press Enter.

1.1.3  Locking Your Screen
To lock the screen, you can do either of the following:

• Click Computer > Lock Screen.
• If the Lock button is present on a panel, click it.

To add the Lock button to a panel, right-click the panel and then click Add to Panel > Actions > 
Lock.

When you lock your screen, the screen saver starts. To lock your screen correctly, you must have a 
screen saver enabled. To unlock the screen, move your mouse to display the locked screen dialog. 
Enter your username and password, then press Enter.

For information on configuring your screen saver, see “Configuring the Screen Saver” on page 43.

1.2  Logging Out
When you are finished using the computer, click Computer > Logout. Then select one of the 
following: 

• Log out

Logs you out of the current session and returns you to the Login dialog.
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• Shut down
Logs you out of the current session, then turns off the computer.

• Restart the computer
Logs you out of the current session, then restarts the computer.

• Suspend the computer
Saves the current memory contents to disk and shuts down the computer. When you restart, the 
saved memory content is loaded and you can resume where you left off.

1.3  Desktop Basics
As with other common desktop products, the main components of the GNOME desktop are icons 
that link to files, folders, or programs, as well as the panel at the bottom of the screen (similar to the 
Task Bar in Windows). Double-click an icon to start its associated program. Right-click an icon to 
access additional menus and options. You can also right-click any empty space on the desktop to 
access additional menus for configuring or managing the desktop itself.

By default, the desktop features two key icons: your personal Home folder, and a trash can for 
deleted items. Other icons representing devices on your computer, such as CD drives, might also be 
present on the desktop. If you double-click your Home folder, the Nautilus file manager starts and 
displays the contents of your home directory. For more information about using Nautilus, see 
“Managing Folders and Files with Nautilus File Manager” on page 20. 

Right-clicking an icon displays a menu offering file operations, like copying, cutting, or renaming. 
Selecting Properties from the menu displays a configuration dialog. The title of an icon as well as 
the icon itself can be changed with Select Custom Icon. The Emblems tab lets you add graphical 
descriptive symbols to the icon. The Permissions tab lets you set access permissions for the selected 
files. The Notes tab lets you manage comments. The menu for the trash can additionally features the 
Empty Trash option, which deletes its contents.

A link is a special type of file that points to another file or folder. When you perform an action on a 
link, the action is performed on the file or folder the link points to. When you delete a link, you 
delete only the link file, not the file that the link points to.

To create a link on the desktop to a folder or a file, access the object in question in File Manager by 
right-clicking the object and then clicking Make Link. Drag the link from the File Manager window 
and drop it onto the desktop. 

• Section 1.3.1, “Default Desktop Icons,” on page 17
• Section 1.3.2, “Desktop Menu,” on page 18
• Section 1.3.3, “Bottom Panel,” on page 18
• Section 1.3.4, “Adding Applets and Applications to the Panel,” on page 19
• Section 1.3.5, “Main Menu,” on page 20

1.3.1  Default Desktop Icons
To remove an icon from the desktop, simply drag it onto the trash can. However, be careful with this 
option—if you move folder or file icons to the trash can, the actual data is deleted. If the icons only 
represent links to a file or to a directory, only the links are deleted.
Getting Started with the GNOME Desktop 17
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NOTE: You cannot move the Home icon to the trash.

1.3.2  Desktop Menu
Right-clicking an empty spot on the desktop displays a menu with various options. Click Create 
Folder to create a new folder. Create a launcher icon for an application with Create Launcher. 
Provide the name of the application and the command for starting it, then select an icon to represent 
it. You can also change the desktop background and align desktop icons. 

1.3.3  Bottom Panel
The desktop includes a panel across the bottom of the screen. The bottom panel contains the 
Computer menu (similar to the Start menu in Windows) and the icons of all applications currently 
running. You can also add applications and applets to the panel for easy access. If you click the 
name of a program in the taskbar, the program's window is moved to the foreground. If the program 
is already in the foreground, a mouse click minimizes it. Clicking a minimized application reopens 
the respective window. 

Figure 1-1   GNOME Bottom Panel

The Show Desktop icon is on the right side of the bottom panel. This icon minimizes all program 
windows and displays the desktop. Or, if all windows are already minimized, it opens them up 
again. 

If you right-click an empty spot in the panel, a menu opens, offering the options listed in the 
following table:

Table 1-1   Panel Menu Options

Option Description

Add to Panel Opens a menu list of applications and applets that can be added to the 
panel. 

Properties Modifies the properties for this panel. 

Delete This Panel Removes the panel from the desktop. All of the panel settings are lost.

Allow Panel to be Moved Locks the panel in its current position (so that it can’t be moved to another 
location on the desktop, and unlocks the panel (so it can be moved).

To move the panel to another location, middle-click and hold on any vacant 
space on the panel, and then drag the panel to the location you want. 

New Panel Creates a new panel and adds it to the desktop.

Help Opens the Help Center.

About Panels Opens information about the panel application.
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1.3.4  Adding Applets and Applications to the Panel
You can add applications and applets to the bottom panel for quick access. An applet is a small 
program, while an application is usually a more robust stand-alone program. Adding an applet puts 
useful utilities where you can easily access them.

The GNOME desktop comes with many applets. You can see a complete list by right-clicking the 
bottom panel and selecting Add to Panel. 

Some useful applets include the following:

Table 1-2   Some Useful Applets

Applet Description

Command Line Enter commands in a small entry field.

Dictionary Lookup Look up a word in an online dictionary.

Force Quit Terminate an application. This is especially useful if you want to 
terminate an application that is no longer responding.

Search for Files Find files, folders, and documents on the computer.

Sticky Notes Create, display, and manage sticky notes on your desktop.

Stock Ticker Display continuously updated stock quotes.

Traditional Main Menu Access programs from a menu like the one in previous versions of 
GNOME. This is especially useful for people who are used to earlier 
versions of GNOME.

Volume Control Increase or decrease the sound volume.

Weather Report Display current weather information for a specified city.

Workspace Switcher Access additional work areas, called workspaces, through virtual 
desktops. For example, you can open applications in different 
workspaces and use them on their own desktops without the clutter 
from other applications.
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1.3.5  Main Menu
Open the main menu by clicking Computer on the far left of the bottom panel. Commonly used 
applications appear in the main menu. A search field lets you quickly search for applications and 
files. Access additional applications, listed in categories, by clicking More Applications.

Figure 1-2   Main Menu

1.4  Accessing Folders and Files
SUSE Linux Enterprise Desktop enables you to access folders and files on your computer and on a 
network.

• Section 1.4.1, “Managing Folders and Files with Nautilus File Manager,” on page 20
• Section 1.4.2, “Accessing Floppy Disks, CDs, or DVDs,” on page 22
• Section 1.4.3, “Finding Files on Your Computer,” on page 23
• Section 1.4.4, “Accessing Files on the Network,” on page 25

1.4.1  Managing Folders and Files with Nautilus File Manager
Use the Nautilus File Manager to create and view folders and documents, run scripts, and create 
CDs of your data. In addition, Nautilus provides support for Web and file viewing.

You can open Nautilus in the following ways:

• Click Computer > Nautilus.
• Click your Home directory icon on the desktop
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Figure 1-3   Nautilus File Manager

You can change to the browser mode by right-clicking the folder and then clicking Browse Folder. 
This gives you a familiar view with a location window that shows the current path and buttons for 
common functions. This applies to the current Nautilus window.

Figure 1-4   Nautilus File Manager in Browser Mode

You can change the preferences for files and folders in Nautilus by clicking Edit > Preferences > 
Behavior, then selecting from the following options:

Table 1-3   Nautilus Options

Option Description

Single Click to Activate Item Performs the default action for an item when you 
click the item. If this option is selected and you point 
to an item, the title of the item is underlined.

Double Click to Activate Items Performs the default action for an item when you 
double-click the item.
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Some simple shortcuts for navigating include the following: 

Table 1-4   Nautilus Navigation Shortcuts

For more information, click Help > Contents in Nautilus.

1.4.2  Accessing Floppy Disks, CDs, or DVDs
To access floppy disks, CDs, or DVDs, insert the medium into the appropriate drive. For several 
types of removable media, a Nautilus window pops up automatically when the media is inserted or 
attached to the computer. If Nautilus does not open, double-click the icon for that drive to view the 
contents.

Always Open in Browser Windows Opens Nautilus in Browser mode whenever you 
open it.

Run Executable Files When They Are Clicked Runs an executable file when you click the file. An 
executable file is a text file than can execute (that is, 
a shell script).

View Executable Files When They Are Clicked Displays the contents of an executable file when you 
click the file.

Ask Each Time Displays a dialog when you click an executable file. 
The dialog asks whether you want to execute the file 
or display the file.

Ask Before Emptying Trash or Deleting Files Displays a confirmation message before the Trash is 
emptied or before files are deleted.

Include a Delete Command That Bypasses Trash Adds a Delete menu item to the Edit menu and the 
pop-up menu that is displayed when you right-click a 
file, folder, or desktop object. When you select an 
item and then click Delete, the item is immediately 
deleted from your file system.

Shortcut Description

Backspace or Alt+Up-arrow Opens the parent folder.

Up or Down Selects an item.

Alt+Down, or Enter Opens an item.

Shift+Alt+Down Opens an item and closes the current folder.

Shift+Alt+Up Opens the parent folder and closes the current folder.

Shift+Ctrl+W Closes all parent folders.

Ctrl+L Opens a location by specifying a path or URL.

Alt+Home Opens your home directory.

Option Description
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WARNING: Do not simply remove floppy disks from the drive after using them. Floppy disks, 
CDs, and DVDs must always be unmounted from the system first. Close all File Manager sessions 
still accessing the medium, then right-click the icon for the medium and select Eject from the menu. 
Then safely remove the floppy disk or CD when the tray opens automatically.

Floppy disks can also be formatted by clicking Computer > More Applications > System > Floppy 
Formatter. In the Floppy Formatter dialog, select the density of the floppy disk and the file system 
settings: Linux native (ext2), the file system for Linux, or DOS (FAT) to use the floppy with 
Windows systems.

1.4.3  Finding Files on Your Computer
To locate files on your computer, click Computer, enter your search terms in the Search field, then 
press Enter. The results are displayed in the Desktop Search dialog box.

Figure 1-5   Desktop Search Dialog Box

You can use the results lists to open a file, forward it via e-mail, or display it in the file manager. 
Simply right-click an item in the results list and select the option you want. The options available for 
an item in the results list depend on the type of file it is. Clicking a file in the list displays a preview 
of the file and information such as the title, path, and when the file was last modified or accessed.

Use the Search menu to limit your search to files in a specific location, such as your address book or 
Web pages, or to display only a specific type of file in your results list. The Sort menu lets you sort 
the items in your results list according to name, relevance, or the date the file was last modified.

You can also access Desktop Search by clicking Computer > More Applications > System > Beagle 
Search Tool, pressing F12, or clicking  on the bottom panel.
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Search Tips

• You can use both upper and lowercase letters in search terms. Searches are not case sensitive 
by default.

To perform a case sensitive search, put double quotation marks (“) around the word you want 
to match exactly. For example, if you use “APPLE” in a search, apple would be ignored.

• To search for optional terms, use OR (for example, apples OR oranges).

IMPORTANT: The OR is case-sensitive when used to indicate optional search terms.

• To exclude search terms, use a minus sign (-) in front of the term you want to exclude (for 
example, apples -oranges would find results containing apples but not oranges).

• To search for an exact phrase or word, put quotation marks (“) around the phrase or word.
• Common words such as “a,” “the,” and “is” are ignored.
• The base form of a search term is used when searching (for example, a search for “driving” will 

match “drive,” “drives,” and “driven”).

Performing a Property Search

By default, the Beagle search tool looks for search terms in the text of documents and in their 
properties. To search for a word in a particular property, use property_keyword:query. For 
example, author:john searches for files that have “john” listed in the Author property.

Table 1-5   Supported Property Keywords

Keyword Property

album Album of the media

artist Artist

author Author of the content

comment User comments

creator Creator of the content

extension or ext File extension (for example, extension:jpeg or ext:mp3). Use 
extension:or ext: to search in files with no extension.

mailfrom E-mail sender name

mailfromaddr E-mail sender address

mailinglist Mailing list ID

mailto E-mail recipient name

mailtoaddr E-mail recipient address

tag FSpot and Digikam image tags

title Title
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Property searches follow the rules mentioned in Section , “Search Tips,” on page 24. You can use 
property searches as an exclusion query or OR query, and phrases can be used as query. For 
example, the following line will search for all PDF or HTML documents containing the word 
“apple” whose author property contains “john” and whose title does not contain the word “oranges.” 

apple ext:pdf OR ext:html author:john -title:oranges

Setting Search and Indexing Preferences

Use the Search Preferences dialog box to set search and indexing preferences. To open Search 
Preferences, click Computer > More Applications > System > Beagle Settings. You can also click 
Search > Preferences in the Desktop Search dialog box.

On the Search tabbed page, click Start search & indexing services automatically to start the search 
daemon when you log in (this is selected by default). You can also choose the keystrokes that will 
display the Desktop Search window by specifying any combination of Ctrl, Alt, and a function key. 
F12 is the default keystroke.

On the Indexing tabbed page, you can choose to index your home directory (selected by default), to 
not index your home directory, and to add additional directories to index. Make sure you have rights 
to the directories you add. You can also specify resources that you don’t want indexed (see Section , 
“Preventing Files and Directories from Being Indexed,” on page 25 for more information).

Preventing Files and Directories from Being Indexed

Use the Search Preferences dialog box to specify resources that you don’t want indexed. These 
resources can include directories, patterns, mail folders, or types of objects.

1 Click Computer > More Applications > System > Beagle Search Tool.
2 Click Search > Preferences.
3 On the Indexing tabbed page, click Add in the Privacy section.
4 Select a resource to exclude from indexing, then specify the path to the resource.
5 Click OK twice.

1.4.4  Accessing Files on the Network
This chapter helps you access network resources using the following tasks:

• “Connecting to Your Network” on page 25
• “Managing Network Connections” on page 27
• “Accessing Network Shares” on page 27
• “Sharing Directories from Your Computer” on page 28

Connecting to Your Network

There are essentially two ways that you can connect to a network: via wired and wireless 
connections. To view your network connection status, click Computer. In the Status area of the main 
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menu, The Network Connections icon shows your network connection status. For example, in the 
following figure, the computer is connected to a wired network using an Ethernet connection.

Figure 1-6   Network Connections Icon in the Main Menu

Click on the icon to get information about your connection, such as IP address, gateway address, and 
similar details. 

Connecting to a Wired Connection

1 Make sure that an Ethernet cable is connected to your computer's network interface card.
2 Click the Network Connections icon on the main panel, then click Ethernet: eth0.

After a wired network connection is established, the Network Connections icon changes to show 
your connection type.

A connection to the network is confirmed when Wired is listed next to the Network menu item. You 
can also confirm connectivity by clicking the Network Connections icon. If connected, the 
Connection Information window displays your IP address and other details about your connection.

Connecting to a Wireless Connection

1 Make sure that your computer contains a wireless network interface card.
2 Click the Network Connections icon on the main panel, then click Wireless: <device>.

The Network Connections icon changes to a wireless signal strength bar, and any detected wireless 
networks are displayed in the Network Connections menu.

If your network name is displayed, select the network name from the Network Connections menu. 
After you are connected, the Network Connections icon shows that you have a wireless connection.

If you do not see your wireless network name in the Network Connections menu:

1 Click the Network Connections icon on the main panel, then click Other.
2 In the Specify an ESSID dialog, type the wireless network name in the ESSID: field.
3 (Conditional) If the wireless network is encrypted, click Show Encryption Key to display the 

Encryption Key field.
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4 Type the encryption code, then click OK.
Your wireless network's name should now appear in the Network Connections menu.

5 Select the wireless network's name. 
Upon connection, the Network Connections icon turns blue.

You can also confirm connection by clicking the Network Connections icon and viewing 
Connection Information. If connected, your IP address and other details are displayed in the 
Connection Information dialog.

Managing Network Connections

The Network Connection icon lets you monitor, manage, and configure your network connections. 
Clicking the icon opens a window that displays which network connection is active, if you have 
more than one network device in your computer.

For example, if your laptop computer is configured to use a wireless port and a port for a network 
cable, you will see two network connections in the list.

If you are connected to the network via a cable and need to switch to use your wireless, simply click 
the Network Connections icon and then click Wireless: eth1. SLED switches your network 
connection and acquires a new IP address, if needed.

IMPORTANT: Prior to making the change, you should save any data, because the change in 
services might require that certain applications or services be restarted.

Using the menu, you can view connection informations such as the IP address being used and your 
hardware address.

If you need to update or make changes to your network settings, click Computer > Control Panel > 
Configure Network. This launches the Network Card Setup wizard, which steps you through the 
configuration process. Using this option requires you to provide the password for root.

Accessing Network Shares

Other network devices, like workstations and servers, can be set up to share some or all of their 
resources. Typically, files and folders are marked to let remote users access them. These are called 
network shares. If your system is configured to access network shares, you can use Nautilus File 
Manager to access them. 

To access network shares, double-click Computer > Nautilus, then click Network Servers. The 
window displays the network shares that you can access. Double-click the network resource that you 
want to access. You might be required to authenticate to the resource by providing a username and 
password.

To access NFS shares, double-click the UNIX Network icon. A list of UNIX shares available to you 
is displayed.
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To access Windows shares, double-click the Windows Network icon. The Windows shares available 
to you are displayed.

Figure 1-7   Workgroups on a Windows Network

Adding a Network Place

1 Click Computer > Nautilus > File > Connect to Server.
2 Specify the name you want displayed for this link and its URL, then click Connect.

An icon for the network place is added to the desktop.

Sharing Directories from Your Computer

You can make directories on your computer available to other users on your network.

Enabling Sharing

Use YaST to enable sharing on your computer. In order to enable sharing, you must have root 
privileges and be a member of a workgroup or domain.

1 Click Computer > More Applications > System > YaST.
2 In YaST, click Network Services > Windows Domain Membership.
3 In the Windows Domain Membership module, click Allow Users To Share Their Directories.
4 Click Finish.

Sharing a Directory

If directory sharing is enabled on your computer, use the following steps to configure a directory to 
be shared.

1 Open Nautilus and browse to the directory you want to share.
2 Right-click the folder for the directory you want to share, then click Sharing Options.
3 Select the Share this folder check box, then type the name you want to use for this share.
4 If you want other users to be able to copy files to your shared directory, select the Allow other 

people to write in this folder check box.
5 (Optional) Type a comment, if desired.
6 Click Create Share.
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1.5  Opening or Creating Documents with 
OpenOffice.org
For creating and editing documents, SLED includes OpenOffice.org, a complete set of office tools 
that can both read and save Microsoft Office file formats. OpenOffice.org has a word processor, a 
spreadsheet, a data base, a drawing tool, and a presentation program. To get started, click Computer 
> OpenOffice.org Writer or select an OpenOffice.org module by clicking Computer > More 
Applications > Office, then select the module you want to open.

A number of sample documents and templates are included with OpenOffice.org. You can access 
the templates by clicking File > New > Templates and Documents. In addition, you can use 
AutoPilot, a feature which guides you through the creation of letters and other typical documents.

For a more in-depth introduction to OpenOffice.org, see Chapter 3, “The OpenOffice.org Office 
Suite,” on page 65 or view the help in any OpenOffice.org program.

1.6  Exploring the Internet
SLED includes Firefox, a Mozilla* based Web browser. You can start it by clicking Computer > 
Firefox.

You can type an address into the location bar at the top or click links in a page to move to different 
pages, just like in any other Web browser.

For more information, see Chapter 9, “Browsing with Firefox,” on page 125.

1.7  E-mail and Calendering
Novell Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in one 
easy-to-use application. With its extensive support for communications and data interchange 
standards, Evolution can work with existing corporate networks and applications, including 
Microsoft Exchange.

To start Evolution, click Computer > More Applications > Communicate > Evolution E-Mail or 
Computer > More Applications > Office > Evolution Calendar.

The first time you start it, Evolution prompts you with a few questions as it sets up a mail account 
and helps you import mail from your old mail client. Then it shows you how many new messages 
you have and lists upcoming appointments and tasks, as well as the current weather and news from 
news feeds. The calendar, address book, and mail tools are available in the shortcut bar on the left.

For more information, see Chapter 4, “Evolution: E-Mail and Calendaring,” on page 85 and Chapter 
5, “GroupWise Linux Client: E-Mailing and Calendaring,” on page 99.

1.8  Moving Text between Applications
To copy text between applications, select the text and then move the mouse cursor to the position 
where you want the text copied. Click the center button on the mouse or the scroll wheel to copy the 
text.

When copying information between programs, you must keep the source program open and paste 
the text before closing it. When a program closes, any content from that application that is on the 
clipboard is lost. 
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1.9  Other Useful Programs
In addition to the programs already discussed, like applets you can add to a panel, SLED also 
includes additional programs, organized in categories in the Application Browser. To access the 
programs, open the Application Browser by clicking Computer > More Applications, then browse 
through the categories to see which applications are available. Categories include the following: 

Table 1-6   SLED Applications

Following chapters in this guide describe some of the more commonly used applications.

1.10  Obtaining Software Updates
Novell offers important updates and enhancements that help protect your computer and ensure that it 
runs smoothly through ZenWorks®. The Software Update feature is designed to help you manage 
the software you have on your computer and to install, update, and remove programs without your 
having to track dependencies and resolve conflicts. Contact your system administrator for more 
information about how your company is disseminating updates.

To access the update tool, click Computer > More Applications > System > Update Software.

If updates are available, the Zen Update icon appears in the notification area of the bottom panel. In 
this case, click the icon to access the update tool.

Category Types of Programs

Audio & Video Music players, CD database, video editors, CD and DVD burners, volume 
controllers, and other audio and video applications

Browse Applications for browsing the Internet and your computer’s file system

Communicate E-mail, instant messaging, video conferencing, and other communication tools

Development Web development, MONO documentation, sharing files between computers

Games Card games, arcade favorites, and puzzles

Images Image viewers and editors, drawing programs, photo browsers, scanning 
programs

Office Word processors and text editors, spreadsheets, presentation software, database 
software, project management utilities, PDF reader, personal information 
managers, calendars

System Search tools, system configuration tools, network tools, device managers

Tools System customization, search configuration, calculators, and other tools
 Enterprise Desktop 10 GNOME User Guide



2
novdocx (E

N
U

)  01 February 2006
2Customizing Your Settings

You can change the way SUSE® Linux Enterprise Desktop (SLED) looks and behaves to suit your 
own personal tastes and needs. Some of the settings you might want to change include:

• Desktop background
• Screen saver
• Keyboard and mouse configuration
• Sounds
• File associations

These settings and others can be changed in the Control Center. To access the Control Center, click 
Computer > Control Center. The Control Center is divided into the following four categories:

• Section 2.1, “Hardware,” on page 32
• Section 2.2, “Look and Feel,” on page 40
• Section 2.3, “Personal,” on page 47
• Section 2.4, “System,” on page 51

Figure 2-1   GNOME Control Center

Some settings require that you use the YaST Control Center. These administrator settings includes 
most of the hardware, the graphical user interface, Internet access, security settings, user 
administration, software installation, and system updates and information. You need the root 
password to access the YaST Control Center.

For information on configuring administrator settings, see Using YaST to Configure the SUSE 
Linux Enterprise Desktop (http://www.novell.com/documentation/nld/nld_deployment/data/
bsj9luh.html) in the SUSE Linux Enterprise Desktop Deployment Guide.
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2.1  Hardware
Hardware settings include the following:

• Section 2.1.1, “Configuring Bluetooth Services,” on page 32
• Section 2.1.2, “Configuring Your Graphics Card and Monitor,” on page 32
• Section 2.1.3, “Modifying Keyboard Preferences,” on page 32
• Section 2.1.4, “Configuring the Mouse,” on page 36
• Section 2.1.5, “Installing and Configuring Printers,” on page 38
• Section 2.1.6, “Configuring Removable Drives and Media,” on page 39
• Section 2.1.7, “Configuring a Scanner,” on page 39
• Section 2.1.8, “Specifying Screen Resolution Settings,” on page 40

2.1.1  Configuring Bluetooth Services
Bluetooth services enable you to connect wireless devices such as mobile phones and personal data 
assistants (PDAs) to your computer. Bluetooth wireless support includes automatic recognition of 
Bluetooth-enabled devices via the YaST central configuration and administration tool. Click 
Computer > Control Center > Hardware > Bluetooth, then set the configuration options that are 
appropriate for your device.

NOTE: Root privileges are required for configuring Bluetooth services.

2.1.2  Configuring Your Graphics Card and Monitor
Your graphics card was configured for your monitor when you installed SLED. If you ever need to 
change these settings, click Computer > Control Center > Hardware > Graphics Card and 
Monitor, then set the appropriate options for your monitor. 

NOTE: Graphics card configuration is done in YaST2 and requires root privileges.

2.1.3  Modifying Keyboard Preferences
Use the Keyboard Preferences tool to modify the autorepeat preferences for your keyboard and to 
configure typing break settings.

Click Computer > Control Center > Hardware > Keyboard. 

You can set the following preferences:

• Keyboard
• Typing Break
• Layouts
• Layout Options
 Enterprise Desktop 10 GNOME User Guide



novdocx (E
N

U
)  01 February 2006
Configuring Keyboard Preferences

Use the Keyboard tabbed page to set general keyboard preferences.

Figure 2-2   Keyboard Preferences Dialog—Keyboard Page

You can modify any of the following keyboard preferences:

Table 2-1   Keyboard Preferences

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Option Description

Key Presses Repeat When Key is 
Held Down

Enables keyboard repeat. The action associated with a key is 
performed repeatedly when you press and hold that key. For 
example, if you press and hold a character key, the character is 
typed repeatedly.

Use the Delay option to select the delay from the time you press a 
key to the time that the action repeats.

Use the Speed option to set the speed at which the action is 
repeated.

Cursor Blinks in Text Boxes and 
Fields

Lets the cursor blink in fields and text boxes.

Use the slider to specify the speed at which the cursor blinks.

Type to Test Settings The test area is an interactive interface that lets you see how the 
keyboard settings affect the display as you type. Type text in the 
test area to test the effect of your settings.
Customizing Your Settings 33



34 SUSE Linux

novdocx (E
N

U
)  01 February 2006
Configuring Typing Break Preferences

Use the Typing Break tabbed page to set typing break preferences.

Figure 2-3   Keyboard Preferences Dialog—Typing Break Page

You can modify any of the following typing break preferences:

Table 2-2   Typing Break Preferences

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Option Description

Lock Screen to Enforce Typing Break Locks the screen when you are due a typing break.

Work Interval Lasts Lets you specify how long you can work before a typing break 
occurs.

Break Interval Lasts Lets you specify the length of your typing breaks.

Allow Postponing of Breaks Lets you postpone typing breaks.
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Configuring Keyboard Layout Preferences

Use the Layouts tabbed page to set your keyboard layout. 

Figure 2-4   Keyboard Preferences Dialog—Layouts Page

Select your keyboard model from the drop-down list, then use the navigational buttons to add or 
remove the selected layout to or from the list of available layouts.

You can select different layouts to suit different locales. 

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Configuring Keyboard Layout Options

Use the Layout Options tabbed page to set your keyboard layout options. 

Figure 2-5   Keyboard Preferences Dialog—Layout Options Page

Select an option from the list of available layout options and click Add to add the option or Remove 
to remove it.
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Click the Accessibility button to start the Keyboard accessibility preference tool. 

2.1.4  Configuring the Mouse
Use the Mouse Preference tool to configure your mouse for right-hand use or for left-hand use. You 
can also specify the speed and sensitivity of mouse movement.

Click Computer > Control Panel > Hardware > Mouse. 

You can customize the settings for the Mouse Preference tool in the following areas:

• Buttons
• Cursors
• Motion

Configuring Button Preferences

Use the Buttons tabbed page to specify whether the mouse buttons are configured for left-hand use. 
You can also specify the delay between clicks for a double-click.

Figure 2-6   Mouse Preferences Dialog—Buttons Page

The following table lists the mouse button preferences you can modify.

Table 2-3   Mouse Button Preferences

Option Description

Left-handed Mouse Configures your mouse for left-hand use, swapping the functions of the left 
mouse button.

Timeout Use the slider to specify the amount of time that can pass between clicks 
when you double-click. If the interval between the first and second clicks 
exceeds the time that is specified here, the action is not interpreted as a 
double-click.
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Configuring Cursor Preferences

Use the Cursors tabbed page to set your mouse pointer preferences.

Figure 2-7   Mouse Preferences Dialog—Cursors Page

The following table lists the mouse pointer preferences you can modify. 

Table 2-4   Mouse Pointer Preferences

Option Description

Cursor Theme Displays the available cursor themes.

Highlight the Pointer When You Press Ctrl Enables a mouse pointer animation when you press and 
release Ctrl. This feature can help you locate the mouse 
pointer.
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Configuring Motion Preferences

Use the Motion tabbed page to set your preferences for mouse movement.

Figure 2-8   Mouse Preferences Dialog—Motion Page

The following table lists the mouse motion preferences you can modify.

Table 2-5   Mouse Motion Preferences

2.1.5  Installing and Configuring Printers
Use the Printers module to install and configure printers.

Option Description

Acceleration Use the slider to specify the speed at which your mouse pointer moves on your 
screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to movements of 
your mouse.

Threshold Use the slider to specify the distance that you must move an item before the move 
action is interpreted as a drag and drop action.
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To start the Printers module, click Computer > Control Center > Hardware > Printers. 

Figure 2-9   Printers Dialog

For more information about setting up printing, see Chapter 8, “Managing Printers,” on page 121.

2.1.6  Configuring Removable Drives and Media
SLED supports a wide variety of removable drives and media, including storage devices, cameras, 
scanners, and more. The configurations for many of these devices are set up automatically when 
SLED is installed. To change the configuration for a drive or other removable device, click 
Computer > Control Center > Hardware > Removable Drives and Media.

Some of the possible configuration settings include:

• What happens when a blank CD is inserted in the CD drive
• What happens when an audio CD is inserted in the drive
• Whether images are automatically imported from a digital camera when it is attached to the 

computer
• Whether removable storage devices are mounted when they are plugged in to the computer 
• Whether PDAs are automatically synced when attached to the computer

In general, you do not need to change the settings that are already configured unless you want to 
change the behavior when a device is connected or if you want to connect a new device that is not 
yet configured. If you attach a device for the first time and it behaves in an unexpected or undesired 
way, check the Removable Drives and Media settings.

2.1.7  Configuring a Scanner
The Scanner configuration enables you to attach and configure a scanner, or to remove an already-
attached scanner. 

NOTE: Scanner configuration is done in YaST2 and requires root privileges.

To open YaST2 and configure a scanner, click Computer > Control Center > Hardware > Scanner. 
Refer to the instructions on the Scanner Configuration screen for information about the available 
options.
Customizing Your Settings 39



40 SUSE Linux

novdocx (E
N

U
)  01 February 2006
2.1.8  Specifying Screen Resolution Settings
Use this module to specify the resolution settings for your screen, including Resolution and Refresh 
Rate.

Click Computer > Control Center > Hardware > Screen Resolution. 

Figure 2-10   Screen Resolution Preferences Dialog

The following table lists the screen resolution preferences you can modify.

Table 2-6   Screen Resolution Preferences

If you cannot find a setting you want, you might need to use the Administrator Settings to 
reconfigure your graphics card and monitor settings. See Configuring the Graphics Card and 
Monitor (http://www.novell.com/documentation/nld/nld_deployment/data/
bsj9mwg.html#bsmqn45) in the SUSE Linux Enterprise Desktop Deployment Guide for more 
information.

2.2  Look and Feel
Look and Feel settings include the following:

• Section 2.2.1, “Changing the Desktop Background,” on page 41
• Section 2.2.2, “Configuring Fonts,” on page 42
• Section 2.2.3, “Configuring the Screen Saver,” on page 43
• Section 2.2.4, “Choosing a Theme,” on page 44
• Section 2.2.5, “Customizing Window Behavior,” on page 46

Option Description

Resolution Select the resolution (in pixels) to use for the screen.

Refresh Rate Select the refresh rate to use for the screen.

Make Default for This Computer Only Makes the screen resolution settings the default settings 
only for the computer that you are logged in to.
 Enterprise Desktop 10 GNOME User Guide

http://www.novell.com/documentation/nld/nld_deployment/data/bsj9mwg.html#bsmqn45
http://www.novell.com/documentation/nld/nld_deployment/data/bsj9mwg.html#bsmqn45


novdocx (E
N

U
)  01 February 2006
2.2.1  Changing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can customize the 
desktop background in the following ways:

• Select an image for the desktop background. The image is superimposed on the desktop 
background color. The desktop background color is visible if you select a transparent image or 
if the image does not cover the entire desktop.

• Select a color for the desktop background. You can select a solid color or create a gradient 
effect with two colors. A gradient effect is a visual effect where one color blends gradually into 
another color.

To change the desktop preferences:

1 Click Computer > Control Center > Look and Feel > Desktop Background.
2 Set the desktop preferences the way that you want them.

The following settings can be changed:

Table 2-7   Background Preferences

Option Description

Desktop Wallpaper Displays an image of your choice on the desktop.

Style Determines what processing steps should be applied to the selected 
image to adapt it optimally to the current screen resolution. To specify how 
to display the image, select one of the following options from the Style 
drop-down list:

• Centered: Displays the image in the middle of the desktop.

• Fill Screen: Enlarges the image to cover the desktop and maintains 
the relative dimensions of the image.

• Scaled: Enlarges the image until the image meets the screen edges 
and maintains the relative dimensions of the image.

• Tiled: Repeats the image over the entire screen.

Add Wallpaper Opens a dialog where you can select an image file to use as the 
background picture.

Remove Removes a Desktop Wallpaper after you select it and then click Remove.
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3 When you are satisfied with your choices, click Close.
Your desktop immediately changes to show the new settings.

2.2.2  Configuring Fonts
Use the Font Preferences dialog to select the fonts to use in your applications, windows, terminals, 
and desktop. To open the Font Preferences dialog, click Computer > Control Center > Look and 
Feel > Fonts.

Figure 2-11   Font Preferences Dialog

Desktop Colors Lets you specify a color scheme using the options in the Desktop Color 
drop-down list and the color selector buttons. You can specify a color 
scheme using any of the following options:

• Solid Color specifies a single color for the desktop background.

To select a color, click Color. In the Pick a Color dialog, select a color 
and then click OK 

• Horizontal Gradient creates a gradient effect from the left screen 
edge to the right screen edge.

Click Left Color to display the Pick a Color dialog, then select the 
color that you want to appear at the left edge.

Click Right Color, then select the color that you want to appear at the 
right edge.

• Vertical Gradient creates a gradient effect from the top screen edge 
to the bottom screen edge.

Click Top Color to display the Pick a Color dialog, then select the 
color that you want to appear at the top edge.

Click Bottom Color, then select the color that you want to appear at 
the bottom edge.

Option Description
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The upper part of the dialog shows the fonts selected for the application, desktop, window title, and 
terminal. Click one of the buttons to open a selection dialog where you can set the font family, style, 
and size.

To specify how to render fonts on your screen, select one of the following options:

• Monochrome: Renders fonts in black and white only. The edges of characters might appear 
jagged in some cases because the characters are not antialiased. Antialiasing is an effect that is 
applied to the edges of characters to make the characters look smoother.

• Best Shapes: Antialiases fonts where possible. Use this option for standard Cathode Ray Tube 
(CRT) monitors.

• Best Contrast: Adjusts fonts to give the sharpest possible contrast and antialiases fonts so that 
characters have smooth edges. This option might enhance the accessibility of the GNOME 
Desktop to users with visual impairments.

• Subpixel Smoothing (LCDs): Uses techniques that exploit the shape of individual Liquid 
Crystal Display (LCD) pixels to render fonts smoothly. Use this option for LCD or flat-screen 
displays.

Click Details to specify further details of how to render fonts on your screen:

• Resolution (Dots Per Inch): Use the spin box to specify the resolution to use when your 
screen renders fonts.

• Smoothing: Select one of the options to specify how to antialias fonts.
• Hinting: Select one of the options to specify how to apply hinting to improves the quality of 

fonts at small sizes and at low screen resolutions.
• Subpixel Order: Select one of the options to specify the subpixel color order for your fonts. 

Use this option for LCD or flat-screen displays.

2.2.3  Configuring the Screen Saver
A screen saver is a program that blanks the screen or displays graphics when the computer is not 
used for a specified amount of time. Originally, screen savers protected monitors from having 
images burned into them. Now they are used primarily for entertainment or security.
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To configure a screen saver, click Computer > Control Center > Look and Feel > Screensaver. 

Figure 2-12   Screensaver Preferences Dialog

You can select from Random (random selection of screen savers from a custom-defined list), Blank 
Screen, or a selection of installed screen savers. 

Select a screen saver from the list to choose it. The currently selected screen saver is displayed in the 
small preview window. Specify the amount of time that the screen is to be idle before the screen 
saver is activated, and whether the screen is locked when the screen saver is activated.

2.2.4  Choosing a Theme
A theme is a group of coordinated settings that specifies the visual appearance of a part of the 
desktop. You can choose themes to change the appearance of the desktop. Use the Theme 
Preferences tool to select from a list of preinstalled themes. The list of available themes includes 
several themes for users with accessibility requirements.

To choose a theme, click Computer > Control Center > Look and Feel > Theme. 

A theme contains settings that affect different parts of the desktop, as follows: 

• Controls

The controls setting for a theme determines the visual appearance of windows, panels, and 
applets. It also determines the visual appearance of the GNOME-compliant interface items that 
appear on windows, panels, and applets, such as menus, icons, and buttons. Some of the 
controls setting options that are available are designed for special accessibility needs. You can 
select an option for the controls setting in the Controls tabbed page of the Theme Details tool.

• Window frame
The window frame setting for a theme determines the appearance of the frames around 
windows only. You can select an option for the window frame setting in the Window Border 
tabbed page of the Theme Details tool.
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• Icon
The icon setting for a theme determines the appearance of the icons on panels and the desktop 
background. You can select an option for the icon setting in the Icons tabbed page of the 
Theme Details tool.

The color settings for the desktop and applications are controlled using themes. You can choose 
from a variety of preinstalled themes. Selecting a style from the list overview applies it 
automatically. Details opens another dialog where you can customize the style of single desktop 
elements, like window content, window borders, and icons. Making changes and leaving the dialog 
by clicking Close switches the theme to Custom Theme. Click Save Theme to save your modified 
theme under a custom name. The Internet and other sources provide many additional themes for 
GNOME as .tar.gz files. Install these with the Install theme. 

Creating a Custom Theme

The themes that are listed in the Theme Preferences tool are different combinations of controls 
options, window frame options, and icon options. You can create a custom theme that uses different 
combinations of options.

1 Click  > Computer > Control Center > Look and Feel > Theme.
2 Select a theme from the list of themes, then click Theme Details.
3 Select the controls option that you want to use in the custom theme from the list in the Controls 

tabbed page.
4 Click the Window Border tab, then select the window frame option that you want to use in the 

custom theme.
5 Click the Icons tab, then select the icons option that you want to use in the custom theme.
6 Click Close > Save Theme.

A Save Theme to Disk dialog is displayed.
7 Type a name and a short description for the custom theme in the dialog, then click Save. 

The custom theme now appears in your list of available themes.

Installing a New Theme

You can add a theme to the list of available themes. The new theme must be an archive file that is 
tarred and zipped (a .tar.gz file).

1 Click Computer > Control Center > Look and Feel > Theme.
2 Click Install Theme.
3 Specify the location of the theme archive file in the Location field, then click OK.

You can also click Browse to browse for the file.
4 Click Install to install the new theme.

Installing a New Theme Option

You can install new controls options, window frame options, or icons options. You can find many 
controls options on the Internet.

1 Click Computer > Control Center > Look and Feel > Theme.
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2 Click Theme Details, then click the tab for the type of theme you want to install.
For example, to install an icons option, click the Icons tab.

3 Click Install Theme.
4 Specify the location of the theme archive file in the Location field, then click OK.
5 Click Install to install the new theme option.

Deleting a Theme Option

You can delete controls options, window frame options, or icons options.

1 Click Computer > Control Center > Look and Feel > Theme.
2 Click Theme Details, then click the tab for the type of option you want to delete.
3 Click Go To Theme Folder.

A File Manager window opens on the default option folder.
4 Use the File Manager window to delete the option.

2.2.5  Customizing Window Behavior
Use the Window Preferences tool to customize window behavior for the desktop. You can determine 
how a window reacts to contact with the mouse pointer or to double-clicks on its titlebar, and you 
can define which key to hold for moving an application window. 

To customize window behavior, click Computer > Control Center > Look and Feel > Windows. 

Figure 2-13   Window Preferences Dialog

When several application windows populate the desktop, the active one by default is the one last 
clicked. Change this behavior by activating Select Windows When the Mouse Moves over Them. If 
desired, activate Raise Selected Window after an Interval and adjust the latency time with the slider. 
This raises a windows a short time after the window receives focus. 

Application windows can be shaded (rolled up) by double-clicking the title bar, leaving only the title 
bar visible. This saves space on the desktop and is the default behavior. It is also possible to set 
windows to maximize when the title bar is double-clicked. 
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Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt, Hyper, or the 
Windows logo key). 

2.3  Personal
Personal settings include the following:

• Section 2.3.1, “Configuring Keyboard Accessibility Settings,” on page 47
• Section 2.3.2, “Configuring Assistive Technology Support,” on page 49
• Section 2.3.3, “Changing Your Password,” on page 50
• Section 2.3.4, “Configuring Language Settings,” on page 50
• Section 2.3.5, “Customizing Keyboard Shortcuts,” on page 51

2.3.1  Configuring Keyboard Accessibility Settings
GNOME provides keyboard settings designed to help users with motion impairments use the 
GNOME desktop. Some of the available settings include: 

• How long a key is pressed and held before being recognized as valid input
• Whether the keyboard can be used as a mouse
• Whether key combinations that use Alt, Control, and Shift can be duplicated with “sticky keys”

To configure keyboard accessibility settings, click Computer > Control Center > Accessibility. 
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The module consists of the three tabs: Basic, Filters, and Mouse Keys. Before modifying settings, 
activate Enable Keyboard Accessibility Features. 

Figure 2-14   Keyboard Accessibility Preferences Dialog

Features (Basic Tab)

The keyboard accessibility functions can be deactivated automatically after a certain time. Set an 
appropriate time limit (measured in seconds) with the slider. The system can additionally provide 
audible feedback when the keyboard accessibility functions are activated and deactivated. 

Enable Sticky Keys (Basic Tab)

Some keyboard shortcuts require that one key (a modifier key) is kept pressed constantly (this 
applies to Alt, Ctrl, and Shift) while the rest of the shortcut is typed. When sticky keys are used, the 
system regards those keys as staying pressed after being pressed once. For an audible feedback 
generated each time a modifier key is pressed, activate Beep when the modifier is pressed. If Disable 
If Two Keys Pressed Together is selected, the keys do not “stick” anymore when two keys are 
pressed simultaneously. The system then assumes that the keyboard shortcut has been completely 
entered. 

Enable Repeat Keys (Basic Tab)

Activate Repeat Keys to make settings with sliders for Delay and Speed. This determines how long a 
key must be pressed for the automatic keyboard repeat function to be activated and at what speed the 
characters are then typed. 

Test the effect of the settings in the field at the bottom of the dialog. Select parameters that reflect 
your normal typing habits. 
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Enable Slow Keys (Filters Tab)

To prevent accidental typing, set a minimum time limit that a key must be pressed and held before it 
is recognized as valid input by the system. Also determine whether audible feedback should be 
provided for keypress events, accepted keypresses, and the rejection of a keypress. 

Enable Bounce Keys (Filters Tab)

To prevent double typing, set a minimum time limit for accepting two subsequent keypress events of 
the same key as the input of two individual characters. If desired, activate audible feedback upon 
rejection of a keypress event. 

Toggle Keys (Filters Tab)

You can request audible feedback from the system when a keycap modifier key is pressed. 

Mouse Keys Tab

Activates the keyboard mouse; the mouse pointer is controlled with the arrow keys of the number 
pad. Use the sliders to set the maximum speed of the mouse pointer, the acceleration time until the 
maximum speed is reached, and the latency between the pressing of a key and the cursor movement. 

2.3.2  Configuring Assistive Technology Support
SLED includes assistive technologies for users with special needs. These technologies include:

• Screen reader
• Screen magnifier
• On-screen keyboard

To configure assistive technology options, click Computer > Control Center > Personal > Assitive 
Technology. To enable the technologies, first select Enable Assistive Technologies and then select 
the technologies you want to enable every time you log in.

Figure 2-15   Assistive Technology Preferences Dialog
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The gok package must be installed in order to get on-screen keyboard support, and the gnopernicus 
and gnome-mag packages must be installed in order to get screenreading and magnifying 
capabilities.

If these packages are not installed on your system (they are installed by default in the SLED 
installation), install them with the following procedure: 

1 Click System > Administrator Settings.
2 Type the root password, then click OK.
3 Click Software > Install and Remove Software.
4 Select Selection from the Filter drop-down menu, then select Accessibility from the Selection 

list.
5 Select gok, gnopernicus, and gnome-mag from the Package list
6 Click Accept.
7 Insert SUSE Linux Enterprise Desktop 10 CD 2, then click OK.
8 Click Cancel > Close after the package installation is complete.

2.3.3  Changing Your Password
For security reasons, it is a good idea to change your password from time to time. To change your 
password:

1 Click Computer > Control Center > Personal > Change Password.
2 Type your old (current) password.
3 Type your new password.
4 Confirm your new password by typing it again, then click OK.

2.3.4  Configuring Language Settings
SLED can be configured to use any of many languages. The language setting determines the 
language of dialogs and menus, and can also determine the keyboard and clock layout.

You can set the following language settings:

• Primary language
• Whether the keyboard language setting should depend on the primary language
• Whether the time zone should depend on the primary language
• Secondary languages

NOTE: You must have administrator (root) privileges to configure language settings.

To configure your language settings:

1 Click Computer > Control Center > Personal > Language.
2 (Conditional) If you are not logged in as root or a user with administrator privileges, enter the 

root password.
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If you do not know the root password, contact your system administrator. You cannot continue 
without the root password.

3 Specify the primary language, whether you want to adapt the keyboard layout or time zone to 
the primary language, and any secondary languages you need to support on the computer.

4 Click Accept.
The language configuration settings are written to several configuration files. This process can 
take a few minutes. The new settings take effect immediately after they are written to the 
configuration files.

2.3.5  Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to standard ways of 
performing an action. SLED allows you to customize the keyboard shortcuts for a number of 
actions.

To open the Keyboard Shortcuts tool, click Computer > Control Center > Personal > Shortcuts. 

Figure 2-16   Keyboard Shortcuts Dialog

To change the shortcut keys for an action, select the action and then press the keys you want to 
associate with the action. To disable the shortcut keys for an action, click the shortcut for the action, 
then press Backspace.

2.4  System
System settings include the following:

• Section 2.4.1, “Configuring Search with Beagle Settings,” on page 52
• Section 2.4.2, “Configuring Date and Time,” on page 52
• Section 2.4.3, “Configuring Network Proxies,” on page 52
• Section 2.4.4, “Configuring Power Management,” on page 53
• Section 2.4.5, “Setting Preferred Applications,” on page 54
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• Section 2.4.6, “Setting Session Sharing Preferences,” on page 55
• Section 2.4.7, “Managing Sessions,” on page 56
• Section 2.4.8, “Setting Sound Preferences,” on page 59
• Section 2.4.9, “Managing Users and Groups,” on page 61

2.4.1  Configuring Search with Beagle Settings
Beagle is the search engine used on the SLED GNOME Desktop. By default, Beagle is configured 
to start automatically and index your home directory. If you want to change these settings, specify 
the number of results displayed after a search or change the Beagle privacy settings, click Computer 
> Control Center > System > Beagle Settings.

2.4.2  Configuring Date and Time
To change your date and time configuration, for example to change your time zone or the way the 
date and time are displayed, click Computer > Control Center > System > Date and Time. This 
opens the YaST Date and Time module, which requires root privileges. Enter the root password and 
follow the instructions on the YaST pages.

2.4.3  Configuring Network Proxies
The Network Proxy Configuration tool lets you configure how your system connects to the Internet. 
You can configure the desktop to connect to a proxy server and specify the details of the server. A 
proxy server is a server that intercepts requests to another server and fulfills the request itself, if it 
can. You can specify the Domain Name Service (DNS) name or the Internet Protocol (IP) address of 
the proxy server. A DNS name is a unique alphabetic identifier for a computer on a network. An IP 
address is a unique numeric identifier for a computer on a network.

Click Computer > Control Center > System > Network Proxies. 

Figure 2-17   Network Proxy Configuration Dialog

The following table lists the Internet connection options that you can modify.
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Table 2-8   Internet Connection Options

2.4.4  Configuring Power Management
This module lets you manage your system’s power-saving options. It is especially useful for 
extending the life of a laptop’s battery charge. However, several options also help to save electricity 
when using a computer that is plugged in to an electricity source.

Click Computer > Control Center > System > Power Management.

Specifying Sleep Mode Times

Sleep mode shuts down the computer when it is unused for a specified amount of time. Whether 
under battery or AC power, you can specify the amount of time that the computer remains unused 
before it is put to sleep.You can also put the computer’s display to sleep without shutting down the 
computer, saving the power required by the display.

Sleep mode is especially important when the computer is operating under battery power. Both the 
screen and the computer draw power from the battery, so you can save a significant amount of 
battery power by shutting down one or both. It is common to put the display to sleep after a shorter 
period of time. (The default is five minutes.) Then, if the computer remains unused for a further 
amount of time (default 20 minutes), it is also put to sleep.

To specify your computer’s sleep settings, open the Power Management module and click the Sleep 
tab. Then, specify the amount of time that should pass before the display and computer are put to 
sleep, for both AC power and battery power.

Option Description

Direct Internet connection Connects directly to the Internet, without a proxy server.

Manual proxy configuration Connects to the Internet through a proxy server and lets you 
configure the proxy server manually.

HTTP proxy The DNS name or IP address of the proxy server to use when 
you request a HTTP service. Specify the port number of the 
HTTP service on the proxy server in the Port box.

Secure HTTP proxy The DNS name or IP address of the proxy server to use when 
you request a Secure HTTP service. Specify the port number 
of the Secure HTTP service on the proxy server in the Port 
box.

FTP proxy The DNS name or IP address of the proxy server to use when 
you request an FTP service. Specify the port number of the 
FTP service on the proxy server in the Port box.

Socks host The DNS name or IP address of the Socks host to use. Specify 
the port number for the Socks protocol on the proxy server in 
the Port spin box.

Automatic proxy configuration Connects to the Internet through a proxy server and lets you 
configure the proxy server automatically.

Autoconfiguration URL The URL that contains the information required to configure the 
proxy server automatically.
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Setting Power Options

To set the type of sleep mode used by your computer and the action to take when the battery power 
reaches the critical level, open the Power Management module and click the Options tab.

There are two available types of sleep mode:

• Standby

Standby mode turns off power-consuming computer components such as the display and the 
hard drive without saving the contents of RAM. Any unsaved data is lost.

• Hibernate
Hibernate mode saves all contents of RAM to the hard disk before shutting off power to the 
system. When you start the system again, the saved data is put back into RAM, restoring your 
computer to the state it was in before it shut off. Hibernate requires an amount of free hard disk 
space equal to the amount of RAM installed on the computer.

Choose the type of sleep mode you prefer by selecting it from the menu. If you have sufficient free 
disk space, Hibernate is the better choice.

You can also specify what your computer does when the battery reaches the critical level. The 
available options are:

• Do Nothing

The computer does not shut down or automatically go into any kind of power-saving mode.
• Hibernate

The computer saves the contents of RAM to the hard disk, then shuts down. When you turn the 
computer on again, the saved data is put back into RAM, restoring your computer to the state it 
was in before it shut off. Hibernate requires an amount of free hard disk space equal to the 
amount of RAM installed on the computer.

• Shut Down
The computer turns off without saving anything. All unsaved data is lost.

Choose the option you prefer by selecting it from the menu. If you have sufficient free disk space, 
Hibernate is the better choice.

Setting Advanced Power Options

The available advanced power options allow you to display how and when the Power icon displays, 
and at what point the battery is considered low or critical. Open the Power Management module, 
then click the Advanced tab to set these options.

You can specify whether the power icon is always or never displayed in the System Tray, or that it is 
present only when the battery is low, or when it is either charging or discharging. 

You can also select the percentage of battery power remaining that is to be considered low or 
critical. Slide the slider for each option until the desired percentage is specified.

2.4.5  Setting Preferred Applications
The Preferred Applications module allows you to specify which applications to use for various 
common tasks:
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To change any of these settings:

1 Click Computer > Control Center > System > Preferred Applications.
2 Click the tab for the type of application you want to set.

The following list shows the options and default settings.
• Web browser

Default: Firefox
• Mail reader

Default: Evolution
• FTP

Default: Nautilus
• News

Default: Thunderbird
• Terminal

GNOME Terminal
3 Select one of the available from the applications from the Choose menu or enter the command 

used to start the application. 
4 Click Close.

The changes take effect immediately.

2.4.6  Setting Session Sharing Preferences
The Remote Desktop preference tool enables you to share a GNOME desktop session between 
multiple users, and to set session-sharing preferences. To open this tool, click Computer > Control 
Center > System > Remote Desktop.

The table below shows the session sharing preferences that can be set with this tool. These settings 
have a direct impact on the security of your system.

Table 2-9   Session Sharing Preferences

Dialog Element Description

Allow other users to view your desktop Select this option to enable remote users to view your session. 
All keyboard, pointer, and clipboard events from the remote user 
are ignored.

Allow other users to control your 
desktop

Select this option to allow other users to access and control your 
session from a remote location.

Users can view your desktop using 
this command

Click on the highlighted text to send the system address to 
remote user by e-mail.
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2.4.7  Managing Sessions
This module lets you manage your sessions. A session occurs between the time that you log in to the 
desktop environment and the time that you log out. You can set session preferences and specify 
which applications to start when you begin a session. You can configure sessions to save the state of 
applications and then restore the state when you start another session.

You can also use this preference tool to manage multiple sessions. For example, you might have a 
mobile session which starts applications you use most frequently when traveling, a demo session 
that starts applications used to present a demonstration or slide show to a customer, and a work 
session that uses a different set of applications when you are working in the office.

Click Computer > Control Center > System > Sessions. 

This module consists of three tabbed pages:

• Session Options: Lets you manage multiple sessions and set preferences for the current 
session. 

• Current Session: Lets you specify startup order values and select restart styles for the session-
managed applications in your current session.

• Startup Programs: Lets you specify non-session-managed startup applications, which start 
automatically when you start a session.

When a user tries to view or control 
your desktop

Select from the following security considerations when a user 
tries to view or control your desktop:

• Ask you for confirmation

Select this option if you want remote users to ask you for 
confirmation when they want to share your session. This 
option enables you to be aware when other users connect 
to your session. You can also decide what time is suitable 
for the remote user to connect to your session.

• Require the user to enter this password

Select this option to authenticate the remote user if 
authentication is used. This option provides an extra level 
of security.

Password Enter the password that the remote user who wants to view or 
control your session must enter.

Dialog Element Description
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Setting Session Preferences

Use the Session Options tabbed page to manage multiple sessions and set preferences for the current 
session.

Figure 2-18   Sessions Dialog—Session Options Page

The following table lists the session options that you can modify. 

Table 2-10   Session Preferences for Current Session

Option Description

Show Splash Screen on Login Displays a splash screen when you start a session.

Prompt on Logout Displays a confirmation dialog when you end a session.

Automatically Save Changes to Session Automatically saves the current state of your session. The 
session manager saves the session-managed applications 
that are open and the settings associated with the session-
managed applications. The next time you start a session, 
the applications start automatically with the saved settings.

If you do not select this option, the Logout Confirmation 
dialog displays a Save Current Setup option when you end 
your session. 

Sessions Lets you manage multiple sessions in the desktop, as 
follows:

• To create a new session, click Add. The Add a New 
Session dialog is displayed, letting you specify a 
name for your session.

• To change the name of a session, select the session 
and then click Edit. The Edit Session Name dialog is 
displayed, letting you specify a new name for your 
session.

• To delete a session, select the session and then click 
Delete.
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Setting Session Properties

Use the Current Session tabbed page to specify startup order values and to choose restart styles for 
the session-managed applications in your current session.

Figure 2-19   Sessions Dialog—Current Session Page

The following table lists the session properties that you can configure.

Table 2-11   Session Properties for Session-Managed Applications

Option Description

Order Specifies the order in which the session manager starts session-managed startup 
applications. The session manager starts applications with lower order values first. The 
default value is 50.

To set the startup order of an application, select the application in the table. Use the Order 
box to specify the startup order value. 

Style Determines the restart style of an application. To select a restart style for an application, 
select the application in the table and then select one of the following styles:

• Normal: Starts automatically when you start a session. Use the kill command to 
terminate applications with this restart style during a session.

• Restart: Restarts automatically when you close or terminate the application. Select 
this style for an application if it must run continuously during your session. To 
terminate an application with this restart style, select the application in the table and 
then click Remove.

• Trash: Does not start when you start a session.

• Settings: Starts automatically when you start a session. Applications with this style 
usually have a low startup order and store your configuration settings for GNOME 
and session-managed applications.

Remove Deletes the selected application from the list. The application is removed from the session 
manager and closed. Applications that you delete are not started the next time you start a 
session. 

Apply Applies changes made to the startup order and the restart style.
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Configuring Startup Applications

Use the Startup Programs tabbed page to specify non-session-managed startup applications.

Figure 2-20   Sessions Dialog—Startup Programs Page

Startup applications are applications that start automatically when you begin a session. You specify 
the commands that run these applications and the commands execute automatically when you log in.

You can also start session-managed applications automatically. For more information, see “Setting 
Session Preferences” on page 57.

To add a startup application, click Add. The Add Startup Program dialog is displayed. Specify the 
command to start the application in the Startup Command field. If you specify more than one startup 
application, use the Order box to specify the startup order of the each application.

To edit a startup application, select the startup application and then click Edit. The Edit Startup 
Program dialog is displayed. Modify the command and the startup order for the startup application.

To delete a startup application, select the startup application and then click Delete. 

2.4.8  Setting Sound Preferences
The Sound Preference tool lets you control when the sound server starts. You can also specify which 
sounds to play when particular events occur.

Click Computer > Control Center > System > Sound. 
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Setting General Sound Preferences

Use the Sounds tab to specify when to launch the sound server. You can also enable sound event 
functions.

Figure 2-21   Sound Preferences Dialog—General Page

Click Enable software sound mixing (ESD) to start the sound server when you start a session. When 
the sound server is active, the desktop can play sounds.

Click Play system sounds to play sounds when particular events occur in the desktop. 

Finally, select the sound to play at each of the specified events.
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Setting System Beep Preferences

Some applications play a beep sound to indicate a keyboard input error. Use the System Beep tab to 
set preferences for the system beep. 

Figure 2-22   Sound Preferences Dialog—System Beep Page

2.4.9  Managing Users and Groups
Use the User Management tool to manage users and groups, including user and group names, group 
membership, password and password encryption, and other options. 

Click Computer > Control Center > System > User Management. The User Management tool opens 
the User and Group Administration module in YaST.
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NOTE: Root privileges are required to manage users and groups.

Follow the directions in YaST for information on changing settings.
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3The OpenOffice.org Office Suite

OpenOffice.org is a powerful open-source office suite that provides tools for all types of office 
tasks, such as writing texts, working with spreadsheets, or creating graphics and presentations. With 
OpenOffice.org, you can use the same data across different computing platforms. You can also open 
and edit files in other formats, including Microsoft Office, then save them back to this format, if 
needed. This chapter covers information about the Novell® edition of OpenOffice.org and some of 
the key features you should be aware of when getting started with the suite. 

• Section 3.1, “Understanding OpenOffice.org,” on page 65
• Section 3.2, “Word Processing with Writer,” on page 72
• Section 3.3, “Using Spreadsheets with Calc,” on page 78
• Section 3.4, “Using Presentations with Impress,” on page 80
• Section 3.5, “Using Databases with Base,” on page 81
• Section 3.6, “Creating Graphics with Draw,” on page 83
• Section 3.7, “Creating Mathematical Formulas with Math,” on page 84
• Section 3.8, “Finding Help and Information About OpenOffice.org,” on page 84

OpenOffice.org consists of several application modules (subprograms), which are designed to 
interact with each other. They are listed in Table 3-1. A full description of each module is available 
in the online help, described in Section 3.8, “Finding Help and Information About OpenOffice.org,” 
on page 84.

Table 3-1   The OpenOffice.org Application Modules

The appearance of the application varies depending on the desktop or window manager you use. 
Regardless of the appearance, the basic layout and functions are the same.

3.1  Understanding OpenOffice.org
This section contains information that applies to all of the application modules in OpenOffice.org. 
Module-specific information can be found in the sections relating to each module.

• Section 3.1.1, “What’s New in OpenOffice.org 2.0,” on page 66

Module Purpose

Writer Word processor application module

Calc Spreadsheet application module

Impress Presentation application module

Base Database application module

Draw Application module for drawing vector graphics

Math Application module for generating mathematical formulas
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• Section 3.1.2, “Enhancements in the Novell Edition of OpenOffice.org 2.0,” on page 66
• Section 3.1.3, “Using the Standard Edition of OpenOffice.org,” on page 67
• Section 3.1.4, “Compatibility with Other Office Applications,” on page 67
• Section 3.1.5, “Starting OpenOffice.org,” on page 69
• Section 3.1.6, “Improving OpenOffice.org Load Time,” on page 69
• Section 3.1.7, “Customizing OpenOffice.org,” on page 69
• Section 3.1.8, “Finding Templates,” on page 72

3.1.1  What’s New in OpenOffice.org 2.0
OpenOffice.org 2.0 contains many improvements and features that were not included in earlier 
versions. The biggest new feature is the Base database module. There have been many other changes 
since the previous version, such as enhanced PDF export and improved word count capabilities. For 
a complete list of features, fixes, and enhancements, go to the OpenOffice.org Web site (http://
www.openoffice.org/dev_docs/features/2.0/).

3.1.2  Enhancements in the Novell Edition of OpenOffice.org 2.0
The Novell Edition of OpenOffice.org included with SLED contains enhancements that are not 
available in the standard edition. These include:

Integration with SUSE Linux Enterprise Desktop 

The Novell Edition of OpenOffice.org features redesigned tool bar icons for maximum consistency 
with SUSE Linux Enterprise Desktop, including support for desktop appearance or theme changes. 
These features provide a consistent interface across the Linux desktop, which enhances overall 
usability and helps minimize enterprise training and support requirements.

Native Desktop Dialogs

The Novell Edition of OpenOffice.org uses your desktop’s native file dialogs rather than those in the 
standard edition. This provides the same look and feel of other applications in your environment, 
giving you a consistent, familiar experience.

Enhanced Support for Microsoft Office File Formats

OpenOffice.org supports import and export of Microsoft Office file formats, even taking advantage 
of compatible fonts to match document length. Transparent document sharing makes 
OpenOffice.org the best choice if you are deploying Linux desktops in a mixed Linux/Windows 
environment. 

E-Mail as Microsoft Office Document

The standard edition of OpenOffice.org supports e-mailing of files as PDF files from within the 
OpenOffice.org application. With the Novell Edition of OpenOffice.org, you can also e-mail any 
document as a Microsoft Office file. For example, you can e-mail a Writer file as a Microsoft Word 
file. If that option is selected, the file is automatically converted and attached to an e-mail in your 
default e-mail application.
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Excel VBA Macro Interoperability

The Novell Edition of OpenOffice.org eases the migration of many macros from Microsoft Excel. 
Although not all macros can be successfully migrated, this interoperability offers more than the 
standard edition, which does not support migration of macros.

Enhanced Fonts

For the Novell Edition of OpenOffice.org, Novell licensed fonts from AGFA that use the same or 
similar names as the fonts available in Microsoft Office. The fonts also look similar to those used by 
Microsoft. This allows OpenOffice.org to match fonts when opening documents originally 
composed in Microsoft Office, and very closely match pagination and page formatting.

Integration with Novell Evolution

The Novell Edition of OpenOffice.org is tightly integrated with Novell Evolution™, allowing users 
to send documents as e-mail and to perform mail merges using the Evolution address book as a 
datasource.

Improved File Access

Files are available from any source available to the computer. Network files open and save 
seamlessly.

Anti-aliased Presentation Graphics

With hardware acceleration enabled (the default), the Novell Edition of OpenOffice.org provides 
higher-quality graphics in Impress slide shows.

Faster Start-up Times

The Novell Edition of OpenOffice.org includes an improved built-in quickstarter that loads 
OpenOffice.org components at system startup and thus improves the application’s start-up time. 
Subsequent document load times have also been improved.

3.1.3  Using the Standard Edition of OpenOffice.org
The standard edition of OpenOffice.org also works with SLED. If you install the latest version of 
OpenOffice.org, all of your Novell Edition files remain compatible. However, the standard edition 
does not contain the Novell enhancements.

3.1.4  Compatibility with Other Office Applications
OpenOffice.org can work with documents, spreadsheets, presentations, and databases in many other 
formats, including Microsoft Office. They can be seamlessly opened like other files and saved back 
to the original format. Because the Microsoft formats are proprietary and the specifications are not 
available to other applications, there are occasionally formatting issues. If you have problems with 
your documents, consider opening them in the original application and resaving in an open format 
such as RTF for text documents or CSV for spreadsheets. 
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TIP: For good information about migrating from other office suites to OpenOffice.org, refer to the 
OpenOffice.org Migration Guide (http://documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf).

Converting Documents to the OpenOffice.org Format

OpenOffice.org can read, edit, and save documents in a number of formats. It is not necessary to 
convert files from those formats to the OpenOffice.org format to use those files. However, if you 
want to convert the files, you can do so. To convert a number of documents, such as when first 
switching to OpenOffice.org, do the following:

1 Select File > Wizard > Document Converter. 
2 Choose the file format from which to convert.

There are several StarOffice and Microsoft Office formats available.
3 Click Next. 
4 Specify where OpenOffice.org should look for templates and documents to convert and in 

which directory the converted files should be placed.

IMPORTANT:  Documents from a Windows partition are usually in a subdirectory of /
windows. 

5 Make sure that all other settings are appropriate, then click Next. 
6 Review the summary of the actions to perform, then start the conversion by clicking Convert.

The amount of time needed for the conversion depends on the number of files and their 
complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites

OpenOffice.org is available for a number of operating systems. This makes it an excellent tool when 
a group of users frequently need to share files and do not use the same system on their computers. 

When sharing documents with others, you have several options. 

If the recipient needs to be able to edit the file: Save the document in the format the other user 
needs. For example, to save as a Microsoft Word file, click File > Save As, then select the Microsoft 
Word file type for the version of Word the other user needs.

If the recipient only needs to read the document: Export the document to a PDF file with File > 
Export as PDF. PDF files can be read on any platform using a viewer like Adobe Acrobat Reader.

If you want to share a document for editing: Use one of the standard document formats. The 
default formats comply with the OASIS standard XML format, making them compatible with a 
number of applications. TXT and RTF formats, although limited in formatting, might be a good 
option for text documents. CSV is useful for spreadsheets. OpenOffice.org might also offer your 
recipient's preferred format, especially Microsoft formats.

If you want to e-mail a document as a PDF: Click File > Send > Document as PDF 
Attachment.Your default e-mail program opens with the file attached. 

If you want to e-mail a document to a Microsoft Word user: Click File > Send > Document as 
MS-Doc Attachment. Your default e-mail program opens with the file attached.
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3.1.5  Starting OpenOffice.org
1 Start the application in one of the following ways:

• On the menu bar, click .
This opens Writer. To open a different module, click File > New from the newly opened 
Writer document, then choose the module you want to open.

• From the Computer menu, click Computer > More Applications > Office, then click the 
name of the OpenOffice.org module you want to start.

• In a terminal window, enter ooffice. The OpenOffice.org window opens. Click File > 
New, then choose the module you want to open.

2 Select the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications by clicking 
File > New > Name of Application.

3.1.6  Improving OpenOffice.org Load Time
To speed up the load time of OpenOffice.org by preloading the application at system startup:

1 Click Tools > Options > Memory.
2 Select Start at Startup.

The next time you restart your system, OpenOffice.org will preload. When you open an 
OpenOffice.org application module, it will open faster.

3.1.7  Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars, menus, and 
keyboard shortcuts can all be reconfigured to help you more quickly access the features you use the 
most. You can also assign macros to application events if you want specific actions to occur when 
those events take place. For example, if you always work with a specific spreadsheet, you can create 
a macro that opens the spreadsheet and assign it to the Start Application event. 

This section contains simple, generic instructions for customizing your environment. The changes 
you make are effective immediately, so you can see if the changes are what you wanted and go back 
and modify them if they weren’t. See the OpenOffice.org help files for detailed instructions.

Customizing Toolbars

Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar.
2 Click Customize Toolbar.
3 Select the toolbar you want to customize.
4 Select the check boxes next to the commands you want to appear on the toolbar, and deselect 

the check boxes next to the commands you don’t want to appear.
5 Select whether to save your customized toolbar in the OpenOffice.org module you are using or 

in the document.
• OpenOffice.org module 
The OpenOffice.org Office Suite 69



70 SUSE Linux

novdocx (E
N

U
)  01 February 2006
The customized toolbar is used whenever you open that module.
• Document filename 

The customized toolbar is used whenever you open that document.
6 Repeat to customize additional toolbars.
7 Click OK.

You can quickly choose the buttons that appear on a particular toolbar.

1 Click the arrow icon at the end of the toolbar you want to change.
2 Click Visible Buttons to display a list of buttons.
3 Select the buttons in the list that appears to enable (check) or disable (uncheck) them.

Customizing Menus

You can add or delete items from current menus, reorganize menus, and even create new menus.

1 Click Tools > Customize > Menu.
2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.
3 Modify, add, or delete menu items as desired.
4 Click OK.

Customizing Keyboard Shortcuts

You can reassign currently assigned keyboard shortcuts and assign new shortcuts to frequently used 
functions.

1 Click Tools > Customize > Keyboard.
2 Select the keys you want to assign to a function, or select the function and assign the keys or 

key combinations.
Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.
4 Click OK.

Customizing Events

OpenOffice.org also provides ways to assign macros to events such as application startup or the 
saving of a document. The assigned macro runs automatically whenever the selected event occurs.

1 Click Tools > Customize > Events.
2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.
3 Assign or remove macros for the selected event.
4 Click OK.
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Changing the Global Settings

Global settings can be changed in any OpenOffice.org application by clicking Tools > Options on 
the menu bar. This opens the window shown in the figure below. A tree structure is used to display 
categories of settings. 

Figure 3-1   The Options Window

The following table lists the settings categories along with a brief description of each category:

Table 3-2   Global Setting Categories

Settings Category Description

OpenOffice.org Various basic settings, including your user data (such as your address and 
e-mail), important paths, and settings for printers and external programs.

Load/Save Includes the settings related to the opening and saving of several file 
types. There is a dialog for general settings and several special dialogs to 
define how external formats should be handled.

Language Settings Covers the various settings related to languages and writing aids, such as 
your locale and spell checker settings. This is also the place to enable 
support for Asian languages.

Internet Includes the dialogs to configure any proxies and to change settings 
related to search engines.

Text Document Configures the global word processing options, such as the basic fonts 
and layout that Writer should use.

HTML Document Changes the settings related to the HTML authoring features of 
OpenOffice.org.

Spreadsheet Changes the settings for Calc, such as those related to sort lists and grids.

Presentation Changes the settings that should apply to all presentations. For example, 
you can specify the measurement unit for the grid used to arrange 
elements.

Drawing Includes the settings related to the vector drawing module, such as the 
drawing scale, grid properties, and some print options.
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IMPORTANT: All settings listed in the table are applied globally. They are used as defaults for 

every new document you create. 

3.1.8  Finding Templates
Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks for a variety 
of different types of documents. OpenOffice.org comes with a few templates, and you can find 
additional templates on the Internet. You can also create your own. Creating templates is beyond the 
scope of this guide, but detailed instructions are found in the OpenOffice.org help system and in 
other documents and tutorials available online.

In addition to templates, you can find other extras and add-ins online. The following table lists a few 
of the prominent places where you can find templates and other extras. (Because Web sites often 
close or their content changes, the information in the following table might not be current when you 
read it.)

Table 3-3   Where to Find OpenOffice.org Templates and Extras

For more information about templates, see Section 3.2.4, “Using Templates to Format Documents,” 
on page 76 and Section 3.3.2, “Using Templates in Calc,” on page 79.

3.2  Word Processing with Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting capabilities. 
Its interface is similar to interfaces for other major word processors, and it includes some features 
that are usually found only in expensive desktop publishing applications.

This section highlights a few key features of Writer. For more information about these features and 
for complete instructions for using Writer, look at the OpenOffice.org help or any of the sources 
listed in Section 3.8, “Finding Help and Information About OpenOffice.org,” on page 84.

Formula Provides a single dialog to set special print options for formulas.

Chart Defines the default colors used for newly created charts.

Data Sources Defines how external data sources should be accessed.

Location What You Can Find

OpenOffice.org documentation Web site (http://
documentation.openoffice.org/
Samples_Templates/User/template_2_x/
index.html)

Templates for Calc spreadsheets, CD cases, seed 
packets, fax cover sheets, and more

Worldlabel.com (http://www.worldlabel.com/Pages/
openoffice-template.htm)

Templates for many types of labels

Settings Category Description
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NOTE: Much of the information in this section can also be applied to other OpenOffice.org 
modules. For example, other modules use styles similarly to how they are used in Writer.

• Section 3.2.1, “Creating a New Document,” on page 73
• Section 3.2.2, “Sharing Documents with Other Word Processors,” on page 73
• Section 3.2.3, “Formatting with Styles,” on page 74
• Section 3.2.4, “Using Templates to Format Documents,” on page 76
• Section 3.2.5, “Working with Large Documents,” on page 76
• Section 3.2.6, “Using Writer as an HTML Editor,” on page 78

3.2.1  Creating a New Document
There are two ways to create a new document: 

To create a document from scratch, click File > New > Text Document. 

To use a standard format and predefined elements for your own documents, try a wizard. Wizards 
are small utilities that let you make some basic decisions then produce a ready-made document from 
a template. For example, to create a business letter, click File > Wizards > Letter. Using the 
wizard's dialogs, easily create a basic document using a standard format. A sample wizard dialog is 
shown in Figure 3-2. 

Figure 3-2   An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format menu to 
adjust the appearance of the document. Use the File menu or the relevant buttons in the toolbar to 
print and save your document. With the options under Insert, add extra items to your document, 
such as a table, picture, or chart. 

3.2.2  Sharing Documents with Other Word Processors
You can use Writer to edit documents created in a variety of other word processors. For example, 
you can import a Microsoft Word document, edit it, and save it again as a Word document. Most 
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Word documents can be imported into OpenOffice.org without any problem. Formatting, fonts, and 
all other aspects of the document remain intact. However, some very complex documents—such as 
documents containing complicated tables, Word macros, or unusual fonts or formatting—might 
require some editing after being imported. OpenOffice.org can also save in many popular word 
processing formats. Likewise, documents created in OpenOffice.org and saved as Word files can be 
opened in Microsoft Word without any trouble.

So, if you use OpenOffice.org in an environment where you frequently share documents with Word 
users, you should have little or no trouble exchanging document files. Just open the files, edit them, 
and save them as Word files.

3.2.3  Formatting with Styles
OpenOffice.org uses styles for applying consistent formatting to various elements in a document. 
The following types of styles are available:

Table 3-4   About the Types of Styles

Opening the Styles and Formatting Window

The Styles and Formatting window (called the Stylist in earlier versions of OpenOffice.org), is a 
versatile formatting tool for applying styles to text, paragraphs, pages, frames, and lists. To open this 
window, click Format > Styles and Formatting. OpenOffice.org comes with several predefined 
styles. You can use these styles as they are, modify them, or create new styles.

TIP: By default, the Styles and Formatting window is a floating window; that is, it opens in its own 
window that you can place anywhere on the screen. If you use styles extensively, you might find it 
helpful to dock the window so that it always present in the same part of the Writer interface. To dock 

Type of Style What it Does

Paragraph Applies standardized formatting to the various types of paragraphs in your 
document. For example, apply a paragraph style to a first-level heading to 
set the font and font size, spacing above and below the heading, location 
of the heading, and other formatting specifications.

Character Applies standardized formatting for types of text. For example, if you want 
emphasized text to appear in italics, you can create an emphasis style that 
italicizes selected text when you apply the style to it.

Frame Applies standardized formatting to frames. For example, if your document 
uses sidebars, you can create frames with specified graphics, borders, 
location, and other formatting so that all of your sidebars have a consistent 
appearance.

Page Applies standardized formatting to a specified type of page. For example, if 
every page of your document contains a header and footer except for the 
first page, you can use a first page style that disables headers and footers. 
You can also use different page styles for left and right pages so that you 
have bigger margins on the insides of pages and your page numbers 
appear on an outside corner.

List Applies standardized formatting to specified list types. For example, you 
can define a checklist with square check boxes and a bullet list with round 
bullets, then easily apply the correct style when creating your lists.
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the Styles and Formatting window, press Control while you double-click on a gray area in the 
window. This tip applies to some other windows in OpenOffice.org as well, including the Navigator.

Applying a Style

To apply a style, select the element you want to apply the style to, and then double-click the style in 
the Styles and Formatting window. For example, to apply a style to a paragraph, place the cursor 
anywhere in that paragraph and double-click the desired style.

Using Styles Versus Using Formatting Buttons and Menu Options

Using styles rather than the Format menu options and buttons helps give your pages, paragraphs, 
texts, and lists a more consistent look and makes it easier to change your formatting. For example, if 
you emphasize text by selecting it and clicking the Bold button, then later decide you want 
emphasized text to be italicized, you need to find all of your bolded text and manually change it to 
italics. If you use a character style, you only need to change the style from bold to italics and all text 
that has been formatted with that style automatically changes from bold to italics. 

Text formatted with a menu option or button overrides any styles you have applied. If you use the 
Bold button to format some text and an emphasis style to format other text, then changing the style 
does not change the text that you formatted with the button, even if you later apply the style to the 
text you bolded with the button. You must manually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format > Paragraph, it is easy to end up 
with inconsistent paragraph formatting. This is especially true if you copy and paste paragraphs 
from other documents with different formatting.

Changing a Style

Styles are powerful because you can change formatting throughout a document by changing a style, 
rather than applying the change separately everywhere you want to apply the new formatting.

1 In the Styles and Formatting window, right-click the style you want to change.
2 Click Modify.
3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online help.
4 Click OK.

Creating a Style

OpenOffice.org comes with a collection of styles to suit many users’ needs. However, most users 
eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.

Make sure you are in the list of styles for the type of style you want to create. For example, if 
you are creating a character style, make sure you are in the character style list.

2 Click New.
3 Click OK.
4 Name your style and choose the settings you want applied with that style.
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For details about the style options available in any tab, click that tab and then click Help.

3.2.4  Using Templates to Format Documents
Most word processor users create more than one kind of document. For example, you might write 
letters, memos, and reports, all of which look different and require different styles. If you create a 
template for each of your document types, the styles you need for each document are always readily 
available.

Creating a template requires a little bit of up-front planning. You need to determine what you want 
the document to look like so you can create the styles you need in that template. You can always 
change your template, but a little planning can save you a lot of time later.

NOTE: You can convert Microsoft Word templates like you would any other Word document. See 
“Converting Documents to the OpenOffice.org Format” on page 68 for information.

A detailed explanation of templates is beyond the scope of this section. However, more information 
is found in the help system, and detailed how-tos are found at the OpenOffice.org Documentation 
page (http://documentation.openoffice.org/HOW_TO/index.html).

Creating a Template

A template is a text document containing only the styles and content that you want to appear in 
every document, such as your address information and letterhead on a letter. When a document is 
created or opened with the template, the styles are automatically applied to that document.

To create a template:

1 Click File > New > Text Document.
2 Create the styles and content that you want to use in any document that uses this template.
3 Click File > Templates > Save.
4 Specify a name for the template.
5 In the Categories box, click the category you want to place the template in. 

The category is the folder where the template is stored.
6 Click OK.

3.2.5  Working with Large Documents
You can use Writer to work on large documents. Large documents can be either a single file or a 
collection of files assembled into a single document.

Navigating in Large Documents

The Navigator tool displays information about the contents of a document. It also lets you quickly 
jump to different elements. For example, you can use the Navigator to get a quick overview of all 
images included in the document.
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To open the Navigator, click Edit > Navigator. The elements listed in the Navigator vary according 
to the document loaded in Writer.

Figure 3-3   Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.

Creating a Single Document from Multiple Documents

If you are working with a very large document, such as a book, you might find it easier to manage 
the book with a master document, rather than keeping the book in a single file. A master document 
enables you to quickly apply formatting changes to a large document or to jump to each 
subdocument for editing.

A master document is a Writer document that serves as a container for individual Writer files. You 
can maintain chapters or other subdocuments as individual files collected in the master document. 
Master documents are also useful if multiple people are working on a document. You can separate 
each person’s portion of the document into subdocuments collected in a master document, allowing 
multiple writers to work on their subdocuments at the same time without fear of overwriting other 
people’s work.

NOTE: If you are coming to OpenOffice.org from Microsoft Word, you might be nervous about 
using master documents because the master document feature in Word has a reputation for 
corrupting documents. This problem does not exist in OpenOffice.org Writer, so you can safely use 
master documents to manage your projects.

To create a master document:

1 Click New > Master Document.

or

Open an existing document and click File > Send > Create Master Document.
2 Insert subdocuments.
3 Click File > Save.

The OpenOffice.org help files contain more complete information about working with master 
documents. Look for the topic entitled “Using Master Documents and Subdocuments.”
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TIP: The styles from all of your subdocuments are imported into the master document. To ensure 
that formatting is consistent throughout your master document, you should use the same template 
for each subdocument. Doing so is not mandatory; however, if subdocuments are formatted 
differently, you will probably need to do some reformatting to successfully bring subdocuments into 
the master document without creating inconsistencies. For example, if two documents imported into 
your master document include different styles with the same name, the master document will use the 
formatting specified for that style in the first document you import.

3.2.6  Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML editor. Writer 
includes HTML tags that can be applied as you would any other style in a Writer document. You can 
view the document as it will appear online, or you can directly edit the HTML code. 

Creating an HTML Document

1 Click File > New > HTML Document. 
2 Click the arrow at the bottom of the Formatting and Styles window.
3 Select HTML Styles.
4 Create your HTML document, using the styles to tag your text.
5 Click File > Save As.
6 Select the location where you want to save your file, name the file, and select HTML Document 

(.html) from the Filter list.
7 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created when you 
edited the HTML file as a Writer document, click View > HTML Source. In HTML Source mode, 
the Formatting and Styles list is no longer available.

NOTE: The first time you switch to HTML Source mode, you are prompted to save the file as 
HTML, if you have not already done so.

3.3  Using Spreadsheets with Calc
Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File > New > 
Spreadsheet or open one with File > Open. Calc can read and save in Microsoft Excel's format, so it 
is easy to exchange spreadsheets with Excel users. 

NOTE: Calc can process many VBA macros in Excel documents; however, support for VBA 
macros is not yet complete. When opening an Excel spreadsheet that makes heavy use of macros, 
you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data from other cells 
to generate a value for the cell in which it is inserted. You can also create charts from cell values.

• Section 3.3.1, “Using Formatting and Styles in Calc,” on page 79
• Section 3.3.2, “Using Templates in Calc,” on page 79
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3.3.1  Using Formatting and Styles in Calc
Calc comes with a few built-in cell and page styles to improve the appearance of your spreadsheets 
and reports. Although these built-in styles are adequate for many uses, you will probably find it 
useful to create styles for your own frequently used formatting preferences.

Creating a Style

1 Click Format > Styles and Formatting.
2 In the Formatting and Styles window, click either the Cell Styles or the Page Styles icon.
3 Right-click in the Formatting and Styles window, then click New.
4 Specify a name for your style and use the various tabs to set the desired formatting options.
5 Click OK.

Modifying a Style

1 Click Format > Styles and Formatting.
2 In the Formatting and Styles window, click either the Cell Styles or the Page Styles icon.
3 Right-click the name of the style you want to change, then click Modify.
4 Change the desired formatting options.
5 Click OK.

3.3.2  Using Templates in Calc
If you use different styles for different types of spreadsheets, you can use templates to save your 
styles for each spreadsheet type. Then, when you create a particular type of spreadsheet, open the 
applicable template and the styles you need for that template are available in the Formatting and 
Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more information 
is found in the help system and detailed how-tos are found at the OpenOffice.org Documentation 
page (http://documentation.openoffice.org/HOW_TO/index.html).

Creating a Template

A Calc template is a spreadsheet that contains styles and content that you want to appear in every 
spreadsheet created with that template, such as headings or other cell styles. When a spreadsheet is 
created or opened with the template, the styles are automatically applied to that spreadsheet.

To create a template:

1 Click File > New > Spreadsheet.
2 Create the styles and content that you want to use in any spreadsheet that uses this template.
3 Click File > Templates > Save.
4 Specify a name for the template.
5 In the Categories box, click the category you want to place the template in. 

The category is the folder where the template is stored.
6 Click OK.
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3.4  Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such as slide 
shows or transparencies. If you have used other presentation software, you can move comfortably to 
Impress, which works very similarly to other presentation software. 

Impress can open and save Microsoft Powerpoint presentations, which means you can exchange 
presentations with Powerpoint users, as long as you save your presentations in Powerpoint format.

• Section 3.4.1, “Creating a Presentation,” on page 80
• Section 3.4.2, “Using Master Pages,” on page 80

3.4.1  Creating a Presentation
1 Click File > New > Presentation.
2 Select the option to use for creating the presentation.

There are two ways to create a presentation:
• Create an empty presentation

Opens Impress with a blank slide. Use this option to create a new presentation from 
scratch, without any preformatted slides.

• Create a presentation from a template
Opens Impress with your choice of template. Use this option to create a new presentation 
with a predesigned OpenOffice.org template or a template you’ve created or installed 
yourself, such as your company’s presentation template. Impress uses styles and templates 
the same way other OpenOffice.org modules do. See Section 3.2.4, “Using Templates to 
Format Documents,” on page 76 for more information about templates.

3.4.2  Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide looks, what 
fonts are used, and other graphical elements. Impress uses two types of master pages:

• Slide master

Contains elements that appear on all slides. For example, you might want your company logo 
to appear in the same place on every slide. The slide master also determines the text formatting 
style for the heading and outline of every slide that uses that master page, as well as any 
information you want to appear in a header or footer.

• Notes master
Determines the formatting and appearance of the notes in your presentation.

Creating a Slide Master

Impress comes with a collection of preformatted master pages. Eventually, most users will want to 
customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.
2 Click View > Master > Slide Master.

This opens the current slide master in Master View.
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3 Right-click the left-hand panel, then click New Master.
4 Edit the slide master until it has the desired look.
5 Click Close Master View or View > Normal to return to Normal View.

TIP: When you have created all of the slide masters you want to use in your presentations, you can 
save them in an Impress template. Then, any time you want to create presentations that use those 
slide masters, open a new presentation with your template.

Applying a Slide Master

Slide masters can be applied to selected slides or to all slides in the presentation.

1 Open your presentation, then click View > Master > Slide Master.
2 (Optional) If you want to apply the slide master to multiple slides, but not to all slides, select 

the slides that you want to use that slide master.
To select multiple slides, in the Slides Pane, Control-click on the slides you want to use that 
slide master.

3 In the Task Pane, right-click the master page you want to apply.
If you do not see the Task Pane, click View > Task Pane. 

4 Apply the slide master by clicking one of the following:.
• Apply to All Slides

Applies the selected slide master to all slides in the presentation.
• Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you select before 
applying the slide master. For example, if you want to apply a different slide master to the 
first slide in a presentation, select that slide, then change to Master View and apply a slide 
master to that slide.

3.5  Using Databases with Base
OpenOffice 2.0 introduces a new database module, Base. Use Base to design a database to store 
many different kinds of information, from a simple address book or recipe file to a sophisticated 
document management system.

Tables, forms, queries, and reports can be created manually or using convenient wizards. For 
example, the Table Wizard contains a number of common fields for business and personal use. 
Databases created in Base can be used as data sources, such as when creating form letters. 

It is beyond the scope of this document to detail database design with Base. More information can 
be found at the sources listed in Section 3.8, “Finding Help and Information About 
OpenOffice.org,” on page 84.

3.5.1  Creating a Database Using Predefined Options
Base comes with several predefined database fields to help you create a database. The steps in this 
section are specific to creating an address book using predefined fields, but it should be easy to 
follow them to use the predefined fields for any of the built-in database options.
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The process for creating a database can be broken into several subprocesses:

• “Creating the Database” on page 82
• “Setting Up the Database Table” on page 82
• “Creating a Form” on page 83
• “Modifying the Form” on page 83
• “What’s Next?” on page 83

Creating the Database

First, create the database.

1 Click File > New > Database.
2 Select Create a new database, then click Next.
3 Click Yes, register the database for me to make your database information available to other 

OpenOffice.org modules, select both check boxes in the bottom half of the dialog, then click 
Finish.

4 Browse to the directory where you want to save the database, specify a name for the database, 
then click OK.

Setting Up the Database Table

Next, define the fields you want to use in your database table.

1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use. If you had 
clicked Business, the list would contain predefined business tables. 

2 In the Sample tables list, click Addresses.
The available fields for the predefined address book appear in the Available fields menu.

3 In the Available fields menu, click the fields you want to use in your address book.
You can select one item at a time, or you can shift-click multiple items to select them.

4 Click the single right-arrow to move the selected items to the Selected fields menu.
To move all available fields to the Selected fields menu, click the double right-arrow.

5 Use the up-arrow and down-arrow to adjust the order of the selected fields.
The fields appear in the table and forms in the order in which they are listed.

6 Click Next.
7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the maximum length of 
the field (the number of characters that can be entered in that field. For this example, leave the 
settings as they are.

8 Click Next.
9 Click Create a primary key, click Automatically add a primary key, click Auto value, then click 

Next.
10 Accept the default name for the table, select Create a form based on this table, then click 

Finish.
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Creating a Form

Next, create the form to use when entering data into your address book.

1 In the Form Wizard, click the double right-arrow to move all available fields to the Fields in 
the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.
3 Select the option to use the form to display all data and leave all of the check boxes empty, then 

click Next.
4 Apply a style and field border, then click Next.

For this example, accept the default selections.
5 Name the form, select the Modify the form option, then click Finish.

Modifying the Form

After the form has been defined, you can modify the appearance of the form to suit your preferences. 

1 Close the form that opened when you finished the previous step.
2 In the main window for your database, right-click the form you want to modify (there should be 

only one option), then click Edit.
3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last Name field, and 
then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?

After you have created your database tables and forms, you are ready to enter your data. You can 
also design queries and reports to help sort and display the data.

Refer to OpenOffice.org online help and other sources listed in Section 3.8, “Finding Help and 
Information About OpenOffice.org,” on page 84 for additional information about Base.

3.6  Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings in today’s 
most common formats and import them into any application that lets you import graphics, including 
the other OpenOffice.org modules. You can also create Flash versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See Section 3.8, 
“Finding Help and Information About OpenOffice.org,” on page 84 for more information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.
2 Save the graphic.
3 Copy the graphic and paste it into the document, or insert the graphic directly from the 

document.
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One particularly useful feature of Draw is the ability to open it from other OpenOffice.org modules 
so you can create a drawing that is automatically imported into your document.

1 From an OpenOffice.org module (for example, from Writer), click Insert > Object > OLE 
Object > OpenOffice.org 2.0 Drawing > OK.

This opens Draw.
2 Create your drawing.
3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.

3.7  Creating Mathematical Formulas with Math
It is usually difficult to include complex mathematical formulas in your documents. The 
OpenOffice.org Math equation editor lets you create formulas using operators, functions, and 
formatting assistants. You can then save those formulas as objects that can be imported into other 
documents. Math functions can be inserted into other OpenOffice.org documents like any other 
graphic object. 

NOTE: Math is not a calculator. The functions it creates are graphical objects. Even if they are 
imported into Calc, these functions cannot be evaluated.

3.8  Finding Help and Information About 
OpenOffice.org
OpenOffice.org contains extensive online help. In addition, a large community of users and 
developers support it. As a result, it is seldom hard to find help or information about using the 
OpenOffice.org. The following table shows some of the places where you can go for additional 
information. (Because Web sites often close or their content changes, the information in the 
following table might not be current when you read it.)

Table 3-5   Where to Get Information About OpenOffice.org

Location What You Can Find

OpenOffice.org online help menu Extensive help on performing any task in 
OpenOffice.org

Official OpenOffice.org support page (http://
support.openoffice.org/index.html)

Manuals, tutorials, user and developer forums, 
users@openoffice.org mailing list, FAQs, and much 
more

OpenOffice.org Migration Guide (oooauthors.org/
en/authors/userguide2/migration/
OtherMSOFiles_25_June_PK.sxw)

Information about migrating to OpenOffice.org from 
other office suites, including Microsoft Office

Taming OpenOffice.org (http://www.taming-
openoffice-org.com/)

Books, news, tips and tricks

OpenOffice.org Macros (http://www.pitonyak.org/
oo.php)

Extensive information about creating and using 
macros
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4Evolution: E-Mail and Calendaring

EvolutionTM makes the tasks of storing, organizing, and retrieving your personal information easy, so 
you can work and communicate more effectively with others. It’s a highly evolved groupware 
program, an integral part of the Internet-connected desktop.

Evolution can help you work in a group by handling e-mail, address, and other contact information, 
and one or more calendars. It can do that on one or several computers, connected directly or over a 
network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks quickly. For example, it takes 
only one or two clicks to enter appointment or contact information sent to you by e-mail, or to send 
e-mail to a contact or appointment. People who get lots of e-mail will appreciate advanced features 
like search folders, which let you save searches as though they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started using it. For complete 
information, refer to the Evolution documentation.

• Section 4.1, “Starting Evolution for the First Time,” on page 85
• Section 4.2, “Using Evolution: An Overview,” on page 93

4.1  Starting Evolution for the First Time
Start the Evolution client by clicking Computer > Evolution Mail and Calendar, or by typing 
evolution in a terminal window.

4.1.1  Using the First-Run Assistant
The first time you run Evolution, it creates a directory called .evolution in your home directory, 
where it stores all of its local data. Then, it opens a First-Run Assistant to help you set up e-mail 
accounts and import data from other applications.

Using the first-run assistant takes two to five minutes.

Later on, if you want to change this account, or if you want to create a new one, click Edit > 
Preferences, then click Mail Accounts. Select the account you want to change, then click Edit. 
Alternately, add a new account by clicking Add.

The First-Run Assistant helps you provide the information Evolution needs to get started.

• “Defining Your Identity” on page 86
• “Receiving Mail” on page 86
• “Receiving Mail Options” on page 88
• “Sending Mail” on page 91
• “Account Management” on page 92
• “Time Zone” on page 92
• “Importing Mail (Optional)” on page 92
Evolution: E-Mail and Calendaring 85



86 SUSE Linux

novdocx (E
N

U
)  01 February 2006
Defining Your Identity

The Identity window is the first step in the assistant. 

Here, you enter some basic personal information. You can define multiple identities later by clicking 
Edit > Preferences, then clicking Mail Accounts.

When the First-Run Assistant starts, the Welcome page is displayed. Click Forward to proceed to 
the Identity window.

1 Type your full name in the Full Name field.
2 Type your e-mail address in the E-Mail Address field.
3 (Optional) Type a reply to address in the Reply-To field.

Use this field if you want replies to e-mails sent to a different address.
4 (Optional) Select if this account is your default account.
5 (Optional) Type your organization name in the Organization field.

This is the company where you work, or the organization you represent when you send e-mail.
6 Click Forward.

Receiving Mail

The Receiving E-mail option lets you determine where you get your e-mail. 

You need to specify the type of server you want to receive mail with. If you are unsure about the 
type of server to choose, ask your system administrator or ISP.

1 Select a server type in the Server Type list.

The following a list of server types that are available:

Novell GroupWise: Select this option if you connect to Novell GroupWise®. Novell 
GroupWise keeps e-mail, calendar, and contact information on the server. 

Microsoft Exchange: Available only if you have installed the Connector for Microsoft* 
Exchange. It allows you to connect to a Microsoft Exchange 2000 or 2003 server, which stores 
e-mail, calendar, and contact information on the server. 

IMAP: Keeps the e-mail on your server so you can access your e-mail from multiple systems.

IMAP4rev1: Keeps the e-mail on your server so you can access your e-mail from multiple 
systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing up space on the 
e-mail server.

USENET News: Connects to the news server and downloads a list of available news digests.

Local Delivery: Choose this option if you want to move e-mail from the spool (the location 
where mail waits for delivery) and store it in your home directory. You need to provide the path 
to the mail spool you want to use. If you want to leave e-mail in your system’s spool files, 
choose the Standard Unix Mbox Spool option instead.
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MH Format Mail Directories: If you download your e-mail using mh or another MH-style 
program, you should use this option. You need to provide the path to the mail directory you 
want to use.

Maildir Format Mail Directories: If you download your e-mail using Qmail or another 
maildir-style program, you should use this option. You need to provide the path to the mail 
directory you want to use.

Standard Unix Mbox Spool or Directory: If you want to read and store e-mail in the mail 
spool on your local system, choose this option. You need to provide the path to the mail spool 
you want to use.

None: Select this if you do not plan to check e-mail with this account. If you select this, there 
are no configuration options.

Remote Configuration Options

If you selected Novell GroupWise, IMAP, POP, or USENET News as your server, you need to 
specify additional information.

1 Type the hostname of your e-mail server in the Hostname field.

If you don’t know the hostname, contact your administrator.
2 Type your username for the account in the Username field.
3 Select to use a secure (SSL) connection.

If your server supports secure connections, you should enable this security option. If you are 
unsure if your server supports a secure connection, contact your system administrator.

4 Select your authentication type in the Authentication list.
or
Click Check for Supported Types to have Evolution check for supported types. Some servers do 
not announce the authentication mechanisms they support, so clicking this button is not a 
guarantee that available mechanisms actually work.
If you are unsure what authentication type you need, contact your system administrator.

5 Select if you want Evolution to remember your password.
6 Click Forward.
7 (Conditional) If you chose Microsoft Exchange, provide your username in the Username field 

and your Outlook Web Access (OWA) URL in the OWA Url field. OWA URL and user names 
should be entered as in OWA. If the mail box path is different from the username, OWA path 
should include mail box path also. You should see something similar to this: http://<server 
name>/exchange/<mail box path>

When you have finished, continue with “Receiving Mail Options” on page 88.

Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail Directories, or 
Standard Unix Mbox Spool or Directory, you must specify the path to the local files in the path field. 
Continue with “Receiving Mail Options” on page 88.
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Receiving Mail Options

After you have selected a mail delivery mechanism, you can set some preferences for its behavior.

• “Novell GroupWise Receiving Options” on page 88
• “Microsoft Exchange Receiving Options” on page 88
• “IMAP and IMAP4rev1 Receiving Options” on page 89
• “POP Receiving Options” on page 89
• “USENET News Receiving Options” on page 90
• “Local Delivery Receiving Options” on page 90
• “MH-Format Mail Directories Receiving Options” on page 90
• “Maildir-Format Mail Directories Receiving Options” on page 90
• “Standard Unix Mbox Spool or Directory Receiving Options” on page 91

Novell GroupWise Receiving Options

If you select Novell GroupWise as your receiving server type, you need to specify the following 
options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want to check for new messages in all folders.
3 Select if you want to apply filters to new messages in the Inbox on the server.
4 Select if you want to check new messages for junk content.
5 Select if you want to only check for junk messages in the Inbox folder.
6 Select if you want to automatically synchronize remote mail locally.
7 Type your Post Office Agent SOAP port in the Post Office Agent SOAP Port field.

If you are unsure what your Post Office Agent SOAP port is, contact your system 
administrator.

8 Click Forward.

When you have finished, continue with Sending Mail.

Microsoft Exchange Receiving Options

If you select Microsoft Exchange as your receiving server type, you need to specify the following 
options.

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Specify the Global Catalog server name in the Global Catalog Server Name field.
The Global Catalog Server contains the user information for users. If you are unsure what your 
Global Catalog server name is, contact your system administrator.

3 Select if you want to limit the number of Global Address Lists (GAL). 
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The GAL contains a list of all e-mail addresses. If you select this option, you need to specify 
the maximum number of responses.

4 Select if you want the password expire warning period.
If you select this option, you need to specify how often Evolution should send the password 
expire message.

5 Select if you want to automatically synchronize remote mail locally.
6 Click Forward.

When you have finished, continue with Sending Mail.

IMAP and IMAP4rev1 Receiving Options

If you select IMAP or IMAP4rev1 as your receiving server type, you need to specify the following 
options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want Evolution to use custom commands to connect to Evolution.
If you select this option, specify the custom command you want Evolution to use.

3 Select if you want Evolution to show only subscribed folders.
Subscribed folders are folders that you have chosen to receive mail from by subscribing to 
them.

4 Select if you want Evolution to override server-supplied folder namespaces.
By choosing this option you can rename the folders that the server provides. If you select this 
option, you need to specify the namespace to use.

5 Select if you want to apply filters to new messages in the Inbox.
6 Select if you want to check new messages for junk content.
7 Select if you want to check for junk messages in the Inbox folder.
8 Select if you want to automatically synchronize remote mail locally.
9 Click Forward.

When you have finished, continue with Sending Mail.

POP Receiving Options

If you select POP as your receiving server type, you need to specify the following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want to leave messages on the server.
3 Select if you want to disable support for all POP3 extensions (support for POP3).
4 Click Forward.

When you have finished, continue with Sending Mail.
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USENET News Receiving Options

If you select USENET News as your receiving server type, you need to specify the following 
options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want to show folders in short notation.
For example, comp.os.linux would appear as c.o.linux.

3 Select if you want to show relative folder names in the subscription dialog box.
If you select to show relative folder names in the subscription page, only the name of the folder 
is displayed. For example the folder evolution.mail would appear as evolution.

4 Click Forward.

When you have finished, continue with Sending Mail.

Local Delivery Receiving Options

If you select Local Delivery as your receiving server type, you need to specify the following 
options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Click Forward.

When you have finished, continue with Sending Mail.

MH-Format Mail Directories Receiving Options

If you select MH-Format Mail Directories as your receiving server type, you need to specify the 
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want to user the .folders summary file.
3 Click Forward.

When you have finished, continue with Sending Mail.

Maildir-Format Mail Directories Receiving Options

If you select Maildir-Format Mail Directories as your receiving server type, you need to specify the 
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.
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2 Select if you want to apply filters to new messages in the Inbox.
3 Click Forward.

When you have finished, continue with Sending Mail.

Standard Unix Mbox Spool or Directory Receiving Options

If you select Standard Unix Mbox Spool or Directory as your receiving server type, you need to 
specify the following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check for new 
messages.

2 Select if you want to apply filters to new messages in the Inbox.
3 Select if you want to store status headers in Elm, Pine, and Mutt formats.
4 Click Forward.

When you have finished, continue with Sending Mail Sending Mail.

Sending Mail

Now that you have entered information about how you plan to get mail, Evolution needs to know 
about how you want to send it. 

1 Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system. Sendmail is more 
flexible, but is not as easy to configure, so you should select this option only if you know how 
to set up a Sendmail service. 

SMTP: Sends mail using an outbound mail server. This is the most common choice for 
sending mail. If you choose SMTP, there are additional configuration options.

SMTP Configuration

1 Type the host address in the Host field.

If you are unsure what your host address is, contact your system administrator.
2 Select if your server requires authentication.

If you selected that your server requires authentication, you need to provide the following 
information:
2a Select your authentication type in the Authentication list.

or
Click Check for Supported Types to have Evolution check for supported types. Some 
servers do not announce the authentication mechanisms they support, so clicking this 
button is not a guarantee that available mechanisms actually work. 

2b Type your username in the Username field.
2c Select if you want Evolution to remember your password.
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3 Select if you use a secure connection (SSL).
4 Click Forward.

Continue with Account Management.

Account Management

Now that you have finished the e-mail configuration process you need to give the account a name. 
The name can be any name you prefer. Type your account name on the Name field, then click 
Forward.

Continue with Time Zone.

Time Zone

In this step, you need to select your time zone either on the map or select from the time zone drop-
down list.

When you have finished, click Forward, then click Apply. Evolution opens with your new account 
created.

If you want to import e-mail from another e-mail client, continue with Importing Mail (Optional). If 
not, skip to “Using Evolution: An Overview” on page 93.

Importing Mail (Optional)

If Evolution finds e-mail or address files from another application, it offers to import them. 

Microsoft Outlook* and versions of Outlook Express after version 4, use proprietary formats that 
Evolution cannot read or import. To import information, you might want to use the Export tool 
under Windows*.

Before importing e-mail from Netscape*, make sure you have selected File > Compact All Folders. 
If you don’t, Evolution will import and undelete the messages in your Trash folders.

NOTE: Evolution uses standard file types for e-mail and calendar information, so you can copy 
those files from your ~/.evolution directory. The file formats used are mbox for e-mail and 
iCal for calendar information.

Contacts files are stored in a database, but can be saved as a standard vCard*. To export contact 
data, open your contacts tool and select the contacts you want to export (press Ctrl+A to select them 
all). Click File > Save as VCard. 
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4.2  Using Evolution: An Overview
Now that the first-run configuration has finished, you’re ready to begin using Evolution. Here’s a 
quick explanation of what’s happening in your main Evolution window. 

Figure 4-1   Evolution Window

Menu Bar

The menu bar gives you access to nearly all of Evolution features.

Folder List

The folder list gives you a list of the available folders for each account. To see the contents of a 
folder, click the folder name and the contents are displayed in the e-mail list.

Toolbar

The toolbar gives you fast and easy access to the frequently used features in each component.

Search Tool

The search tool lets you search your e-mail, contacts, calendar, and tasks to easily find what you’re 
looking for.

Message List

The message list displays a list of e-mail that you have received. To view an e-mail in the preview 
pane, click the e-mail in the e-mail list.
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Shortcut Buttons

The shortcut bar lets you switch between folders and between Evolution tools. At the bottom of the 
shortcut bar there are buttons that let you switch tools, and above that is a list of all the available 
folders for the current tool. If you have the Evolution Connector for Microsoft Exchange installed, 
you have an Exchange button in addition to buttons for the other tools.

Status Bar

The status bar periodically displays a message, or tells you the progress of a task. This most often 
happens when you’re checking or sending e-mail. These progress queues are shown in the previous 
figure. The Online/Offline indicator is here, too, in the lower left of the window.

Preview Pane

The preview pane displays the contents of the e-mail that is selected in the e-mail list.

4.2.1  The Menu Bar
The menu bar’s contents always provide all the possible actions for any given view of your data. If 
you’re looking at your Inbox, most of the menu items relate to e-mail. Some content relates to other 
components of Evolution and some, especially those in the File menu, relates to the application as a 
whole. 

File: Anything related to a file or to the operations of the application usually falls under this menu, 
such as creating things, saving them to disk, printing them, and quitting the program itself. 

Edit: Holds useful tools that help you edit text and move it around. Lets you access the settings and 
configuration options in the Edit menu.

View: Lets you decide how Evolution should look. Some of the features control the appearance of 
Evolution as a whole, and others the way a particular kind of information appears. 

Folder: Holds actions that can be performed on folders. You can find things like copy, rename, 
delete, and so on.

Message: Holds actions that can be applied to a message. If there is only one target for the action, 
such as replying to a message, you can normally find it in the Message menu.

Search: Lets you search for messages, or for phrases within a message. You can also see previous 
searches you have made. In addition to the Search menu, there is a text entry box in the toolbar that 
you can use to search for messages. You can also create a search folder from a search.

Help: Opens the Evolution Help files.

4.2.2  The Shortcut Bar
Evolution’s most important job is to give you access to your information and help you use it quickly. 
One way it does that is through the shortcut bar, which is the column on the left side of the main 
window. The buttons, such as Mail and Contacts, are the shortcuts. Above them is a list of folders 
for the current Evolution tool.

The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree, similar to a file 
tree. Most people find one to four folders at the base of the tree, depending on the tool and their 
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system configuration. Each Evolution tool has at least one, called On This Computer, for local 
information. For example, the folder list for the e-mail tool shows any remote e-mail storage you 
have set up, plus local folders and search folders. 

If you get large amounts of e-mail, you might want more folders than just your Inbox. You can 
create multiple calendar, task, or contacts folders. 

To create a new folder:

1 Click Folder > New.
2 Type the name of the folder in the Folder Name field.
3 Select the location of the new folder.
4 Click OK.

Folder Management

Right-click a folder or subfolder to display a menu with the following options:

Copy: Copies the folder to a different location. When you select this item, Evolution offers a choice 
of locations to copy the folder to.

Move: Moves the folder to another location. 

Mark Messages As Read: Marks all the messages in the folder as read.

New Folder: Creates another folder in the same location. 

Delete: Deletes the folder and all its contents. 

Rename: Lets you change the name of the folder. 

Disable: Disables the account.

Properties: Checks the number of total and unread messages in a folder, and, for remote folders, 
lets you select whether to copy the folder to your local system for offline operation.

You can also rearrange folders and messages by dragging and dropping them.

Any time new e-mail arrives in a e-mail folder, that folder label is displayed in bold text, along with 
the number of new messages in that folder.

4.2.3  E-Mail
Evolution e-mail is like other e-mail programs in several ways:

• It can send and receive e-mail in HTML or as plain text, and makes it easy to send and receive 
multiple file attachments. 

• It supports multiple e-mail sources, including IMAP, POP3, and local mbox or mh spools and 
files created by other e-mail programs.

• It can sort and organize your e-mail in a wide variety of ways with folders, searches, and filters. 
• It lets you guard your privacy with encryption.

However, Evolution has some important differences from other e-mail programs. First, it’s built to 
handle very large amounts of e-mail. The junk e-mail, message filtering and searching functions 
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were built for speed and efficiency. There’s also the search folder, an advanced organizational 
feature not found in some e-mail clients. If you get a lot of e-mail, or if you keep every message you 
get in case you need to refer to it later, you’ll find this feature especially useful. Here’s a quick 
explanation of what’s happening in your main Evolution e-mail window. 

Message List

The message list displays all the e-mails that you have. This includes all your read and unread 
messages, and e-mail that is flagged to be deleted.

Preview Pane

This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole window, or 
double-click the message in the message list to have it open in a new window. To change the size of 
a pane, drag the divider between the two panes. 

As with folders, you can right-click messages in the message list and get a menu of possible actions, 
including moving or deleting them, creating filters or search folders based on them, and marking 
them as junk mail.

Most of the e-mail-related actions you want to perform are listed in the Actions menu in the menu 
bar. The most frequently used ones, like Reply and Forward, also appear as buttons in the toolbar. 
Most of them are also located in the right-click menu and as keyboard shortcuts.

4.2.4  The Calendar
To begin using the calendar, click Calendar in the shortcut bar. By default, the calendar shows 
today’s schedule on a ruled background. At the upper right, there’s a monthly calendar you can use 
to switch days. Below that, there’s a Task list, where you can keep a list of tasks separate from your 
calendar appointments.

Appointment List

The appointment list displays all your scheduled appointments.

Month Pane

The month pane is a small view of a calendar month. To display additional months, drag the column 
border to the left. You can also select a range of days in the month pane to display a custom range of 
days in the appointment list.

Task List

Tasks are distinct from appointments because they generally don’t have times associated with them. 
You can see a larger view of your task list by clicking Tasks in the shortcut bar.

4.2.5  The Contacts Tool
The Evolution contacts tool can handle all of the functions of an address book or phone book. 
However, it’s easier to update Evolution than it is to change an actual paper book, in part because 
Evolution can synchronize with Palm OS* devices and use LDAP directories on a network.
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Another advantage of the Evolution contacts tool is its integration with the rest of the application. 
For example, you can right-click on an e-mail address in Evolution mail to instantly create a contact 
entry.

To use the contacts tool, click Contacts in the shortcut bar. By default, the display shows all your 
contacts in alphabetical order, in a minicard view. You can select other views from the View menu, 
and adjust the width of the columns by clicking and dragging the gray column dividers.

The largest section of the contacts display shows a list of individual contacts. You can also search 
the contacts in the same way that you search e-mail folders, using the search tool on the right side of 
the toolbar.
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5GroupWise Linux Client: E-Mailing 
and Calendaring

GroupWise® is a robust, dependable messaging and collaboration system that connects you to your 
universal mailbox anytime and anywhere. This section gives you an introductory overview of the 
GroupWise client to help you start using the GroupWise Cross-Platform client quickly and easily.

• Section 5.1, “Getting Acquainted with the Main GroupWise Window,” on page 99
• Section 5.2, “Using Different GroupWise Modes,” on page 104
• Section 5.3, “Understanding Your Mailbox,” on page 105
• Section 5.4, “Using the Toolbar,” on page 107
• Section 5.5, “Using Shortcut Keys,” on page 107
• Section 5.6, “Learning More,” on page 109

5.1  Getting Acquainted with the Main GroupWise 
Window
Your main work area in GroupWise is called the Main Window. From the Main Window of 
GroupWise, you can read your messages, schedule appointments, view your Calendar, manage 
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contacts, change the mode of GroupWise you’re running in, open folders, open documents, and 
much more.

Figure 5-1   Groupwise Main Window

You can open more than one Main Window in GroupWise by clicking Window, then clicking New 
Main Window. This is useful if you proxy for another user. You can look at your own Main Window 
and the Main Window belonging to the person you are proxying for. You might also want to open a 
certain folder in one window and look at your Calendar in another. You can open as many Main 
Windows as your computer’s memory allows.

The basic components of the Main Window are explained below.

5.1.1  Toolbar
The toolbar lets you quickly accomplish common GroupWise tasks, such as opening the Address 
Book, sending mail messages, and finding an item. For information about the toolbar, see Section 
5.4, “Using the Toolbar,” on page 107.

5.1.2  Folder and Item List Header
The Folder and Item List header provides a drop-down list where you can select the mode of 
GroupWise you want to run (Online or Caching), select to open your archived or backup mailbox, 
and select a proxy mailbox.
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5.1.3  Folder List
The Folder List at the left of the Main Window lets you organize your GroupWise items. You can 
create new folders to store your items in. Next to any folder (except for shared folders), the number 
of unread items is shown in square brackets. Next to the Sent Items folder, the number in square 
brackets shows how many items are pending to be sent from Caching mode. 

Here is what you’ll find in each of the default folders:

• “User Folder” on page 101
• “Mailbox Folder” on page 101
• “Sent Items Folder” on page 101
• “Calendar Folder” on page 102
• “Contacts Folder” on page 102
• “Checklist Folder” on page 102
• “Documents Folder” on page 103
• “Trash Folder” on page 103
• “Shared Folders” on page 103

User Folder

Your user folder  (indicated by your name) represents your GroupWise database. All folders in 
you Main Window are subfolders of your user folder.

Mailbox Folder

The Mailbox  displays all the items you have received, with the exception of scheduled items 
(appointments, tasks, and reminder notes) you have accepted or declined. Accepted scheduled items 
are moved to the Calendar. 

Sent Items Folder

The Sent Items folder  displays all sent items from the Mailbox and Calendar. The Sent Items 
folder in versions prior to GroupWise 6.5 was a query folder, which had some differences from the 
current Sent Items folder.

The following is a comparison between the previous Sent Items query folder and the current Sent 
Items folder.

Table 5-1   Comparison Between Sent Items Query Folder and Sent Items Folder

Sent Items Folder (Current) Sent Items Query Folder (Previous)

All sent items reside in this folder unless they are 
moved to a folder other than the Mailbox or 
Calendar. If a sent item is moved to another 
folder, it no longer displays in the Sent Items 
folder.

No items actually reside in this folder. This folder is 
a Find Results folder, which means a Find is 
performed when you click the folder and the results 
of the Find (all sent items) are displayed in the 
folder. If you delete an item from this folder, the 
original item remains in its original folder and 
redisplays the next time you open this folder.
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Calendar Folder

The Calendar folder  shows several calendar view options. 

Contacts Folder

The Contacts folder , by default, represents the Frequent Contacts address book in the Address 
Book. Any modification you make in the Contacts Folder is also made in the Frequent Contacts 
address book.

From this folder, you can view, create and modify contacts, resources, organizations and groups.

Your proxies never see your Contacts folder.

Checklist Folder

Use the Checklist folder  to create a task list. You can move any items (mail messages, phone 
messages, reminder notes, tasks, or appointments) to this folder and arrange them in the order you 
want. Each item is marked with a check box so that you can check items off as you complete them. 

The following is a comparison between the Checklist folder and the Task List query folder (found in 
previous versions of GroupWise).

Table 5-2   Comparison Between Checklist Folder and Task List Folder

You can resend, reschedule, and retract sent 
items from this folder.

You can resend, reschedule, and retract sent items 
from this folder.

Checklist Folder Task List Folder

This folder contains the following items:

• Items you have moved to this folder

• Items you have posted to this folder

• Items that are part of a checklist that you 
have created in another folder

No items actually reside in this folder. This folder is a 
Find Results folder, which means a Find is 
performed when you click the folder and the results 
of the Find (all scheduled tasks) are displayed in the 
folder. If you delete an item from this folder, the 
original item remains in its original folder and 
redisplays the next time you open this folder.

Any item type can reside in this folder. Only tasks show in this folder. Tasks are scheduled 
items that are associated with a due date.

To mark an item completed, click the check 
box next to the item in the Item List.

To mark an item completed, open the item, then click 
Completed.

Due dates are set by the person who sent you the 
task. If you post a task for yourself, you can set a 
due date.

To set the priority of an item, open the item, then 
type a priority in the Priority field.

Checklist items do not display in the Task List 
of the Calendar.

Tasks display in the Task List of the Calendar and 
can be marked Completed from the Calendar.

Sent Items Folder (Current) Sent Items Query Folder (Previous)
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Documents Folder

Your document references are organized in the Documents folder  so you can locate them easily. 

The Documents folder can contain only documents. If any other type of item is moved to this folder 
by a GroupWise client older than version 5.5, the item is deleted.

Cabinet Folder

The Cabinet  contains all your personal folders. You can rearrange and nest folders by clicking 
Edit > Folders. You can change how the folders are sorted by right-clicking the Cabinet folder, 
clicking Properties, then selecting what you want to sort by.

Junk Mail Folder

All e-mail items from addresses and Internet domains that are junked through Junk Mail Handling 
are placed in the Junk Mail folder . This folder is not created in the folder list unless a Junk Mail 
option is enabled.

While Junk Mail options are enabled, this folder cannot be deleted. However, the folder can be 
renamed or moved to a different location in the folder list. If all Junk Mail options are disabled, the 
folder can be deleted. The folder can also be deleted if the Junk Mail Handling feature is disabled by 
the system administrator.

To delete items from the Junk Mail Folder, right-click the folder, click Empty Junk Mail Folder, 
then click Yes.

Trash Folder

All deleted mail and phone messages, appointments, tasks, documents, and reminder notes are 
stored in the Trash folder . Items in the Trash can be viewed, opened, or returned to your Mailbox 
before the Trash is emptied. (Emptying the Trash removes items in the Trash from the system.) 

You can empty your entire Trash, or empty only selected items. Items in the Trash are automatically 
emptied according to the number days entered in the Cleanup tab in Environment Options, or you 
can empty the Trash manually. The system administrator might specify that your Trash is emptied 
automatically on a regular basis.

Shared Folders

A shared folder  is like any other folder in your Cabinet, except other people have access to it. 
You can create shared folders or share existing personal folders in your Cabinet. You choose whom 
to share the folder with, and what rights to grant each user. Then, users can post messages to the 
shared folder, drag existing items into the folder, and create discussion threads. You can’t share 
system folders, which include the Cabinet, Trash, and Work In Progress folders.

Tasks that are past due show as red in the Calendar.

Checklist Folder Task List Folder
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5.1.4  Item List
The Item List on the right side of the Main Window displays your mail and phone messages, 
appointments, reminder notes, tasks, and document references. You can sort the Item List by 
clicking a column heading. To reverse the sort order, click the column heading a second time. For 
information about the icons used with different items, see “Icons Appearing Next to Items in Your 
Mailbox and Calendar” on page 105.

5.1.5  QuickViewer
The QuickViewer opens below the Folder and Item List. You can quickly scan items and their 
attachments in the QuickViewer rather than open each item in another window.

5.2  Using Different GroupWise Modes
GroupWise provides two different ways to run the GroupWise client: Online mode and Caching 
mode.

You might be able to run GroupWise in either mode, or your system administrator might require that 
you use only a certain mode.

Most GroupWise features are available in all both GroupWise modes, with some exceptions. 
Subscribing to other users’ notifications is not available in Caching mode.

5.2.1  Online Mode
When you use Online mode, you are connected to your post office on the network. Your mailbox 
displays the messages and information stored in your network mailbox (also called your Online 
Mailbox). Online mode is connected to your network mailbox continuously. In Online mode, if your 
Post Office Agent shuts down or you lose your network connection, you temporarily lose your 
connection to your mailbox.

You should use this mode if you do not have a lot of network traffic, or if you use several different 
workstations and do not want to download a local mailbox to each one. 

5.2.2  Caching Mode
Caching mode stores a copy of your network mailbox, including your messages and other 
information, on your local drive. This allows you to use GroupWise whether or not your network or 
Post Office Agent is available. Because you are not connected to the network all the time, this mode 
cuts down on network traffic and has the best performance. A connection is made automatically to 
retrieve and send new messages. All updates are performed in the background so your work is not 
interrupted. 

To use Caching mode, the client installation must be a standard installation, not a workstation 
installation.

You should use this mode if you have enough disk space on your local drive to store your mailbox. 

Several users can set up their Caching Mailboxes on a single shared computer.
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5.3  Understanding Your Mailbox
All of your items, whether you send or receive them, are stored in your GroupWise Mailbox. You 
can quickly display only received items, sent items, posted items, or draft items by clicking a setting 
on the Display drop-down list. You can further restrict which items display in your Mailbox by 
using filters. 

You can organize your messages by moving them into folders within your Cabinet, and you can 
create new folders as necessary. 

5.3.1  Bolded Items in Your Mailbox
All unopened items in your Mailbox are bolded to help you easily identify which items and 
documents you have not yet read. The icon appearing next to an item also indicates if it is unopened.

Sent items are also bolded to show when they are queued but not uploaded, status information has 
not been received about the item being delivered, or they have not yet been transferred to the 
Internet.

5.3.2  Icons Appearing Next to Items in Your Mailbox and 
Calendar
The icons that appear next to items in your Mailbox and Calendar show information about the items. 
The following table explains what each icon means.

Table 5-3   Icon Descriptions

Icon Description

Next to an item you have sent in Caching mode, the  icon indicates that the item 
has been queued, but the queue has not been uploaded. After the item has been 
uploaded, this icon indicates that status information has not been received about the 
item being delivered to the destination post office or transferred to the Internet.

Next to the Sent Items folder, the  icon indicates that there is at least one item that 
has been queued but has not been uploaded.

Appears next to an item you have sent. If the item has been opened by at least one 
person, this icon appears until all recipients have 1) opened the mail, phone 
message, or reminder note; 2) accepted the appointment; or 3) completed the task.

Appears next to an item you have sent. The item couldn’t be delivered to the 
destination post office or it failed to transfer to the Internet.

Appears next to an item you have sent. Next to an appointment or task, this icon 
indicates that at least one person has declined/deleted the item. Next to a mail 
message, phone message, or reminder note, this icon indicates that at least one 
person has deleted the item without opening it.

One or more attachments are included with the item.

One or more sound annotations are included with the item, or the item is a voice mail 
message.

Draft item.
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Appears next to an item you have sent.

Appears next to an item you have replied to.

Appears next to an item you have forwarded.

Appears next to an item you have delegated.

Appears next to an item you have replied to and forwarded

Appears next to an item you have replied to and delegated.

Appears next to an item you have forwarded and delegated.

Appears next to an item you have replied to, forwarded, and delegated

Posted item.

Specific version of a document.

Official version of a document.

Unopened mail message with a low, standard, or high priority.

Opened mail message with a low, standard, or high priority.

Unopened appointment with a low, standard, or high priority.

Opened appointment with a low, standard, or high priority.

Unopened task with a low, standard, or high priority.

Opened task with a low, standard, or high priority.

Unopened reminder note with a low, standard, or high priority.

Opened reminder note with a low, standard, or high priority.

Unopened phone message with a low, standard, or high priority.

Opened phone message with a low, standard, or high priority.

The sender has requested that you reply to this item. The item can be a low, 
standard, or high priority.

Appears in a Busy Search. If it appears to the left of a username or resource, you 
can click a scheduled time across from the username or resource on the Individual 
Schedules tab to display more information about the appointment in the box below. 
However, the user or resource owner must give you appointment Read rights in the 
Access List before this icon appears. 

Appears on your Calendar, indicates an alarm is set for the item.

Appears on your Calendar, indicates the item is a group appointment, reminder note, 
or task.

Appears on your Calendar, indicates the item is marked private.

Appears on your Calendar, indicates that you declined the item but didn’t delete it.

Icon Description
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5.4  Using the Toolbar
Use the toolbar to access many of the features and options found in GroupWise. The toolbar at the 
top of a folder or item is context sensitive; it changes to provide the options you need most in that 
location.

5.5  Using Shortcut Keys
You can use a number of shortcut keys in GroupWise for accessibility or to save time when you 
perform various operations. The table below lists some of these keystrokes, what they do, and the 
context where they work.

Table 5-4   Shortcut Keys

Keystroke Action Where It Works

F1 Open online help Main Window, Calendar, item, dialog box

F2 Search for text. In an item

F5 Refresh the view Main Window, Calendar

F7 Opens the Spell Checker In an item

F8 Mark the selected item private Item List

F9 Open the font dialog box In an item

Ctrl+A Select all items; select all text Item List; text

Ctrl+B Bold text In text

Ctrl+C Copy selected text In text

Ctrl+F Open the Find dialog box Main Window, Calendar, item, dialog box

Ctrl+G Go to today’s date Calendar

Ctrl+I Italicize text In text

Ctrl+L Attach a file to a message In an item

Ctrl+M Open a new mail message Main Window, Calendar, item, dialog box

Ctrl+O Open the selected message Item List

Ctrl+P Open the Print dialog box Main Window, item

Ctrl+Q Turn the QuickViewer on and off Main Window, Calendar

Ctrl+R Mark the selected item unread Item List

Ctrl+S Save a draft in the Work in 
Progress folder

In an item

Ctrl+U Underline text In text

Ctrl+V Paste selected text In text

Ctrl+X Cut selected text In text
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Ctrl+Z Undo the last action In text

Ctrl+Up-arrow

or

Ctrl+Down-arrow

Opens the previous or next item In an item

Ctrl+Shift+Left-arrow

or

Ctrl+Shift+Right-
arrow

Select text one word at a time In text

Ctrl+Shift+A Open a new appointment Main Window, Calendar, item, dialog box

Ctrl+Shift+T Open a new task Main Window, Calendar, item, dialog box

Ctrl+Shift+R Open a new reminder note Main Window, Calendar, item, dialog box

Ctrl+Shift+P Open a new phone message Main Window, Calendar, item, dialog box

Alt+F4 From the Main Window or 
Calendar, exit GroupWise.

From an item, exit the item.

From a dialog box, exit the dialog 
box.

Main Window, Calendar, item, dialog box

Alt + [letter] Activate the menu bar (Use the 
underlined letters in the menu 
names)

Main Window, Calendar, item

Alt+D Send item In a new item

Alt+S Send item In a new item

Alt+Enter Display the properties of the 
selected item

Item List

Alt+Del Delete an item In an item

Shift+Left-arrow

or

Shift+Right-arrow

Select text one character at a time In text

Shift+End

or

Shift+Home

Select text to the end or beginning 
of a line

In text

Shift + [letter] In the Folder List, Shift + the first 
letter of a subfolder name goes to 
the subfolder.

Folder list

Tab Cycle through fields, buttons, and 
areas

Main Window, Calendar, dialog box, item

Keystroke Action Where It Works
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5.6  Learning More
You can learn more about GroupWise from the following resources:

• “Online Help” on page 109
• “GroupWise 7 Documentation Web Page” on page 109
• “GroupWise Cool Solutions Web Community” on page 109

5.6.1  Online Help
Complete user documentation is available in Help. In the Main Window, click Help > Help Topics, 
then use the Contents tab, Index tab, or Search tab to locate the help topics you want. 

5.6.2  GroupWise 7 Documentation Web Page
For the latest version of the GroupWise user guide and for extensive GroupWise administration 
documentation, go to the GroupWise 7 area on the Novell Documentation Web site (http://
www.novell.com/documentation/gw7).

This user guide is also available from the GroupWise client by clicking Help > User Guide.

5.6.3  GroupWise Cool Solutions Web Community
At GroupWise Cool Solutions, you’ll find tips, tricks, feature articles, and answers to frequent 
questions. In the Main Window, click Help > Cool Solutions Web Community or go to http://
www.novell.com/coolsolutions/gwmag (http://www.novell.com/coolsolutions/gwmag).

Shift+Tab Reverse the order of cycling 
through fields, buttons, and areas

Main Window, Calendar, dialog box, item

Ctrl+Tab In text, indent the text.

In a tabbed dialog box, open the 
next tab.

In text, dialog box

Alt+Up Arrow Zooms in the message body of an 
item.

In an item

Alt+Down Arrow Zooms out the message body of an 
item.

In an item

Keystroke Action Where It Works
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6Instant Messaging with Gaim

Use Gaim to use all of your instant messaging accounts from a single instant messaging client. Gaim 
supports all of the most popular instant messaging protocols, so you can log in to all of your 
accounts at once and chat live with your contacts in one tabbed interface, regardless of which IM 
system they use.

This chapter explains the Gaim options you need to know about to set up Gaim and communicate 
with your contacts. It does not explain all of Gaim’s features and options. For more information, 
open Gaim, then click Help > Online Help or press F1.

• Section 6.1, “Supported Protocols,” on page 111
• Section 6.2, “Setting Up an Account,” on page 111
• Section 6.3, “Managing Your Buddy List,” on page 112
• Section 6.4, “Chatting,” on page 112

6.1  Supported Protocols
Gaim supports the following instant messaging protocols:

• AIM/ICQ
• Gadu-Gadu
• GroupWise
• IRC
• Jabber
• MSN
• Napster
• Yahoo
• Zephyr

6.2  Setting Up an Account
To use Gaim, you must already have accounts on the systems you want to use. For example, to use 
Gaim for your AIM account, you must first have an AIM account. Once you have those accounts, 
set them up in the Gaim Add Account dialog.

1 Start Gaim by clicking Computer > More Applications > Communicate > Gaim.
2 Click Accounts > Add to open the Add Account dialog.

The first time you run Gaim, or any subsequent times you start Gaim when you don’t have any 
accounts set up, the Add Account dialog opens automatically.

3 Choose the protocol you want to set up.
The Add Account dialog differs for each protocol, depending on what setup options are 
available for that protocol.

4 Enter the setup options for the chosen protocol.
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Typical options include your account name and password. Your protocol might support 
additional options, such as a buddy icon, alias, login options, or others.

5 Click Save.
6 Repeat Steps 2 to 5 for each additional protocol.

Once an account is added, you can log in to that account by entering your account name and 
password in the Gaim Login dialog.

6.3  Managing Your Buddy List
Use the Buddy List to manage your contacts, also known as buddies. You can add and remove 
buddies from your Buddy List, and you can organize your buddies in groups so they are easy to find.

6.3.1  Displaying Buddies in the Buddy List
Once your accounts are set up, all buddies who are online appear in your Buddy List. If you also 
want your buddies who are not online to appear in the Buddy List, click Buddies > Show Offline 
Buddies. 

6.3.2  Adding a Buddy
To add a buddy to your Buddy List, click Buddies > Add Buddy, then enter the information about 
that buddy. 

NOTE: For some protocols, you cannot add a buddy in the Gaim interface. You must use the client 
for those protocols if you want to add to your buddy list. After you have added a buddy in the 
protocol’s client, that buddy appears in your Gaim Buddy List.

6.3.3  Removing a Buddy
To remove a buddy, right-click on that buddy’s name in the Buddy List, then click Remove.

6.4  Chatting
To open a chat session, double-click a buddy name in the Buddy List. The Chat screen opens. Type 
your message, then press Enter to send it.

Each chat session you open appears as a tab in the Chat screen. Click on a buddy’s tab to chat with 
that buddy. Close a chat session by closing the tab for that buddy.
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7Using Voice over IP

Linphone is a small Web phone application for your Linux desktop. It allows you to make two-party 
calls over the Internet. There is no need for special hardware items: a standard workstation with a 
properly configured sound card, microphone, and speakers or headphones is all you need to get 
started with Linphone. 

7.1  Configuring Linphone
Before you start using Linphone there are some basic decisions to make and some configuration 
tasks to complete. First, determine and configure the run mode of Linphone, determine the 
connection type to use, then start the Linphone configuration (Go > Preferences) to make the 
necessary adjustments. 

7.1.1  Determining the Run Mode of Linphone
Linphone can be run in two different modes, depending on the type of desktop you run and on its 
configuration. 

Normal Application 
After the Linphone software has been installed, it can be started via the GNOME and KDE 
application menus or via the command line. When Linphone is not running, incoming calls 
cannot be received. 

GNOME Panel Applet 
Linphone can be added to the GNOME panel. Right-click an empty area in the panel, select 
Add to Panel, and select Linphone. Linphone is then permanently added to the panel and 
automatically started on login. As long as you do not receive any incoming calls, it runs in the 
background. As soon as you get an incoming call, the main window opens and you can receive 
the call. To open the main window to call someone, just click the applet icon. 

7.1.2  Determining the Connection Type
There are several different ways to make a call in Linphone. How you make a call and how you 
reach the other party is determined by the way you are connected to the network or the Internet. 

Linphone uses the session initiation protocol (SIP) to establish a connection with a remote host. In 
SIP, each party is identified by a SIP URL:

sip:username@hostname   

username is your login on your Linux machine and hostname the name of the computer you are 
using. If you use a SIP provider, the URL would look like the following example:

sip:username@sipserver   

username is the username chosen when registering at a SIP server. sipserver is the address of the 
SIP server or your SIP provider. For details on the registration procedure, refer to “Configuring the 
SIP Options” on page 115 and check the provider's registration documentation. For a list of 
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providers suitable for your purpose, check the Web pages mentioned in “For More Information” on 
page 119. 

The URL to use is determined by the type of connection you choose. If you chose to call another 
party directly without any further routing by a SIP provider, you would enter a URL of the first type. 
If you chose to call another party via a SIP server, you would enter a URL of the second type. 

Calling in the Same Network

If you intend to call a friend or coworker belonging to the same network, you just need the correct 
username and hostname to create a valid SIP URL. The same applies if this person wants to call you. 
As long as there is no firewall between you and the other party, no further configuration is required. 

Calling across Networks or the Internet (Static IP Setup)

If you are connected to the Internet using a static IP address, anyone who wants to call you just 
needs your username and the hostname or IP address of your workstation to create a valid SIP URL, 
as described in “Calling in the Same Network” on page 114. If you or the calling party are located 
behind a firewall that filters incoming and outgoing traffic, open the SIP port (5060) and the RTP 
port (7078) on the firewall machine to enable Linphone traffic across the firewall. 

Calling across Networks or the Internet (Dynamic IP Setup)

If your IP setup is not static—if you dynamically get a new IP address every time you connect to the 
Internet—it is impossible for any caller to create a valid SIP URL based on your username and an IP 
address. In these cases, either use the services offered by a SIP provider or use a DynDNS setup to 
make sure that an external caller gets connected to the right host machine. More information about 
DynDNS can be found at Wikipedia.org (http://en.wikipedia.org/wiki/Dynamic_DNS). 

Calling across Networks and Firewalls

Machines hidden behind a firewall do not reveal their IP address over the Internet. Thus, they cannot 
be reached directly from anyone trying to call a user working at such a machine. Linphone supports 
calling across network borders and firewalls by using a SIP proxy or relaying the calls to a SIP 
provider. Refer to “Configuring the SIP Options” on page 115 for a detailed description of the 
necessary adjustments for using an external SIP server. 

7.1.3  Configuring the Network Parameters
Most of the settings contained in the Network tab do not need any further adjustments. You should 
be able to make your first call without changing them. 

NAT Traversal Options 
Enable this option only if you find yourself in a private network behind a firewall and if you do 
not use a SIP provider to route your calls. Select the check box and enter the IP address of the 
firewall machine in dot notation, for example, 192.168.34.166. 

RTP Properties 
Linphone uses the real-time transport protocol (RTP) to transmit the audio data of your calls. 
The port for RTP is set to 7078 and should not be modified, unless you have another 
application using this port. The jitter compensation parameter is used to control the number of 
audio packages Linphone buffers before actually playing them. By increasing this parameter, 
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you improve the quality of transmission. The more packages buffered, the greater a chance for 
“late comers” to be played back. On the other hand increasing the number of buffered packages 
also increases the latency—you hear the voice of your counterpart with a certain delay. When 
changing this parameter, carefully balance these two factors. 

Other 
If you use a combination of VoIP and landline telephony, you might want to use the dual tone 
multiplexed frequency (DTMF) technology to trigger certain actions, like a remote check of 
your voice mail just by punching certain keys. Linphone supports two protocols for DTMF 
transmission, SIP INFO and RTP rfc2833. If you need DTMF functionality in Linphone, 
choose a SIP provider that supports one of these protocols. For a comprehensive list of VoIP 
providers, refer to “For More Information” on page 119. 

7.1.4  Configuring the Sound Device
Once your sound card has been properly detected by Linux, Linphone automatically uses the 
detected device as the default sound device. Leave the value of Use sound device as it is. Use 
Recording source to determine which recording source should be used. In most cases, this would be 
a microphone (micro). To select a custom ring sound, use Browse to choose one and test your 
choice using Listen. Click Apply to accept your changes. 

7.1.5  Configuring the SIP Options
The SIP dialog contains all SIP configuration settings. 

SIP Port 
Determine on which port the SIP user agent should run. The default port for SIP is 5060. 
Leave the default setting unchanged unless you know of any other application or protocol that 
needs this port. 

Identity 
Anyone who wants to call you directly without using a SIP proxy or a SIP provider needs to 
know your valid SIP address. Linphone creates a valid SIP address for you. 

Remote Services 
This list holds one or more SIP service providers where you have created a user account. Server 
information can be added, modified, or deleted at any time. See “Adding a SIP Proxy and 
Registering at a Remote SIP Server” on page 115 to learn about the registration procedure. 

Authentication Information 
To register at a remote SIP server, provide certain authentication data, such as a password and 
username. Linphone stores this data once provided. To discard this data for security reasons, 
click Clear all stored authentication data. 

The Remote services list can be filled with several addresses of remote SIP proxies or service 
providers. 

Adding a SIP Proxy and Registering at a Remote SIP Server

1 Choose a suitable SIP provider and create a user account there. 
2 Start Linphone. 
Using Voice over IP 115



116 SUSE Linux

novdocx (E
N

U
)  01 February 2006
3 Go to Go > Preferences > SIP. 
4 Click Add proxy/registrar to open a registration form. 
5 Fill in the appropriate values for Registration Period, SIP Identity, SIP Proxy and Route. If 

working from behind a firewall, always select Send registration and enter an appropriate value 
for Registration Period. This resends the original registration data after a given time to keep the 
firewall open at the ports needed by Linphone. Otherwise, these ports would automatically be 
closed if the firewall did not receive any more packages of this type. Resending the registration 
data is also needed to keep the SIP server informed about the current status of the connection 
and the location of the caller. For SIP identity, enter the SIP URL that should be used for local 
calls. To use this server also as a SIP proxy, enter the same data for SIP Proxy. Finally, add an 
optional route, if needed, and leave the dialog with OK. 

7.1.6  Configuring the Audio Codecs
Linphone supports a several codecs for the transmission of voice data. Set your connection type and 
choose your preferred codecs from the list window. Codecs not suitable for your current connection 
type are red and cannot be selected. 

7.2  Testing Linphone
Check your Linphone configuration using sipomatic, a small test program that can answer calls 
made from Linphone. 

Testing a Linphone Setup

1 Open a terminal. 
2 Enter sipomatic at the command line prompt. 
3 Start Linphone. 
4 Enter sip:robot@127.0.0.1:5064 as SIP address and click Call or Answer. 
5 If Linphone is configured correctly, you will hear a phone ringing and, after a short while, you 

will hear a short announcement. 

If you successfully completed this procedure, you can be sure that your audio setup and the network 
setup are working. If this test fails, check whether your sound device is correctly configured and 
whether the playback level is set to a reasonable value. If you still fail to hear anything, check the 
network setup including the port numbers for SIP and RTP. If any other application or protocol uses 
the defaults ports for these as proposed by Linphone, consider changing ports and retry. 

7.3  Making a Call
Once Linphone is configured appropriately, making a call is straightforward. Depending on the type 
of call (see “Determining the Connection Type” on page 113 for reference), the calling procedures 
differ slightly. 

1 Start Linphone using the menu or a command line. 
2 Enter the SIP address of the other party at the SIP address prompt. The address should look like 
sip:username@domainname or username@hostname for direct local calls or like 
username@sipserver or userid@sipserver for proxied calls or calls using the 
service of a SIP provider. 
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3 If using a SIP service provider or a proxy, select the appropriate proxy or provider from Proxy 
to use and provide the authentication data requested by this proxy.

4 Click Call or Answer and wait for the other party to pick up the phone. 
5 Once you are done or wish to end the call, click Release or Refuse and leave Linphone. 

If you need to tweak the sound parameters during a call, click Show more to show four tabs holding 
more options. The first one holds the Sound options for Playback level and Recording level. Use the 
sliders to adjust both volumes to fit your needs. 

The Presence tab lets you set your online status. This information can be relayed to anyone who 
tries to contact you. If you are permanently away and wish to inform the calling party of this fact, 
just check Away. If you are just busy, but want the calling party to retry, check Busy, I'll be back in 
... min and specify how long you will not be reachable. Once you are reachable again, set the status 
back to the default (Reachable). Whether another party can check your online status is determined 
by the Subscribe Policy set in the address book, as described in “Using the Address Book” on 
page 117. If any party listed in your address book published their online status, you can monitor it 
using the My online friends tab. 

The DTMF tab can be used to enter DTMF codes for checking voice mail. To check your voice mail, 
enter the appropriate SIP address and use the keypad in the DTMF tab to enter the voice mail code. 
Finally, click Call or Answer as if you were making an ordinary call. 

7.4  Answering a Call
Depending on the run mode selected for Linphone, there are several ways you would notice an 
incoming call: 

Normal Application 
Incoming calls can only be received and answered if Linphone is already running. You then 
hear the ring sound on your headset or your speakers. If Linphone is not running, the call 
cannot be received. 

GNOME Panel Applet 
Normally, the Linphone panel applet would run silently without giving any notice of its 
existence. This changes as soon as a call comes in: the main window of Linphone opens and 
you hear a ring sound on your headset or speakers. 

Once you have noticed an incoming call, just click Call or Answer to pick up the phone and start 
talking. If you do not want to accept this call, click Release of Refuse. 

7.5  Using the Address Book
Linphone offers to manage your SIP contacts. Start the address book with Go > Address book. An 
empty list window opens. Click Add to add a contact. 

The following entries need to be made for a valid contact: 

Name 
Enter the name of your contact. This may be a full name, but you can also use a nickname here. 
Choose something you easily remember this person as. If you choose to see this person's online 
status, this name is shown in the My online friends tab of the main window. 
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SIP Address 
Enter a valid SIP address for your contact. 

Proxy to Use 
If needed, enter the proxy to use for this particular connection. In most cases, this would just be 
the SIP address of the SIP server you use. 

Subscribe Policy 
Your subscribe policy determines whether your presence or absence can be tracked by others. 

To call any contact from the address book, select this contact with the mouse, click Select to make 
the address appear in the address field of the main window, and start the call with Call or Answer as 
usual. 

7.6  Troubleshooting

I try to call someone, but fail to establish a connection. 
There are several reasons why a call could fail: 

Your connection to the Internet is broken. 
Because Liphone uses the Internet to relay your calls, make sure that your computer is 
properly connected to and configured for the Internet. This can easily be tested by trying 
to view a Web page using your browser. If the Internet connection works, the other party 
might not be reachable. 

The person you are calling is not reachable. 
If the other party refused your call, you would not be connected. If Linphone is not 
running on the other party's machine while you are calling, you will not be connected. If 
the other party's Internet connection is broken, you cannot make the connection. 

My call seems to connect, but I cannot hear anything. 
First, make sure that your sound device is properly configured. Do this by launching any other 
application using sound output, such as a media player. Make sure that Linphone has sufficient 
permissions to open this device. Close all other programs using the sound device to avoid 
resource conflicts. 
If the above checks were successful, but you still fail to hear anything, raise the recording and 
playback levels under the Sound tab. 

 The voice output on both ends sounds strangely clipped.  
Try to adjust the jitter buffer using RTP properties in Preferences > Network to compensate for 
delayed voice packages. When doing this, be aware that it increases the latency. 

DTMF does not work. 
You tried to check your voice mail using the DTMF pad, but the connection could not be 
established. There are three different protocols used for the transmission of DTMF data, but 
only two of these are supported by Linphone (SIP INFO and RTP rfc2833). Check with your 
provider whether it supports one of these. The default protocol used by Linphone is rfc2833, 
but if that fails you can set the protocol to SIP INFO in Preferences > Network > Other. If it 
does not work with either of them, DTMF transmission cannot be done using Linphone. 
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7.7  Glossary
Find some brief explanation of the most important technical terms and protocols mentioned in this 
document: 

VoIP 
VoIP stands for voice over Internet protocol. This technology allows the transmission of 
ordinary telephone calls over the Internet using packet-linked routes. The voice information is 
sent in discrete packets like any other data transmitted over the Internet via IP. 

SIP 
SIP stands for session initiation protocol. This protocol is used to establish media sessions over 
networks. In a Linphone context, SIP is the magic that triggers the ring at your counterpart's 
machine, starts the call, and also terminates it as soon as one of the partners decides to hang up. 
The actual transmission of voice data is handled by RTP. 

RTP 
RTP stands for real-time transport protocol. It allows the transport of media streams over 
networks and works over UDP. The data is transmitted by means of discrete packets that are 
numbered and carry a time stamp to allow correct sequencing and the detection of lost 
packages. 

DTMF 
A DTMF encoder, like a regular telephone, uses pairs of tones to represent the various keys. 
Each key is associated with a unique combination of one high and one low tone. A decoder 
then translates these touch-tone combinations back into numbers. Linphone supports DTMF 
signalling to trigger remote actions, such as checking voice mail. 

codec 
Codecs are algorithms specially designed to compress audio and video data. 

jitter 
Jitter is the variance of latency (delay) in a connection. Audio devices or connection-oriented 
systems, like ISDN or PSTN, need a continuous stream of data. To compensate for this, VoIP 
terminals and gateways implement a jitter buffer that collect the packets before relaying them 
onto their audio devices or connection-oriented lines (like ISDN). Increasing the size of the 
jitter buffer decreases the likelihood of data being missed, but the latency of the connection is 
increased. 

7.8  For More Information
For general information about VoIP, check the VoIP Wiki at voip-info.org (http://voip-info.org/tiki-
index.php). For a comprehensive list of providers offering VoIP services in your home country, refer 
to the service providers list at voip-info.org (http://voip-info.org/wiki-
VOIP+Service+Providers+Residential). 
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8Managing Printers

SUSE® Linux Enterprise Desktop (SLED) makes it easy to print your documents, whether your 
computer is connected directly to a printer or linked remotely on a network. This chapter describes 
how to set up printers in SLED and manage print jobs with the following tasks:

• “Installing a Printer” on page 121
• “Modifying Printer Settings” on page 122
• “Canceling Print Jobs” on page 122
• “Deleting a Printer” on page 122

8.1  Installing a Printer
Before you can install a printer, you need to know the root password and have your printer 
information ready. Depending on how you connect to the printer, you might also need the printer 
URI, TCP/IP address or host, and the driver for the printer. A number of common printer drivers 
ship with SLED. If you cannot find a driver for the printer, check the printer manufacturer's Web 
site.

8.1.1  Installing a Network Printer
1 Click Computer > Control Center > Add Printer > New Printer.
2 Enter the root password.
3 Click Network Printer, then select the type of connection for this printer.

CUPS Printer (IPP): A printer attached to a different Linux system on the same network 
running CUPS or a printer configured on another operating system to use IPP.
Windows Printer (SMB): A printer attached to a different system which is sharing a printer 
over a SMB network (for example, a printer attached to a Microsoft Windows machine). 
UNIX Printer (LPD): A printer attached to a different UNIX system that can be accessed over 
a TCP/IP network (for example, a printer attached to another Linux system on your network).
HP JetDirect: A printer connected directly to the network instead of to a computer. 

4 Specify the printer's information, then click Forward.
5 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's Web site to 
download the latest driver. 

6 Specify desired options (such as a description or location) for the printer in the Properties 
dialog box, then click Close.

The installed printer appears in the Printers panel. You can now print to the printer from any 
application.

8.1.2  Installing a Local Printer
1 Connect the printer cable to your computer and connect the printer's power supply.
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The printer dialog should open. If it doesn’t, click Computer > Control Center > Add Printer > 
New Printer to open it.

2 Enter the root password.
3 Click Local Printer.
4 If the printer was autodetected, select the printer from the list. If the printer was not 

autodetected, click Use another printer by specifying a port and then select the correct printer 
port.

5 Click Forward.
6 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's Web site to 
download the latest driver. 

7 Specify desired options (such as a description or location) for the printer in the Properties 
dialog box, then click Close.

The installed printer appears in the Printers dialog box. You can now print to the printer from any 
application.

8.2  Modifying Printer Settings
1 Click Computer > Control Center > Printers.
2 Right-click the printer you want to modify, then click Properties.
3 Modify the properties, then click Close.

8.3  Canceling Print Jobs
1 Click Computer > Control Center > Printer.
2 Double-click the printer you sent the job to. 
3 Right-click the print job, then click Cancel.

If the print job does not appear in the list, then the print job might have been printed already.

8.4  Deleting a Printer
1 Click Computer > Control Center > Printer.
2 Click Edit > Become Administrator.
3 Type the root password, then click Continue.
4 Right-click the printer you want to delete, then click Remove.
 Enterprise Desktop 10 GNOME User Guide
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9Browsing with Firefox

Included with your SUSE® Linux Enterprise Desktop is the Mozilla Firefox Web browser. With 
features like tabs, pop-up window blocking, and download and image management, Firefox 
combines the latest Web technologies. You can view more than one Web page in a single window. 
You can suppress annoying advertisements and disable images that only slow you down. Its easy 
access to different search engines helps you find the information you need. Start the program from 
the main menu or by entering the command firefox. The main program features are described in 
the following sections.  

9.1  Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 9-1 on page 125. 
The navigation toolbar includes Forward and Back and a location bar for a Web address. 
Bookmarks are also available for quick access. For more information about the various Firefox 
features, use the Help menu. 

Figure 9-1   The Browser Window of Firefox
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9.1.1  Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing may make it easier to switch 
between them. Load Web sites in separate tabs within one window. 

To open a new tab, select File > New Tab. This opens an empty tab in the Firefox window. 
Alternatively, right-click a link and select Open link in new tab. Right-click the tab itself to access 
more tab options. You can create a new tab, reload one or all existing tabs, or close them. You can 
also change the sequence of the tabs by dragging and dropping them on a requested position. 

9.1.2  Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing history. 
Extensions may add new ways to use the sidebar as well. To display the Sidebar, select View > 
Sidebar and select the desired contents. 

9.2  Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The search bar 
looks for pages while the find bar looks for things on the current page. 

9.2.1  Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or Amazon. For 
example, if you want to find information about SUSE using the current engine, click in the search 
bar, type SUSE, and hit Enter. The results appear in your window. To choose your search engine, 
click the icon in the search bar. A menu opens with a list of available search engines. 

9.2.2  Installing a Different Search Engine
If you favorite search engine is not listed, Firefox gives you the possibility to configure it. Try the 
following steps:

1 Establish an Internet connection first.
2 Click in the search bar on the icon.
3 Select Add Engines from the menu.
4 Firefox displays a Web page with available search engines. It is also sorted by categories. You 

can choose from Wikipdedia, Leo, and others. Click the desired search plug-in.
5 Install your search plug-in with Ok or abort with Cancel.

9.2.3  Searching in the Current Page
To search inside a Web page, click Edit > Find in This Page or press CtrlF. The find bar opens. 
Usually, it is displayed at the bottom of a window. Type your query in the input field. Firefox finds 
the first occurence of this phrase. You can find other occurences of the phrase by pressing F3 or 
Find Next button in the find bar. You can also highlight all occurences by pressing the Highlight all 
button. 
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9.3  Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. To add the current 
Web site to your list of bookmarks, click Bookmarks > Bookmark This Page. If your browser 
currently displays multiple Web sites on tabs, only the URL on the currently selected tab is added to 
your list of bookmarks. 

When adding a bookmark, you can specify an alternative name for the bookmark and select a folder 
where Firefox should store it. To bookmark Web sites on multiple tabs, select Bookmark All Tabs. 
Firefox creates a new folder that includes bookmarks of each site displayed on each tab. To remove 
a Web site from the bookmarks list, click Bookmarks, right-click the bookmark in the list, then click 
Delete. 

9.3.1  Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address location) for each 
bookmark and organize the bookmarks into folders and sections. It resembles Figure 9-2 on 
page 127. 

Figure 9-2   Using the Firefox Bookmark Manager

To open the bookmark manager, click Bookmark > Manage Bookmarks. A window opens and 
displays your bookmarks. With New Folder, create a new folder with a name and a description. If 
you need a new bookmark, click New Bookmark. This lets you insert the name, location, keywords, 
and also a description. The keyword is a shortcut to your bookmark. If you need your newly created 
bookmark in the sidebar, check Load this bookmark in the sidebar. 
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9.3.2  Importing Bookmarks from Other Browsers
If you used a different browser in the past, you probably want to use your preferences and 
bookmarks in Firefox, too. At the moment, you can import from Netscape 4.x, 6, 7, Mozilla 1.x, and 
Opera. 

To import your settings, click File > Import. Select the browser from which to import settings. After 
you click Next, your settings are imported. Find your imported bookmarks in a newly created folder, 
beginning with From.

9.3.3  Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date with the latest 
news. This enables you to save time with one glance at your favorite sites.

Many sites and blogs support this format. A Web site indicates this by showing an orange icon in the 
right part of the location bar. Click it and choose Add NAME OF THE FEED as Live Bookmark. A 
dialog box opens where you can select the name and location of your live bookmark. Confirm with 
Add. 

Some sites do not tell Firefox that they support a news feed, although they actually do. To add a live 
bookmark manually, you need the URL of the feed. Do the following:

Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks > Manage Bookmarks. A new window opens.
2 Select File > New Live Bookmark. A dialog box opens.
3 Insert a name for the live bookmark and add your URL, for example, http://
www.novell.com/newsfeeds/rss/coolsolutions.xml. Firefox updates your 
live bookmarks.

4 Close your bookmark manager.

9.4  Using the Download Manager
With the help of the download manager, keep track of your current and past downloads. To open the 
download manager, click Tools > Downloads. Firefox opens a window with your downloads. While 
downloading a file, see a progress bar and the current file. If necessary, pause a download and 
resume it later. To open a downloaded file, click Open. With Remove, remove it from the list. If you 
need information about the file, right-click the filename and choose Properties. 

If you need further control of the download manager, open the configuration window from Edit > 
Preferences and go to the Downloads tab. Here, determine the download folder, how the manager 
behaves, and some configuration of file types. 

9.5  Customizing Firefox
Firefox can be customized extensively. You can install extensions, change themes, and add smart 
keywords for your online searches. 
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9.5.1  Extensions
Mozilla Firefox is a multifunctional application, which means that you can download and install 
add-ons, known as extensions. For example, add a new download manager and mouse gestures. This 
has the advantage that Firefox itself stays small and unbloated. 

To add an extension, click Tools > Extensions. In the bottom-right corner, click Get More 
Extensions to open the Mozilla extensions update Web page where you can choose from a variety of 
available extensions. Click the extension to install then click the install link to download and install 
it. When you restart Firefox, the new extension is functional. You can also look at the various 
extensions at addons.mozilla.org (http://addons.mozilla.org/). 

Figure 9-3   Installing Firefox Extensions

9.5.2  Changing Themes
If you do not like the standard look and feel of Firefox, install a new theme. Themes do not change 
the functionality, only the appearance of the browser. When installing a theme, Firefox asks for 
confirmation first. Allow the installation or cancel it. After a successful installation, you can enable 
the new theme. 

1 Click Tools > Themes. 
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2 In the new dialog that appears, click Get More Themes. If you already installed a theme, find it 
in the list, as in Figure 9-4 on page 130.

Figure 9-4   Installing Firefox Themes

3 A new window appears with the Web site addons.mozilla.org (https://addons.mozilla.org). 
4 Choose a theme and click Install Now.
5 Confirm the download and installation.
6 After downloading the theme, a dialog appears and informs you about your list of themes. 

Activate the new theme with Use Theme.
7 Close the window and restart Firefox.

If a theme is installed, you can always switch to a different theme without restarting by clicking 
Tools > Themes then Use Theme. If you do not use a theme anymore, you can delete it in the same 
dialog with Uninstall.

9.5.3  Adding Smart Keywords to Your Online Searches
Searching the Internet is one of the main tasks a browser can perform for you. Firefox lets you 
define your own smart keywords: abbreviations to use as a “command” for searching the Web. For 
example, if you use Wikipedia often, use a smart keyword to simplify this task: 

1 Go to Wikipedia (http://en.wikipedia.org).
2 After Firefox displays the Web page, see the search text field. Right-click it then choose Add a 

Keyword for this Search from the menu that opens.
3 The Add Bookmark dialog appears. In Name, name this Web page, for example, Wikipedia (en).
4 For Keyword, enter your abbreviation of this Web page, for example, wiki.
5 With Create in, choose the location of the entry in your bookmarks section. You can put it into 

Quick Searches, but any other level is also appropriate.
6 Finalize with Add.

You have successfully generated a new keyword. Whenever you need to look into Wikipedia, you 
do not have to use the entire URL. Just type wiki Linux to view an entry about Linux.
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9.6  Printing from Firefox
Configure the way Firefox prints the content it displays using the Page Setup dialog. Click File > 
Page Setup then go to the Format & Options tab to select the orientation of your print jobs. You can 
scale or make it adjust automatically. To print a background, select Print Background (colors & 
images). Click the Margins & Header/Footer tab to adjust margins and select what to include in the 
headers and footers. 

After you configured your settings, print a Web page with File > Print. Select the printer or a file in 
which to save the output. With Properties, set the paper size, specify the print command, choose 
grayscale or color, and determine the margins. When satisfied with your settings, approve with 
Print.

9.7  For More Information
Get more information about Firefox from the official home page at http://www.mozilla.com/firefox/ 
(http://www.mozilla.com/firefox/). Refer to the integrated help to find out more about certain 
options or features. 
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10Manipulating Graphics with The 
GIMP

The GIMP (The GNU Image Manipulation Program) is a program for creating and editing pixel 
graphics. In most aspects, its features are comparable to those of Adobe Photoshop and other 
commercial programs. Use it to resize and retouch photographs, design graphics for Web pages, 
make covers for your custom CDs, or almost any other graphics project. It meets the needs of both 
amateurs and professionals. 

Like many other Linux programs, The GIMP is developed as a cooperative effort of developers 
worldwide who volunteer their time and code to the project. The program is under constant 
development, so the version included in your system may vary slightly from the version discussed 
here. The layout of the individual windows and window sections is especially likely to vary. 

The GIMP is an extremely complex program. Only a small range of features, tools, and menu items 
are discussed in this chapter. See “For More Information” on page 139 for ideas of where to find 
more information about the program. 

10.1  Graphics Formats
There are two main formats for graphics—pixel and vector. The GIMP works only with pixel 
graphics, which is the normal format for photographs and scanned images. Pixel graphics consist of 
small blocks of color that together create the entire image. The files can easily become quite large 
because of this. It is also not possible to increase the size of a pixel image without losing quality. 

Unlike pixel graphics, vector graphics do not store information for all individual pixels. Instead, 
they store information about how image points, lines, or areas are grouped together. Vector images 
can also be scaled very easily. The drawing application of OpenOffice.org, for example, uses this 
format. 

10.2  Starting GIMP
Start GIMP from the main menu. Alternatively, enter gimp & in a command line. 

10.2.1  Initial Configuration
When starting GIMP for the first time, a configuration wizard opens for preparatory configuration. 
The default settings are acceptable for most purposes. Press Continue in each dialog unless you are 
familiar with the settings and prefer another setup. 

10.2.2  The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the toolbox, 
closed if no longer needed. Closing the toolbox closes the application. In the default configuration, 
GIMP saves your window layout when you exit. Dialogs left open reappear when you next start the 
program. 
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The Toolbox

The main window of GIMP, shown in “The Main Window” on page 136, contains the main controls 
of the application. Closing it exits the application. At the very top, the menu bar offers access to file 
functions, extensions, and help. Below that, find icons for the various tools. Hover the mouse over 
an icon to display information about it. 

Figure 10-1   The Main Window

The current foreground and background color are shown in two overlapping boxes. The default 
colors are black for the foreground and white for the background. Click the box to open a color 
selection dialog. Swap the foreground and background color with the bent arrow symbol to the 
upper right of the boxes. Use the black and white symbol to the lower left to reset the colors to the 
default. 

To the right, the current brush, pattern, and gradient are shown. Click the displayed one to access the 
selection dialog. The lower portion of the window allows configuration of various options for the 
current tool. 

Layers, Channels, Paths, Undo

In the first section, use the drop-down box to select the image to which the tabs refer. By clicking 
Auto, control whether the active image is chosen automatically. By default, Auto is enabled. 

Layers shows the different layers in the current images and can be used to manipulate the layers. 
Channels shows and can manipulate the color channels of the image. 

Paths are a vector-based method of selecting parts of an image. They can also be used for drawing. 
Paths shows the paths available for an image and provides access to path functions. Undo shows a 
limited history of modifications made to the current image. 

10.3  Getting Started in GIMP
Although GIMP can be a bit overwhelming for new users, most quickly find it easy to use once they 
work out a few basics. Crucial basic functions are creating, opening, and saving images. 

10.3.1  Creating a New Image
To create a new image, select File > New or press Ctrl+N. This opens a dialog in which to make 
settings for the new image. If desired, select a predefined setting called a Template. To create a 
custom template, select File > Dialogs > Templates and use the controls offered by the window that 
opens. 

In the Image Size section, set the size of the image to create in pixels or another unit. Click the unit 
to select another unit from the list of available units. The ratio between pixels and a unit is set in 
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Resolution, which appears when the Advanced Options section is open. A resolution of 72 pixels per 
inch corresponds to screen display. It is sufficient for Web page graphics. A higher resolution should 
be used for images to print. For most printers, a resolution of 300 pixels per inch results in an 
acceptable quality. 

In Colorspace, select whether the image should be in color (RGB) or Grayscale. Select the Fill Type 
for the new image. Foreground Color and Background Color use the colors selected in the toolbox. 
White uses a white background in the image. Transparent creates a clear image. Transparency is 
represented by a gray checkerboard pattern. Enter a comment for the new image in Comment. 

When the settings meet your needs, press OK. To restore the default settings, click Reset. Clicking 
Cancel aborts creation of a new image. 

10.3.2  Opening an Existing Image
To open an existing image, select File > Open or press Ctrl+O. In the dialog that opens, select the 
desired file. You can also press CtrlL and type directly the URI of the desired image. Then click OK 
to open the selected image or press Cancel to skip opening an image. 

10.3.3  Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan directly from 
the GIMP, make sure that the package xsane is installed. To open the scanning dialog, select File 
> Acquire > XSane: scanning device. 

Create a preview when the object to scan is smaller than the total scanning area. Press Acquire 
preview in the Preview dialog to create a preview. If you want to scan only part of the area, select the 
desired rectangular part with the mouse. 

In the xsane dialog, select whether to scan a grayscale or color image and the required scan 
resolution. The higher the resolution, the better the quality of the scanned image is. However, this 
also results in a correspondingly larger file and the scanning process can take a very long time at 
higher resolutions. The size of the final image (both in pixels and bytes) is shown in the lower part 
of the dialog. 

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values. Changes 
are visible in the preview immediately. Once all settings have been made, click Scan to scan the 
image. 

10.3.4  The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the top of the 
window provides access to all image functions. Alternatively, access the menu by right-clicking the 
image or clicking the small arrow button in the left corner of the rulers. 

File offers the standard file options, such as Save and Print. Close closes the current image. Quit 
closes the entire application. 

 With the items in the View menu, control the display of the image and the image window. New View 
opens a second display window of the current image. Changes made in one view are reflected in all 
other views of that image. Alternate views are useful for magnifying a part of an image for 
manipulation while seeing the complete image in another view. Adjust the magnification level of the 
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current window with Zoom. When Shrink Wrap is selected, the image window is resized to fit the 
current image display exactly. 

10.4  Saving Images
No image function is as important as File > Save. It is better to save too often than too rarely. Use 
File > Save as to save the image with a new filename. It is a good idea to save image stages under 
different names or make backups in another directory so you can easily restore a previous state. 

When saving for the first time or using Save as, a dialog opens in which to specify the filename and 
type. Enter the filename in the field at the top. For Save in folder, select the directory in which to 
save the file from a list of commonly used directories. To use a different directory or create a new 
one, open Browse for other folders. It is recommended to leave Select File Type set to By Extension. 
With that setting, GIMP determines the file type based on the extension appended to the filename. 
The following file types are frequently useful: 

XCF 
This is the native format of the application. It saves all layer and path information along with 
the image itself. Even if you need an image in another format, it is usually a good idea to save a 
copy as XCF to simplify future modifications. 

PAT 
This is the format used for GIMP patterns. Saving an image in this format enables using the 
image as a fill pattern in GIMP. 

JPG 
JPG or JPEG is a common format for photographs and Web page graphics without 
transparency. Its compression method enables reduction of file sizes, but information is lost 
when compressing. It may be a good idea to use the preview option when adjusting the 
compression level. Levels of 85% to 75% often result in an acceptable image quality with 
reasonable compression. Saving a backup in a lossless format, like XCF, is also recommended. 
If editing an image, save only the finished image as JPG. Repeatedly loading a JPG then saving 
can quickly result in poor image quality. 

GIF 
Although very popular in the past for graphics with transparency, GIF is less often used now 
because of license issues. GIF is also used for animated images. The format can only save 
indexed images. The file size can often be quite small if only a few colors are used. 

PNG 
With its support for transparency, lossless compression, free availability, and increasing 
browser support, PNG is replacing GIF as the preferred format for Web graphics with 
transparency. An added advantage is that PNG offers partial transparency, which is not offered 
by GIF. This enables smoother transitions from colored areas to transparent areas 
(antialiasing). 

To save the image in the chosen format, press Save. To abort, press Cancel. If the image has features 
that cannot be saved in the chosen format, a dialog appears with choices for resolving the situation. 
Choosing Export, if offered, normally gives the desired results. A window then opens with the 
options of the format. Reasonable default values are provided. 
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10.5  Printing Images
To print an image, select File > Print from the image menu. If your printer is configured in the 
system, it should appear in the list. In some cases, it may be necessary to select an appropriate driver 
with Setup Printer. Select the appropriate paper size with Media Size and the type in Media Type. 
Other settings are available in the Image / Output Settings tab. 

Figure 10-2   The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image Size to take 
these settings from the image itself. This is recommended if you set an appropriate print size and 
resolution in the image. Adjust the image's position on the page with the fields in Position or by 
dragging the image in Preview. 

When satisfied with the settings, press Print. To save the settings for future use, instead use Print 
and Save Settings. Cancel aborts printing. 

10.6  For More Information
The following resources are useful for a GIMP user, even if some of them apply to older versions. 

• Help provides access to the internal help system. This documentation is also available in 
HTML and PDF formats at gimp.org (http://docs.gimp.org). 

• The GIMP User Group offers an informative Web site at sunsite.dk (http://gug.sunsite.dk). 
• gimp.org (http://www.gimp.org) is the official home page of The GIMP. 
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• Grokking the GIMP by Carey Bunks is an excellent book based on an older GIMP version. 
Although some aspects of the program have changed, it can provide excellent guidance for 
image manipulation. An online version is available at gimp-savvy.com (http://gimp-
savvy.com/BOOK/). 
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11Using Digital Cameras with Linux

f-spot is a management tool for your collection of digital images tailored for the GNOME desktop. It 
allows you to assign different tags to your images in order to categorize them and offers various neat 
image editing options.

The first time you run f-spot, tell it where to find the images to import to your f-spot collection. If 
you already have a collection of images stored on your hard drive, enter the path to the respective 
directory and optionally include subfolders. f-spot imports these images into its database.

TIP: If all the images you are importing belong to the same category, you can attach the appropriate 
tag on import. Select Attach Tag and choose the matching tag from the drop down menu.

Figure 11-1   Importing Images to f-spot

f-spot's main window is divided into three main areas. Categories, tags, and detailed information for 
the selected images are displayed in a sidebar to the left and a thumbnails of all images bearing the 
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selected tag or category or, if none is selected, the entire collection is displayed in the right part of 
the window. 

Figure 11-2   f-spot Main Window

A menu bar right at the top of the window allows you to access the main menus. A toolbar below 
offers several different functions depicted by a matching icon:

Table 11-1   f-spot Toolbar

Icon Description

Rotate (Left or Right) Use this shortcut to change an image's orientation.

Browse The Browse mode allows you to view and search you entire collection 
or tagged subsets of it. You can also use the time line to search images 
by creation date.

Edit Image This mode allows you to select one image and do some basic image 
processing. Details are available in Section 11.6, “Basic Image 
Processing with f-spot,” on page 146.

Fullscreen Switch to fullscreen display mode.

Slideshow Start a slide show.
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11.1  Downloading Pictures from Your Camera
Import new images from your digital camera connected to the USB port of your computer using File 
> Import from Camera. The type of camera is detected automatically.

Figure 11-3   Import from Camera

f-spot launches a preview window displaying all the images that are available for download from 
camera. The files are copied to the target directory specified via Copy Files to. If Import files after 
copy is selected, all images copied from camera are automatically imported to f-spot's database. 
Tagging can be done on import, if you select the appropriate tag with Select Tags. If you do not want 
to import all images on your camera to your database, just deselect the unwanted one in the preview 
window.

11.2  Getting Information
Once you select an image, some basic statistical information on this image is displayed in the lower 
left part of the window. This includes the filename, its version (copy or original image), the date of 
creation, its size and the exposure which was used in creating this particular image. View the EXIF 
data associated with the image file with View > EXIF Data.
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11.3  Managing Tags
Use tags to categorize any of your images to create manageable subsets of your collection. If, for 
example, you would like to get some sort of order in your collection of portrait shots of your loved 
ones, proceed like this:

1 Select the Browse mode of f-spot.
2 In the left frame of the f-spot window, select the People category, right-click it, then choose 

Create New Tag. The new tags then appear as subcategories below the People category:
2a Create a new tag called Friends.
2b Create a new tag called Family.

3 Now attach tags to images or groups of selected images. Right-click an image, choose Attach 
Tag, and select the appropriate tag for this image. To attach a tag to a group of images, click the 
first one then press Shift and select the other ones without releasing the Shift key. Right-click 
for the tag menu and select the matching category.

After the images have been categorized, you can browse your collection by tag. Just check People > 
Family and the displayed collection is limited to the images tagged Family. Searching your 
collection by tag is also possible through Find > Find by Tag. The result of your search is displayed 
in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching them. The tag 
editing functions are also accessible via the Tags menu in the top menu bar.

11.4  Search and Find
As mentioned in Section 11.3, “Managing Tags,” on page 144, tags can be used as a means to find 
certain images. Another way, which is quite unique to f-spot, is to use the Timeline below the 
toolbar. By dragging the little frame along this time line, limit the images displayed in the thumbnail 
overview to those taken in the selected time frame. f-spot starts with a sensibly chosen default time 
line, but you can always edit the time span by moving the sliders to the right and left ends of the time 
line.

11.5  Exporting Image Collections
f-spot offers a range of different export functions for your collections under File > Export. Probably 
the most often used of these are Export to Web Gallery and Export to CD.

To export a selection of images to a web gallery, proceed as follows:

1 Select the images to export.
2 Click File > Export > Export to Web Gallery and select a gallery to which to export your 

images or add a new one. f-spot establishes a connection to the Web location entered for your 
web gallery. Select the album to which to export the images and decide whether to scale the 
images automatically and export titles and comments.
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Figure 11-4   Exporting Images to a Web Gallery

To export a selection of images to CD, proceed as follows:

1 Select the images to export.
2 Click File > Export > Export to CD and click OK.

f-spot copies the files and opens the CD writing dialog. Assign a name to your image disk and 
determine the writing speed. Click Write to start the CD writing process.

Figure 11-5   Exporting Images to a CD
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11.6  Basic Image Processing with f-spot
f-spot offers several very basic image editing functionalities. Enter the edit mode of f-spot by 
clicking the Edit Image icon in the toolbar or by double-clicking the image to edit. Switch images 
using the arrow keys at the bottom right. Choose from the following edit functions:

Table 11-2   f-spot Edit Functions

TIP: Professional image editing can be done with the GIMP. More information about The GIMP 
can be found in Chapter 10, “Manipulating Graphics with The GIMP,” on page 135.

Function Description

Sharpen Access this function with Edit > Sharpen. Adjust the 
values for Amount, Radius, and Threshold to your 
needs and click OK.

Crop Image To crop the image to a selection you made, either 
choose a fixed ratio crop or the No Constraint 
option from the drop-down menu at the bottom left, 
select the region to crop, and click the scissor icon 
next to the ratio menu.

Red Eye Reduction In a portrait shot, select the eye region of the face 
and click the red eye icon.

Adjust Color View the histogram used in the creation of the shot 
and correct exposure and color temperature if 
necessary.
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12Playing and Managing Your Music 
with Helix Banshee

Helix* Banshee is a GNOME music management and playback application that lets you import 
CDs, sync your music collection to an iPod, play music directly from an iPod, create playlists with 
songs from your library, and create audio and MP3 CDs from subsets of your library.

To access Helix Banshee, click Computer > Helix Banshee Music Player.

The first time you open Helix Banshee, you are prompted to import music. Click Automatic Import 
to search for music in your home directory and add it to the library. Click Import Folder to tell Helix 
Banshee where to look for music.

Figure 12-1   Import Music Library

After successfully importing your music, your library is displayed.

Figure 12-2   Helix Banshee Library
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12.1  Managing Your Library
You can use the library to do a variety of things, including playing, organizing, and importing 
music. You can also view a variety of information about your music collection, including playback 
statistics (when a song was last played and how many times). 

12.1.1  Playing Your Music
To play a song, simply select the song in the library and click the Play button ( ). 

Use the buttons on the upper left corner ( ) to pause a song or play the next or previous 
song. Use  to adjust the volume. You can also use the items on the Playback menu to repeat or 
shuffle songs.

Helix Banshee also has an integrated CD player. When you insert a music CD, your CD title appears 
in the left panel. Select the title and click the Play button to play your full CD.

12.1.2  Organizing Your Music
To create a new playlist, click Music > New Playlist (or press Ctrl+N). A new playlist is displayed in 
the left panel. Double-click New Playlist and enter the name you want. You can drag and drop songs 
from one playlist to another, or use the options on the Edit menu to remove or delete songs and 
rename or delete playlists.

You can edit the name of the artist, album, and title, as well as the track number and track count. 
Simply select a song, then click Edit > Edit Song Metadata. If you want to set all fields in a set to 
the same value, select multiple songs in a playlist, then click Edit > Edit Song Metadata.

Figure 12-3   Editing Song Dialog Box

12.1.3  Importing Music
Helix Banshee can import music from a file, folder, or CD. Click Music > Import Music, choose an 
import source, then click Import Music Source.

To rip music from a CD to your music collection, click the Rip button near the top right. 
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12.2  Using Helix Banshee with Your iPod
To play music from your iPod, simply plug your iPod into you system. Your iPod appears in the left 
panel. Select the song you want to hear, then click the Play button.

Figure 12-4   iPod List in Helix Banshee

When the iPod is selected in the left panel, information about your iPod is displayed at the bottom 
left, including disk usage and Sync, Properties, and Eject buttons.

Figure 12-5   iPod Buttons in Helix Banshee

There are three ways to manage the music on your iPod:

• Manually: Browse your iPod and drag music between your library and the iPod.
• Automatically sync: Automatically copies everything in your library to the iPod.
• Automatic merge: All the music on your iPod that is not in your library is downloaded to your 

library, and all the music that is in your library and not in your iPod is uploaded to your iPod.
Playing and Managing Your Music with Helix Banshee 149



150 SUSE Linux

novdocx (E
N

U
)  01 February 2006
Use the iPod Properties dialog to rename and reclaim your iPod, and view vital statistics.

Figure 12-6   Helix Banshee iPod Properties

12.3  Creating Audio and MP3 CDs
To create audio and MP3 CDs, select the songs you want, then click the Write CD button in the 
upper right side of Helix Banshee.

12.4  Configuring Preferences
You can configure Helix Banshee preferences by clicking Edit > Preferences. The Preferences 
dialog contains the following tabs:

Library 
Lets you specify a music folder location. This location is used when you import music. Click 
Copy files to Helix Banshee Music Folder when importing to Library to place a copy of the 
files you import in your Helix Banshee music folder.

Encoding 
Lets you determine encoding profiles for CD ripping and iPod transcoding. 

Burning 
Lets you specify CD burning options. You can choose a disk drive, write speed, and disk 
format (Audio CD, MP3 CD, or Data CD). You can also configure advanced options, such as 
ejecting the CD when finished.

Advanced 
Lets you choose from either the Helix Remote or the GStreamer engine for audio playback in 
Helix Banshee. 
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13Burning CDs and DVDs

GNOME uses the Nautilus file manager to burn CDs and DVDs. To burn a CD or DVD:

1 Click Computer > More Applications > Audio & Video > GNOME CD/DVD Creator or insert 
a blank disc and click Create Data CD.

2 Copy the files you want to put on the CD into the Nautilus CD/DVD Creator window.
3 Click Write to Disc.
4 Modify information in the Write to Disc dialog or accept the defaults, then click Write.

The files are burned on the disc. This could take a few minutes, depending on the amount of 
data being burned and the speed of your burner.

You can use the Helix Banshee music player to burn audio and MP3 CDs, as explained in Section 
12.3, “Creating Audio and MP3 CDs,” on page 150.
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AGetting to Know Linux Software

Linux comes with a wealth of applications, often offering more than one solution to specific needs. 
The difficulty is finding the application that suits your needs best. The next few sections introduce 
some of the most powerful Linux counterparts of common Windows software. Each section is 
dedicated to one particular field of application and presents an overview of the Windows 
applications and Linux equivalents for several tasks. Below each table, find further information 
about the Linux applications with links to more information. This list is by no means complete, 
because software development is an evolutionary process and new applications are being created 
every minute.

TIP: Missing Applications

Not all applications mentioned below are installed on your system by default and some may not be 
shipped with your product. If the application you want to use is missing, ask your system 
administrator. If the application is provided by your product, you can install it with YaST. Use the 
search function of the YaST software management tool to find the package names.

A.1  Office
This section features the most popular and powerful Linux office and business software solutions. 
These include office suites, databases, accounting software, and project management software. 

Table A-1   Office Software for Windows and Linux

Task Windows 
Application

Linux 
Application

Office Suite MS Office, 
StarOffice, 
OpenOffice.org

OpenOffice.org, 
StarOffice, 
KOffice 

Word Processor MS Word, 
StarOffice/
OpenOffice.org 
Writer, 
WordPerfect

OpenOffice.org/
StarOffice 
Writer, KWord

Spreadsheet MS Excel, 
StarOffice/
OpenOffice.org 
Calc

OpenOffice.org/
StarOffice Calc, 
Gnumeric, 
KSpread

Presentation MS PowerPoint, 
StarOffice/
OpenOffice.org 
Impress

OpenOffice.org/
StarOffice 
Impress, 
KPresenter

Data Plotting MS Excel, 
MicroCall Origin

OpenOffice.org 
Calc, Kst, 
Gnuplot, Grace 
(Xmgr), LabPlot
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FreeMind  
FreeMind helps you to visualize your thoughts by creating and editing a mind map. You can 
easily copy nodes or the style of nodes and paste texts from sources such as HTML, RTF, and 
mails. The mind maps can be exported into various formats, such as HTML and XML. For 
more information, refer to http://freemind.sourceforge.net (http://freemind.sourceforge.net/
wiki/index.php/Main_Page).

GnuCash  
GnuCash is a software tool to control both your personal and business finances. Keep track of 
income and expenses and manage your bank accounts and stock portfolios all using one piece 
of software. Learn more about GnuCash at www.gnucash.org (http://www.gnucash.org). 

Gnumeric  
Gnumeric is a spreadsheet solution for the GNOME desktop environment. Find more 
information about Gnumeric at www.gnumeric.org (http://www.gnumeric.org).

Gnuplot  
Gnuplot is a very powerful and portable command line–controlled data plotting software. It is 
also available for MacOS and Windows platforms. Plots created by Gnuplot can be exported to 
various formats, such as PostScript, PDF, and SVG, allowing you to process these plots easily. 
Find more information about Gnuplot at www.gnuplot.info (http://www.gnuplot.info/
index.html). 

Grace  
Grace is a very mature 2D plotting tool for almost all flavors of Unix including Linux. Create 
and edit plots with a graphical user interface. Grace supports an unlimited number of graphs per 
plot. Its export formats include JPEG, PNG, SVG, PDF, PS, and EPS. Find more information at 
plasma-gate.weizmann.ac.il/Grace/ (http://plasma-gate.weizmann.ac.il/Grace/).

Kdissert  
Kdissert is an application for structuring ideas and concepts, mostly aimed at students but also 
helpful for teachers, decision makers, engineers, and businessmen. Ideas are first laid down on 
a canvas then associated into a tree. You can generate various outputs from the mind map, such 

Local Database MS Access, 
OpenOffice.org 
Base

OpenOffice.org 
Base, Rekall, 
kexi, Mergeant, 
PostgreSQL 

Financial 
Accounting

MS Money, 
Quicken, 
moneyplex

GnuCash, 
moneyplex, 
KMyMoney

Project 
Management

MS Project Planner, 
Taskjuggler

Mind Mapping MindManager, 
Free Mind

VYM (View Your 
Mind), Free 
Mind, KDissert

Task Windows 
Application

Linux 
Application
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as PDF files, text documents (also for OpenOffice.org Writer), and HTML files. Find more 
information at http://freehackers.org/~tnagy/kdissert/ (http://freehackers.org/~tnagy/kdissert/).

KMyMoney  
KMyMoney is a personal finance manager for KDE. It enables users of open source operating 
systems to keep track of their personal finances by providing a broad array of financial features 
and tools. Learn more about KMyMoney at kmymoney2.sourceforge.net (http://
kmymoney2.sourceforge.net).

KOffice  
KOffice is an integrated office suite for the KDE desktop. It comes with various modules like 
word processing (KWord), spreadsheets (KSpread), presentations (KPresenter), several image 
processing applications (Kivio, Karbon14, Krita), a database front-end (Kexi), and many more. 
Find more information about KOffice at www.koffice.org (http://www.koffice.org/).

Kst  
Kst is a KDE application for real-time data viewing and plotting with basic data analysis 
functionality. Kst contains many powerful built-in features, such as robust plotting of live 
streaming data, and is expandable with plug-ins and extensions. Find more about Kst at 
kst.ked.org (http://kst.kde.org/). 

LabPlot 
LabPlot is a program for creating and managing two or three-dimensional data plots. Graphs 
can be produced both from data and functions and one plot might include multiple graphs. It 
also offers various data analysis methods. Find more information about LabPlot at 
labplot.sourceforge.net (http://labplot.sourceforge.net/).

Mergeant  
Mergeant is a database front-end for the GNOME desktop. Find more information at 
www.gnome-db.org (http://www.gnome-db.org).

moneyplex  
moneyplex is a tool to control your finances. All tasks from managing incoming resources and 
expenses and monitoring your stock portfolio to online transactions via the HBCI standard are 
handled by moneyplex. Keep track of your financial transactions over time using various 
analysis options. Because this tool is also available for Windows, users can migrate very easily 
without having to learn a whole new application interface. Find more information about 
moneyplex at www.matrica.de (http://www.matrica.de). 

OpenOffice.org  
OpenOffice.org is the open source equivalent of MS Office. It is a very powerful office suite 
including a word processor (Write), a spreadsheet (Calc), a database manager (Base), a 
presentation manager (Impress), a drawing program (Draw), and a formula editor for 
generating mathematical equations and formulas (Math). Users familiar with the MS Office 
family of applications find a very similar application interface and all the functionality to which 
they are accustomed. Because OpenOffice.org is capable of importing data from MS Office 
applications, the transition from one office suite to the other is very smooth. A Windows 
version of OpenOffice.org even exists, enabling Windows users to switch to an open source 
alternative while still using Windows. Find more information about OpenOffice.org at 
www.openoffice.org (http://www.openoffice.org/) and read our OpenOffice.org chapter for a 
short introduction to the office suite.
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Planner  
Planner is a project management tool for the GNOME desktop aiming to provide functionality 
similar to the project management tools used under Windows. Among its various features are 
Gantt charting abilities and different kinds of views of tasks and resources. Find more 
information about Planner at www.imendio.com/projects/planner/ (http://www.imendio.com/
projects/planner/). 

PostgreSQL  
PostgreSQL is an object-relational database management system that supports an extended 
subset of the SQL standard, including transactions, foreign keys, subqueries, triggers, and user-
defined types and functions. Find more information about PostgreSQL at www.postgresql.org 
(http://www.postgresql.org/). 

Rekall  
Rekall is a tool for manipulating databases. Supported databases include MySQL, PostgreSQL, 
XBase with XBSQL, IBM DB2, and ODBC. Use Rekall to generate different sorts of reports 
and forms, design database queries, or import and export data to various formats. Find more 
information about Rekall at www.thekompany.com/products/rekall/ (http://
www.thekompany.com/products/rekall/). 

StarOffice  
StarOffice is a proprietary version of OpenOffice.org and is distributed by Sun Microsystems. 
It is available on multiple platforms including Windows and Solaris. It includes certain 
advanced features not available with the free version (OpenOffice.org). Find more information 
about StarOffice at www.sun.com/software/star/staroffice/  (http://www.sun.com/software/star/
staroffice/). 

Taskjuggler  
Taskjuggler is a lean, but very powerful project management software. Take control of your 
projects using the Gantt charting features or by generating all kinds of reports (in XML, 
HTML, or CSV format). Those users who are not comfortable with controlling applications 
from the command line can use a graphical front-end to Taskjuggler. Find more information 
about Taskjuggler at www.taskjuggler.org (http://www.taskjuggler.org). 

VYM (View Your Mind)  
VYM is a software for visualizing your thoughts by creating and manipulating mind maps. 
Most manipulations do not require more than one mouse click. Branches can be inserted, 
deleted, and reordered very easily. VYM also offers a set of flags allowing you to mark certain 
parts of the map (important, time critical, etc.). Links, notes, and images can be added to a mind 
map as well. VYM mind maps use an XML format, allowing you to export your mind maps to 
HTML easily. Find more information about VYM at www.insilmaril.de/vym (http://
www.insilmaril.de/vym).

A.2  Network
The following section features various Linux applications for networking purposes. Get to know the 
most popular Linux browsers and e-mail and chat clients. 
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Table A-2   Network Software for Windows and Linux

Epiphany  
Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of its features 
and extensions resemble Firefox. Find more information about Epiphany at www.gnome.org/
projects/epiphany (http://www.gnome.org/projects/epiphany/).

Evolution    
Evolution is personal information management software for the GNOME desktop combining 
mail, calendar, and address book functionality. It offers advanced e-mail filter and search 
options, provides sync functionality for Palm devices, and allows you to run Evolution as an 
Exchange or GroupWise client to integrate better into heterogeneous environments. Find more 
information about Evolution at www.gnome.org/projects/evolution (http://www.gnome.org/
projects/evolution/). 

Firefox     
Firefox is the youngest member of the Mozilla browser family. It runs on various platforms, 
including Linux, MacOS, and Windows. Its main features include built-in customizable 
searches, pop-up blocking, RSS news feeds, password management, tabbed browsing, and 
some advanced security and privacy options. Firefox is very flexible, allowing you to 
customize almost anything you want (searches, toolbars, skins, buttons, etc.). Neat add-ons and 
extensions can be downloaded from the Firefox Web site (https://addons.update.mozilla.org/
?application=firefox)). Find more information about Firefox at www.mozilla.org/products/
firefox (http://www.mozilla.org/products/firefox/). You can also read our Firefox chapter. 

Gaim  
Gaim is a smart instant messenger program supporting multiple protocols, such as AIM and 
ICQ (Oscar protocol), MSN Messenger, Yahoo!, IRC, Jabber, SILC, and GroupWise 
Messenger. It is possible to log in to different accounts on different IM networks and chat on 

Task Windows 
Application

Linux 
Application

Web Browser Internet 
Explorer, 
Firefox, Opera

Konqueror, 
Firefox, Opera, 
Epiphany

E-Mail Client/
Personal 
Information 
Management

MS Outlook, 
Lotus Notes, 
Mozilla 
Thunderbird

Evolution, 
Kontact, Mozilla 
Thunderbird

Instant 
Messaging/IRC 
Clients

MSN, AIM, 
Yahoo 
Messenger, 
XChat, Gaim

Gaim, Kopete, 
Konversation, 
XChat

Conferencing 
(Video and 
Audio)

NetMeeting GnomeMeeting/
Ekiga

Voice over IP X-Lite Linphone, 
Skype

FTP Clients leechftp, wsftp gftp, kbear
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different channels simultaneously. Gaim also exists in a Windows version. Find more 
information about Gaim at gaim.sourceforge.net (http://gaim.sourceforge.net/about.php). 

gftp  
gftp is an FTP client using the GTK toolkit. Its features include simultaneous downloads, 
resume of interrupted file transfers, file transfer queues, download of entire directories, FTP 
proxy support, remote directory caching, passive and nonpassive file transfers, and drag and 
drop support. Find more information at gftp.seul.org (http://gftp.seul.org). 

GnomeMeeting/Ekiga   
GnomeMeeting (recently renamed Ekiga) is the open source equivalent of Microsoft's 
NetMeeting. It features LDAP and ILS support for address lookup and integrates with 
Evolution to share the address data stored there. GnomeMeeting/Ekiga supports PC-to-phone 
calls, allowing you to call another party with just your computer, sound card, and microphone 
without any additional hardware. Find more information about GnomeMeeting/Ekiga at 
www.ekiga.org (http://www.ekiga.org).

kbear  
KBear is a KDE FTP client with the ability to have concurrent connections to multiple hosts, 
three separate view modes, support for multiple protocols (like FTP and SFTP), a site manager 
plug-in, firewall support, logging capabilities, and much more. Find more information at 
sourceforge.net/projects/kbear (http://sourceforge.net/projects/kbear). 

Konqueror    
Konqueror is a multitalented application created by the KDE developers. It acts as file manager 
and document viewer, but is also a very powerful and highly customizable Web browser. It 
supports the current Web standards, such as CSS(2), Java applets, JavaScript and Netscape 
plug-ins (Flash and RealVideo), DOM, and SSL. It offers neat helpers like an integrated search 
bar and supports tabbed browsing. Bookmarks can be imported from various other Web 
browsers, like Internet Explorer, Mozilla, and Opera. Find more information about Konqueror 
at www.konqueror.org (http://www.konqueror.org/). You can also read our chapter about 
Konqueror as a Web browser in KDE User Guide. 

Kontact    
Kontact is the KDE personal information management suite. It includes e-mail, calendar, 
address book, and Palm sync functionalities. Like Evolution, it can act as an Exchange or 
GroupWise client. Kontact combines several stand-alone KDE applications (KMail, 
KAddressbook, KOrganizer, and KPilot) to form an entity providing all the PIM functionality 
you need. Find more information about Kontact at www.kontact.org (http://www.kontact.org/). 
You can also read our Kontact chapter in KDE User Guide. 

Konversation  
Konversation is an easy-to-use IRC client for KDE. Its features include support for SSL 
connections, strikeout, multichannel joins, away and unaway messages, ignore list 
functionality, Unicode, autoconnect to a server, optional time stamps in chat windows, and 
configurable background colors. Find more information about Konversation at 
konversation.kde.org (http://konversation.kde.org).

Kopete  
Kopete is a very intuitive and easy-to-use instant messenger tool supporting protocols 
including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, Gadu-Gadu, Lotus 
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Sametime, SMS messages, and Jabber. Find more information about Kopete at kopete.kde.org 
(http://kopete.kde.org/). 

Linphone  
Linphone is a smart and lean Voice over IP client using the SIP protocol to establish calls. Find 
more information at www.linphone.org (http://www.linphone.org). You can also read our 
Linphone chapter. 

Mozilla Thunderbird  
Thunderbird is an e-mail client application that comes as part of the Mozilla suite. It is also 
available for Microsoft Windows and MacOS, which facilitates the transition from one of these 
operating systems to Linux. Find more information about Mozilla Thunderbird at 
www.mozilla.org/products/thunderbird (http://www.mozilla.org/products/thunderbird/).

Opera   
Opera is a powerful Web browser with neat add-ons like an optional e-mail client and a chat 
module. Opera offers pop-up blocking, RSS feeds, built-in and customizable searches, a 
password manager, and tabbed browsing. The main functionalities are easily reached through 
their respective panels. Because this tool is also available for Windows, it allows a much easier 
transition to Linux for those who have been using it under Windows. Find more information 
about Opera at www.opera.com (http://www.opera.com/). 

Skype  
Skype is an application for several platforms (Linux, Windows, Mac Os X) that can be used for 
phone calls over the Internet with a good sound quality and with end-to-end encryption. When 
using Skype, configuring the firewall or router is not necessary. For more information, refer to 
www.skype.com (http://www.skype.com/products/). 

XChat  
XChat is an IRC client that runs on most Linux and UNIX platforms as well as under Windows 
and MacOS X. Find more information about XChat at www.xchat.org (http://www.xchat.org/). 

A.3  Multimedia
The following section introduces the most popular multimedia applications for Linux. Get to know 
media players, sound editing solutions, and video editing tools. 

Table A-3   Multimedia Software for Windows and Linux

Task Windows 
Application

Linux 
Application

Audio CD Player CD Player, 
Winamp, 
Windows Media 
Player

KsCD, Grip, 
Helix Banshee

CD Burner Nero, Roxio 
Easy CD 
Creator

K3b
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amaroK  
The amaroK media player handles various audio formats and plays the streaming audio 
broadcasts of radio stations on the Internet. The program handles all file types supported by the 
sound server acting as a back-end—currently aRts or GStreamer. Find more information about 
amaroK at amarok.kde.org (http://amarok.kde.org/). 

Audacity   
Audacity is a powerful, free sound editing tool. Record, edit, and play any Ogg Vorbis or WAV 
file. Mix tracks, apply effects to them, and export the results to WAV or Ogg Vorbis. Find 
more information about Audacity at audacity.sourceforge.net (http://audacity.sourceforge.net/). 

Grip  
Grip provides CD player functionalities for the GNOME desktop. It supports CDDB lookups 
for track and album data. Find more information at www.nostatic.org/grip/ (http://
www.nostatic.org/grip/).

Helix Banshee  
Helix Banshee is a music management and playback application for the GNOME desktop. 
With Helix Banshee, import CDs, sync your music collection to an iPod, play music directly 

CD Ripper WMPlayer kaudiocreator, 
Sound Juicer, 
Helix Banshee 

Audio Player Winamp, 
Windows Media 
Player, iTunes

amaroK, XMMS, 
Rhythmbox, 
Helix Banshee 

Video Player Winamp, 
Windows Media 
Player

Kaffeine, 
MPlayer, Xine, 
XMMS, Totem, 
RealPlayer

Audio Editor SoundForge, 
Cooledit, 
Audacity

Audacity

Sound Mixer sndvol32 alsamixer, Kmix

Music Notation Finale, 
SmartScore, 
Sibelius

LilyPond, MusE, 
Noteedit, 
Rosegarden

Video Creator 
and Editor

Windows Movie 
Maker, Adobe 
Premiere, Media 
Studio Pro, 
MainActor 

MainActor, Kino

TV Viewer AVerTV, 
PowerVCR 3.0, 
CinePlayer DVR

xawtv (analog), 
motv (analog), 
xawtv4, tvtime, 
kdetv, zapping, 
Kaffeine

Task Windows 
Application

Linux 
Application
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from an iPod, create playlists with songs from your library, and create audio and MP3 CDs 
from subsets of your library. For more information, refer to GNOME User Guide.

Kaffeine  
Kaffeine is a versatile multimedia application supporting a wide range of audio and video 
formats including Ogg Vorbis, WMV, MOV, and AVI. Import and edit play lists of various 
types, create screen shots, and save media streams to your local hard disk. Find more 
information about Kaffeine at kaffeine.sourceforge.net (http://kaffeine.sourceforge.net/). 

KAudiocreator  
KAudioCreator is a lean CD ripper application. If configured accordingly, KAudioCreator also 
generates playlist files for your selection that can be used by players like amaroK, XMMS, or 
Helix Banshee. Read more about using KAudioCreator in KDE User Guide or go to 
www.icefox.net/programs/?program=KAudioCreator (http://www.icefox.net/programs/
?program=KAudioCreator).

kdetv  
A TV viewer and recorder application for the KDE desktop supporting analog TV. Find more 
information about kdetv at www.kdetv.org (http://www.kdetv.org/). 

KsCD  
KsCD is a neat little CD player application for the KDE desktop. Its user interface very much 
resembles that of a normal hardware CD player, guaranteeing ease of use. KsCD supports 
CDDB, enabling you to get any track and album information from the Internet or your local file 
system. Find more information at docs.kde.org/en/3.3/kdemultimedia/kscd (http://
docs.kde.org/en/3.3/kdemultimedia/kscd/).

K3b   
K3b is a multitalented media creation tool. Create data, audio, or video CD and DVD projects 
by dragging and dropping. Find more information about K3b at www.k3b.org (http://
www.k3b.org/). You can also refer to our K3b chapter. 

LilyPond  
LilyPond is a free music sheet editor. Because the input format is text-based, you can use any 
text editor to create note sheets. Users do not need to tackle any formatting or notation issues, 
like spacing, line-breaking, or polyphonic collisions. All these issues are automatically 
resolved by LilyPond. It supports many special notations like chord names and tablatures. The 
output can be exported to PNG, TeX, PDF, PostScript, and MIDI. Find more information about 
LilyPond at lilpond.org (http://lilypond.org/web/). 

MainActor  
MainActor is a fully fledged video authoring software. Because there is a Windows version of 
MainActor, transition from Windows is easy. Find more information about MainActor at 
www.mainactor.com (http://www.mainactor.com/). 

MPlayer  
MPlayer is a movie player that runs on several systems. Find more information about MPlayer 
at www.mplayerhq.hu (http://www.mplayerhq.hu/homepage/design7/info.html). 

MusE  
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MusE's goal is to be a complete multitrack virtual studio for Linux. Find more information 
about MusE at www.muse-sequencer.org (http://www.muse-sequencer.org/index.php).

Noteedit  
Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and to export and 
import scores to and from many formats, such as MIDI, MusicXML and LilyPond. Find more 
information about Noteedit at developer.berlios.de/projects/noteedit (http://
developer.berlios.de/projects/noteedit/). 

Rhythmbox  
Rhythmbox is a powerful, multitalented media player for the GNOME desktop. It allows you to 
organize and browse your music collection using playlists and even supports Internet radio. 
Find more information about Rhythmbox at www.gnome.org/projects/rhythmbox (http://
www.gnome.org/projects/rhythmbox/).

Rosegarden  
Rosegarden is a free music composition and editing environment. It features an audio and 
MIDI sequencer and a score editor. Find more information about Rosegarden at 
rosegardenmusic.com (http://rosegardenmusic.com/). 

Sound Juicer  
Sound Juicer is a lean CD ripper application for the GNOME desktop. Find more information 
about Sound Juicer at www.burtonini.com/blog/computers/sound-juicer (http://
www.burtonini.com/blog/computers/sound-juicer).

Totem  
Totem is a movie player application for the GNOME desktop. It supports Shoutcast, m3u, asx, 
SMIL, and ra playlists, lets you use keyboard controls, and plays a wide range of audio and 
video formats. Find more information about Totem at www.gnome.org/projects/totem (http://
www.gnome.org/projects/totem/). 

tvtime  
tvtime is a lean TV viewer application supporting analog TV. Find more information about 
tvtime, including a comprehensive usage guide, at tvtime.sourceforge.net (http://
tvtime.sourceforge.net/). 

xawtv and motv  
xawtv is a TV viewer and recorder application supporting analog TV. motv is basically the 
same as xawtv, but with a slightly different user interface. Find more information about the 
xawtv project at linux.bytesex.org/xawtv (http://linux.bytesex.org/xawtv/). 

xawtv4  
xawtv4 is a successor of the xawtv application. It supports both analog and digital audio and 
video broadcasts. For more information, refer to linux.bytesex.org/xawtv (http://
linux.bytesex.org/xawtv/). 

Xine  
Xine is a multimedia player that plays CDs, DVDs, and VCDs. It interprets many multimedia 
formats. For more information, refer to xinehq.de (http://xinehq.de/). 

XMMS  
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XMMS is the traditional choice for multimedia playback. It is focused on music playback, 
offering support for CD playback and Ogg Vorbis files. Users of Winamp should find XMMS 
comfortable because of its similarity. Find more information about XMMS at www.xmms.org 
(http://www.xmms.org/). 

zapping  
A TV viewer and recorder application for the GNOME desktop supporting analog TV. Find 
more information about Zapping at zapping.sourceforge.net (http://zapping.sourceforge.net/
cgi-bin/view/Main/WebHome). 

A.4  Graphics
The following section presents some of the Linux software solutions for graphics work. These 
include simple drawing applications as well as fully-fledged image editing tools and powerful 
rendering and animation programs. 

Table A-4   Graphics Software for Windows and Linux

Task Windows 
Application

Linux 
Application

Simple Graphic 
Editing

MS Paint KolourPaint

Professional 
Graphic Editing

Adobe 
Photoshop, 
Paint Shop Pro, 
Corel 
PhotoPaint, The 
GIMP

The GIMP, Krita

Creating Vector 
Graphics

Adobe 
Illustrator, 
CorelDraw, 
OpenOffice.org 
Draw, Freehand

OpenOffice.org 
Draw, Inkscape, 
Dia

SVG Editing WebDraw, 
Freehand, 
Adobe Illustrator

Inkscape, Dia, 
Kivio 

Creating 3D 
Graphics

3D Studio MAX, 
Maya, POV-
Ray, Blender

POV-Ray, 
Blender, 
KPovmodeler

Managing 
Digital 
Photographs

Software 
provided by the 
camera 
manufacturer

Digikam, f-spot

Scanning Vuescan Vuescan, The 
GIMP

Image Viewing ACDSee gwenview, 
gThumb, Eye of 
Gnome, f-spot
Getting to Know Linux Software 165

http://www.xmms.org/
http://zapping.sourceforge.net/cgi-bin/view/Main/WebHome


166 SUSE Linux

novdocx (E
N

U
)  01 February 2006
Blender  
Blender is a powerful rendering and animation tool available on many platforms, including 
Windows, MacOS, and Linux. Find more information about Blender at www.blender3d.com 
(http://www.blender3d.com/). 

Dia  
Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports many types of 
special diagrams, such as network or UML charts. Export formats include SVG, PNG, and 
EPS. To support your own custom diagram types, provide the new shapes in a special XML 
format. Find more information about Dia at www.gnome.org/projects/dia (http://
www.gnome.org/projects/dia/). 

Digikam   
Digikam is a smart digital photo management tool for the KDE desktop. Importing and 
organizing your digital images is a matter of a few clicks. Create albums, add tags to spare you 
from copying images around different subdirectories, and eventually export your images to 
your own Web site. Find more information about Digikam at www.digikam.org (http://
www.digikam.org/).  You can also refer to our Digikam chapter in KDE User Guide. 

Eye of Gnome (eog)  
Eye of Gnome is an image viewer application for the GNOME desktop. Find more information 
at www.gnome.org/gnome-office/eog.shtml (http://www.gnome.org/gnome-office/eog.shtml).

f-spot  
f-spot is a flexible digital photograph management tool for the GNOME desktop. It lets you 
create and manage albums and supports various export options like HTML pages or burning of 
image archives to CD. You can also use it as an image viewer on the command line. Find more 
information about f-spot at www.gnome.org/projects/f-spot (http://www.gnome.org/projects/f-
spot/). You can also refer to our chapter in GNOME User Guide. 

gThumb  
gThumb is an image viewer, browser, and organizer for the GNOME desktop. It supports the 
import of your digital images via gphoto2, allows you to carry out basic transformation and 
modifications, and lets you tag your images to create albums matching certain categories. Find 
more information about gThumb at gthumb.sourceforge.net (http://gthumb.sourceforge.net/). 

Gwenview  
Gwenview is a simple image viewer for KDE. It features a folder tree window and a file list 
window that provides easy navigation of your file hierarchy. Find more information at 
gwenview.sourceforge.net (http://gwenview.sourceforge.net/home/). 

Inkscape  
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio can find a 
similar range of features and a familiar user interface in Inkscape. Among its features, find 
SVG-to-PNG export, layering, transforms, gradients, and grouping of objects. Find more 
information about Inkscape at www.inkscape.org (http://www.inkscape.org/). 

Kivio  
Kivio is a flow-charting application that integrates into the KOffice suite. Former users of Visio 
find a familiar look and feel in Kivio. Find more information about Kivio at www.koffice.org/
kivio (http://www.koffice.org/kivio/).
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KolourPaint  
KolourPaint is an easy-to-use paint program for the KDE desktop. You can use it for tasks such 
as painting or drawing diagrams and editing screen shots, photos, and icons. For more 
information, refer to kolourpaint.sourceforge.net (http://kolourpaint.sourceforge.net/). 

KPovmodeler  
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop. KPovmodeler 
saves users from needing a detailed knowledge of POV-Ray scripting by translating the POV-
Ray language in an easy-to-understand tree view. Native POV-Ray scripts can be imported to 
KPovmodeler as well. Find more information at www.kpovmodeler.org (http://
www.kpovmodeler.org).

Krita 
Krita is KOffice's answer to Adobe Photoshop and The GIMP. It can be used for pixel-based 
image creation and editing. Its features include many of the advanced image editing capabilities 
you would normally expect with Adobe Photoshop or The GIMP. Find more information at 
www.koffice.org/krita (http://www.koffice.org/krita).

OpenOffice.org Draw  
See “OpenOffice.org” on page 157. 

POV-Ray  
The Persistence of Vision Raytracer creates three-dimensional, photo-realistic images using a 
rendering technique called ray tracing. Because there is a Windows version of POV-Ray, it 
does not take much for Windows users to switch to the Linux version of this application. Find 
more information about POV-Ray at www.povray.org (http://www.povray.org/). 

The GIMP   
The GIMP is the open source alternative to Adobe Photoshop. Its feature list rivals that of 
Photoshop, so it is well suited for professional image manipulation. There is even a Windows 
version of GIMP available. Find more information at www.gimp.org (http://www.gimp.org/). 
You can also refer to our GIMP chapter. 

VueScan  
VueScan is a scanning software available for several platforms. You can install it parallel to 
your vendor's scanner software. It supports the scanner's special hardware, like batch scanning, 
autofocus, infrared channels for dust and scratch suppression, and multiscan to reduce scanner 
noise in the dark areas of slides. It features simple and accurate color correction from color 
negatives. Find out more at www.hamrick.com (http://www.hamrick.com/index.html). 

A.5  System and File Management
The following section provides an overview of Linux tools for system and file management. Get to 
know text and source code editors, backup solutions, and archiving tools. 
Getting to Know Linux Software 167

http://kolourpaint.sourceforge.net/
http://www.kpovmodeler.org
http://www.koffice.org/krita
http://www.povray.org/
http://www.gimp.org/
http://www.hamrick.com/index.html


168 SUSE Linux

novdocx (E
N

U
)  01 February 2006
Table A-5   System and File Management Software for Windows and Linux

Adobe Reader  
Adobe Reader for Linux is the exact counterpart of the Windows and Mac versions of this 
application. The look and feel on Linux are the same as on other platforms. The other parts of 
the Adobe Acrobat suite have not been ported to Linux. Find more information at 
www.adobe.com (http://www.adobe.com/products/acrobat/readermain.html).

Ark  
Ark is a GUI-based pack program for the KDE desktop. It supports common formats, such as 
zip, tar.gz, tar.bz2, lha, and rar. You can view, select, pack, and unpack single files 
within an archive. Due to Ark's integration with Konqueror, you can also trigger actions (such 
as unpacking an archive) from the context menu in the file manager, similar to WinZip. 

dump  
The dump package contains both dump and restore. dump examines files in a file system, 
determines which ones need to be backed up, and copies those files to a specified disk, tape, or 
other storage medium. The restore command performs the inverse function of dump—it can 
restore a full backup of a file system. Find more information at dump.sourceforge.net (http://
dump.sourceforge.net/). 

Evince  

Task Windows 
Application

Linux 
Application

File Manager Windows 
Explorer

Konqueror, 
Nautilus

Text Editor NotePad, 
WordPad, 
(X)Emacs

kate, GEdit, 
(X)Emacs, vim

PDF Creator Adobe Distiller Scribus

PDF Viewer Adobe Reader Adobe Reader, 
Evince, KPDF, 
Xpdf

Text 
Recognition

Recognita, 
FineReader

GOCR

Command Line 
Pack Programs

zip, rar, arj, lha, 
etc.

zip, tar, gzip, 
bzip2, etc.

GUI Based Pack 
Programs

WinZip Ark, File Roller

Hard Disk 
Partitioner

PowerQuest, 
Acronis, 
Partition 
Commander

YaST, GNU 
Parted

Backup 
Software

ntbackup, 
Veritas

KDar, taper, 
dump
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Evince is a document viewer for PDF and PostScript formats for the GNOME desktop. Find 
more information at www.gnome.org/projects/evince (http://www.gnome.org/projects/evince/
).

File Roller  
File Roller is a GUI-based pack program for the GNOME desktop. It provides features similar 
to Ark's. For more information, refer to fileroller.sourceforge.net (http://
fileroller.sourceforge.net/home.html).

GEdit  
GEdit is the official text editor of the GNOME desktop. It provides features similar to Kate's. 
Find more information at www.gnome.org/projects/gedit (http://www.gnome.org/projects/
gedit/). 

GNU Parted  
GNU Parted is a command line tool for creating, destroying, resizing, checking, and copying 
partitions and the file systems on them. If you need to create space for new operating systems, 
use this tool to reorganize disk usage and copy data between different hard disks. Find more 
information at www.gnu.org/software/parted (http://www.gnu.org/software/parted/). 

GOCR  
GOCR is an OCR (optical character recognition) tool. It converts scanned images of text into 
text files. Find more information at jocr.sourceforge.net (http://jocr.sourceforge.net/). 

gzip, tar, bzip2    
There are plenty of packaging programs for reducing disk usage. In general, they differ only in 
their pack algorithm. Linux can also handle the packaging formats used on Windows. bzip2 
is a bit more efficient than gzip, but needs more time, depending on the pack algorithm. 

kate  
Kate is part of the KDE suite. It has the ability to open several files at once either locally or 
remotely. With syntax highlighting, project file creation, and external scripts execution, it is a 
perfect tool for a programmer. Find more information at kate.kde.org (http://kate.kde.org/). 

KDar  
KDar stands for KDE disk archiver and is a hardware-independent backup solution. KDar uses 
catalogs (unlike tar), so it is possible to extract a single file without reading the whole archive 
and it is also possible to create incremental backups. KDar can split an archive into multiple 
slices and trigger the burning of a data CD or DVD for each slice. Find more information about 
KDar at kdar.sourceforge.net (http://kdar.sourceforge.net/). 

Konqueror  
Konqueror is the default file manager for the KDE desktop, which can also be used as a Web 
browser, document and image viewer, and CD ripper. Find more information about this 
multifunctional application at www.konqueror.org (http://www.konqueror.org/).

KPDF  
KPDF is a PDF viewing application for the KDE desktop. Its features include searching the 
PDF and full screen reading mode like in Adobe Reader. Find more information at 
kpdf.kde.org (http://kpdf.kde.org/).
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Nautilus  
Nautilus is the default file manager of the GNOME desktop. It can be used to create folders and 
documents, display and manage your files and folders, run scripts, write data to a CD, and open 
URI locations. For an introduction to using Nautilus as a file manager, see GNOME User 
Guide. Find information about Nautilus on the Internet at www.gnome.org/projects/nautilus 
(http://www.gnome.org/projects/nautilus/).

taper  
Taper is a backup and restore program that provides a friendly user interface to allow backup 
and restoration of files to and from a tape drive. Alternatively, files can be backed up to archive 
files. Recursively selected directories are supported. Find more information at 
taper.sourceforge.net (http://taper.sourceforge.net/). 

vim  
vim (vi improved) is a program similar to the text editor vi. Users may need time to adjust to 
vim, because it distinguishes between command mode and insert mode. The basic features are 
the same as in all text editors. vim offers some unique options, like macro recording, file format 
detection and conversion, and multiple buffers in a screen. Find more information at 
www.vim.org (http://www.vim.org/). 

(X)Emacs   
GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU Emacs. To 
quote the GNU Emacs Manual, “Emacs is the extensible, customizable, self-documenting real-
time display editor.” Both offer nearly the same functionality with minor differences. Used by 
experienced developers, they are highly extensible through the Emacs Lisp language. They 
support many languages, like Russian, Greek, Japanese, Chinese, and Korean. Find more 
information at www.xemacs.org (http://www.xemacs.org/) and www.gnu.org/software/emacs 
(http://www.gnu.org/software/emacs/emacs.html). 

Xpdf  
Xpdf is lean PDF viewing suite for Linux and Unix platforms. It includes a viewer application 
and some export plug-ins for PostScript or text formats. Find more information at 
www.foolabs.com/xpdf (http://www.foolabs.com/xpdf/).

A.6  Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems for 
professional software development. 

Table A-6   Development Software for Windows and Linux

Task Windows 
Application

Linux 
Application

Integrated 
Development 
Environments

Borland C++, 
Delphi, Visual 
Studio, .NET

KDevelop, Eric, 
Eclipse, 
MonoDevelop, 
Anjuta

Toolkits MFC, Qt, GTK+ Qt, GTK+

Compilers VisualStudio GCC
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Anjuta  
Anjuta is an IDE for GNOME/GTK+ application development. It includes an editor with 
automated formatting, code completion, and highlighting. As well as GTK+, it supports Perl, 
Pascal, and Java development. A GDB-based debugger is also included. Find more information 
about Anjuta at anjuta.sourceforge.net (http://anjuta.sourceforge.net).

CVS  
CVS, the Concurrent Versions System, is one of the most important version control systems for 
open source. It is a front-end to the Revision Control System (RCS) included in the standard 
Linux distributions. Find more information at the home page www.cvshome.org (http://
www.cvshome.org/). 

Eclipse  
The Eclipse Platform is designed for building integrated development environments that can be 
extended with custom plug-ins. The base distribution also contains a full-featured Java 
development environment. Find more information at www.eclipse.org (http://
www.eclipse.org). 

Eric  
Eric is an IDE optimized for Python and Python-Qt development. Find more information about 
Eric at www.die-offenbachs.de/detlev/eric3.html (http://www.die-offenbachs.de/detlev/
eric3.html).

GCC  
GCC is a compiler collection with front-ends for various programming languages. Check out a 
complete list of features and find extensive documentation at gcc.gnu.org (http://gcc.gnu.org).

GDB  
GDB is a debugging tool for programs written in various programming languages. Find more 
information about GDB at www.gnu.org/software/gdb (http://www.gnu.org/software/gdb/
gdb.html).

Glade  
Glade is a user interface builder for GTK+ and GNOME development. As well as GTK+ 
support, it offers support for C, C++, C#, Perl, Python, Java, and others. Find more information 
about Glade at glade.gnome.org (http://glade.gnome.org/).

GTK+  

Debugging 
Tools

Visual Studio GDB, valgrind

GUI Design Visual Basic, 
Visual C++

Glade, Qt 
Designer

Versioning 
Systems

Clearcase, 
Perforce, 
SourceSafe

CVS, 
Subversion

Task Windows 
Application

Linux 
Application
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GTK+ is a multiplatform toolkit for creating graphical user interfaces. It is used for all 
GNOME applications, The GIMP, and several others. GTK+ has been designed to support a 
range of languages, not only C/C++. Originally it was written for GIMP, hence the name 
“GIMP Toolkit.” Find more information at www.gtk.org (http://www.gtk.org). Language 
bindings for GTK+ are summarized under www.gtk.org/bindings.html (http://www.gtk.org/
bindings.html). 

KDevelop  
KDevelop allows you to write programs for different languages (C/C++, Python, Perl, etc.). It 
includes a documentation browser, a source code editor with syntax highlighting, a GUI for the 
compiler, and much more. Find more information at www.kdevelop.org (http://
www.kdevelop.org). 

MonoDevelop  
The Mono Project is an open development initiative that is working to develop an open source 
Unix version of the .NET development platform. Its objective is to enable Unix developers to 
build and deploy cross-platform .NET applications. MonoDevelop complements the Mono 
development with an IDE. Find more information about MonoDevelop at 
www.monodevelop.com (http://www.monodevelop.com/). 

Qt  
Qt is a program library for developing applications with graphical user interfaces. It allows you 
to develop professional programs rapidly. The Qt library is available not only for Linux, but for 
a number of Unix flavors and even for Windows and Macintosh. Thus it is possible to write 
programs that can be easily ported to those platforms. Find more information at 
www.trolltech.com (http://www.trolltech.com). Language bindings for Qt development are 
summarized under developer.kde.org/language-bindings (http://developer.kde.org/language-
bindings/). 

Qt Designer  
Qt Designer is a user interface and form builder for Qt and KDE development. It can be run as 
part of the KDevelop IDE or in stand-alone mode. QtDesigner can be run under Windows and 
even integrates into the Visual Studio development suite. Find more information about Qt 
Designer at www.trolltech.com/products/qt/designer.html (http://www.trolltech.com/products/
qt/designer.html).

Subversion  
Subversion does the same thing CVS does but has major enhancements, like moving, 
renaming, and attaching meta information to files and directories. The Subversion home page is 
subversion.tigris.org (http://subversion.tigris.org/). 

Valgrind  
Valgrind is a suite of programs for debugging and profiling x86 applications. Find more 
information about Valgrind at valgrind.org (http://valgrind.org/info/).
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