
SUSE® Linux Enterprise Desktop provides the tools that Linux* users require in their daily activities. It comes
with an easy-to-use graphical user interface (KDE desktop) that communicates with the underlying Linux system
to access and manage files, folders, and programs. SUSE Linux Enterprise Desktop provides an integrated suite
of applications that meet all professional requirements to perform tasks in a business environment. The
OpenOffice.org suite is also included, which allows you to edit and save files in a number of formats. Because
the office suite is available for several operating systems, you can use the same data across different computing
platforms.

Getting Started
When you start your system, you are usually prompted to
enter your username and password. If you did not install
your system yourself, check with your system administrator
for your username and password.

After logging in to KDE for the first time, you see the KDE
desktop, which shows the following basic elements:

Desktop Icons: Click an icon on the desktop to access
its associated program or application. Right-click to open
a context menu for moving, copying, or performing other
functions on an icon.

Desktop Context Menu: Right-click an empty area on
the desktop to access this context menu for creating new
objects, such as files, folders, or bookmarks; configuring
the appearance of the desktop; running applications; and
logging out.

KDE Panel: By default, the panel of your KDE desktop
consists of the following areas (from left to right): main
menu button, quick launcher, desktop previewer, taskbar,
and system tray. You can add or remove icons in the panel
and customize the appearance of the panel as well as its
location on the desktop. Click the arrow at the far right to
hide the panel. If you hold your mouse pointer over an icon
in the panel, a short description is displayed.

Main Menu Button: Click the icon at the far left of the
panel to access a menu leading to all programs, tools, and
applications on your system. The function-oriented menu
structure makes it easy to find the right application for your
purpose even if you do not know the application names
yet.
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Quick Launcher The quick launcher contains some
larger icons that are shortcuts to frequently used programs,
folders, and functions, such as an Internet browser, your
home folder, and the online Help Center.

Desktop Previewer: Between the quick launcher and
the taskbar, find a miniature preview that shows your virtual
desktops. SUSE Linux Enterprise Desktop allows you to or-
ganize your programs and tasks on several desktops, which
minimizes the number of windows to arrange on the screen
(Section “Using Virtual Desktops”). To switch between
desktops, click one of the symbols in the previewer.

Taskbar: By default, all started applications and open
windows are displayed in the taskbar, which allows you to
access any application regardless of the currently active
desktop. Click to open the application. Right-click to see
options for moving, restoring, or minimizing the window.

System Tray: This rightmost part of the panel usually
holds some smaller icons, including the system clock display-
ing time and date, the volume control, and icons for several
other helper applications.

Starting Programs
To run a program in SUSE Linux Enterprise Desktop, click
the main menu icon in the panel or press Alt + F1 to open
it and navigate the submenus. Click an entry to start the
corresponding program.

If you already know the name of an application but are not
sure how to start it from the main menu, use the main menu
search function. Just type a part of the application's name
into the search field without pressing Enter afterwards. If
the application is installed on your system, the menu
structure leading to this application is highlighted in the
main menu.

Customizing Your Desktop
You can change the way your KDE desktop looks and be-
haves to suit your own personal tastes and needs.

Changing Individual Desktop Elements
In the following, find some examples of how to change in-
dividual desktops elements.

Adding Program Icons to Your Desktop
To create a link to an application and place it on the desk-
top, proceed as follows:

1. Click the main menu button.
2. Browse to the desired program.
3. Left-click and drag the menu entry to the desktop then

release the mouse button.
4. Select Link Here from the context menu that appears

then position the icon as desired.

To delete an icon from your desktop, right-click the pro-
gram icon and select Move to Trash.

Customizing the KDE Panel
You can customize the KDE panel according to your prefer-
ences by adding, deleting, or moving icons or changing the
overall appearance of the panel.

1. To add or remove icons from the panel, right-click an
empty patch in the panel. A context-menu appears.

2. To add an application, click Add Application to Panel
and select the desired application from one of the cat-
egories of the submenu.

3. To add an applet (miniprogram), click Add Applet to
Panel and, from the dialog box that appears, select the
desired applet. Click Add to Panel to insert the applet
into the panel.

4. To remove icons from the panel, select Remove from
Panel → Applications or Remove from Panel → Applet
and choose the icon to remove.

5. To change the overall appearance or behavior of the
panel, select Configure Panel from the context menu.
A configuration dialog appears where you can adjust
further settings.
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Changing the Desktop Background
You can change the background colors of your desktop or
select a picture to use as the background. Because KDE of-
fers virtual desktops (see Section “Using Virtual Desktops”),
you can apply these changes to one or all of your virtual
desktops.

1. Right-click an empty patch of the desktop and select
Configure Desktop. A configuration dialog appears.

2. In Settings for Desktop select the virtual desktops to
which the changes should apply.

3. If you want a different picture as the background, click
Picture and select one of the pictures provided by the
list. To use a custom picture, click the folder button
beneath the list and select an image file from the file
system.

4. Click Slide Show to have multiple images appear in a
slide show mode.

5. If you do not want a picture on the background, click
No picture.

6. From the Options group, click the left button below
Colors to select the color for your background. For a
multicolor background, set Colors to an option other
than Single Color and click the right button below to
select a second color.

7. Click Apply then OK to close the configuration dialog.

Using the KDE Control Center
Apart from changing individual desktop elements, KDE al-
lows you to personalize your desktop to a very high degree.
Find more settings to adjust the overall appearance and
behavior of your desktop in the KDE Control Center. There,
you can also change fonts, keyboard and mouse configura-
tion, regional and language settings, parameters for your
Internet and network usage, and more.

Start the Control Center from the main menu by selecting
Personal Settings or press Alt + F2 and enter kcontrol.

The sidebar provides different categories with a subset of
settings each. To get an impression of the numerous possi-
bilities, just click a category icon and explore the possibilities
provided there.

For an overview of all categories, switch to a tree view.
Change the view by selecting View → Mode → Tree View.

Clicking an item displays the corresponding settings on the
right. Change the settings as desired. No changes take effect
until you click Apply. Reset all items on the page to the
default values by clicking Default. Performing tasks in some
areas of the Control Center requires system administrator
(otherwise known as root) permissions.

Using Virtual Desktops
The desktop environment allows you to organize your pro-
grams and tasks on several virtual desktops. If you often
run a lot of programs simultaneously, this minimizes the
number of windows to arrange on your screen. You might,
for example, use one desktop for e-mailing and calendaring
and another for word processing or graphics applications.

Moving an Application to a Virtual Desktop
You can display a running application on one or all virtual
desktops or move it to other desktops.

1. Open the application.
2. Right-click the application’s title bar.
3. Click To Desktop.
4. Select the desktop on which to place the application.
5. To switch between desktops, click the desired desktop

in the desktop previewer in the panel.
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Adding Additional Virtual Desktops
Some users might need more desktops than provided by
default. To add additional desktops:

1. Right-click the desktop previewer in the panel and select
Configure Desktops. A configuration dialog appears
where you can increase or reduce the number of virtual
desktops. You can also change the default names of the
desktop.

2. Click OK to apply the changes and to close the configu-
ration dialog.

3. If you want the names of the desktops to appear in the
desktop previewer rather than the number, right-click
the desktop previewer and select Pager Options →
Desktop Name.

Using Konqueror
Konqueror is a unified Web browser, file manager, docu-
ment viewer, and image viewer. As a file manager, it lets
you display, manage, and create files and generally organize
your file system the way you like.

Start Konqueror as a file manager by clicking the house
icon in the panel. Konqueror displays the contents of your
home directory.

Konqueror Main Window
The Konqueror main window consists of the following ele-
ments:

Menu Bar The menu bar holds menu items for actions
like copying, moving, or deleting files, changing views,
starting additional tools, defining your settings, and getting
help.

Toolbar: The toolbar provides quick access to frequently
used functions that can also be accessed via the menu. If
you hover the pointer over an icon, a short description is
displayed.

Location Bar: The location bar shows the path to your
directory or file in your file system. You can enter a path
to a directory directly by typing it in or by clicking one of
the directories in the display field. Delete the contents of
the location bar by clicking the black symbol with a white
X on the left. After typing an address, press Enter.

Navigation Panel Hide and show the navigation panel
on the left by pressing F9. The navigation panel displays
your information in a tree view. Determine which contents
you want to see by clicking one of the symbols in the tab
at the left of the navigation panel. If you hold your mouse
pointer over an icon, a short description is displayed.

Display Field: The display field shows the contents of
the selected directory or file. In the View menu, choose
between different view modes to display the contents, such
as Icon View, Tree View, or Detailed List View. If you click a
file, Konqueror shows a preview of the contents or loads
the file into an application for further processing. If you
hold the mouse pointer over the file, Konqueror shows a
tooltip with detailed information about the file, such as
owner, permissions, or last modification date.

Managing Files and Folders with Konqueror
To perform actions like copying, moving, or deleting files,
you need appropriate permissions to the folders and files
involved in your action.

To copy or move a file or folder, proceed as follows:

1. To select one or multiple files and folders in Konqueror
press Ctrl and click the files.

2. Right-click and select Copy or Cut from the context
menu.

3. Navigate to the destination folder in which to insert the
object. Right-click the destination folder and select
Paste. The object is copied or moved there.

You can also use drag and drop to copy or move objects.
When dropping the object, you are asked whether the ob-
ject should be moved or copied.

To delete a file or folder, right-click the object and select
Move to Trash from the context menu. The object is moved
to the trash bin from which you can restore it if necessary
or delete the object irretrievably.
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Browsing the Internet with Konqueror
If you want to use Konqueror as a Web browser, just type
an URL in the location bar. Like Firefox, Konqueror also
features tabbed browsing. This means that you can load
one page in the background while reading another. To open
an empty tab in Konqueror, press Ctrl + Shift + N and enter
a new URL. Alternatively, right-click a link in the Web site
currently displayed and select Open in New Tab. Right-click
a tab to access more tab options like reloading, duplicating,
or closing the tab.

You can also use bookmarks for your favorite Web sites
(and also for files and folders). Add and manage your
bookmarks with the Bookmarks menu.

Browsing the Internet with Firefox
As well as Konqueror, SUSE Linux Enterprise Desktop also
includes the Firefox Web browser. To start Firefox, press
Alt + F2 and enter firefox.

With features like tabbed browsing, pop-up window block-
ing, and download and image management, Firefox com-
bines the latest Web technologies. Its easy access to differ-
ent search engines helps you find the information you need.
Enter a URL in the location bar to start browsing. To open
an empty tab in Firefox, press Ctrl + T and enter a new URL.
To open a link in a new tab, click the link with your middle
mouse button. Right-click the tab itself to access more tab
options. You can create a new tab, reload one or all existing
tabs, or close them. You can also change the sequence of
the tabs by dragging and dropping them to the desired
position.

Finding Information with Firefox
Firefox offers two different kinds of search options: you
can find information on the Web or you can search the
current Web page for keywords.

1. To start a search on the Web with the Google engine,
just type your search keywords in the integrated search
bar at the right of the location bar and press Enter. The
results appear in the window.

2. To use a different search engine, click the G icon in the
search bar to open a list of other search engines.

3. Click the desired engine and press Enter to start the
search.

To search the current Web page for keywords, press Ctrl F
to open a find bar at the bottom of the window. Enter your
search keyword there and use the buttons beneath the bar
to search in different directions or to highlight all hits in
the text.

Downloading Files from the Web
If you download a file with Firefox, the Download Manager
starts and saves this file to the folder configured in the
preferences. By default, your desktop is the destination
folder for downloaded files. Firefox shows your finished
downloads in a dialog box.

You can open the downloaded files from there directly. To
clean up the history of downloaded files, click Clean Up.

Configuring Firefox Preferences
To adjust the default download folder or activate or modify
the pop-up blocking feature, click Edit → Preferences.
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From here, you can also configure numerous other settings,
such as appearance, language, privacy, and tab options. Just
click the icons and set the options on each page according
to your preferences. Click Close to apply the changes.

Managing Passwords with KWallet
When you select the option to remember a password in a
KDE application for the first time (for your e-mail account,
for example), the KWallet wizard starts by default. KWallet
is a password management tool that can collect all pass-
words and store them in an encrypted file.

To activate KWallet, select Basic Setup and click Next. Select
Yes, I wish to use the KDE wallet to store my personal infor-
mation and enter a password. This is your master password
to open KWallet. It cannot be recovered if you forget it.
Click Finish to close the wizard. After this initial configura-
tion, you can open your wallet at any time to view, search,
delete, or create entries. Normally you do not need to insert
an entry manually. KDE recognizes if a resource requires
authentication and KWallet starts automatically, prompting
you for the KWallet password.

E-Mailing and Calendaring
For reading and managing your mails and appointments in
SUSE Linux Enterprise Desktop, you can use Kontact as your
personal information management tool (PIM). Kontact
combines KDE applications like KMail, KOrganizer, and
KAddressBook into a single interface. This gives you easy
access to your e-mail, calendar, address book, and other
PIM functionality.

Starting Kontact for the First Time
To start Kontact, press Alt + F2 and enter kontact. To
access one of the components, click the corresponding icon
on the left sidebar.

Before you can send or receive mails, you must configure
your e-mail account.

1. Click the Mail icon then select Settings → Configure
KMail.

2. In the configuration dialog, click Accounts. There you
can configure the settings for outgoing and incoming
mails.

3. For incoming mails, click the Receiving tab and click
Add. Select the appropriate account type and enter the
details in the following dialog.

4. Proceed similarly for outgoing mails on the Sending
tab. If you are not sure about the settings or items to
select, consult your Internet Service Provider or system
administrator.

Instant Messaging with Kopete
Kopete is an online messenger application allowing multiple
partners connected to the Internet to chat with each other.
Kopete currently supports all commonmessenger protocols,
such as ICQ, MSN, Yahoo, SMS, Jabber, IRC, and GroupWise
Messenger. To be able to use instant messaging (IM) you
must register with a provider offering IM services.

To start Kopete, press Alt + F2 and enter kopete. When
starting Kopete for the first time, a configuration wizard
appears that assists you in creating your user profile.
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First, select the service with which you have registered and
click Continue. Then enter the user data received on regis-
tration with the messaging service: a user ID, a password,
and the server name and port. Complete the configuration
of the messenger account by clicking Finish.

Add contacts to chat with them by clicking File → Add
Contact. An assistant appears to help with creation. Howev-
er, you must be online and connected to the selected
messaging service to add a contact to your list.

To start a chat, click the desired contact and type your
message in the lower part of the chatting window. Press
Enter to send the message. The upper part of the window
displays the messages you have sent and received.

Starting OpenOffice.org
The office suite OpenOffice.org offers a complete set of
office tools, including word processor, spreadsheet, presen-
tation, vector drawing, and database components. Because
OpenOffice.org is available for a number of operating sys-
tems, you can use the same data across different computing
platforms.

To start OpenOffice.org, press Alt + F2 and enter OOo or
click the Office icon on the desktop. To create a new docu-
ment, select File→ New and choose the type of document
to create. To open an existing document, select Open and
choose the appropriate file from the file system.

Viewing PDF Files
Documents that need to be shared or printed across plat-
forms can be saved as PDF (Portable Document Format)
files, for example, in the OpenOffice.org suite. SUSE Linux
Enterprise Desktop ships with several PDF viewers, such as
KPDF and Adobe* Acrobat* Reader.

To access KPDF or Adobe* Acrobat* Reader:

1. Click the main menu button.
2. Click Office → Document Viewer. Select Acrobat Reader

or KPDF to open the PDF viewer of your choice. Alter-
natively, press Alt + F2 and enter acroread or kpdf.

3. To view a PDF file, click File→ Open. Locate the desired
PDF file and click Open.

4. Navigate through the documents by using the navigation
icons at the top or bottom of the window. If your PDF
document provides bookmarks, you can access them
in the left panel of the viewer.

Searching for Data
KDE provides more than one application for finding data
on your computer or in the file system. With Kerry, you can
easily search your personal information space (usually your
home folder), which is indexed by Beagle. KFind is another
option.

Using Kerry
Use Kerry to find documents, e-mails, Web history, IM/ITC
conversations, source code, images, music files, applications,
and much more:

1. Press F12 to open the Kerry Beagle Search dialog.
2. Enter the search string in Search. Enter words or

phrases and modify your search options as described
in the tips displayed in the search window.

3. Select the scope of the search in Within on the right.
4. Click Find to start the search. The results are displayed

in the window. Use the links in each result to open the
result directly or show its location in the file system
with the file manager.

Using KFind
To perform basic and advanced searches, use KFind. Start
it from the main menu by clicking Find Files/Folders or press
Alt + F2 and enter kfind.

Searching by Name
To use a filename (or a part of it) as the search keyword,
proceed as follows:

1. Enter the filename or a part of the filename in the
Named input field. Use wild cards, such as an asterisk
(*), to indicate missing characters in the filename.

7



2. Specify the folder in which to search for the file. Either
enter a path to the folder in Look in or click Browse to
locate the folder.

3. To search subfolders, check Include Subfolders.
4. Click Find to start the search. The results are displayed

in the lower part of the dialog. To directly open the
result, just click it. Right-click it to choose one of the
options from the context menu.

Searching by Contents or Properties
For a more detailed search, you can also specify further
options, such as a text the file must contain or the creation
or modification date of a file.

1. On the Name/Location tab, specify at least the path to
search for the file. You can leave the Named empty.

2. To search for certain contents in a file, click the Con-
tents tab. In Containing Text, enter the word or phrase
the file to find must contain. This option does not work
for all types of files.

3. To search for properties such as creation or modifica-
tion date of the file, click the Properties tab and choose
the options you want.

4. Click Find to start the search.

Creating a CD or DVD
If you possess a CD or DVD writer, you can burn files to a
CD or DVD with K3b.

1. Press Alt + F2 and enter k3b. K3b opens.
2. Click New Data CD Project in the bottom part window.

3. Use the tree view in the top left part of the window to
search for the files or folders to burn. When they appear
in the top right part of the window, drag and drop them
into the Current Projects window.

4. Insert a writable CD into the device then click the Burn
icon.

5. Enter the required information in the Data Project dia-
log. If you are not sure which settings to choose, click
K3b Defaults. This should work well for almost all files.

6. Click Burn.

Obtaining Software Updates
Novell offers a continuous stream of software security up-
dates for your product. Using the Software Updater applet
in your desktop panel, you can easily apply security updates
with a few clicks. Whenever you connect to the Internet,
Software Updater automatically checks whether updates
for your system are available from the update sources
specified in the Software Updater configuration.

Before you can use Software Updater on your system, you
must register your product at the Novell update server. To
review the updates available, click the Software Updater
icon in the system tray to open the list.

Manually determine the updates to apply by selecting or
deselecting them in the list. To apply the selected updates,
click Update.

Configuring Your System with YaST
Whereas the KDE Control Center is only for configuring
your KDE desktop, you can change the installation and the
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configuration of your whole system with YaST. Therefore,
administrator (root) permission is required to open YaST.

YaST holds various modules for adjusting your system set-
tings. They are are subdivided into the following categories:

Software: Use the modules of this category to set certain
options for installation and update and to install or remove
software packages.

Hardware: Use modules to configure the hardware of
your computer, such as monitor, keyboard, mouse, printer,
or scanner.

System: With these modules, you can change system
settings, such as date, time, or language, and perform tasks,
such as backup or restoration of files.

Network Devices: Use these modules to configure your
network devices, such as network cards, ISDN, DSL, or mo-
dem.

Network Services: These modules are for network ser-
vices and for configuring several clients, such as LDAP and
NFS clients.

Novell AppArmor: Use the modules of this category to
configure the Novell AppArmor application security system.

Security and Users: Here, you can configure security
aspects, such as the firewall options, and create and manage
users and groups.

To open YaST, press Alt + F2 and enter yast. A dialog
opens in which to enter the root password. The YaST
modules offer integrated online help texts.

Managing Printers
Printers can either be connected to your system locally or
accessed over a network. To use a local printer, make sure
that it is connected to your machine. Shut down the system
before connecting a non-USB printer to your system.

You can configure printers with YaST. Start YaST and select
Hardware → Printer in the YaST control center. This opens
the main printer configuration window. Depending on the
network environment or your local printer model, YaST may
be able to configure the printer automatically. If autodetec-
tion of printing devices fails, click Add in the Printer Confi-
guration dialog to start the manual configuration workflow.
Follow the instructions in the YaST online help. If you are
not sure which option to choose and which information to
enter, ask your system administrator.

After configuring a printing device correctly, you can ad-
dress it from any application.

Logging Out
When you are finished using the computer, you can log out
and leave the system running or restart or shut down the
computer. Click the main menu button on your panel and
select Log Out. If you want to leave the system running,
click End Current Session in the dialog that opens. Otherwise,
click Turn Off Computer.

For More Information
This guide gave you a short introduction to the KDE desktop
and some key applications running on it. To discover more,
refer to KDE User Guide and the other manuals available
for SUSE Linux Enterprise Desktop at http://
www.novell.com/documentation/sled10/.
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